Pick To Light

[image]

Pick To Light 设备通讯类库
Pick To Light
Send Feedback
    Pick To Light 设备通讯类库 以 XGate、XConverter、XRelay 类作为主入口点管理其下连接的设备。

1. 通过 RS485Bus.Devices.AddOrUpdate() 调用路径安装设备到指定的总线。

2. 通过 Broadcaster.Method() 执行广播命令，广播命令的执行异常会立即抛出；
执行无返回值的广播命令时不能确定设备是否收到和响应命令。

3. 通过 StartUnicastCommandQueue() 开始执行当前控制器上的所有设备的命令队列，
会为每条总线启用一个单播命令执行线程，各总线间并行，总线内轮询。

对设备的控制是异步的，控制命令存留在队列，等待单播命令执行线程来调用，
单播命令的执行异常会被捕获并引发 PtlDevice.Error 事件；
成功的命令会被移出队列，失败的命令会在下一轮继续被执行；
XGate 的运行时命令亦是如此。

命令队列执行线程在执行单播命令时可被组播命令抢占时间片，组播命令在执行前会进行严格的参数验证；
组播命令不能确定设备是否收到和响应命令，所以不应用于核心逻辑。

4. 为不阻塞通讯，本类库中提供的的所有事件的处理程序应快速返回或者通过 EventThreadConfiguration 配置到其他线程；
为不中断通讯，本类库中 EventSubscriber.UnhandledException 事件公开了其他事件的处理程序产生的异常，
但其本身的处理程序产生的异常将被捕获。

5. Xml 序列化仅可获得设备的安装信息；
二进制序列化会获得设备的执行进度，但仍需调用 StartUnicastCommandQueue() 来继续执行；
另外，也很显然，不应在发起通讯（包括启动设备心跳发生器）后修改安装信息，如：
XGate.IPEndPoint、PtlDevice.Address、PtlDevice.MinorType、IOPort.Owner、IOPort.Index 等。

6. 进行全新业务逻辑前需要调用 XGate.Initialize()，PtlDevice.Initialize() 来初始化设备，
此方法会清空未完成的命令、清零通讯统计、解锁可能处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。

7. 启用心跳可以在设备不进行业务通讯时发现通讯错误，但出错的通讯也会影响该总线的轮询耗时。

8. AppearanceChanged 事件会在相关单播命令成功执行后引发，在此事件发生之前获取当前外观信息是被置疑的，
且因为无返回值的广播、组播命令不能保证设备成功响应，所以这些外观更改不会被跟踪。

9. 设置 XGate 工作参数后，需要重启才能生效。

    Pick To Light Device communication library takes XGate, XConverter,XRelay as main entry point to manage all devices connected under it.

1. Install the device to the specified bus via the RS485Bus.Devices.AddOrUpdate () call path.

2. By executing the broadcast command through Broadcaster.Method(), the execution exception of the broadcast command is thrown immediately;
it can not make sure that weather devices can receive and replay the command or not when execute no return value broadcast command.

3. Start execute the command queue for all devices on current controller by startUnicastCommandQueue (),
a unicast command execution thread is enabled for each bus, parallel between each bus, polling within the bus.

The control of the device is asynchronous, The control command is left in the queue, waiting for unicast commands to execute threads to invoke,
The execution exception of the unicast command will be captured and the PtlDevice.Error event will raised;
The successful command will be moved out of the queue, and the failed command will continue to be executed in the next round;
the same as XGate’s execution.

The command queue execution thread can be preempted by the multicast command when the unicast command is executed, and multicast commands perform strict parameter validation before they are executed;
Multicast can not make sure weather devices can receive and reply commands, so it can’t be applied in core logic.

4. For nonblocking Communications, all the handle process of events that are provided in this class library should be returned quickly or passed by EventThreadConfiguration to other threads;
For uninterrupted communication in this class library, the EventSubscriber.UnhandledException event exposes exceptions raised by handlers of other events, however, the exception raised by its own handlers will be captured.

5. Xml serialization only can get installation information from the device;
Binary serialization can get the execution of the device, but calls StartUnicastCommandQueue () to continue.
In addition, it is clear that the installation information should not be modified after starting communications (including starting device heartbeat generators), such as:
XGate.IPEndPoint, PtlDevice.Address, PtlDevice.MinorType, IOPort.Owner, IOPort.Index and so on.

6. Before you start a new business logic, you need to call XGate.Initialize (), PtlDevice.Initialize () to initialize the device,
this method will clear out unfinished commands, clears communications statistics, unlocks devices that may be locked, and empties possible content and status caches that may exist.

7. Enabling heartbeat can detect communication errors when the device is not engaged in business communications, but an error communication can also affect the polling time of the bus.

8. The AppearanceChanged event will be raised after the relevant unicast command has been successfully executed. Obtaining the current appearance information before this event is questioned, these appearance changes are not tracked because the broadcast and multicast commands that do not return values cannot guarantee the successful response of the device.

9. After you set up the XGate work parameter, you need to restart it to take it effect.

10. 示例（Example）：

Ptl900U ptl900U = new Ptl900U();
ptl900U.Address = 1;
ptl900U.MinorType = Ptl900UType.P24;
ptl900U.Pressed += this.ptl900U_Pressed;

XGate xgate = new XGate("192.168.0.10");
xgate.Buses[0].Devices.AddOrUpdate(ptl900U);
xgate.StartUnicastCommandQueue();

ptl900U.Initialize();

Display900UItem pickInfo = new Display900UItem();
pickInfo.SubLocation = 0xA1;
pickInfo.Count = 5;

ptl900U.Display(pickInfo, LightColor.Red, true);

Namespaces

Namespace | Description
Ptl.Device | 以 XGate、XConverter、XRelay 为中心管理着所有的设备及其通讯。
Ptl.Device.Communication | ModbusClient、SerialPortClient 以及 TcpTransparentClient 实现与设备的通讯。
Ptl.Device.Communication.Command | 设备控制时用到的枚举和基础类型。
Ptl.Device.Communication.Protocol | 下有多个子级命名空间分组定义了协议。
Ptl.Device.Communication.Protocol.Broadcast | 广播协议。
Ptl.Device.Communication.Protocol.Multicast | 组播协议。
Ptl.Device.Communication.Protocol.Unicast | 单播协议。
Ptl.Device.Communication.Protocol.XGateProtocols | XGate 协议。
Ptl.Device.Communication.XGateConfig | XGate 连接信息配置。
Ptl.Device.Communication.XGateSettings | XGate 的设置。
Ptl.Device.Log | 提供类库运行状态的记录功能。


Ptl.Device Namespace

[image]

Pick To Light 设备通讯类库
Ptl.Device Namespace
Send Feedback
以 XGate、XConverter、XRelay 为中心管理着所有的设备及其通讯。

Classes

 | Class | Description
Public class | CommunicationStatistics | 设备的通讯统计。
Public class | EventSubscriber | 为本类库中的事件订阅者记录处理异常。
Public class | EventThreadConfiguration | 提供对回调事件的线程模型配置。
Public class | InputPortStatusChangedEventArgs | 输入口状态改变事件的事件参数。
Public class | InstallProject | 表示一个安装工程，记录着设备的安装状况。
Public class | IOPort | Ptl 设备上的输入输出口。
Public class | IOPortCollection<(Of <(<'T>)>)> | 输入输出口集合。
Public class | Lighthouse | 灯塔输出口。
Public class | LighthouseAppearance | 灯塔的外观。
Public class | Ptl600U | 文本标签，常用于发布操作指示信息。
Public class | Ptl600UAppearance | 文本标签的外观。
Public class | Ptl900U | 拣货标签，有 数量 概念。
Public class | Ptl900UAppearance | 拣货标签的外观。
Public class | Ptl900UPressedEventArgs | 为 Ptl900U.Pressed 事件提供事件参数。
Public class | PtlDevice | PTL 设备的基类。
Public class | PtlDeviceCollection | RS485Bus 下的设备集合；同一 RS485Bus 下的 PtlDevice.Address 是唯一的。
Public class | PtlDeviceErrorEventArgs | 设备错误事件的事件参数。
Public class | PtlDeviceExecuteProtocolEventArgs | 设备协议被成功执行事件的事件参数。
Public class | PtlIOPort | 提供扫描枪和灯塔的接入和控制功能。
Public class | PtlIOPortWith600U | 提供扫描枪、灯塔、600U 的接入和控制。
Public class | PtlMXP1O5 | 提供扫描枪、灯塔、600U 的接入和控制。
Public class | PtlTera | 多灯指示型标签。
Public class | PtlTeraAppearance | Tera 的外观。
Public class | PtlXDO10RFID | 提供 RFID、灯塔、600U 的接入和控制。
Public class | PtlXIOPort | 提供扫描枪和灯塔的接入和控制功能；灯塔不支持闪烁。
Public class | PtlXMatrixPort | 提供扫描枪、600U 的接入和控制。
Public class | RS485Bus | RS485 总线，上可挂接多个设备。
Public class | RS485BusCollection | XGate 中的 RS485 总线集合。
Public class | ScannedBarcodeEventArgs | 为 Scanner.ScannedBarcode 事件提供事件参数。
Public class | Scanner | 扫描枪输入口。
Public class | UnhandledEventExceptionEventArgs | 为 EventSubscriber.UnhandledException 事件提供事件参数。
Public class | XConverter | RS232 与 RS485 协议转换器，连接单条 RS485 总线。
Public class | XGate | Modbus TCP 与 Modbus RTU/ASCII 协议转换器，可接插多条 RS485 总线。
Public class | XGateAppearance | XGate 的外观。
Public class | XGateCollection | XGate 集合。
Public class | XRelay | TCP-RS232/485 透传中继器，连接单条 RS485 总线。

Enumerations

 | Enumeration | Description
Public enumeration | EventThreadMode | 事件的线程模式。
Public enumeration | Ptl600UType | Ptl600U 的类型。
Public enumeration | Ptl900UType | Ptl900U 的类型。
Public enumeration | PtlDeviceType | PTL 设备类型。
Public enumeration | PtlMXP1O5Type | MXP1O5 的类型。
Public enumeration | PtlTeraType | Tera 的类型。
Public enumeration | PtlXDO10RFIDType | XDO10RFID 的类型。
Public enumeration | PtlXIOPortType | PtlXIOPort 的类型。
Public enumeration | PtlXMatrixPortType | PtlXMatrixPort 的类型。


CommunicationStatistics Class

[image]

Pick To Light 设备通讯类库
CommunicationStatistics Class
Members See Also Send Feedback
设备的通讯统计。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class CommunicationStatistics : IXmlSerializable
Visual Basic
<SerializableAttribute>
Public Class CommunicationStatistics
    Implements IXmlSerializable

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..CommunicationStatistics

See Also

CommunicationStatistics Members
Ptl.Device Namespace


CommunicationStatistics Members

[image] [image]

Pick To Light 设备通讯类库
CommunicationStatistics Members
CommunicationStatistics Class Constructors Methods Properties See Also Send Feedback

The CommunicationStatistics type exposes the following members.

Constructors

 | Name | Description
Public method | CommunicationStatistics | Initializes a new instance of the CommunicationStatistics class

Methods

 | Name | Description
Public method | Add(Boolean, Int32) | 添加通讯统计信息。
Public method | Add(Boolean, TimeSpan) | 添加通讯统计信息。
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | Merge | 将给定的统计信息与当前信息合并。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | WriteXml | 将对象转换为其 XML 表示形式。

Properties

 | Name | Description
Public property | FailedCountByMilliseconds | 获取按通讯耗时分组的失败次数。
Public property | SuccessfulCountByMilliseconds | 获取按通讯耗时分组的成功次数。
Public property | SyncRoot | 获取集合访问同步根。
Public property | TotalCount | 获取通信总次数。
Public property | TotalFailedCount | 获取通信失败总次数。
Public property | TotalSuccessfulCount | 获取成功通信总次数。

See Also

CommunicationStatistics Class


CommunicationStatistics Constructor

[image]

Pick To Light 设备通讯类库
CommunicationStatistics Constructor
CommunicationStatistics Class See Also Send Feedback
Initializes a new instance of the CommunicationStatistics class

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public CommunicationStatistics()
Visual Basic
Public Sub New

See Also

CommunicationStatistics Class
CommunicationStatistics Members


CommunicationStatistics Methods

[image] [image]

Pick To Light 设备通讯类库
CommunicationStatistics Methods
CommunicationStatistics Class See Also Send Feedback

The CommunicationStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Add(Boolean, Int32) | 添加通讯统计信息。
Public method | Add(Boolean, TimeSpan) | 添加通讯统计信息。
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | Merge | 将给定的统计信息与当前信息合并。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | WriteXml | 将对象转换为其 XML 表示形式。

See Also

CommunicationStatistics Class


CommunicationStatistics.Add Method

[image] [image]

Pick To Light 设备通讯类库
CommunicationStatistics..::..Add Method
CommunicationStatistics Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(Boolean, Int32) | 添加通讯统计信息。
Public method | Add(Boolean, TimeSpan) | 添加通讯统计信息。

See Also

CommunicationStatistics Class
CommunicationStatistics Members


CommunicationStatistics.Add Method (Boolean, Int32)

[image]

Pick To Light 设备通讯类库
CommunicationStatistics..::..Add Method (Boolean, Int32)
CommunicationStatistics Class See Also Send Feedback
添加通讯统计信息。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Add(
    bool successful,
    int milliseconds
)
Visual Basic
Public Sub Add (
    successful As Boolean,
    milliseconds As Integer
)

Parameters

successful
Type: System..::..Boolean
是否成功的通讯。
milliseconds
Type: System..::..Int32
耗时。

See Also

CommunicationStatistics Class
CommunicationStatistics Members
Add Overload


CommunicationStatistics.Add Method (Boolean, TimeSpan)

[image]

Pick To Light 设备通讯类库
CommunicationStatistics..::..Add Method (Boolean, TimeSpan)
CommunicationStatistics Class See Also Send Feedback
添加通讯统计信息。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Add(
    bool successful,
    TimeSpan span
)
Visual Basic
Public Sub Add (
    successful As Boolean,
    span As TimeSpan
)

Parameters

successful
Type: System..::..Boolean
是否成功的通讯。
span
Type: System..::..TimeSpan
耗时。

See Also

CommunicationStatistics Class
CommunicationStatistics Members
Add Overload


CommunicationStatistics.GetSchema Method

[image]

Pick To Light 设备通讯类库
CommunicationStatistics..::..GetSchema Method
CommunicationStatistics Class See Also Send Feedback
此方法是保留方法，请不要使用。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XmlSchema GetSchema()
Visual Basic
Public Function GetSchema As XmlSchema

Return Value

Type: XmlSchema
始终返回空。

Implements

IXmlSerializable..::..GetSchema()()()()

See Also

CommunicationStatistics Class
CommunicationStatistics Members


CommunicationStatistics.Merge Method

[image]

Pick To Light 设备通讯类库
CommunicationStatistics..::..Merge Method
CommunicationStatistics Class See Also Send Feedback
将给定的统计信息与当前信息合并。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Merge(
    CommunicationStatistics another
)
Visual Basic
Public Sub Merge (
    another As CommunicationStatistics
)

Parameters

another
Type: Ptl.Device..::..CommunicationStatistics
待合并的统计信息。

See Also

CommunicationStatistics Class
CommunicationStatistics Members


CommunicationStatistics.ReadXml Method

[image]

Pick To Light 设备通讯类库
CommunicationStatistics..::..ReadXml Method
CommunicationStatistics Class See Also Send Feedback
从对象的 XML 表示形式生成该对象。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void ReadXml(
    XmlReader reader
)
Visual Basic
Public Sub ReadXml (
    reader As XmlReader
)

Parameters

reader
Type: System.Xml..::..XmlReader
对象从中进行反序列化的 System.Xml.XmlReader 流。

Implements

IXmlSerializable..::..ReadXml(XmlReader)

Exceptions

Exception | Condition
System..::..ArgumentNullException | reader 为空。

See Also

CommunicationStatistics Class
CommunicationStatistics Members


CommunicationStatistics.WriteXml Method

[image]

Pick To Light 设备通讯类库
CommunicationStatistics..::..WriteXml Method
CommunicationStatistics Class See Also Send Feedback
将对象转换为其 XML 表示形式。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void WriteXml(
    XmlWriter writer
)
Visual Basic
Public Sub WriteXml (
    writer As XmlWriter
)

Parameters

writer
Type: System.Xml..::..XmlWriter
对象要序列化为的 System.Xml.XmlWriter 流。

Implements

IXmlSerializable..::..WriteXml(XmlWriter)

Exceptions

Exception | Condition
System..::..ArgumentNullException | writer 为空。

See Also

CommunicationStatistics Class
CommunicationStatistics Members


CommunicationStatistics Properties

[image] [image]

Pick To Light 设备通讯类库
CommunicationStatistics Properties
CommunicationStatistics Class See Also Send Feedback

The CommunicationStatistics type exposes the following members.

Properties

 | Name | Description
Public property | FailedCountByMilliseconds | 获取按通讯耗时分组的失败次数。
Public property | SuccessfulCountByMilliseconds | 获取按通讯耗时分组的成功次数。
Public property | SyncRoot | 获取集合访问同步根。
Public property | TotalCount | 获取通信总次数。
Public property | TotalFailedCount | 获取通信失败总次数。
Public property | TotalSuccessfulCount | 获取成功通信总次数。

See Also

CommunicationStatistics Class


CommunicationStatistics.FailedCountByMilliseconds Property

[image]

Pick To Light 设备通讯类库
CommunicationStatistics..::..FailedCountByMilliseconds Property
CommunicationStatistics Class See Also Send Feedback
获取按通讯耗时分组的失败次数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public SortedDictionary<int, long> FailedCountByMilliseconds { get; }
Visual Basic
Public ReadOnly Property FailedCountByMilliseconds As SortedDictionary(Of Integer, Long)
    Get

Property Value

Type: SortedDictionary <(Of <(<' Int32, Int64 >)>)>

See Also

CommunicationStatistics Class
CommunicationStatistics Members


CommunicationStatistics.SuccessfulCountByMilliseconds Property

[image]

Pick To Light 设备通讯类库
CommunicationStatistics..::..SuccessfulCountByMilliseconds Property
CommunicationStatistics Class See Also Send Feedback
获取按通讯耗时分组的成功次数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public SortedDictionary<int, long> SuccessfulCountByMilliseconds { get; }
Visual Basic
Public ReadOnly Property SuccessfulCountByMilliseconds As SortedDictionary(Of Integer, Long)
    Get

Property Value

Type: SortedDictionary <(Of <(<' Int32, Int64 >)>)>

See Also

CommunicationStatistics Class
CommunicationStatistics Members


CommunicationStatistics.SyncRoot Property

[image]

Pick To Light 设备通讯类库
CommunicationStatistics..::..SyncRoot Property
CommunicationStatistics Class See Also Send Feedback
获取集合访问同步根。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get

Property Value

Type: Object

See Also

CommunicationStatistics Class
CommunicationStatistics Members


CommunicationStatistics.TotalCount Property

[image]

Pick To Light 设备通讯类库
CommunicationStatistics..::..TotalCount Property
CommunicationStatistics Class See Also Send Feedback
获取通信总次数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public long TotalCount { get; }
Visual Basic
Public ReadOnly Property TotalCount As Long
    Get

Property Value

Type: Int64

See Also

CommunicationStatistics Class
CommunicationStatistics Members


CommunicationStatistics.TotalFailedCount Property

[image]

Pick To Light 设备通讯类库
CommunicationStatistics..::..TotalFailedCount Property
CommunicationStatistics Class See Also Send Feedback
获取通信失败总次数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public long TotalFailedCount { get; }
Visual Basic
Public ReadOnly Property TotalFailedCount As Long
    Get

Property Value

Type: Int64

See Also

CommunicationStatistics Class
CommunicationStatistics Members


CommunicationStatistics.TotalSuccessfulCount Property

[image]

Pick To Light 设备通讯类库
CommunicationStatistics..::..TotalSuccessfulCount Property
CommunicationStatistics Class See Also Send Feedback
获取成功通信总次数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public long TotalSuccessfulCount { get; }
Visual Basic
Public ReadOnly Property TotalSuccessfulCount As Long
    Get

Property Value

Type: Int64

See Also

CommunicationStatistics Class
CommunicationStatistics Members


EventSubscriber Class

[image]

Pick To Light 设备通讯类库
EventSubscriber Class
Members See Also Send Feedback
为本类库中的事件订阅者记录处理异常。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static class EventSubscriber
Visual Basic
Public NotInheritable Class EventSubscriber

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..EventSubscriber

See Also

EventSubscriber Members


EventSubscriber Members

[image] [image]

Pick To Light 设备通讯类库
EventSubscriber Members
EventSubscriber Class Methods Events See Also Send Feedback

The EventSubscriber type exposes the following members.

Methods

Name | Description
OnUnhandledException | 引发未捕获异常事件，捕获本事件的处理程序引发的异常。

Events

Name | Description
UnhandledException | 在其他事件的订阅者未捕获异常时发生；会捕获本事件的处理程序引发的异常。

See Also

EventSubscriber Class


EventSubscriber Methods

[image] [image]

Pick To Light 设备通讯类库
EventSubscriber Methods
EventSubscriber Class See Also Send Feedback

The EventSubscriber type exposes the following members.

Methods

Name | Description
OnUnhandledException | 引发未捕获异常事件，捕获本事件的处理程序引发的异常。

See Also

EventSubscriber Class


EventSubscriber.OnUnhandledException Method

[image]

Pick To Light 设备通讯类库
EventSubscriber..::..OnUnhandledException Method
EventSubscriber Class See Also Send Feedback
引发未捕获异常事件，捕获本事件的处理程序引发的异常。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static void OnUnhandledException(
    UnhandledEventExceptionEventArgs e
)
Visual Basic
Public Shared Sub OnUnhandledException (
    e As UnhandledEventExceptionEventArgs
)

Parameters

e
Type: Ptl.Device..::..UnhandledEventExceptionEventArgs
事件参数。

Exceptions

Exception | Condition
System..::..ArgumentNullException | e 为空。

See Also

EventSubscriber Class
EventSubscriber Members


EventSubscriber Events

[image] [image]

Pick To Light 设备通讯类库
EventSubscriber Events
EventSubscriber Class See Also Send Feedback

The EventSubscriber type exposes the following members.

Events

Name | Description
UnhandledException | 在其他事件的订阅者未捕获异常时发生；会捕获本事件的处理程序引发的异常。

See Also

EventSubscriber Class


EventSubscriber.UnhandledException Event

[image]

Pick To Light 设备通讯类库
EventSubscriber..::..UnhandledException Event
EventSubscriber Class See Also Send Feedback
在其他事件的订阅者未捕获异常时发生；会捕获本事件的处理程序引发的异常。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static event EventHandler<UnhandledEventExceptionEventArgs> UnhandledException
Visual Basic
Public Shared Event UnhandledException As EventHandler(Of UnhandledEventExceptionEventArgs)

Value

Type: System..::..EventHandler <(Of <(<' UnhandledEventExceptionEventArgs >)>)>

See Also

EventSubscriber Class
EventSubscriber Members


EventThreadConfiguration Class

[image]

Pick To Light 设备通讯类库
EventThreadConfiguration Class
Members See Also Send Feedback
提供对回调事件的线程模型配置。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static class EventThreadConfiguration
Visual Basic
Public NotInheritable Class EventThreadConfiguration

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..EventThreadConfiguration

See Also

EventThreadConfiguration Members


EventThreadConfiguration Members

[image] [image]

Pick To Light 设备通讯类库
EventThreadConfiguration Members
EventThreadConfiguration Class Properties See Also Send Feedback

The EventThreadConfiguration type exposes the following members.

Properties

Name | Description
Mode | 获取或设置回调事件的线程模型。

See Also

EventThreadConfiguration Class


EventThreadConfiguration Properties

[image] [image]

Pick To Light 设备通讯类库
EventThreadConfiguration Properties
EventThreadConfiguration Class See Also Send Feedback

The EventThreadConfiguration type exposes the following members.

Properties

Name | Description
Mode | 获取或设置回调事件的线程模型。

See Also

EventThreadConfiguration Class


EventThreadConfiguration.Mode Property

[image]

Pick To Light 设备通讯类库
EventThreadConfiguration..::..Mode Property
EventThreadConfiguration Class See Also Send Feedback
获取或设置回调事件的线程模型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static EventThreadMode Mode { get; set; }
Visual Basic
Public Shared Property Mode As EventThreadMode
    Get
    Set

Property Value

Type: EventThreadMode

See Also

EventThreadConfiguration Class
EventThreadConfiguration Members


EventThreadMode Enumeration

[image]

Pick To Light 设备通讯类库
EventThreadMode Enumeration
See Also Send Feedback
事件的线程模式。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum EventThreadMode
Visual Basic
Public Enumeration EventThreadMode

Members

Member name | Value | Description
CommunicationThread | 0 | 在通讯线程引发；阻塞通讯。
RandomThread | 1 | 使用随机的线程池线程引发；异步无序。
IsolatedThread | 2 | 使用某独立线程引发；排队、不阻塞通讯。
CurrentThread | 3 | 使用当前线程引发；排队、不阻塞通讯。

See Also


InputPortStatusChangedEventArgs Class

[image]

Pick To Light 设备通讯类库
InputPortStatusChangedEventArgs Class
Members See Also Send Feedback
输入口状态改变事件的事件参数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class InputPortStatusChangedEventArgs : EventArgs
Visual Basic
<SerializableAttribute>
Public Class InputPortStatusChangedEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Ptl.Device..::..InputPortStatusChangedEventArgs

See Also

InputPortStatusChangedEventArgs Members


InputPortStatusChangedEventArgs Members

[image] [image]

Pick To Light 设备通讯类库
InputPortStatusChangedEventArgs Members
InputPortStatusChangedEventArgs Class Constructors Properties See Also Send Feedback

The InputPortStatusChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | InputPortStatusChangedEventArgs | Initializes a new instance of the InputPortStatusChangedEventArgs class

Properties

 | Name | Description
Public property | Index | 获取或设置基于 0 的索引。
Public property | Status | 获取或设置状态。

See Also

InputPortStatusChangedEventArgs Class


InputPortStatusChangedEventArgs Constructor

[image]

Pick To Light 设备通讯类库
InputPortStatusChangedEventArgs Constructor
InputPortStatusChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the InputPortStatusChangedEventArgs class

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public InputPortStatusChangedEventArgs()
Visual Basic
Public Sub New

See Also

InputPortStatusChangedEventArgs Class
InputPortStatusChangedEventArgs Members


InputPortStatusChangedEventArgs Properties

[image] [image]

Pick To Light 设备通讯类库
InputPortStatusChangedEventArgs Properties
InputPortStatusChangedEventArgs Class See Also Send Feedback

The InputPortStatusChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Index | 获取或设置基于 0 的索引。
Public property | Status | 获取或设置状态。

See Also

InputPortStatusChangedEventArgs Class


InputPortStatusChangedEventArgs.Index Property

[image]

Pick To Light 设备通讯类库
InputPortStatusChangedEventArgs..::..Index Property
InputPortStatusChangedEventArgs Class See Also Send Feedback
获取或设置基于 0 的索引。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte Index { get; set; }
Visual Basic
Public Property Index As Byte
    Get
    Set

Property Value

Type: Byte

See Also

InputPortStatusChangedEventArgs Class
InputPortStatusChangedEventArgs Members


InputPortStatusChangedEventArgs.Status Property

[image]

Pick To Light 设备通讯类库
InputPortStatusChangedEventArgs..::..Status Property
InputPortStatusChangedEventArgs Class See Also Send Feedback
获取或设置状态。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

InputPortStatusChangedEventArgs Class
InputPortStatusChangedEventArgs Members


InstallProject Class

[image]

Pick To Light 设备通讯类库
InstallProject Class
Members See Also Send Feedback
表示一个安装工程，记录着设备的安装状况。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class InstallProject
Visual Basic
<SerializableAttribute>
Public Class InstallProject

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..InstallProject

See Also

InstallProject Members


InstallProject Members

[image] [image]

Pick To Light 设备通讯类库
InstallProject Members
InstallProject Class Constructors Properties See Also Send Feedback

The InstallProject type exposes the following members.

Constructors

 | Name | Description
Public method | InstallProject | Initializes a new instance of the InstallProject class

Properties

 | Name | Description
Public property | Description | 获取或设置描述。
Public property | HeartbeatGenerator | 获取设备心跳发生器。
Public property | Name | 获取或设置名称。
Public property | XGates | 获取或设置控制器集合。

See Also

InstallProject Class


InstallProject Constructor

[image]

Pick To Light 设备通讯类库
InstallProject Constructor
InstallProject Class See Also Send Feedback
Initializes a new instance of the InstallProject class

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public InstallProject()
Visual Basic
Public Sub New

See Also

InstallProject Class
InstallProject Members


InstallProject Properties

[image] [image]

Pick To Light 设备通讯类库
InstallProject Properties
InstallProject Class See Also Send Feedback

The InstallProject type exposes the following members.

Properties

 | Name | Description
Public property | Description | 获取或设置描述。
Public property | HeartbeatGenerator | 获取设备心跳发生器。
Public property | Name | 获取或设置名称。
Public property | XGates | 获取或设置控制器集合。

See Also

InstallProject Class


InstallProject.Description Property

[image]

Pick To Light 设备通讯类库
InstallProject..::..Description Property
InstallProject Class See Also Send Feedback
获取或设置描述。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

InstallProject Class
InstallProject Members


InstallProject.HeartbeatGenerator Property

[image]

Pick To Light 设备通讯类库
InstallProject..::..HeartbeatGenerator Property
InstallProject Class See Also Send Feedback
获取设备心跳发生器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public HeartbeatGenerator HeartbeatGenerator { get; }
Visual Basic
Public ReadOnly Property HeartbeatGenerator As HeartbeatGenerator
    Get

Property Value

Type: HeartbeatGenerator

See Also

InstallProject Class
InstallProject Members


InstallProject.Name Property

[image]

Pick To Light 设备通讯类库
InstallProject..::..Name Property
InstallProject Class See Also Send Feedback
获取或设置名称。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

See Also

InstallProject Class
InstallProject Members


InstallProject.XGates Property

[image]

Pick To Light 设备通讯类库
InstallProject..::..XGates Property
InstallProject Class See Also Send Feedback
获取或设置控制器集合。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGateCollection XGates { get; set; }
Visual Basic
Public Property XGates As XGateCollection
    Get
    Set

Property Value

Type: XGateCollection

Exceptions

Exception | Condition
System..::..ArgumentNullException | 设置时使用空值。

See Also

InstallProject Class
InstallProject Members


IOPort Class

[image]

Pick To Light 设备通讯类库
IOPort Class
Members See Also Send Feedback
Ptl 设备上的输入输出口。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public abstract class IOPort
Visual Basic
<SerializableAttribute>
Public MustInherit Class IOPort

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..IOPort
Ptl.Device..::..Lighthouse
Ptl.Device..::..Scanner

See Also

IOPort Members


IOPort Members

[image] [image]

Pick To Light 设备通讯类库
IOPort Members
IOPort Class Constructors Methods Properties Events See Also Send Feedback

The IOPort type exposes the following members.

Constructors

 | Name | Description
Protected method | IOPort | Initializes a new instance of the IOPort class

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列。
Public method | Initialize | 清空未完成协议以及清空可能存在的显示内容和状态缓存。
Protected method | OnAppearanceChanged | 引发端口的当前外观更改事件。
Public method | PerformAppearanceChanged | 引发端口的当前外观更改事件。
Public method | Refresh | 刷新显示。

Properties

 | Name | Description
Public property | CommandCount | 获取队列中未完成的命令数。
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。
Public property | Index | 获取或设置端口序号。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。
Public property | Owner | 获取或设置所属 Ptl 设备。
Public property | Tag | 获取或设置相关联数据。

Events

 | Name | Description
Public event | AppearanceChanged | 端口的当前外观更改事件。

See Also

IOPort Class


IOPort Constructor

[image]

Pick To Light 设备通讯类库
IOPort Constructor
IOPort Class See Also Send Feedback
Initializes a new instance of the IOPort class

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected IOPort()
Visual Basic
Protected Sub New

See Also

IOPort Class
IOPort Members


IOPort Methods

[image] [image]

Pick To Light 设备通讯类库
IOPort Methods
IOPort Class See Also Send Feedback

The IOPort type exposes the following members.

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列。
Public method | Initialize | 清空未完成协议以及清空可能存在的显示内容和状态缓存。
Protected method | OnAppearanceChanged | 引发端口的当前外观更改事件。
Public method | PerformAppearanceChanged | 引发端口的当前外观更改事件。
Public method | Refresh | 刷新显示。

See Also

IOPort Class


IOPort.ClearCommandQueue Method

[image]

Pick To Light 设备通讯类库
IOPort..::..ClearCommandQueue Method
IOPort Class See Also Send Feedback
清空协议队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void ClearCommandQueue()
Visual Basic
Public Overridable Sub ClearCommandQueue

See Also

IOPort Class
IOPort Members


IOPort.Initialize Method

[image]

Pick To Light 设备通讯类库
IOPort..::..Initialize Method
IOPort Class See Also Send Feedback
清空未完成协议以及清空可能存在的显示内容和状态缓存。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Initialize()
Visual Basic
Public Overridable Sub Initialize

See Also

IOPort Class
IOPort Members


IOPort.OnAppearanceChanged Method

[image]

Pick To Light 设备通讯类库
IOPort..::..OnAppearanceChanged Method
IOPort Class See Also Send Feedback
引发端口的当前外观更改事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void OnAppearanceChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnAppearanceChanged (
    e As EventArgs
)

Parameters

e
Type: System..::..EventArgs
事件参数。

See Also

IOPort Class
IOPort Members


IOPort.PerformAppearanceChanged Method

[image]

Pick To Light 设备通讯类库
IOPort..::..PerformAppearanceChanged Method
IOPort Class See Also Send Feedback
引发端口的当前外观更改事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void PerformAppearanceChanged()
Visual Basic
Public Sub PerformAppearanceChanged

See Also

IOPort Class
IOPort Members


IOPort.Refresh Method

[image]

Pick To Light 设备通讯类库
IOPort..::..Refresh Method
IOPort Class See Also Send Feedback
刷新显示。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Refresh()
Visual Basic
Public Overridable Sub Refresh

See Also

IOPort Class
IOPort Members


IOPort Properties

[image] [image]

Pick To Light 设备通讯类库
IOPort Properties
IOPort Class See Also Send Feedback

The IOPort type exposes the following members.

Properties

 | Name | Description
Public property | CommandCount | 获取队列中未完成的命令数。
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。
Public property | Index | 获取或设置端口序号。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。
Public property | Owner | 获取或设置所属 Ptl 设备。
Public property | Tag | 获取或设置相关联数据。

See Also

IOPort Class


IOPort.CommandCount Property

[image]

Pick To Light 设备通讯类库
IOPort..::..CommandCount Property
IOPort Class See Also Send Feedback
获取队列中未完成的命令数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual int CommandCount { get; }
Visual Basic
Public Overridable ReadOnly Property CommandCount As Integer
    Get

Property Value

Type: Int32

See Also

IOPort Class
IOPort Members


IOPort.CommandQueueSyncRoot Property

[image]

Pick To Light 设备通讯类库
IOPort..::..CommandQueueSyncRoot Property
IOPort Class See Also Send Feedback
获取协议队列的同步根。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected Object CommandQueueSyncRoot { get; }
Visual Basic
Protected ReadOnly Property CommandQueueSyncRoot As Object
    Get

Property Value

Type: Object

See Also

IOPort Class
IOPort Members


IOPort.CommunicateSyncRoot Property

[image]

Pick To Light 设备通讯类库
IOPort..::..CommunicateSyncRoot Property
IOPort Class See Also Send Feedback
获取通讯操作的同步根。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected Object CommunicateSyncRoot { get; }
Visual Basic
Protected ReadOnly Property CommunicateSyncRoot As Object
    Get

Property Value

Type: Object

See Also

IOPort Class
IOPort Members


IOPort.Index Property

[image]

Pick To Light 设备通讯类库
IOPort..::..Index Property
IOPort Class See Also Send Feedback
获取或设置端口序号。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual byte Index { get; set; }
Visual Basic
Public Overridable Property Index As Byte
    Get
    Set

Property Value

Type: Byte

See Also

IOPort Class
IOPort Members


IOPort.NormalCommandQueue Property

[image]

Pick To Light 设备通讯类库
IOPort..::..NormalCommandQueue Property
IOPort Class See Also Send Feedback
获取 非加锁解锁协议 队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected Collection<CommandBase> NormalCommandQueue { get; }
Visual Basic
Protected ReadOnly Property NormalCommandQueue As Collection(Of CommandBase)
    Get

Property Value

Type: Collection <(Of <(<' CommandBase >)>)>

See Also

IOPort Class
IOPort Members


IOPort.Owner Property

[image]

Pick To Light 设备通讯类库
IOPort..::..Owner Property
IOPort Class See Also Send Feedback
获取或设置所属 Ptl 设备。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual PtlDevice Owner { get; set; }
Visual Basic
Public Overridable Property Owner As PtlDevice
    Get
    Set

Property Value

Type: PtlDevice

See Also

IOPort Class
IOPort Members


IOPort.Tag Property

[image]

Pick To Light 设备通讯类库
IOPort..::..Tag Property
IOPort Class See Also Send Feedback
获取或设置相关联数据。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Object Tag { get; set; }
Visual Basic
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object

See Also

IOPort Class
IOPort Members


IOPort Events

[image] [image]

Pick To Light 设备通讯类库
IOPort Events
IOPort Class See Also Send Feedback

The IOPort type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | 端口的当前外观更改事件。

See Also

IOPort Class


IOPort.AppearanceChanged Event

[image]

Pick To Light 设备通讯类库
IOPort..::..AppearanceChanged Event
IOPort Class See Also Send Feedback
端口的当前外观更改事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public event EventHandler AppearanceChanged
Visual Basic
Public Event AppearanceChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

IOPort Class
IOPort Members


IOPortCollection(T) Class

[image]

Pick To Light 设备通讯类库
IOPortCollection<(Of <(<'T>)>)> Class
Members See Also Send Feedback
输入输出口集合。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class IOPortCollection<T> : IEnumerable<T>,
    IEnumerable, IXmlSerializable
where T : new(), IOPort
Visual Basic
<SerializableAttribute>
Public Class IOPortCollection(Of T As {New, IOPort})
    Implements IEnumerable(Of T), IEnumerable, IXmlSerializable

Type Parameters

T
具体的输入或输出口。

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..IOPortCollection<(Of <(<'T>)>)>

See Also

IOPortCollection<(Of <(<'T>)>)> Members


IOPortCollection(T) Members

[image] [image]

Pick To Light 设备通讯类库
IOPortCollection<(Of <(<'T>)>)> Members
IOPortCollection<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The IOPortCollection<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | IOPortCollection<(Of <(<'T>)>)>()()()() | 初始化 空 输入输出口集合。
Public method | IOPortCollection<(Of <(<'T>)>)>(PtlDevice, Byte) | 初始化 RS485 总线集合。

Methods

 | Name | Description
Public method | GetEnumerator | 获取迭代器。
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | WriteXml | 将对象转换为其 XML 表示形式。

Properties

 | Name | Description
Public property | Count | 获取集合的大小。
Public property | Item | 按站点号获取设备。

See Also

IOPortCollection<(Of <(<'T>)>)> Class


IOPortCollection(T) Constructor

[image] [image]

Pick To Light 设备通讯类库
IOPortCollection<(Of <(<'T>)>)> Constructor
IOPortCollection<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IOPortCollection<(Of <(<'T>)>)>()()()() | 初始化 空 输入输出口集合。
Public method | IOPortCollection<(Of <(<'T>)>)>(PtlDevice, Byte) | 初始化 RS485 总线集合。

See Also

IOPortCollection<(Of <(<'T>)>)> Class
IOPortCollection<(Of <(<'T>)>)> Members


IOPortCollection(T) Constructor

[image]

Pick To Light 设备通讯类库
IOPortCollection<(Of <(<'T>)>)> Constructor
IOPortCollection<(Of <(<'T>)>)> Class See Also Send Feedback
初始化 空 输入输出口集合。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public IOPortCollection()
Visual Basic
Public Sub New

See Also

IOPortCollection<(Of <(<'T>)>)> Class
IOPortCollection<(Of <(<'T>)>)> Members
IOPortCollection<(Of <(<'T>)>)> Overload


IOPortCollection(T) Constructor (PtlDevice, Byte)

[image]

Pick To Light 设备通讯类库
IOPortCollection<(Of <(<'T>)>)> Constructor (PtlDevice, Byte)
IOPortCollection<(Of <(<'T>)>)> Class See Also Send Feedback
初始化 RS485 总线集合。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public IOPortCollection(
    PtlDevice owner,
    byte count
)
Visual Basic
Public Sub New (
    owner As PtlDevice,
    count As Byte
)

Parameters

owner
Type: Ptl.Device..::..PtlDevice
宿主设备。
count
Type: System..::..Byte
集合大小。

Exceptions

Exception | Condition
System..::..ArgumentNullException | owner 为空。

See Also

IOPortCollection<(Of <(<'T>)>)> Class
IOPortCollection<(Of <(<'T>)>)> Members
IOPortCollection<(Of <(<'T>)>)> Overload


IOPortCollection(T) Methods

[image] [image]

Pick To Light 设备通讯类库
IOPortCollection<(Of <(<'T>)>)> Methods
IOPortCollection<(Of <(<'T>)>)> Class See Also Send Feedback

The IOPortCollection<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator | 获取迭代器。
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | WriteXml | 将对象转换为其 XML 表示形式。

See Also

IOPortCollection<(Of <(<'T>)>)> Class


IOPortCollection(T).GetEnumerator Method

[image]

Pick To Light 设备通讯类库
IOPortCollection<(Of <(<'T>)>)>..::..GetEnumerator Method
IOPortCollection<(Of <(<'T>)>)> Class See Also Send Feedback
获取迭代器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public IEnumerator<T> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of T)

Return Value

Type: IEnumerator <(Of <(<' T >)>)>
可用于按序号正序循环访问集合的 System.Collections.Generic.IEnumerator<T>。

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

IOPortCollection<(Of <(<'T>)>)> Class
IOPortCollection<(Of <(<'T>)>)> Members


IOPortCollection(T).GetSchema Method

[image]

Pick To Light 设备通讯类库
IOPortCollection<(Of <(<'T>)>)>..::..GetSchema Method
IOPortCollection<(Of <(<'T>)>)> Class See Also Send Feedback
此方法是保留方法，请不要使用。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XmlSchema GetSchema()
Visual Basic
Public Function GetSchema As XmlSchema

Return Value

Type: XmlSchema
始终返回空。

Implements

IXmlSerializable..::..GetSchema()()()()

See Also

IOPortCollection<(Of <(<'T>)>)> Class
IOPortCollection<(Of <(<'T>)>)> Members


IOPortCollection(T).ReadXml Method

[image]

Pick To Light 设备通讯类库
IOPortCollection<(Of <(<'T>)>)>..::..ReadXml Method
IOPortCollection<(Of <(<'T>)>)> Class See Also Send Feedback
从对象的 XML 表示形式生成该对象。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void ReadXml(
    XmlReader reader
)
Visual Basic
Public Sub ReadXml (
    reader As XmlReader
)

Parameters

reader
Type: System.Xml..::..XmlReader
对象从中进行反序列化的 System.Xml.XmlReader 流。

Implements

IXmlSerializable..::..ReadXml(XmlReader)

Exceptions

Exception | Condition
System..::..ArgumentNullException | reader 为空。

See Also

IOPortCollection<(Of <(<'T>)>)> Class
IOPortCollection<(Of <(<'T>)>)> Members


IOPortCollection(T).WriteXml Method

[image]

Pick To Light 设备通讯类库
IOPortCollection<(Of <(<'T>)>)>..::..WriteXml Method
IOPortCollection<(Of <(<'T>)>)> Class See Also Send Feedback
将对象转换为其 XML 表示形式。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void WriteXml(
    XmlWriter writer
)
Visual Basic
Public Sub WriteXml (
    writer As XmlWriter
)

Parameters

writer
Type: System.Xml..::..XmlWriter
对象要序列化为的 System.Xml.XmlWriter 流。

Implements

IXmlSerializable..::..WriteXml(XmlWriter)

Exceptions

Exception | Condition
System..::..ArgumentNullException | writer 为空。

See Also

IOPortCollection<(Of <(<'T>)>)> Class
IOPortCollection<(Of <(<'T>)>)> Members


IOPortCollection(T) Properties

[image] [image]

Pick To Light 设备通讯类库
IOPortCollection<(Of <(<'T>)>)> Properties
IOPortCollection<(Of <(<'T>)>)> Class See Also Send Feedback

The IOPortCollection<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Count | 获取集合的大小。
Public property | Item | 按站点号获取设备。

See Also

IOPortCollection<(Of <(<'T>)>)> Class


IOPortCollection(T).Count Property

[image]

Pick To Light 设备通讯类库
IOPortCollection<(Of <(<'T>)>)>..::..Count Property
IOPortCollection<(Of <(<'T>)>)> Class See Also Send Feedback
获取集合的大小。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

See Also

IOPortCollection<(Of <(<'T>)>)> Class
IOPortCollection<(Of <(<'T>)>)> Members


IOPortCollection(T).Item Property

[image]

Pick To Light 设备通讯类库
IOPortCollection<(Of <(<'T>)>)>..::..Item Property
IOPortCollection<(Of <(<'T>)>)> Class See Also Send Feedback
按站点号获取设备。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public T this[
    byte index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Byte
) As T
    Get

Parameters

index
Type: System..::..Byte
基于 0 的端口索引。

Property Value

Type: T

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index 大于等于集合大小。

See Also

IOPortCollection<(Of <(<'T>)>)> Class
IOPortCollection<(Of <(<'T>)>)> Members


Lighthouse Class

[image]

Pick To Light 设备通讯类库
Lighthouse Class
Members See Also Send Feedback
灯塔输出口。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class Lighthouse : IOPort
Visual Basic
<SerializableAttribute>
Public Class Lighthouse
    Inherits IOPort

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..IOPort
Ptl.Device..::..Lighthouse

See Also

Lighthouse Members


Lighthouse Members

[image] [image]

Pick To Light 设备通讯类库
Lighthouse Members
Lighthouse Class Constructors Methods Properties Events See Also Send Feedback

The Lighthouse type exposes the following members.

Constructors

 | Name | Description
Public method | Lighthouse | Initializes a new instance of the Lighthouse class

Methods

 | Name | Description
Public method | Clear | 熄灭灯塔。
Public method | ClearCommandQueue | 清空协议队列。 (Inherited from IOPort.)
Public method | Display()()()() | 点亮灯塔。
Public method | Display(LightOnOffPeriod, LightOnOffRatio) | 点亮灯塔。
Public method | Initialize | 清空未完成协议以及清空可能存在的显示内容和状态缓存。 (Overrides IOPort..::..Initialize()()()().)
Protected method | OnAppearanceChanged | 引发端口的当前外观更改事件。 (Inherited from IOPort.)
Public method | PerformAppearanceChanged | 引发端口的当前外观更改事件。 (Inherited from IOPort.)
Public method | Refresh | 刷新显示。 (Overrides IOPort..::..Refresh()()()().)

Properties

 | Name | Description
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from IOPort.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from IOPort.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from IOPort.)
Public property | CurrentAppearance | 获取当前外观。
Public property | Index | 获取或设置端口序号。 (Inherited from IOPort.)
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from IOPort.)
Public property | Owner | 获取或设置所属 Ptl 设备。 (Inherited from IOPort.)
Public property | Tag | 获取或设置相关联数据。 (Inherited from IOPort.)

Events

 | Name | Description
Public event | AppearanceChanged | 端口的当前外观更改事件。 (Inherited from IOPort.)

See Also

Lighthouse Class


Lighthouse Constructor

[image]

Pick To Light 设备通讯类库
Lighthouse Constructor
Lighthouse Class See Also Send Feedback
Initializes a new instance of the Lighthouse class

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Lighthouse()
Visual Basic
Public Sub New

See Also

Lighthouse Class
Lighthouse Members


Lighthouse Methods

[image] [image]

Pick To Light 设备通讯类库
Lighthouse Methods
Lighthouse Class See Also Send Feedback

The Lighthouse type exposes the following members.

Methods

 | Name | Description
Public method | Clear | 熄灭灯塔。
Public method | ClearCommandQueue | 清空协议队列。 (Inherited from IOPort.)
Public method | Display()()()() | 点亮灯塔。
Public method | Display(LightOnOffPeriod, LightOnOffRatio) | 点亮灯塔。
Public method | Initialize | 清空未完成协议以及清空可能存在的显示内容和状态缓存。 (Overrides IOPort..::..Initialize()()()().)
Protected method | OnAppearanceChanged | 引发端口的当前外观更改事件。 (Inherited from IOPort.)
Public method | PerformAppearanceChanged | 引发端口的当前外观更改事件。 (Inherited from IOPort.)
Public method | Refresh | 刷新显示。 (Overrides IOPort..::..Refresh()()()().)

See Also

Lighthouse Class


Lighthouse.Clear Method

[image]

Pick To Light 设备通讯类库
Lighthouse..::..Clear Method
Lighthouse Class See Also Send Feedback
熄灭灯塔。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear

See Also

Lighthouse Class
Lighthouse Members


Lighthouse.Display Method

[image] [image]

Pick To Light 设备通讯类库
Lighthouse..::..Display Method
Lighthouse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Display()()()() | 点亮灯塔。
Public method | Display(LightOnOffPeriod, LightOnOffRatio) | 点亮灯塔。

See Also

Lighthouse Class
Lighthouse Members


Lighthouse.Display Method

[image]

Pick To Light 设备通讯类库
Lighthouse..::..Display Method
Lighthouse Class See Also Send Feedback
点亮灯塔。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display()
Visual Basic
Public Overridable Sub Display

See Also

Lighthouse Class
Lighthouse Members
Display Overload


Lighthouse.Display Method (LightOnOffPeriod, LightOnOffRatio)

[image]

Pick To Light 设备通讯类库
Lighthouse..::..Display Method (LightOnOffPeriod, LightOnOffRatio)
Lighthouse Class See Also Send Feedback
点亮灯塔。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    LightOnOffPeriod period,
    LightOnOffRatio ratio
)
Visual Basic
Public Overridable Sub Display (
    period As LightOnOffPeriod,
    ratio As LightOnOffRatio
)

Parameters

period
Type: Ptl.Device.Communication.Command..::..LightOnOffPeriod
亮灭周期。
ratio
Type: Ptl.Device.Communication.Command..::..LightOnOffRatio
亮灭比例。

See Also

Lighthouse Class
Lighthouse Members
Display Overload


Lighthouse.Initialize Method

[image]

Pick To Light 设备通讯类库
Lighthouse..::..Initialize Method
Lighthouse Class See Also Send Feedback
清空未完成协议以及清空可能存在的显示内容和状态缓存。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override void Initialize()
Visual Basic
Public Overrides Sub Initialize

See Also

Lighthouse Class
Lighthouse Members


Lighthouse.Refresh Method

[image]

Pick To Light 设备通讯类库
Lighthouse..::..Refresh Method
Lighthouse Class See Also Send Feedback
刷新显示。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override void Refresh()
Visual Basic
Public Overrides Sub Refresh

See Also

Lighthouse Class
Lighthouse Members


Lighthouse Properties

[image] [image]

Pick To Light 设备通讯类库
Lighthouse Properties
Lighthouse Class See Also Send Feedback

The Lighthouse type exposes the following members.

Properties

 | Name | Description
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from IOPort.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from IOPort.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from IOPort.)
Public property | CurrentAppearance | 获取当前外观。
Public property | Index | 获取或设置端口序号。 (Inherited from IOPort.)
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from IOPort.)
Public property | Owner | 获取或设置所属 Ptl 设备。 (Inherited from IOPort.)
Public property | Tag | 获取或设置相关联数据。 (Inherited from IOPort.)

See Also

Lighthouse Class


Lighthouse.CurrentAppearance Property

[image]

Pick To Light 设备通讯类库
Lighthouse..::..CurrentAppearance Property
Lighthouse Class See Also Send Feedback
获取当前外观。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public LighthouseAppearance CurrentAppearance { get; }
Visual Basic
Public ReadOnly Property CurrentAppearance As LighthouseAppearance
    Get

Property Value

Type: LighthouseAppearance

See Also

Lighthouse Class
Lighthouse Members


Lighthouse Events

[image] [image]

Pick To Light 设备通讯类库
Lighthouse Events
Lighthouse Class See Also Send Feedback

The Lighthouse type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | 端口的当前外观更改事件。 (Inherited from IOPort.)

See Also

Lighthouse Class


LighthouseAppearance Class

[image]

Pick To Light 设备通讯类库
LighthouseAppearance Class
Members See Also Send Feedback
灯塔的外观。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class LighthouseAppearance
Visual Basic
<SerializableAttribute>
Public Class LighthouseAppearance

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..LighthouseAppearance

See Also

LighthouseAppearance Members


LighthouseAppearance Members

[image] [image]

Pick To Light 设备通讯类库
LighthouseAppearance Members
LighthouseAppearance Class Constructors Properties See Also Send Feedback

The LighthouseAppearance type exposes the following members.

Constructors

 | Name | Description
Public method | LighthouseAppearance | Initializes a new instance of the LighthouseAppearance class

Properties

 | Name | Description
Public property | ON | 获取或设置是否处于点亮状态。
Public property | Period | 获取或设置的亮灭周期。
Public property | Ratio | 获取或设置的亮灭比例。

See Also

LighthouseAppearance Class


LighthouseAppearance Constructor

[image]

Pick To Light 设备通讯类库
LighthouseAppearance Constructor
LighthouseAppearance Class See Also Send Feedback
Initializes a new instance of the LighthouseAppearance class

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public LighthouseAppearance()
Visual Basic
Public Sub New

See Also

LighthouseAppearance Class
LighthouseAppearance Members


LighthouseAppearance Properties

[image] [image]

Pick To Light 设备通讯类库
LighthouseAppearance Properties
LighthouseAppearance Class See Also Send Feedback

The LighthouseAppearance type exposes the following members.

Properties

 | Name | Description
Public property | ON | 获取或设置是否处于点亮状态。
Public property | Period | 获取或设置的亮灭周期。
Public property | Ratio | 获取或设置的亮灭比例。

See Also

LighthouseAppearance Class


LighthouseAppearance.ON Property

[image]

Pick To Light 设备通讯类库
LighthouseAppearance..::..ON Property
LighthouseAppearance Class See Also Send Feedback
获取或设置是否处于点亮状态。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool ON { get; set; }
Visual Basic
Public Property ON As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

LighthouseAppearance Class
LighthouseAppearance Members


LighthouseAppearance.Period Property

[image]

Pick To Light 设备通讯类库
LighthouseAppearance..::..Period Property
LighthouseAppearance Class See Also Send Feedback
获取或设置的亮灭周期。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public LightOnOffPeriod Period { get; set; }
Visual Basic
Public Property Period As LightOnOffPeriod
    Get
    Set

Property Value

Type: LightOnOffPeriod

See Also

LighthouseAppearance Class
LighthouseAppearance Members


LighthouseAppearance.Ratio Property

[image]

Pick To Light 设备通讯类库
LighthouseAppearance..::..Ratio Property
LighthouseAppearance Class See Also Send Feedback
获取或设置的亮灭比例。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public LightOnOffRatio Ratio { get; set; }
Visual Basic
Public Property Ratio As LightOnOffRatio
    Get
    Set

Property Value

Type: LightOnOffRatio

See Also

LighthouseAppearance Class
LighthouseAppearance Members


Ptl600U Class

[image]

Pick To Light 设备通讯类库
Ptl600U Class
Members See Also Send Feedback
文本标签，常用于发布操作指示信息。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class Ptl600U : PtlDevice
Visual Basic
<SerializableAttribute>
Public Class Ptl600U
    Inherits PtlDevice

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..PtlDevice
Ptl.Device..::..Ptl600U

See Also

Ptl600U Members


Ptl600U Members

[image] [image]

Pick To Light 设备通讯类库
Ptl600U Members
Ptl600U Class Constructors Methods Properties Events See Also Send Feedback

The Ptl600U type exposes the following members.

Constructors

 | Name | Description
Public method | Ptl600U | 初始化 Ptl600U。

Methods

 | Name | Description
Public method | Clear | 清空指定的内容。
Public method | ClearCommandQueue | 清空协议队列。 (Inherited from PtlDevice.)
Public method | Display(String, LightColor) | 显示指定的内容。
Public method | Display(String, LightMode) | 显示指定的内容。
Public method | Display(Display600UContent, LightColor) | 显示指定的内容。
Public method | Display(Display600UContent, LightMode) | 显示指定的内容。
Public method | Display(String, LightColor, Boolean) | 显示指定的内容。
Public method | Display(String, LightMode, Boolean) | 显示指定的内容。
Public method | Display(Display600UContent, LightColor, Boolean) | 显示指定的内容。
Public method | Display(Display600UContent, LightMode, Boolean) | 显示指定的内容。
Public method | Display(Display600UContent, LightMode, SoundMode, Boolean) | 显示指定的内容。
Public method | Display(Byte, String, LightMode, SoundMode, Boolean) | 显示指定的内容。
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。 (Overrides PtlDevice..::..Initialize()()()().)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnClearAll | 引发 ClearAll 事件。
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnPressed | 引发 Pressed 事件。
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | PerformPressed | 引发 Pressed 事件。
Public method | Refresh | 刷新显示。 (Overrides PtlDevice..::..Refresh()()()().)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计。 (Inherited from PtlDevice.)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

Properties

 | Name | Description
Public property | Address | 获取或设置站点号。 (Inherited from PtlDevice.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from PtlDevice.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | CurrentAppearance | 获取当前外观。
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
 | MaxDescriptionLength | 获取或设置描述的最大字节数，默认 60。
 | MaxDescriptionLineCount | 获取或设置描述的最大行数，默认 3。
 | MaxSubTitleLength | 获取或设置副标题的最大字节数，默认 36。
 | MaxTextLength | 获取或设置 ASCII 文本的最大长度，默认 20。
 | MaxTitleLength | 获取或设置标题的最大字节数，默认 36。
Public property | MinorType | 获取或设置小类型。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
 | SurfaceTextEncoding | 获取或设置 Surface 型标签上文本的编码，默认 gb2312。
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public event | Pressed | OK 按钮被按下事件。

See Also

Ptl600U Class


Ptl600U Constructor

[image]

Pick To Light 设备通讯类库
Ptl600U Constructor
Ptl600U Class See Also Send Feedback
初始化 Ptl600U。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Ptl600U()
Visual Basic
Public Sub New

See Also

Ptl600U Class
Ptl600U Members


Ptl600U Methods

[image] [image]

Pick To Light 设备通讯类库
Ptl600U Methods
Ptl600U Class See Also Send Feedback

The Ptl600U type exposes the following members.

Methods

 | Name | Description
Public method | Clear | 清空指定的内容。
Public method | ClearCommandQueue | 清空协议队列。 (Inherited from PtlDevice.)
Public method | Display(String, LightColor) | 显示指定的内容。
Public method | Display(String, LightMode) | 显示指定的内容。
Public method | Display(Display600UContent, LightColor) | 显示指定的内容。
Public method | Display(Display600UContent, LightMode) | 显示指定的内容。
Public method | Display(String, LightColor, Boolean) | 显示指定的内容。
Public method | Display(String, LightMode, Boolean) | 显示指定的内容。
Public method | Display(Display600UContent, LightColor, Boolean) | 显示指定的内容。
Public method | Display(Display600UContent, LightMode, Boolean) | 显示指定的内容。
Public method | Display(Display600UContent, LightMode, SoundMode, Boolean) | 显示指定的内容。
Public method | Display(Byte, String, LightMode, SoundMode, Boolean) | 显示指定的内容。
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。 (Overrides PtlDevice..::..Initialize()()()().)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnClearAll | 引发 ClearAll 事件。
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnPressed | 引发 Pressed 事件。
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | PerformPressed | 引发 Pressed 事件。
Public method | Refresh | 刷新显示。 (Overrides PtlDevice..::..Refresh()()()().)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计。 (Inherited from PtlDevice.)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

See Also

Ptl600U Class


Ptl600U.Clear Method

[image]

Pick To Light 设备通讯类库
Ptl600U..::..Clear Method
Ptl600U Class See Also Send Feedback
清空指定的内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Clear(
    Clear600UMode mode
)
Visual Basic
Public Overridable Sub Clear (
    mode As Clear600UMode
)

Parameters

mode
Type: Ptl.Device.Communication.Command..::..Clear600UMode
清空方式。

Remarks

推荐使用 Display(string.Empty, LightColor.Off) 代替。

See Also

Ptl600U Class
Ptl600U Members


Ptl600U.Display Method

[image] [image]

Pick To Light 设备通讯类库
Ptl600U..::..Display Method
Ptl600U Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Display(String, LightColor) | 显示指定的内容。
Public method | Display(String, LightMode) | 显示指定的内容。
Public method | Display(Display600UContent, LightColor) | 显示指定的内容。
Public method | Display(Display600UContent, LightMode) | 显示指定的内容。
Public method | Display(String, LightColor, Boolean) | 显示指定的内容。
Public method | Display(String, LightMode, Boolean) | 显示指定的内容。
Public method | Display(Display600UContent, LightColor, Boolean) | 显示指定的内容。
Public method | Display(Display600UContent, LightMode, Boolean) | 显示指定的内容。
Public method | Display(Display600UContent, LightMode, SoundMode, Boolean) | 显示指定的内容。
Public method | Display(Byte, String, LightMode, SoundMode, Boolean) | 显示指定的内容。

See Also

Ptl600U Class
Ptl600U Members


Ptl600U.Display Method (String, LightColor)

[image]

Pick To Light 设备通讯类库
Ptl600U..::..Display Method (String, LightColor)
Ptl600U Class See Also Send Feedback
显示指定的内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    string text,
    LightColor lightColor
)
Visual Basic
Public Overridable Sub Display (
    text As String,
    lightColor As LightColor
)

Parameters

text
Type: System..::..String
ASCII 文本。
lightColor
Type: Ptl.Device.Communication.Command..::..LightColor
按钮灯色。

See Also

Ptl600U Class
Ptl600U Members
Display Overload


Ptl600U.Display Method (String, LightMode)

[image]

Pick To Light 设备通讯类库
Ptl600U..::..Display Method (String, LightMode)
Ptl600U Class See Also Send Feedback
显示指定的内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    string text,
    LightMode lightMode
)
Visual Basic
Public Overridable Sub Display (
    text As String,
    lightMode As LightMode
)

Parameters

text
Type: System..::..String
ASCII 文本。
lightMode
Type: Ptl.Device.Communication.Command..::..LightMode
按钮亮灯模式。

See Also

Ptl600U Class
Ptl600U Members
Display Overload


Ptl600U.Display Method (Display600UContent, LightColor)

[image]

Pick To Light 设备通讯类库
Ptl600U..::..Display Method (Display600UContent, LightColor)
Ptl600U Class See Also Send Feedback
显示指定的内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    Display600UContent content,
    LightColor lightColor
)
Visual Basic
Public Overridable Sub Display (
    content As Display600UContent,
    lightColor As LightColor
)

Parameters

content
Type: Ptl.Device.Communication.Command..::..Display600UContent
内容。
lightColor
Type: Ptl.Device.Communication.Command..::..LightColor
按钮灯色。

See Also

Ptl600U Class
Ptl600U Members
Display Overload


Ptl600U.Display Method (Display600UContent, LightMode)

[image]

Pick To Light 设备通讯类库
Ptl600U..::..Display Method (Display600UContent, LightMode)
Ptl600U Class See Also Send Feedback
显示指定的内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    Display600UContent content,
    LightMode lightMode
)
Visual Basic
Public Overridable Sub Display (
    content As Display600UContent,
    lightMode As LightMode
)

Parameters

content
Type: Ptl.Device.Communication.Command..::..Display600UContent
内容。
lightMode
Type: Ptl.Device.Communication.Command..::..LightMode
按钮亮灯模式。

See Also

Ptl600U Class
Ptl600U Members
Display Overload


Ptl600U.Display Method (String, LightColor, Boolean)

[image]

Pick To Light 设备通讯类库
Ptl600U..::..Display Method (String, LightColor, Boolean)
Ptl600U Class See Also Send Feedback
显示指定的内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    string text,
    LightColor lightColor,
    bool enableCollect
)
Visual Basic
Public Overridable Sub Display (
    text As String,
    lightColor As LightColor,
    enableCollect As Boolean
)

Parameters

text
Type: System..::..String
ASCII 文本。
lightColor
Type: Ptl.Device.Communication.Command..::..LightColor
按钮灯色。
enableCollect
Type: System..::..Boolean
是否启用采集。

See Also

Ptl600U Class
Ptl600U Members
Display Overload


Ptl600U.Display Method (String, LightMode, Boolean)

[image]

Pick To Light 设备通讯类库
Ptl600U..::..Display Method (String, LightMode, Boolean)
Ptl600U Class See Also Send Feedback
显示指定的内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    string text,
    LightMode lightMode,
    bool enableCollect
)
Visual Basic
Public Overridable Sub Display (
    text As String,
    lightMode As LightMode,
    enableCollect As Boolean
)

Parameters

text
Type: System..::..String
ASCII 文本。
lightMode
Type: Ptl.Device.Communication.Command..::..LightMode
按钮亮灯模式。
enableCollect
Type: System..::..Boolean
是否启用采集。

See Also

Ptl600U Class
Ptl600U Members
Display Overload


Ptl600U.Display Method (Display600UContent, LightColor, Boolean)

[image]

Pick To Light 设备通讯类库
Ptl600U..::..Display Method (Display600UContent, LightColor, Boolean)
Ptl600U Class See Also Send Feedback
显示指定的内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    Display600UContent content,
    LightColor lightColor,
    bool enableCollect
)
Visual Basic
Public Overridable Sub Display (
    content As Display600UContent,
    lightColor As LightColor,
    enableCollect As Boolean
)

Parameters

content
Type: Ptl.Device.Communication.Command..::..Display600UContent
内容。
lightColor
Type: Ptl.Device.Communication.Command..::..LightColor
按钮灯色。
enableCollect
Type: System..::..Boolean
是否启用采集。

See Also

Ptl600U Class
Ptl600U Members
Display Overload


Ptl600U.Display Method (Display600UContent, LightMode, Boolean)

[image]

Pick To Light 设备通讯类库
Ptl600U..::..Display Method (Display600UContent, LightMode, Boolean)
Ptl600U Class See Also Send Feedback
显示指定的内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    Display600UContent content,
    LightMode lightMode,
    bool enableCollect
)
Visual Basic
Public Overridable Sub Display (
    content As Display600UContent,
    lightMode As LightMode,
    enableCollect As Boolean
)

Parameters

content
Type: Ptl.Device.Communication.Command..::..Display600UContent
内容。
lightMode
Type: Ptl.Device.Communication.Command..::..LightMode
按钮亮灯模式。
enableCollect
Type: System..::..Boolean
是否启用采集。

See Also

Ptl600U Class
Ptl600U Members
Display Overload


Ptl600U.Display Method (Display600UContent, LightMode, SoundMode, Boolean)

[image]

Pick To Light 设备通讯类库
Ptl600U..::..Display Method (Display600UContent, LightMode, SoundMode, Boolean)
Ptl600U Class See Also Send Feedback
显示指定的内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    Display600UContent content,
    LightMode lightMode,
    SoundMode sound,
    bool enableCollect
)
Visual Basic
Public Overridable Sub Display (
    content As Display600UContent,
    lightMode As LightMode,
    sound As SoundMode,
    enableCollect As Boolean
)

Parameters

content
Type: Ptl.Device.Communication.Command..::..Display600UContent
内容。
lightMode
Type: Ptl.Device.Communication.Command..::..LightMode
按钮的亮灯模式。
sound
Type: Ptl.Device.Communication.Command..::..SoundMode
声音。
enableCollect
Type: System..::..Boolean
是否启用采集。

Remarks

调用本方法前调用 ClearCommandQueue() 能清除上一次未完成的任务；调用 Clear(Clear600UMode.Button) 能清除非预期的按钮状态缓存。

See Also

Ptl600U Class
Ptl600U Members
Display Overload


Ptl600U.Display Method (Byte, String, LightMode, SoundMode, Boolean)

[image]

Pick To Light 设备通讯类库
Ptl600U..::..Display Method (Byte, String, LightMode, SoundMode, Boolean)
Ptl600U Class See Also Send Feedback
显示指定的内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    byte rowIndex,
    string text,
    LightMode lightMode,
    SoundMode sound,
    bool enableCollect
)
Visual Basic
Public Overridable Sub Display (
    rowIndex As Byte,
    text As String,
    lightMode As LightMode,
    sound As SoundMode,
    enableCollect As Boolean
)

Parameters

rowIndex
Type: System..::..Byte
行号。
text
Type: System..::..String
ASCII 文本。
lightMode
Type: Ptl.Device.Communication.Command..::..LightMode
按钮亮灯模式。
sound
Type: Ptl.Device.Communication.Command..::..SoundMode
声音。
enableCollect
Type: System..::..Boolean
是否启用采集。

Remarks

调用本方法前调用 ClearCommandQueue() 能清除上一次未完成的任务；调用 Clear(Clear600UMode.Button) 能清除非预期的按钮状态缓存。

See Also

Ptl600U Class
Ptl600U Members
Display Overload


Ptl600U.Initialize Method

[image]

Pick To Light 设备通讯类库
Ptl600U..::..Initialize Method
Ptl600U Class See Also Send Feedback
清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override void Initialize()
Visual Basic
Public Overrides Sub Initialize

See Also

Ptl600U Class
Ptl600U Members


Ptl600U.OnClearAll Method

[image]

Pick To Light 设备通讯类库
Ptl600U..::..OnClearAll Method
Ptl600U Class See Also Send Feedback
引发 ClearAll 事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void OnClearAll(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnClearAll (
    e As EventArgs
)

Parameters

e
Type: System..::..EventArgs
事件参数。

See Also

Ptl600U Class
Ptl600U Members


Ptl600U.OnPressed Method

[image]

Pick To Light 设备通讯类库
Ptl600U..::..OnPressed Method
Ptl600U Class See Also Send Feedback
引发 Pressed 事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void OnPressed(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnPressed (
    e As EventArgs
)

Parameters

e
Type: System..::..EventArgs
事件参数。

See Also

Ptl600U Class
Ptl600U Members


Ptl600U.PerformPressed Method

[image]

Pick To Light 设备通讯类库
Ptl600U..::..PerformPressed Method
Ptl600U Class See Also Send Feedback
引发 Pressed 事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void PerformPressed()
Visual Basic
Public Sub PerformPressed

See Also

Ptl600U Class
Ptl600U Members


Ptl600U.Refresh Method

[image]

Pick To Light 设备通讯类库
Ptl600U..::..Refresh Method
Ptl600U Class See Also Send Feedback
刷新显示。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override void Refresh()
Visual Basic
Public Overrides Sub Refresh

See Also

Ptl600U Class
Ptl600U Members


Ptl600U Properties

[image] [image]

Pick To Light 设备通讯类库
Ptl600U Properties
Ptl600U Class See Also Send Feedback

The Ptl600U type exposes the following members.

Properties

 | Name | Description
Public property | Address | 获取或设置站点号。 (Inherited from PtlDevice.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from PtlDevice.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | CurrentAppearance | 获取当前外观。
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
 | MaxDescriptionLength | 获取或设置描述的最大字节数，默认 60。
 | MaxDescriptionLineCount | 获取或设置描述的最大行数，默认 3。
 | MaxSubTitleLength | 获取或设置副标题的最大字节数，默认 36。
 | MaxTextLength | 获取或设置 ASCII 文本的最大长度，默认 20。
 | MaxTitleLength | 获取或设置标题的最大字节数，默认 36。
Public property | MinorType | 获取或设置小类型。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
 | SurfaceTextEncoding | 获取或设置 Surface 型标签上文本的编码，默认 gb2312。
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

See Also

Ptl600U Class


Ptl600U.CurrentAppearance Property

[image]

Pick To Light 设备通讯类库
Ptl600U..::..CurrentAppearance Property
Ptl600U Class See Also Send Feedback
获取当前外观。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Ptl600UAppearance CurrentAppearance { get; }
Visual Basic
Public ReadOnly Property CurrentAppearance As Ptl600UAppearance
    Get

Property Value

Type: Ptl600UAppearance

See Also

Ptl600U Class
Ptl600U Members


Ptl600U.MaxDescriptionLength Property

[image]

Pick To Light 设备通讯类库
Ptl600U..::..MaxDescriptionLength Property
Ptl600U Class See Also Send Feedback
获取或设置描述的最大字节数，默认 60。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static int MaxDescriptionLength { get; set; }
Visual Basic
Public Shared Property MaxDescriptionLength As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Ptl600U Class
Ptl600U Members


Ptl600U.MaxDescriptionLineCount Property

[image]

Pick To Light 设备通讯类库
Ptl600U..::..MaxDescriptionLineCount Property
Ptl600U Class See Also Send Feedback
获取或设置描述的最大行数，默认 3。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static int MaxDescriptionLineCount { get; set; }
Visual Basic
Public Shared Property MaxDescriptionLineCount As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Ptl600U Class
Ptl600U Members


Ptl600U.MaxSubTitleLength Property

[image]

Pick To Light 设备通讯类库
Ptl600U..::..MaxSubTitleLength Property
Ptl600U Class See Also Send Feedback
获取或设置副标题的最大字节数，默认 36。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static int MaxSubTitleLength { get; set; }
Visual Basic
Public Shared Property MaxSubTitleLength As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Ptl600U Class
Ptl600U Members


Ptl600U.MaxTextLength Property

[image]

Pick To Light 设备通讯类库
Ptl600U..::..MaxTextLength Property
Ptl600U Class See Also Send Feedback
获取或设置 ASCII 文本的最大长度，默认 20。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static int MaxTextLength { get; set; }
Visual Basic
Public Shared Property MaxTextLength As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Ptl600U Class
Ptl600U Members


Ptl600U.MaxTitleLength Property

[image]

Pick To Light 设备通讯类库
Ptl600U..::..MaxTitleLength Property
Ptl600U Class See Also Send Feedback
获取或设置标题的最大字节数，默认 36。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static int MaxTitleLength { get; set; }
Visual Basic
Public Shared Property MaxTitleLength As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Ptl600U Class
Ptl600U Members


Ptl600U.MinorType Property

[image]

Pick To Light 设备通讯类库
Ptl600U..::..MinorType Property
Ptl600U Class See Also Send Feedback
获取或设置小类型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual Ptl600UType MinorType { get; set; }
Visual Basic
Public Overridable Property MinorType As Ptl600UType
    Get
    Set

Property Value

Type: Ptl600UType

See Also

Ptl600U Class
Ptl600U Members


Ptl600U.SurfaceTextEncoding Property

[image]

Pick To Light 设备通讯类库
Ptl600U..::..SurfaceTextEncoding Property
Ptl600U Class See Also Send Feedback
获取或设置 Surface 型标签上文本的编码，默认 gb2312。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static Encoding SurfaceTextEncoding { get; set; }
Visual Basic
Public Shared Property SurfaceTextEncoding As Encoding
    Get
    Set

Property Value

Type: Encoding

Exceptions

Exception | Condition
System..::..ArgumentNullException | 设置时使用空值。

See Also

Ptl600U Class
Ptl600U Members


Ptl600U Events

[image] [image]

Pick To Light 设备通讯类库
Ptl600U Events
Ptl600U Class See Also Send Feedback

The Ptl600U type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public event | Pressed | OK 按钮被按下事件。

See Also

Ptl600U Class


Ptl600U.Pressed Event

[image]

Pick To Light 设备通讯类库
Ptl600U..::..Pressed Event
Ptl600U Class See Also Send Feedback
OK 按钮被按下事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public event EventHandler Pressed
Visual Basic
Public Event Pressed As EventHandler

Value

Type: System..::..EventHandler

See Also

Ptl600U Class
Ptl600U Members


Ptl600UAppearance Class

[image]

Pick To Light 设备通讯类库
Ptl600UAppearance Class
Members See Also Send Feedback
文本标签的外观。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class Ptl600UAppearance
Visual Basic
<SerializableAttribute>
Public Class Ptl600UAppearance

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..Ptl600UAppearance

See Also

Ptl600UAppearance Members


Ptl600UAppearance Members

[image] [image]

Pick To Light 设备通讯类库
Ptl600UAppearance Members
Ptl600UAppearance Class Constructors Properties See Also Send Feedback

The Ptl600UAppearance type exposes the following members.

Constructors

 | Name | Description
Public method | Ptl600UAppearance | Initializes a new instance of the Ptl600UAppearance class

Properties

 | Name | Description
Public property | Background | 获取或设置彩屏背景。
Public property | Description | 获取或设置描述，可中文。
Public property | Light | 获取或设置亮灯模式。
Public property | Picture | 获取或设置图片。
Public property | Sound | 获取或设置声音模式。
Public property | SubTitle | 获取或设置副标题，可中文。
Public property | Text | 获取或设置 ASCII 文本。
Public property | Title | 获取或设置标题，可中文。

See Also

Ptl600UAppearance Class


Ptl600UAppearance Constructor

[image]

Pick To Light 设备通讯类库
Ptl600UAppearance Constructor
Ptl600UAppearance Class See Also Send Feedback
Initializes a new instance of the Ptl600UAppearance class

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Ptl600UAppearance()
Visual Basic
Public Sub New

See Also

Ptl600UAppearance Class
Ptl600UAppearance Members


Ptl600UAppearance Properties

[image] [image]

Pick To Light 设备通讯类库
Ptl600UAppearance Properties
Ptl600UAppearance Class See Also Send Feedback

The Ptl600UAppearance type exposes the following members.

Properties

 | Name | Description
Public property | Background | 获取或设置彩屏背景。
Public property | Description | 获取或设置描述，可中文。
Public property | Light | 获取或设置亮灯模式。
Public property | Picture | 获取或设置图片。
Public property | Sound | 获取或设置声音模式。
Public property | SubTitle | 获取或设置副标题，可中文。
Public property | Text | 获取或设置 ASCII 文本。
Public property | Title | 获取或设置标题，可中文。

See Also

Ptl600UAppearance Class


Ptl600UAppearance.Background Property

[image]

Pick To Light 设备通讯类库
Ptl600UAppearance..::..Background Property
Ptl600UAppearance Class See Also Send Feedback
获取或设置彩屏背景。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Nullable<SurfaceBackground> Background { get; set; }
Visual Basic
Public Property Background As Nullable(Of SurfaceBackground)
    Get
    Set

Property Value

Type: Nullable <(Of <(<' SurfaceBackground >)>)>

See Also

Ptl600UAppearance Class
Ptl600UAppearance Members


Ptl600UAppearance.Description Property

[image]

Pick To Light 设备通讯类库
Ptl600UAppearance..::..Description Property
Ptl600UAppearance Class See Also Send Feedback
获取或设置描述，可中文。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Ptl600UAppearance Class
Ptl600UAppearance Members


Ptl600UAppearance.Light Property

[image]

Pick To Light 设备通讯类库
Ptl600UAppearance..::..Light Property
Ptl600UAppearance Class See Also Send Feedback
获取或设置亮灯模式。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public LightMode Light { get; set; }
Visual Basic
Public Property Light As LightMode
    Get
    Set

Property Value

Type: LightMode
为空时会被 LightMode.Default 取代。

See Also

Ptl600UAppearance Class
Ptl600UAppearance Members


Ptl600UAppearance.Picture Property

[image]

Pick To Light 设备通讯类库
Ptl600UAppearance..::..Picture Property
Ptl600UAppearance Class See Also Send Feedback
获取或设置图片。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public SurfacePicture Picture { get; set; }
Visual Basic
Public Property Picture As SurfacePicture
    Get
    Set

Property Value

Type: SurfacePicture

See Also

Ptl600UAppearance Class
Ptl600UAppearance Members


Ptl600UAppearance.Sound Property

[image]

Pick To Light 设备通讯类库
Ptl600UAppearance..::..Sound Property
Ptl600UAppearance Class See Also Send Feedback
获取或设置声音模式。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public SoundMode Sound { get; set; }
Visual Basic
Public Property Sound As SoundMode
    Get
    Set

Property Value

Type: SoundMode

See Also

Ptl600UAppearance Class
Ptl600UAppearance Members


Ptl600UAppearance.SubTitle Property

[image]

Pick To Light 设备通讯类库
Ptl600UAppearance..::..SubTitle Property
Ptl600UAppearance Class See Also Send Feedback
获取或设置副标题，可中文。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string SubTitle { get; set; }
Visual Basic
Public Property SubTitle As String
    Get
    Set

Property Value

Type: String

See Also

Ptl600UAppearance Class
Ptl600UAppearance Members


Ptl600UAppearance.Text Property

[image]

Pick To Light 设备通讯类库
Ptl600UAppearance..::..Text Property
Ptl600UAppearance Class See Also Send Feedback
获取或设置 ASCII 文本。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set

Property Value

Type: String

See Also

Ptl600UAppearance Class
Ptl600UAppearance Members


Ptl600UAppearance.Title Property

[image]

Pick To Light 设备通讯类库
Ptl600UAppearance..::..Title Property
Ptl600UAppearance Class See Also Send Feedback
获取或设置标题，可中文。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set

Property Value

Type: String

See Also

Ptl600UAppearance Class
Ptl600UAppearance Members


Ptl600UType Enumeration

[image]

Pick To Light 设备通讯类库
Ptl600UType Enumeration
See Also Send Feedback
Ptl600U 的类型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum Ptl600UType
Visual Basic
Public Enumeration Ptl600UType

Members

Member name | Value | Description
P1101 | 0 | 11 列 1 行点阵。
P1102 | 1 | 11 列 2 行点阵。
D3 | 31 | 3 位数码管。
D6 | 61 | 6 位数码管。
Surface | 201 | 彩屏。

See Also


Ptl900U Class

[image]

Pick To Light 设备通讯类库
Ptl900U Class
Members See Also Send Feedback
拣货标签，有 数量 概念。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class Ptl900U : PtlDevice
Visual Basic
<SerializableAttribute>
Public Class Ptl900U
    Inherits PtlDevice

Remarks

设备自行灭灯并显示后备明细； 所以在不启用采集时，单个显示项的熄灭和多个显示项中最后一项的当前外观不能被跟踪。

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..PtlDevice
Ptl.Device..::..Ptl900U

See Also

Ptl900U Members


Ptl900U Members

[image] [image]

Pick To Light 设备通讯类库
Ptl900U Members
Ptl900U Class Constructors Methods Properties Events See Also Send Feedback

The Ptl900U type exposes the following members.

Constructors

 | Name | Description
Public method | Ptl900U | 初始化 Ptl900U。

Methods

 | Name | Description
Public method | Clear | 清空内容。
Public method | ClearCommandQueue | 清空协议队列。 (Inherited from PtlDevice.)
Public method | Display(Display900UItem, LightColor) | 显示指定内容。
Public method | Display(ICollection<(Of <<'(Display900UItem>)>>), LightColor) | 显示指定内容。
Public method | Display(Display900UItem, LightColor, Boolean) | 显示指定内容。
Public method | Display(Display900UItem, LightMode, Boolean) | 显示指定内容。
Public method | Display(ICollection<(Of <<'(Display900UItem>)>>), LightColor, Boolean) | 显示指定内容。
Public method | Display(ICollection<(Of <<'(Display900UItem>)>>), LightMode, SoundMode, Boolean, Boolean, Int32) | 显示指定内容。
Public method | Display(ICollection<(Of <<'(Display900UItem>)>>), LightMode, SoundMode, SurfaceBackground, Boolean, Boolean, Int32) | 显示指定内容。
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。 (Overrides PtlDevice..::..Initialize()()()().)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnPressed | 引发 Pressed 事件。
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | PerformPressed | 引发 Pressed 事件。
Public method | Refresh | 刷新显示。 (Overrides PtlDevice..::..Refresh()()()().)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计。 (Inherited from PtlDevice.)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

Properties

 | Name | Description
Public property | Address | 获取或设置站点号。 (Inherited from PtlDevice.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from PtlDevice.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | CurrentAppearance | 获取当前外观。
 | EmptySubLocation | 获取或设置空白行列码，默认 0xFF。
Public property | F1OkColorAfterPress | 获取或设置 F1 值。
 | FixLongSubLocationLength | 获取或设置长行列码的固定字节数，默认 4。
 | FixUnitLength | 获取或设置单位的固定字节数，默认 2。
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
 | MaxBatchCodeLength | 获取或设置批号的最大长度，默认 12。
 | MaxDescriptionLength | 获取或设置描述的最大字节数，默认 60。
 | MaxDescriptionLineCount | 获取或设置描述的最大行数，默认 3。
 | MaxDeviceStoredItemsCount | 获取或设置设备上可驻留的最大项数，默认 2。
 | MaxNameLength | 获取或设置品名的最大字节数，默认 36。
Public property | MinorType | 获取或设置小类型。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
 | SurfaceTextEncoding | 获取或设置 Surface 型标签上文本的编码，默认 gb2312。
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public event | Pressed | OK 按钮被按下事件。

See Also

Ptl900U Class


Ptl900U Constructor

[image]

Pick To Light 设备通讯类库
Ptl900U Constructor
Ptl900U Class See Also Send Feedback
初始化 Ptl900U。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Ptl900U()
Visual Basic
Public Sub New

See Also

Ptl900U Class
Ptl900U Members


Ptl900U Methods

[image] [image]

Pick To Light 设备通讯类库
Ptl900U Methods
Ptl900U Class See Also Send Feedback

The Ptl900U type exposes the following members.

Methods

 | Name | Description
Public method | Clear | 清空内容。
Public method | ClearCommandQueue | 清空协议队列。 (Inherited from PtlDevice.)
Public method | Display(Display900UItem, LightColor) | 显示指定内容。
Public method | Display(ICollection<(Of <<'(Display900UItem>)>>), LightColor) | 显示指定内容。
Public method | Display(Display900UItem, LightColor, Boolean) | 显示指定内容。
Public method | Display(Display900UItem, LightMode, Boolean) | 显示指定内容。
Public method | Display(ICollection<(Of <<'(Display900UItem>)>>), LightColor, Boolean) | 显示指定内容。
Public method | Display(ICollection<(Of <<'(Display900UItem>)>>), LightMode, SoundMode, Boolean, Boolean, Int32) | 显示指定内容。
Public method | Display(ICollection<(Of <<'(Display900UItem>)>>), LightMode, SoundMode, SurfaceBackground, Boolean, Boolean, Int32) | 显示指定内容。
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。 (Overrides PtlDevice..::..Initialize()()()().)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnPressed | 引发 Pressed 事件。
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | PerformPressed | 引发 Pressed 事件。
Public method | Refresh | 刷新显示。 (Overrides PtlDevice..::..Refresh()()()().)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计。 (Inherited from PtlDevice.)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

See Also

Ptl900U Class


Ptl900U.Clear Method

[image]

Pick To Light 设备通讯类库
Ptl900U..::..Clear Method
Ptl900U Class See Also Send Feedback
清空内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear

Remarks

常在此方法之前调用 ClearCommandQueue() 以清除上一次未完成的任务。

See Also

Ptl900U Class
Ptl900U Members


Ptl900U.Display Method

[image] [image]

Pick To Light 设备通讯类库
Ptl900U..::..Display Method
Ptl900U Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Display(Display900UItem, LightColor) | 显示指定内容。
Public method | Display(ICollection<(Of <<'(Display900UItem>)>>), LightColor) | 显示指定内容。
Public method | Display(Display900UItem, LightColor, Boolean) | 显示指定内容。
Public method | Display(Display900UItem, LightMode, Boolean) | 显示指定内容。
Public method | Display(ICollection<(Of <<'(Display900UItem>)>>), LightColor, Boolean) | 显示指定内容。
Public method | Display(ICollection<(Of <<'(Display900UItem>)>>), LightMode, SoundMode, Boolean, Boolean, Int32) | 显示指定内容。
Public method | Display(ICollection<(Of <<'(Display900UItem>)>>), LightMode, SoundMode, SurfaceBackground, Boolean, Boolean, Int32) | 显示指定内容。

See Also

Ptl900U Class
Ptl900U Members


Ptl900U.Display Method (Display900UItem, LightColor)

[image]

Pick To Light 设备通讯类库
Ptl900U..::..Display Method (Display900UItem, LightColor)
Ptl900U Class See Also Send Feedback
显示指定内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    Display900UItem item,
    LightColor lightColor
)
Visual Basic
Public Overridable Sub Display (
    item As Display900UItem,
    lightColor As LightColor
)

Parameters

item
Type: Ptl.Device.Communication.Command..::..Display900UItem
显示项。
lightColor
Type: Ptl.Device.Communication.Command..::..LightColor
按钮灯色。

See Also

Ptl900U Class
Ptl900U Members
Display Overload


Ptl900U.Display Method (ICollection(Display900UItem), LightColor)

[image]

Pick To Light 设备通讯类库
Ptl900U..::..Display Method (ICollection<(Of <(<'Display900UItem>)>)>, LightColor)
Ptl900U Class See Also Send Feedback
显示指定内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    ICollection<Display900UItem> items,
    LightColor lightColor
)
Visual Basic
Public Overridable Sub Display (
    items As ICollection(Of Display900UItem),
    lightColor As LightColor
)

Parameters

items
Type: System.Collections.Generic..::..ICollection <(Of <(<' Display900UItem >)>)>
显示项集合。
lightColor
Type: Ptl.Device.Communication.Command..::..LightColor
按钮灯色。

See Also

Ptl900U Class
Ptl900U Members
Display Overload


Ptl900U.Display Method (Display900UItem, LightColor, Boolean)

[image]

Pick To Light 设备通讯类库
Ptl900U..::..Display Method (Display900UItem, LightColor, Boolean)
Ptl900U Class See Also Send Feedback
显示指定内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    Display900UItem item,
    LightColor lightColor,
    bool mustCollect
)
Visual Basic
Public Overridable Sub Display (
    item As Display900UItem,
    lightColor As LightColor,
    mustCollect As Boolean
)

Parameters

item
Type: Ptl.Device.Communication.Command..::..Display900UItem
显示项。
lightColor
Type: Ptl.Device.Communication.Command..::..LightColor
按钮灯色。
mustCollect
Type: System..::..Boolean
是否必须采集。

See Also

Ptl900U Class
Ptl900U Members
Display Overload


Ptl900U.Display Method (Display900UItem, LightMode, Boolean)

[image]

Pick To Light 设备通讯类库
Ptl900U..::..Display Method (Display900UItem, LightMode, Boolean)
Ptl900U Class See Also Send Feedback
显示指定内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    Display900UItem item,
    LightMode lightMode,
    bool mustCollect
)
Visual Basic
Public Overridable Sub Display (
    item As Display900UItem,
    lightMode As LightMode,
    mustCollect As Boolean
)

Parameters

item
Type: Ptl.Device.Communication.Command..::..Display900UItem
显示项。
lightMode
Type: Ptl.Device.Communication.Command..::..LightMode
按钮亮灯模式。
mustCollect
Type: System..::..Boolean
是否必须采集。

See Also

Ptl900U Class
Ptl900U Members
Display Overload


Ptl900U.Display Method (ICollection(Display900UItem), LightColor, Boolean)

[image]

Pick To Light 设备通讯类库
Ptl900U..::..Display Method (ICollection<(Of <(<'Display900UItem>)>)>, LightColor, Boolean)
Ptl900U Class See Also Send Feedback
显示指定内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    ICollection<Display900UItem> items,
    LightColor lightColor,
    bool mustCollect
)
Visual Basic
Public Overridable Sub Display (
    items As ICollection(Of Display900UItem),
    lightColor As LightColor,
    mustCollect As Boolean
)

Parameters

items
Type: System.Collections.Generic..::..ICollection <(Of <(<' Display900UItem >)>)>
显示项集合。
lightColor
Type: Ptl.Device.Communication.Command..::..LightColor
按钮灯色。
mustCollect
Type: System..::..Boolean
是否必须采集。

See Also

Ptl900U Class
Ptl900U Members
Display Overload


Ptl900U.Display Method (ICollection(Display900UItem), LightMode, SoundMode, Boolean, Boolean, Int32)

[image]

Pick To Light 设备通讯类库
Ptl900U..::..Display Method (ICollection<(Of <(<'Display900UItem>)>)>, LightMode, SoundMode, Boolean, Boolean, Int32)
Ptl900U Class See Also Send Feedback
显示指定内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    ICollection<Display900UItem> items,
    LightMode lightMode,
    SoundMode sound,
    bool mustCollect,
    bool enableF1OkColorAfterPress,
    int waitMillisecondsForDisplay
)
Visual Basic
Public Overridable Sub Display (
    items As ICollection(Of Display900UItem),
    lightMode As LightMode,
    sound As SoundMode,
    mustCollect As Boolean,
    enableF1OkColorAfterPress As Boolean,
    waitMillisecondsForDisplay As Integer
)

Parameters

items
Type: System.Collections.Generic..::..ICollection <(Of <(<' Display900UItem >)>)>
显示项集合。
lightMode
Type: Ptl.Device.Communication.Command..::..LightMode
按钮亮灯模式。
sound
Type: Ptl.Device.Communication.Command..::..SoundMode
声音。
mustCollect
Type: System..::..Boolean
是否必须采集。
enableF1OkColorAfterPress
Type: System..::..Boolean
是否启用 F1 功能。
waitMillisecondsForDisplay
Type: System..::..Int32
等待屏幕显示的时间，用于等待 TFT 屏显示。

See Also

Ptl900U Class
Ptl900U Members
Display Overload


Ptl900U.Display Method (ICollection(Display900UItem), LightMode, SoundMode, SurfaceBackground, Boolean, Boolean, Int32)

[image]

Pick To Light 设备通讯类库
Ptl900U..::..Display Method (ICollection<(Of <(<'Display900UItem>)>)>, LightMode, SoundMode, SurfaceBackground, Boolean, Boolean, Int32)
Ptl900U Class See Also Send Feedback
显示指定内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Display(
    ICollection<Display900UItem> items,
    LightMode lightMode,
    SoundMode sound,
    SurfaceBackground background,
    bool mustCollect,
    bool enableF1OkColorAfterPress,
    int waitMillisecondsForDisplay
)
Visual Basic
Public Overridable Sub Display (
    items As ICollection(Of Display900UItem),
    lightMode As LightMode,
    sound As SoundMode,
    background As SurfaceBackground,
    mustCollect As Boolean,
    enableF1OkColorAfterPress As Boolean,
    waitMillisecondsForDisplay As Integer
)

Parameters

items
Type: System.Collections.Generic..::..ICollection <(Of <(<' Display900UItem >)>)>
显示项集合。
lightMode
Type: Ptl.Device.Communication.Command..::..LightMode
按钮亮灯模式。
sound
Type: Ptl.Device.Communication.Command..::..SoundMode
声音。
background
Type: Ptl.Device.Communication.Command..::..SurfaceBackground
彩屏背景。
mustCollect
Type: System..::..Boolean
是否必须采集。
enableF1OkColorAfterPress
Type: System..::..Boolean
是否启用 F1 功能。
waitMillisecondsForDisplay
Type: System..::..Int32
等待屏幕显示的时间，用于等待 TFT 屏显示。

Remarks

调用本方法前依次调用 ClearCommandQueue() 和 Clear() 能清除上一次未完成任务的设备状态缓存。

Exceptions

Exception | Condition
System..::..ArgumentNullException | items 为空或任意元素为空或元素数为零。
System..::..ArgumentOutOfRangeException | items 元素数大于 255。

See Also

Ptl900U Class
Ptl900U Members
Display Overload


Ptl900U.Initialize Method

[image]

Pick To Light 设备通讯类库
Ptl900U..::..Initialize Method
Ptl900U Class See Also Send Feedback
清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override void Initialize()
Visual Basic
Public Overrides Sub Initialize

See Also

Ptl900U Class
Ptl900U Members


Ptl900U.OnPressed Method

[image]

Pick To Light 设备通讯类库
Ptl900U..::..OnPressed Method
Ptl900U Class See Also Send Feedback
引发 Pressed 事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void OnPressed(
    Ptl900UPressedEventArgs e
)
Visual Basic
Protected Overridable Sub OnPressed (
    e As Ptl900UPressedEventArgs
)

Parameters

e
Type: Ptl.Device..::..Ptl900UPressedEventArgs
事件参数。

See Also

Ptl900U Class
Ptl900U Members


Ptl900U.PerformPressed Method

[image]

Pick To Light 设备通讯类库
Ptl900U..::..PerformPressed Method
Ptl900U Class See Also Send Feedback
引发 Pressed 事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void PerformPressed(
    Ptl900UPressedEventArgs e
)
Visual Basic
Public Sub PerformPressed (
    e As Ptl900UPressedEventArgs
)

Parameters

e
Type: Ptl.Device..::..Ptl900UPressedEventArgs
事件参数。

See Also

Ptl900U Class
Ptl900U Members


Ptl900U.Refresh Method

[image]

Pick To Light 设备通讯类库
Ptl900U..::..Refresh Method
Ptl900U Class See Also Send Feedback
刷新显示。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override void Refresh()
Visual Basic
Public Overrides Sub Refresh

Remarks

无法刷新因启用 F1 功能而保留的灯色。

See Also

Ptl900U Class
Ptl900U Members


Ptl900U Properties

[image] [image]

Pick To Light 设备通讯类库
Ptl900U Properties
Ptl900U Class See Also Send Feedback

The Ptl900U type exposes the following members.

Properties

 | Name | Description
Public property | Address | 获取或设置站点号。 (Inherited from PtlDevice.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from PtlDevice.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | CurrentAppearance | 获取当前外观。
 | EmptySubLocation | 获取或设置空白行列码，默认 0xFF。
Public property | F1OkColorAfterPress | 获取或设置 F1 值。
 | FixLongSubLocationLength | 获取或设置长行列码的固定字节数，默认 4。
 | FixUnitLength | 获取或设置单位的固定字节数，默认 2。
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
 | MaxBatchCodeLength | 获取或设置批号的最大长度，默认 12。
 | MaxDescriptionLength | 获取或设置描述的最大字节数，默认 60。
 | MaxDescriptionLineCount | 获取或设置描述的最大行数，默认 3。
 | MaxDeviceStoredItemsCount | 获取或设置设备上可驻留的最大项数，默认 2。
 | MaxNameLength | 获取或设置品名的最大字节数，默认 36。
Public property | MinorType | 获取或设置小类型。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
 | SurfaceTextEncoding | 获取或设置 Surface 型标签上文本的编码，默认 gb2312。
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

See Also

Ptl900U Class


Ptl900U.CurrentAppearance Property

[image]

Pick To Light 设备通讯类库
Ptl900U..::..CurrentAppearance Property
Ptl900U Class See Also Send Feedback
获取当前外观。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Ptl900UAppearance CurrentAppearance { get; }
Visual Basic
Public ReadOnly Property CurrentAppearance As Ptl900UAppearance
    Get

Property Value

Type: Ptl900UAppearance

See Also

Ptl900U Class
Ptl900U Members


Ptl900U.EmptySubLocation Property

[image]

Pick To Light 设备通讯类库
Ptl900U..::..EmptySubLocation Property
Ptl900U Class See Also Send Feedback
获取或设置空白行列码，默认 0xFF。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static byte EmptySubLocation { get; set; }
Visual Basic
Public Shared Property EmptySubLocation As Byte
    Get
    Set

Property Value

Type: Byte

See Also

Ptl900U Class
Ptl900U Members


Ptl900U.F1OkColorAfterPress Property

[image]

Pick To Light 设备通讯类库
Ptl900U..::..F1OkColorAfterPress Property
Ptl900U Class See Also Send Feedback
获取或设置 F1 值。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public F1OkColorAfterPress F1OkColorAfterPress { get; set; }
Visual Basic
Public Property F1OkColorAfterPress As F1OkColorAfterPress
    Get
    Set

Property Value

Type: F1OkColorAfterPress

See Also

Ptl900U Class
Ptl900U Members


Ptl900U.FixLongSubLocationLength Property

[image]

Pick To Light 设备通讯类库
Ptl900U..::..FixLongSubLocationLength Property
Ptl900U Class See Also Send Feedback
获取或设置长行列码的固定字节数，默认 4。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static int FixLongSubLocationLength { get; set; }
Visual Basic
Public Shared Property FixLongSubLocationLength As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Ptl900U Class
Ptl900U Members


Ptl900U.FixUnitLength Property

[image]

Pick To Light 设备通讯类库
Ptl900U..::..FixUnitLength Property
Ptl900U Class See Also Send Feedback
获取或设置单位的固定字节数，默认 2。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static int FixUnitLength { get; set; }
Visual Basic
Public Shared Property FixUnitLength As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Ptl900U Class
Ptl900U Members


Ptl900U.MaxBatchCodeLength Property

[image]

Pick To Light 设备通讯类库
Ptl900U..::..MaxBatchCodeLength Property
Ptl900U Class See Also Send Feedback
获取或设置批号的最大长度，默认 12。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static int MaxBatchCodeLength { get; set; }
Visual Basic
Public Shared Property MaxBatchCodeLength As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Ptl900U Class
Ptl900U Members


Ptl900U.MaxDescriptionLength Property

[image]

Pick To Light 设备通讯类库
Ptl900U..::..MaxDescriptionLength Property
Ptl900U Class See Also Send Feedback
获取或设置描述的最大字节数，默认 60。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static int MaxDescriptionLength { get; set; }
Visual Basic
Public Shared Property MaxDescriptionLength As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Ptl900U Class
Ptl900U Members


Ptl900U.MaxDescriptionLineCount Property

[image]

Pick To Light 设备通讯类库
Ptl900U..::..MaxDescriptionLineCount Property
Ptl900U Class See Also Send Feedback
获取或设置描述的最大行数，默认 3。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static int MaxDescriptionLineCount { get; set; }
Visual Basic
Public Shared Property MaxDescriptionLineCount As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Ptl900U Class
Ptl900U Members


Ptl900U.MaxDeviceStoredItemsCount Property

[image]

Pick To Light 设备通讯类库
Ptl900U..::..MaxDeviceStoredItemsCount Property
Ptl900U Class See Also Send Feedback
获取或设置设备上可驻留的最大项数，默认 2。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static int MaxDeviceStoredItemsCount { get; set; }
Visual Basic
Public Shared Property MaxDeviceStoredItemsCount As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Ptl900U Class
Ptl900U Members


Ptl900U.MaxNameLength Property

[image]

Pick To Light 设备通讯类库
Ptl900U..::..MaxNameLength Property
Ptl900U Class See Also Send Feedback
获取或设置品名的最大字节数，默认 36。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static int MaxNameLength { get; set; }
Visual Basic
Public Shared Property MaxNameLength As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Ptl900U Class
Ptl900U Members


Ptl900U.MinorType Property

[image]

Pick To Light 设备通讯类库
Ptl900U..::..MinorType Property
Ptl900U Class See Also Send Feedback
获取或设置小类型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual Ptl900UType MinorType { get; set; }
Visual Basic
Public Overridable Property MinorType As Ptl900UType
    Get
    Set

Property Value

Type: Ptl900UType

See Also

Ptl900U Class
Ptl900U Members


Ptl900U.SurfaceTextEncoding Property

[image]

Pick To Light 设备通讯类库
Ptl900U..::..SurfaceTextEncoding Property
Ptl900U Class See Also Send Feedback
获取或设置 Surface 型标签上文本的编码，默认 gb2312。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static Encoding SurfaceTextEncoding { get; set; }
Visual Basic
Public Shared Property SurfaceTextEncoding As Encoding
    Get
    Set

Property Value

Type: Encoding

Exceptions

Exception | Condition
System..::..ArgumentNullException | 设置时使用空值。

See Also

Ptl900U Class
Ptl900U Members


Ptl900U Events

[image] [image]

Pick To Light 设备通讯类库
Ptl900U Events
Ptl900U Class See Also Send Feedback

The Ptl900U type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public event | Pressed | OK 按钮被按下事件。

See Also

Ptl900U Class


Ptl900U.Pressed Event

[image]

Pick To Light 设备通讯类库
Ptl900U..::..Pressed Event
Ptl900U Class See Also Send Feedback
OK 按钮被按下事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public event EventHandler<Ptl900UPressedEventArgs> Pressed
Visual Basic
Public Event Pressed As EventHandler(Of Ptl900UPressedEventArgs)

Value

Type: System..::..EventHandler <(Of <(<' Ptl900UPressedEventArgs >)>)>

See Also

Ptl900U Class
Ptl900U Members


Ptl900UAppearance Class

[image]

Pick To Light 设备通讯类库
Ptl900UAppearance Class
Members See Also Send Feedback
拣货标签的外观。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class Ptl900UAppearance
Visual Basic
<SerializableAttribute>
Public Class Ptl900UAppearance

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..Ptl900UAppearance

See Also

Ptl900UAppearance Members


Ptl900UAppearance Members

[image] [image]

Pick To Light 设备通讯类库
Ptl900UAppearance Members
Ptl900UAppearance Class Constructors Properties See Also Send Feedback

The Ptl900UAppearance type exposes the following members.

Constructors

 | Name | Description
Public method | Ptl900UAppearance | Initializes a new instance of the Ptl900UAppearance class

Properties

 | Name | Description
Public property | Background | 获取或设置彩屏背景。
Public property | BatchCode | 获取或设置批号。
Public property | Count | 获取或设置数量。
Public property | Description | 获取或设置描述。
Public property | Direction | 获取或设置方向。
Public property | EnableF1OkColorAfterPress | 获取或设置是否启用 F1 功能。
Public property | Light | 获取或设置亮灯模式。
Public property | LongSubLocation | 获取或设置长行列码。
Public property | Name | 获取或设置名称。
Public property | Sound | 获取或设置声音。
Public property | SubLocation | 获取或设置行列码。
Public property | Unit | 获取或设置单位。

See Also

Ptl900UAppearance Class


Ptl900UAppearance Constructor

[image]

Pick To Light 设备通讯类库
Ptl900UAppearance Constructor
Ptl900UAppearance Class See Also Send Feedback
Initializes a new instance of the Ptl900UAppearance class

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Ptl900UAppearance()
Visual Basic
Public Sub New

See Also

Ptl900UAppearance Class
Ptl900UAppearance Members


Ptl900UAppearance Properties

[image] [image]

Pick To Light 设备通讯类库
Ptl900UAppearance Properties
Ptl900UAppearance Class See Also Send Feedback

The Ptl900UAppearance type exposes the following members.

Properties

 | Name | Description
Public property | Background | 获取或设置彩屏背景。
Public property | BatchCode | 获取或设置批号。
Public property | Count | 获取或设置数量。
Public property | Description | 获取或设置描述。
Public property | Direction | 获取或设置方向。
Public property | EnableF1OkColorAfterPress | 获取或设置是否启用 F1 功能。
Public property | Light | 获取或设置亮灯模式。
Public property | LongSubLocation | 获取或设置长行列码。
Public property | Name | 获取或设置名称。
Public property | Sound | 获取或设置声音。
Public property | SubLocation | 获取或设置行列码。
Public property | Unit | 获取或设置单位。

See Also

Ptl900UAppearance Class


Ptl900UAppearance.Background Property

[image]

Pick To Light 设备通讯类库
Ptl900UAppearance..::..Background Property
Ptl900UAppearance Class See Also Send Feedback
获取或设置彩屏背景。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Nullable<SurfaceBackground> Background { get; set; }
Visual Basic
Public Property Background As Nullable(Of SurfaceBackground)
    Get
    Set

Property Value

Type: Nullable <(Of <(<' SurfaceBackground >)>)>

See Also

Ptl900UAppearance Class
Ptl900UAppearance Members


Ptl900UAppearance.BatchCode Property

[image]

Pick To Light 设备通讯类库
Ptl900UAppearance..::..BatchCode Property
Ptl900UAppearance Class See Also Send Feedback
获取或设置批号。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string BatchCode { get; set; }
Visual Basic
Public Property BatchCode As String
    Get
    Set

Property Value

Type: String

See Also

Ptl900UAppearance Class
Ptl900UAppearance Members


Ptl900UAppearance.Count Property

[image]

Pick To Light 设备通讯类库
Ptl900UAppearance..::..Count Property
Ptl900UAppearance Class See Also Send Feedback
获取或设置数量。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Nullable<ushort> Count { get; set; }
Visual Basic
Public Property Count As Nullable(Of UShort)
    Get
    Set

Property Value

Type: Nullable <(Of <(<' UInt16 >)>)>

See Also

Ptl900UAppearance Class
Ptl900UAppearance Members


Ptl900UAppearance.Description Property

[image]

Pick To Light 设备通讯类库
Ptl900UAppearance..::..Description Property
Ptl900UAppearance Class See Also Send Feedback
获取或设置描述。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String

See Also

Ptl900UAppearance Class
Ptl900UAppearance Members


Ptl900UAppearance.Direction Property

[image]

Pick To Light 设备通讯类库
Ptl900UAppearance..::..Direction Property
Ptl900UAppearance Class See Also Send Feedback
获取或设置方向。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Direction Direction { get; set; }
Visual Basic
Public Property Direction As Direction
    Get
    Set

Property Value

Type: Direction

See Also

Ptl900UAppearance Class
Ptl900UAppearance Members


Ptl900UAppearance.EnableF1OkColorAfterPress Property

[image]

Pick To Light 设备通讯类库
Ptl900UAppearance..::..EnableF1OkColorAfterPress Property
Ptl900UAppearance Class See Also Send Feedback
获取或设置是否启用 F1 功能。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool EnableF1OkColorAfterPress { get; set; }
Visual Basic
Public Property EnableF1OkColorAfterPress As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Ptl900UAppearance Class
Ptl900UAppearance Members


Ptl900UAppearance.Light Property

[image]

Pick To Light 设备通讯类库
Ptl900UAppearance..::..Light Property
Ptl900UAppearance Class See Also Send Feedback
获取或设置亮灯模式。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public LightMode Light { get; set; }
Visual Basic
Public Property Light As LightMode
    Get
    Set

Property Value

Type: LightMode
为空时会被 LightMode.Default 取代。

See Also

Ptl900UAppearance Class
Ptl900UAppearance Members


Ptl900UAppearance.LongSubLocation Property

[image]

Pick To Light 设备通讯类库
Ptl900UAppearance..::..LongSubLocation Property
Ptl900UAppearance Class See Also Send Feedback
获取或设置长行列码。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string LongSubLocation { get; set; }
Visual Basic
Public Property LongSubLocation As String
    Get
    Set

Property Value

Type: String

See Also

Ptl900UAppearance Class
Ptl900UAppearance Members


Ptl900UAppearance.Name Property

[image]

Pick To Light 设备通讯类库
Ptl900UAppearance..::..Name Property
Ptl900UAppearance Class See Also Send Feedback
获取或设置名称。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

See Also

Ptl900UAppearance Class
Ptl900UAppearance Members


Ptl900UAppearance.Sound Property

[image]

Pick To Light 设备通讯类库
Ptl900UAppearance..::..Sound Property
Ptl900UAppearance Class See Also Send Feedback
获取或设置声音。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public SoundMode Sound { get; set; }
Visual Basic
Public Property Sound As SoundMode
    Get
    Set

Property Value

Type: SoundMode

See Also

Ptl900UAppearance Class
Ptl900UAppearance Members


Ptl900UAppearance.SubLocation Property

[image]

Pick To Light 设备通讯类库
Ptl900UAppearance..::..SubLocation Property
Ptl900UAppearance Class See Also Send Feedback
获取或设置行列码。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Nullable<byte> SubLocation { get; set; }
Visual Basic
Public Property SubLocation As Nullable(Of Byte)
    Get
    Set

Property Value

Type: Nullable <(Of <(<' Byte >)>)>

See Also

Ptl900UAppearance Class
Ptl900UAppearance Members


Ptl900UAppearance.Unit Property

[image]

Pick To Light 设备通讯类库
Ptl900UAppearance..::..Unit Property
Ptl900UAppearance Class See Also Send Feedback
获取或设置单位。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Unit { get; set; }
Visual Basic
Public Property Unit As String
    Get
    Set

Property Value

Type: String

See Also

Ptl900UAppearance Class
Ptl900UAppearance Members


Ptl900UPressedEventArgs Class

[image]

Pick To Light 设备通讯类库
Ptl900UPressedEventArgs Class
Members See Also Send Feedback
为 Ptl900U.Pressed 事件提供事件参数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class Ptl900UPressedEventArgs : EventArgs,
    IXmlSerializable
Visual Basic
<SerializableAttribute>
Public Class Ptl900UPressedEventArgs
    Inherits EventArgs
    Implements IXmlSerializable

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Ptl.Device..::..Ptl900UPressedEventArgs

See Also

Ptl900UPressedEventArgs Members


Ptl900UPressedEventArgs Members

[image] [image]

Pick To Light 设备通讯类库
Ptl900UPressedEventArgs Members
Ptl900UPressedEventArgs Class Constructors Methods Properties See Also Send Feedback

The Ptl900UPressedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | Ptl900UPressedEventArgs | Initializes a new instance of the Ptl900UPressedEventArgs class

Methods

 | Name | Description
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | WriteXml | 将对象转换为其 XML 表示形式。

Properties

 | Name | Description
Public property | FnLongPressed | 获取或设置 Fn 键是否被长按。
Public property | ResultByItem | 获取显示项及其返回值集合。

See Also

Ptl900UPressedEventArgs Class


Ptl900UPressedEventArgs Constructor

[image]

Pick To Light 设备通讯类库
Ptl900UPressedEventArgs Constructor
Ptl900UPressedEventArgs Class See Also Send Feedback
Initializes a new instance of the Ptl900UPressedEventArgs class

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Ptl900UPressedEventArgs()
Visual Basic
Public Sub New

See Also

Ptl900UPressedEventArgs Class
Ptl900UPressedEventArgs Members


Ptl900UPressedEventArgs Methods

[image] [image]

Pick To Light 设备通讯类库
Ptl900UPressedEventArgs Methods
Ptl900UPressedEventArgs Class See Also Send Feedback

The Ptl900UPressedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | WriteXml | 将对象转换为其 XML 表示形式。

See Also

Ptl900UPressedEventArgs Class


Ptl900UPressedEventArgs.GetSchema Method

[image]

Pick To Light 设备通讯类库
Ptl900UPressedEventArgs..::..GetSchema Method
Ptl900UPressedEventArgs Class See Also Send Feedback
此方法是保留方法，请不要使用。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XmlSchema GetSchema()
Visual Basic
Public Function GetSchema As XmlSchema

Return Value

Type: XmlSchema
始终返回空。

Implements

IXmlSerializable..::..GetSchema()()()()

See Also

Ptl900UPressedEventArgs Class
Ptl900UPressedEventArgs Members


Ptl900UPressedEventArgs.ReadXml Method

[image]

Pick To Light 设备通讯类库
Ptl900UPressedEventArgs..::..ReadXml Method
Ptl900UPressedEventArgs Class See Also Send Feedback
从对象的 XML 表示形式生成该对象。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void ReadXml(
    XmlReader reader
)
Visual Basic
Public Sub ReadXml (
    reader As XmlReader
)

Parameters

reader
Type: System.Xml..::..XmlReader
对象从中进行反序列化的 System.Xml.XmlReader 流。

Implements

IXmlSerializable..::..ReadXml(XmlReader)

Exceptions

Exception | Condition
System..::..ArgumentNullException | reader 为空。

See Also

Ptl900UPressedEventArgs Class
Ptl900UPressedEventArgs Members


Ptl900UPressedEventArgs.WriteXml Method

[image]

Pick To Light 设备通讯类库
Ptl900UPressedEventArgs..::..WriteXml Method
Ptl900UPressedEventArgs Class See Also Send Feedback
将对象转换为其 XML 表示形式。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void WriteXml(
    XmlWriter writer
)
Visual Basic
Public Sub WriteXml (
    writer As XmlWriter
)

Parameters

writer
Type: System.Xml..::..XmlWriter
对象要序列化为的 System.Xml.XmlWriter 流。

Implements

IXmlSerializable..::..WriteXml(XmlWriter)

Exceptions

Exception | Condition
System..::..ArgumentNullException | writer 为空。

See Also

Ptl900UPressedEventArgs Class
Ptl900UPressedEventArgs Members


Ptl900UPressedEventArgs Properties

[image] [image]

Pick To Light 设备通讯类库
Ptl900UPressedEventArgs Properties
Ptl900UPressedEventArgs Class See Also Send Feedback

The Ptl900UPressedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | FnLongPressed | 获取或设置 Fn 键是否被长按。
Public property | ResultByItem | 获取显示项及其返回值集合。

See Also

Ptl900UPressedEventArgs Class


Ptl900UPressedEventArgs.FnLongPressed Property

[image]

Pick To Light 设备通讯类库
Ptl900UPressedEventArgs..::..FnLongPressed Property
Ptl900UPressedEventArgs Class See Also Send Feedback
获取或设置 Fn 键是否被长按。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool FnLongPressed { get; set; }
Visual Basic
Public Property FnLongPressed As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

Ptl900UPressedEventArgs Class
Ptl900UPressedEventArgs Members


Ptl900UPressedEventArgs.ResultByItem Property

[image]

Pick To Light 设备通讯类库
Ptl900UPressedEventArgs..::..ResultByItem Property
Ptl900UPressedEventArgs Class See Also Send Feedback
获取显示项及其返回值集合。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Dictionary<Display900UItem, ushort> ResultByItem { get; }
Visual Basic
Public ReadOnly Property ResultByItem As Dictionary(Of Display900UItem, UShort)
    Get

Property Value

Type: Dictionary <(Of <(<' Display900UItem, UInt16 >)>)>

See Also

Ptl900UPressedEventArgs Class
Ptl900UPressedEventArgs Members


Ptl900UType Enumeration

[image]

Pick To Light 设备通讯类库
Ptl900UType Enumeration
See Also Send Feedback
Ptl900U 的类型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum Ptl900UType
Visual Basic
Public Enumeration Ptl900UType

Members

Member name | Value | Description
P0 | 0 | 无位数。
P01 | 11 | 1 位。
P02 | 21 | 2 位。
P03 | 31 | 3 位。
P04 | 41 | 4 位。
P05 | 51 | 5 位。
P11 | 22 | 2 位。
P12 | 32 | 3 位。
P13 | 42 | 4 位。
P14 | 52 | 5 位。
P15 | 62 | 6 位。
P21 | 33 | 3 位。
P22 | 43 | 4 位。
P23 | 53 | 5 位。
P24 | 63 | 6 位。
P25 | 73 | 7 位。
P31 | 44 | 4 位。
P32 | 54 | 5 位。
P33 | 64 | 6 位。
P34 | 74 | 7 位。
P35 | 84 | 8 位。
H424 | 101 | 三窗点阵。
S1 | 201 | 单彩屏。
S2 | 202 | 双彩屏。

See Also


PtlDevice Class

[image]

Pick To Light 设备通讯类库
PtlDevice Class
Members See Also Send Feedback
PTL 设备的基类。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public abstract class PtlDevice
Visual Basic
<SerializableAttribute>
Public MustInherit Class PtlDevice

Remarks

对设备的控制是异步的，协议会加入队列，由 CommandQueueExecutor 调用 ExecuteFirstCommand 方法来异步执行。

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..PtlDevice
Ptl.Device..::..Ptl600U
Ptl.Device..::..Ptl900U
Ptl.Device..::..PtlIOPort
Ptl.Device..::..PtlTera

See Also

PtlDevice Members


PtlDevice Members

[image] [image]

Pick To Light 设备通讯类库
PtlDevice Members
PtlDevice Class Constructors Methods Properties Events See Also Send Feedback

The PtlDevice type exposes the following members.

Constructors

 | Name | Description
Protected method | PtlDevice | Initializes a new instance of the PtlDevice class

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列。
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。
Public method | Lock | 锁定设备按键。
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。
Protected method | OnError | 引发设备错误事件。
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。
Public method | PerformError | 引发设备错误事件。
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。
Public method | Refresh | 刷新显示。
Protected method | RemoveHeartbeat | 移除心跳命令。
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计。
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。
Public method | Unlock | 解锁设备按键。

Properties

 | Name | Description
Public property | Address | 获取或设置站点号。
Public property | CommandCount | 获取队列中未完成的命令数。
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。
Public property | CommunicationStatistics | 获取通讯统计信息。
Public property | InError | 获取设备是否处于错误状态。
Public property | IsLocked | 获取设备是否锁定。
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。
Public property | MajorType | 获取或设置大类型。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。
Public property | Tag | 获取或设置相关联数据。

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。
Public event | Error | 设备错误事件。
Public event | ExecuteProtocol | 设备协议被成功执行事件。
Public event | InErrorChanged | 设备错误状态更改事件。
Public event | IsLockedChanged | 设备锁定状态更改事件。

See Also

PtlDevice Class


PtlDevice Constructor

[image]

Pick To Light 设备通讯类库
PtlDevice Constructor
PtlDevice Class See Also Send Feedback
Initializes a new instance of the PtlDevice class

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected PtlDevice()
Visual Basic
Protected Sub New

See Also

PtlDevice Class
PtlDevice Members


PtlDevice Methods

[image] [image]

Pick To Light 设备通讯类库
PtlDevice Methods
PtlDevice Class See Also Send Feedback

The PtlDevice type exposes the following members.

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列。
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。
Public method | Lock | 锁定设备按键。
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。
Protected method | OnError | 引发设备错误事件。
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。
Public method | PerformError | 引发设备错误事件。
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。
Public method | Refresh | 刷新显示。
Protected method | RemoveHeartbeat | 移除心跳命令。
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计。
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。
Public method | Unlock | 解锁设备按键。

See Also

PtlDevice Class


PtlDevice.ClearCommandQueue Method

[image]

Pick To Light 设备通讯类库
PtlDevice..::..ClearCommandQueue Method
PtlDevice Class See Also Send Feedback
清空协议队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void ClearCommandQueue()
Visual Basic
Public Overridable Sub ClearCommandQueue

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.Initialize Method

[image]

Pick To Light 设备通讯类库
PtlDevice..::..Initialize Method
PtlDevice Class See Also Send Feedback
清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Initialize()
Visual Basic
Public Overridable Sub Initialize

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.Lock Method

[image]

Pick To Light 设备通讯类库
PtlDevice..::..Lock Method
PtlDevice Class See Also Send Feedback
锁定设备按键。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Lock()
Visual Basic
Public Overridable Sub Lock

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.OnAppearanceChanged Method

[image]

Pick To Light 设备通讯类库
PtlDevice..::..OnAppearanceChanged Method
PtlDevice Class See Also Send Feedback
引发设备的当前外观更改事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void OnAppearanceChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnAppearanceChanged (
    e As EventArgs
)

Parameters

e
Type: System..::..EventArgs
事件参数。

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.OnError Method

[image]

Pick To Light 设备通讯类库
PtlDevice..::..OnError Method
PtlDevice Class See Also Send Feedback
引发设备错误事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void OnError(
    PtlDeviceErrorEventArgs e
)
Visual Basic
Protected Overridable Sub OnError (
    e As PtlDeviceErrorEventArgs
)

Parameters

e
Type: Ptl.Device..::..PtlDeviceErrorEventArgs
事件参数。

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.OnExecuteProtocol Method

[image]

Pick To Light 设备通讯类库
PtlDevice..::..OnExecuteProtocol Method
PtlDevice Class See Also Send Feedback
引发设备协议被成功执行事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void OnExecuteProtocol(
    PtlDeviceExecuteProtocolEventArgs e
)
Visual Basic
Protected Overridable Sub OnExecuteProtocol (
    e As PtlDeviceExecuteProtocolEventArgs
)

Parameters

e
Type: Ptl.Device..::..PtlDeviceExecuteProtocolEventArgs
事件参数。

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.OnInErrorChanged Method

[image]

Pick To Light 设备通讯类库
PtlDevice..::..OnInErrorChanged Method
PtlDevice Class See Also Send Feedback
引发设备错误状态更改事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void OnInErrorChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnInErrorChanged (
    e As EventArgs
)

Parameters

e
Type: System..::..EventArgs
事件参数。

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.OnIsLockedChanged Method

[image]

Pick To Light 设备通讯类库
PtlDevice..::..OnIsLockedChanged Method
PtlDevice Class See Also Send Feedback
引发设备锁定状态更改事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void OnIsLockedChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnIsLockedChanged (
    e As EventArgs
)

Parameters

e
Type: System..::..EventArgs
事件参数。

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.PerformAppearanceChanged Method

[image]

Pick To Light 设备通讯类库
PtlDevice..::..PerformAppearanceChanged Method
PtlDevice Class See Also Send Feedback
引发设备的当前外观更改事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void PerformAppearanceChanged()
Visual Basic
Public Sub PerformAppearanceChanged

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.PerformError Method

[image]

Pick To Light 设备通讯类库
PtlDevice..::..PerformError Method
PtlDevice Class See Also Send Feedback
引发设备错误事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void PerformError(
    PtlDeviceErrorEventArgs e
)
Visual Basic
Public Sub PerformError (
    e As PtlDeviceErrorEventArgs
)

Parameters

e
Type: Ptl.Device..::..PtlDeviceErrorEventArgs
事件参数。

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.PerformExecuteProtocol Method

[image]

Pick To Light 设备通讯类库
PtlDevice..::..PerformExecuteProtocol Method
PtlDevice Class See Also Send Feedback
引发设备协议被成功执行事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void PerformExecuteProtocol(
    PtlDeviceExecuteProtocolEventArgs e
)
Visual Basic
Public Sub PerformExecuteProtocol (
    e As PtlDeviceExecuteProtocolEventArgs
)

Parameters

e
Type: Ptl.Device..::..PtlDeviceExecuteProtocolEventArgs
事件参数。

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.Refresh Method

[image]

Pick To Light 设备通讯类库
PtlDevice..::..Refresh Method
PtlDevice Class See Also Send Feedback
刷新显示。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Refresh()
Visual Basic
Public Overridable Sub Refresh

Remarks

常用于设备断电后更换设备后。

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.RemoveHeartbeat Method

[image]

Pick To Light 设备通讯类库
PtlDevice..::..RemoveHeartbeat Method
PtlDevice Class See Also Send Feedback
移除心跳命令。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected internal virtual void RemoveHeartbeat()
Visual Basic
Protected Friend Overridable Sub RemoveHeartbeat

Remarks

此方法常用于在业务命令下发前清空未执行的心跳命令，减少通讯耗时。

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.ResetCommunicationStatistics Method

[image]

Pick To Light 设备通讯类库
PtlDevice..::..ResetCommunicationStatistics Method
PtlDevice Class See Also Send Feedback
使用新的统计信息重新开始统计。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void ResetCommunicationStatistics()
Visual Basic
Public Overridable Sub ResetCommunicationStatistics

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.TryAddHeartbeat Method

[image]

Pick To Light 设备通讯类库
PtlDevice..::..TryAddHeartbeat Method
PtlDevice Class See Also Send Feedback
尝试加入心跳命令，只在命令队列为空时才会加入。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual bool TryAddHeartbeat()
Visual Basic
Public Overridable Function TryAddHeartbeat As Boolean

Return Value

Type: Boolean
是否成功加入心跳命令。

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.Unlock Method

[image]

Pick To Light 设备通讯类库
PtlDevice..::..Unlock Method
PtlDevice Class See Also Send Feedback
解锁设备按键。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Unlock()
Visual Basic
Public Overridable Sub Unlock

See Also

PtlDevice Class
PtlDevice Members


PtlDevice Properties

[image] [image]

Pick To Light 设备通讯类库
PtlDevice Properties
PtlDevice Class See Also Send Feedback

The PtlDevice type exposes the following members.

Properties

 | Name | Description
Public property | Address | 获取或设置站点号。
Public property | CommandCount | 获取队列中未完成的命令数。
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。
Public property | CommunicationStatistics | 获取通讯统计信息。
Public property | InError | 获取设备是否处于错误状态。
Public property | IsLocked | 获取设备是否锁定。
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。
Public property | MajorType | 获取或设置大类型。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。
Public property | Tag | 获取或设置相关联数据。

See Also

PtlDevice Class


PtlDevice.Address Property

[image]

Pick To Light 设备通讯类库
PtlDevice..::..Address Property
PtlDevice Class See Also Send Feedback
获取或设置站点号。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual byte Address { get; set; }
Visual Basic
Public Overridable Property Address As Byte
    Get
    Set

Property Value

Type: Byte

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | 设置时值小于 1 或大于 247。

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.CommandCount Property

[image]

Pick To Light 设备通讯类库
PtlDevice..::..CommandCount Property
PtlDevice Class See Also Send Feedback
获取队列中未完成的命令数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual int CommandCount { get; }
Visual Basic
Public Overridable ReadOnly Property CommandCount As Integer
    Get

Property Value

Type: Int32

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.CommandQueueSyncRoot Property

[image]

Pick To Light 设备通讯类库
PtlDevice..::..CommandQueueSyncRoot Property
PtlDevice Class See Also Send Feedback
获取协议队列的同步根。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected Object CommandQueueSyncRoot { get; }
Visual Basic
Protected ReadOnly Property CommandQueueSyncRoot As Object
    Get

Property Value

Type: Object

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.CommunicateSyncRoot Property

[image]

Pick To Light 设备通讯类库
PtlDevice..::..CommunicateSyncRoot Property
PtlDevice Class See Also Send Feedback
获取通讯操作的同步根。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected Object CommunicateSyncRoot { get; }
Visual Basic
Protected ReadOnly Property CommunicateSyncRoot As Object
    Get

Property Value

Type: Object

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.CommunicationStatistics Property

[image]

Pick To Light 设备通讯类库
PtlDevice..::..CommunicationStatistics Property
PtlDevice Class See Also Send Feedback
获取通讯统计信息。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public CommunicationStatistics CommunicationStatistics { get; }
Visual Basic
Public ReadOnly Property CommunicationStatistics As CommunicationStatistics
    Get

Property Value

Type: CommunicationStatistics

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.InError Property

[image]

Pick To Light 设备通讯类库
PtlDevice..::..InError Property
PtlDevice Class See Also Send Feedback
获取设备是否处于错误状态。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Nullable<bool> InError { get; private set; }
Visual Basic
Public Property InError As Nullable(Of Boolean)
    Get
    Private Set

Property Value

Type: Nullable <(Of <(<' Boolean >)>)>

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.IsLocked Property

[image]

Pick To Light 设备通讯类库
PtlDevice..::..IsLocked Property
PtlDevice Class See Also Send Feedback
获取设备是否锁定。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Nullable<bool> IsLocked { get; private set; }
Visual Basic
Public Property IsLocked As Nullable(Of Boolean)
    Get
    Private Set

Property Value

Type: Nullable <(Of <(<' Boolean >)>)>

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.LockUnlockCommandQueue Property

[image]

Pick To Light 设备通讯类库
PtlDevice..::..LockUnlockCommandQueue Property
PtlDevice Class See Also Send Feedback
获取 加锁解锁协议 队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected Collection<CommandBase> LockUnlockCommandQueue { get; }
Visual Basic
Protected ReadOnly Property LockUnlockCommandQueue As Collection(Of CommandBase)
    Get

Property Value

Type: Collection <(Of <(<' CommandBase >)>)>

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.MajorType Property

[image]

Pick To Light 设备通讯类库
PtlDevice..::..MajorType Property
PtlDevice Class See Also Send Feedback
获取或设置大类型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public PtlDeviceType MajorType { get; protected set; }
Visual Basic
Public Property MajorType As PtlDeviceType
    Get
    Protected Set

Property Value

Type: PtlDeviceType

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.NormalCommandQueue Property

[image]

Pick To Light 设备通讯类库
PtlDevice..::..NormalCommandQueue Property
PtlDevice Class See Also Send Feedback
获取 非加锁解锁协议 队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected Collection<CommandBase> NormalCommandQueue { get; }
Visual Basic
Protected ReadOnly Property NormalCommandQueue As Collection(Of CommandBase)
    Get

Property Value

Type: Collection <(Of <(<' CommandBase >)>)>

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.Tag Property

[image]

Pick To Light 设备通讯类库
PtlDevice..::..Tag Property
PtlDevice Class See Also Send Feedback
获取或设置相关联数据。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Object Tag { get; set; }
Visual Basic
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object

See Also

PtlDevice Class
PtlDevice Members


PtlDevice Events

[image] [image]

Pick To Light 设备通讯类库
PtlDevice Events
PtlDevice Class See Also Send Feedback

The PtlDevice type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。
Public event | Error | 设备错误事件。
Public event | ExecuteProtocol | 设备协议被成功执行事件。
Public event | InErrorChanged | 设备错误状态更改事件。
Public event | IsLockedChanged | 设备锁定状态更改事件。

See Also

PtlDevice Class


PtlDevice.AppearanceChanged Event

[image]

Pick To Light 设备通讯类库
PtlDevice..::..AppearanceChanged Event
PtlDevice Class See Also Send Feedback
设备的当前外观更改事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public event EventHandler AppearanceChanged
Visual Basic
Public Event AppearanceChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.Error Event

[image]

Pick To Light 设备通讯类库
PtlDevice..::..Error Event
PtlDevice Class See Also Send Feedback
设备错误事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public event EventHandler<PtlDeviceErrorEventArgs> Error
Visual Basic
Public Event Error As EventHandler(Of PtlDeviceErrorEventArgs)

Value

Type: System..::..EventHandler <(Of <(<' PtlDeviceErrorEventArgs >)>)>

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.ExecuteProtocol Event

[image]

Pick To Light 设备通讯类库
PtlDevice..::..ExecuteProtocol Event
PtlDevice Class See Also Send Feedback
设备协议被成功执行事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public event EventHandler<PtlDeviceExecuteProtocolEventArgs> ExecuteProtocol
Visual Basic
Public Event ExecuteProtocol As EventHandler(Of PtlDeviceExecuteProtocolEventArgs)

Value

Type: System..::..EventHandler <(Of <(<' PtlDeviceExecuteProtocolEventArgs >)>)>

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.InErrorChanged Event

[image]

Pick To Light 设备通讯类库
PtlDevice..::..InErrorChanged Event
PtlDevice Class See Also Send Feedback
设备错误状态更改事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public event EventHandler InErrorChanged
Visual Basic
Public Event InErrorChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

PtlDevice Class
PtlDevice Members


PtlDevice.IsLockedChanged Event

[image]

Pick To Light 设备通讯类库
PtlDevice..::..IsLockedChanged Event
PtlDevice Class See Also Send Feedback
设备锁定状态更改事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public event EventHandler IsLockedChanged
Visual Basic
Public Event IsLockedChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

PtlDevice Class
PtlDevice Members


PtlDeviceCollection Class

[image]

Pick To Light 设备通讯类库
PtlDeviceCollection Class
Members See Also Send Feedback
RS485Bus 下的设备集合；同一 RS485Bus 下的 PtlDevice.Address 是唯一的。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class PtlDeviceCollection : IEnumerable<PtlDevice>,
    IEnumerable, IXmlSerializable
Visual Basic
<SerializableAttribute>
Public Class PtlDeviceCollection
    Implements IEnumerable(Of PtlDevice), IEnumerable,
    IXmlSerializable

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..PtlDeviceCollection

See Also

PtlDeviceCollection Members


PtlDeviceCollection Members

[image] [image]

Pick To Light 设备通讯类库
PtlDeviceCollection Members
PtlDeviceCollection Class Constructors Methods Properties See Also Send Feedback

The PtlDeviceCollection type exposes the following members.

Constructors

 | Name | Description
Public method | PtlDeviceCollection | Initializes a new instance of the PtlDeviceCollection class

Methods

 | Name | Description
Public method | AddOrUpdate | 添加或按站点号更新设备。
Public method | GetEnumerator | 获取迭代器。
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | Remove(Byte) | 按站点号删除设备。
Public method | Remove(PtlDevice) | 删除设备。
Public method | WriteXml | 将对象转换为其 XML 表示形式。

Properties

 | Name | Description
Public property | Count | 获取集合的大小。
Public property | Item | 按站点号获取设备。

See Also

PtlDeviceCollection Class


PtlDeviceCollection Constructor

[image]

Pick To Light 设备通讯类库
PtlDeviceCollection Constructor
PtlDeviceCollection Class See Also Send Feedback
Initializes a new instance of the PtlDeviceCollection class

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public PtlDeviceCollection()
Visual Basic
Public Sub New

See Also

PtlDeviceCollection Class
PtlDeviceCollection Members


PtlDeviceCollection Methods

[image] [image]

Pick To Light 设备通讯类库
PtlDeviceCollection Methods
PtlDeviceCollection Class See Also Send Feedback

The PtlDeviceCollection type exposes the following members.

Methods

 | Name | Description
Public method | AddOrUpdate | 添加或按站点号更新设备。
Public method | GetEnumerator | 获取迭代器。
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | Remove(Byte) | 按站点号删除设备。
Public method | Remove(PtlDevice) | 删除设备。
Public method | WriteXml | 将对象转换为其 XML 表示形式。

See Also

PtlDeviceCollection Class


PtlDeviceCollection.AddOrUpdate Method

[image]

Pick To Light 设备通讯类库
PtlDeviceCollection..::..AddOrUpdate Method
PtlDeviceCollection Class See Also Send Feedback
添加或按站点号更新设备。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void AddOrUpdate(
    PtlDevice device
)
Visual Basic
Public Sub AddOrUpdate (
    device As PtlDevice
)

Parameters

device
Type: Ptl.Device..::..PtlDevice
待接入的设备。

Exceptions

Exception | Condition
System..::..ArgumentNullException | device 为空。

See Also

PtlDeviceCollection Class
PtlDeviceCollection Members


PtlDeviceCollection.GetEnumerator Method

[image]

Pick To Light 设备通讯类库
PtlDeviceCollection..::..GetEnumerator Method
PtlDeviceCollection Class See Also Send Feedback
获取迭代器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public IEnumerator<PtlDevice> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of PtlDevice)

Return Value

Type: IEnumerator <(Of <(<' PtlDevice >)>)>
可用于按站点号正序循环访问集合的 System.Collections.Generic.IEnumerator<PtlDevice>。

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

PtlDeviceCollection Class
PtlDeviceCollection Members


PtlDeviceCollection.GetSchema Method

[image]

Pick To Light 设备通讯类库
PtlDeviceCollection..::..GetSchema Method
PtlDeviceCollection Class See Also Send Feedback
此方法是保留方法，请不要使用。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XmlSchema GetSchema()
Visual Basic
Public Function GetSchema As XmlSchema

Return Value

Type: XmlSchema
始终返回空。

Implements

IXmlSerializable..::..GetSchema()()()()

See Also

PtlDeviceCollection Class
PtlDeviceCollection Members


PtlDeviceCollection.ReadXml Method

[image]

Pick To Light 设备通讯类库
PtlDeviceCollection..::..ReadXml Method
PtlDeviceCollection Class See Also Send Feedback
从对象的 XML 表示形式生成该对象。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void ReadXml(
    XmlReader reader
)
Visual Basic
Public Sub ReadXml (
    reader As XmlReader
)

Parameters

reader
Type: System.Xml..::..XmlReader
对象从中进行反序列化的 System.Xml.XmlReader 流。

Implements

IXmlSerializable..::..ReadXml(XmlReader)

Exceptions

Exception | Condition
System..::..ArgumentNullException | reader 为空。

See Also

PtlDeviceCollection Class
PtlDeviceCollection Members


PtlDeviceCollection.Remove Method

[image] [image]

Pick To Light 设备通讯类库
PtlDeviceCollection..::..Remove Method
PtlDeviceCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(Byte) | 按站点号删除设备。
Public method | Remove(PtlDevice) | 删除设备。

See Also

PtlDeviceCollection Class
PtlDeviceCollection Members


PtlDeviceCollection.Remove Method (Byte)

[image]

Pick To Light 设备通讯类库
PtlDeviceCollection..::..Remove Method (Byte)
PtlDeviceCollection Class See Also Send Feedback
按站点号删除设备。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool Remove(
    byte address
)
Visual Basic
Public Function Remove (
    address As Byte
) As Boolean

Parameters

address
Type: System..::..Byte
待删除设备的站点号。

Return Value

Type: Boolean
是否成功删除。

See Also

PtlDeviceCollection Class
PtlDeviceCollection Members
Remove Overload


PtlDeviceCollection.Remove Method (PtlDevice)

[image]

Pick To Light 设备通讯类库
PtlDeviceCollection..::..Remove Method (PtlDevice)
PtlDeviceCollection Class See Also Send Feedback
删除设备。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool Remove(
    PtlDevice device
)
Visual Basic
Public Function Remove (
    device As PtlDevice
) As Boolean

Parameters

device
Type: Ptl.Device..::..PtlDevice
待删除设备。

Return Value

Type: Boolean
是否成功删除。

Exceptions

Exception | Condition
System..::..ArgumentNullException | device 为空。

See Also

PtlDeviceCollection Class
PtlDeviceCollection Members
Remove Overload


PtlDeviceCollection.WriteXml Method

[image]

Pick To Light 设备通讯类库
PtlDeviceCollection..::..WriteXml Method
PtlDeviceCollection Class See Also Send Feedback
将对象转换为其 XML 表示形式。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void WriteXml(
    XmlWriter writer
)
Visual Basic
Public Sub WriteXml (
    writer As XmlWriter
)

Parameters

writer
Type: System.Xml..::..XmlWriter
对象要序列化为的 System.Xml.XmlWriter 流。

Implements

IXmlSerializable..::..WriteXml(XmlWriter)

Exceptions

Exception | Condition
System..::..ArgumentNullException | writer 为空。

See Also

PtlDeviceCollection Class
PtlDeviceCollection Members


PtlDeviceCollection Properties

[image] [image]

Pick To Light 设备通讯类库
PtlDeviceCollection Properties
PtlDeviceCollection Class See Also Send Feedback

The PtlDeviceCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | 获取集合的大小。
Public property | Item | 按站点号获取设备。

See Also

PtlDeviceCollection Class


PtlDeviceCollection.Count Property

[image]

Pick To Light 设备通讯类库
PtlDeviceCollection..::..Count Property
PtlDeviceCollection Class See Also Send Feedback
获取集合的大小。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

See Also

PtlDeviceCollection Class
PtlDeviceCollection Members


PtlDeviceCollection.Item Property

[image]

Pick To Light 设备通讯类库
PtlDeviceCollection..::..Item Property
PtlDeviceCollection Class See Also Send Feedback
按站点号获取设备。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public PtlDevice this[
    byte address
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    address As Byte
) As PtlDevice
    Get

Parameters

address
Type: System..::..Byte
设备站点号。

Property Value

Type: PtlDevice

See Also

PtlDeviceCollection Class
PtlDeviceCollection Members


PtlDeviceErrorEventArgs Class

[image]

Pick To Light 设备通讯类库
PtlDeviceErrorEventArgs Class
Members See Also Send Feedback
设备错误事件的事件参数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class PtlDeviceErrorEventArgs : EventArgs
Visual Basic
<SerializableAttribute>
Public Class PtlDeviceErrorEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Ptl.Device..::..PtlDeviceErrorEventArgs

See Also

PtlDeviceErrorEventArgs Members


PtlDeviceErrorEventArgs Members

[image] [image]

Pick To Light 设备通讯类库
PtlDeviceErrorEventArgs Members
PtlDeviceErrorEventArgs Class Constructors Properties See Also Send Feedback

The PtlDeviceErrorEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | PtlDeviceErrorEventArgs(Exception) | 使用指定的异常信息初始化设备错误事件的事件参数。
Public method | PtlDeviceErrorEventArgs(ICommunicationClient, Exception) | 使用指定的通讯客户端和异常信息初始化设备错误事件的事件参数。

Properties

 | Name | Description
Public property | CommunicationClient | 获取或设置可能存在的通讯客户端。
Public property | Exception | 获取或设置异常信息。

See Also

PtlDeviceErrorEventArgs Class


PtlDeviceErrorEventArgs Constructor

[image] [image]

Pick To Light 设备通讯类库
PtlDeviceErrorEventArgs Constructor
PtlDeviceErrorEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PtlDeviceErrorEventArgs(Exception) | 使用指定的异常信息初始化设备错误事件的事件参数。
Public method | PtlDeviceErrorEventArgs(ICommunicationClient, Exception) | 使用指定的通讯客户端和异常信息初始化设备错误事件的事件参数。

See Also

PtlDeviceErrorEventArgs Class
PtlDeviceErrorEventArgs Members


PtlDeviceErrorEventArgs Constructor (Exception)

[image]

Pick To Light 设备通讯类库
PtlDeviceErrorEventArgs Constructor (Exception)
PtlDeviceErrorEventArgs Class See Also Send Feedback
使用指定的异常信息初始化设备错误事件的事件参数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public PtlDeviceErrorEventArgs(
    Exception exception
)
Visual Basic
Public Sub New (
    exception As Exception
)

Parameters

exception
Type: System..::..Exception
异常信息。

Exceptions

Exception | Condition
System..::..ArgumentNullException | exception 为空。

See Also

PtlDeviceErrorEventArgs Class
PtlDeviceErrorEventArgs Members
PtlDeviceErrorEventArgs Overload


PtlDeviceErrorEventArgs Constructor (ICommunicationClient, Exception)

[image]

Pick To Light 设备通讯类库
PtlDeviceErrorEventArgs Constructor (ICommunicationClient, Exception)
PtlDeviceErrorEventArgs Class See Also Send Feedback
使用指定的通讯客户端和异常信息初始化设备错误事件的事件参数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public PtlDeviceErrorEventArgs(
    ICommunicationClient communicationClient,
    Exception exception
)
Visual Basic
Public Sub New (
    communicationClient As ICommunicationClient,
    exception As Exception
)

Parameters

communicationClient
Type: Ptl.Device.Communication..::..ICommunicationClient
通讯客户端。
exception
Type: System..::..Exception
异常信息。

Exceptions

Exception | Condition
System..::..ArgumentNullException | communicationClient 或 exception 为空。

See Also

PtlDeviceErrorEventArgs Class
PtlDeviceErrorEventArgs Members
PtlDeviceErrorEventArgs Overload


PtlDeviceErrorEventArgs Properties

[image] [image]

Pick To Light 设备通讯类库
PtlDeviceErrorEventArgs Properties
PtlDeviceErrorEventArgs Class See Also Send Feedback

The PtlDeviceErrorEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | CommunicationClient | 获取或设置可能存在的通讯客户端。
Public property | Exception | 获取或设置异常信息。

See Also

PtlDeviceErrorEventArgs Class


PtlDeviceErrorEventArgs.CommunicationClient Property

[image]

Pick To Light 设备通讯类库
PtlDeviceErrorEventArgs..::..CommunicationClient Property
PtlDeviceErrorEventArgs Class See Also Send Feedback
获取或设置可能存在的通讯客户端。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ICommunicationClient CommunicationClient { get; set; }
Visual Basic
Public Property CommunicationClient As ICommunicationClient
    Get
    Set

Property Value

Type: ICommunicationClient

Remarks

不是通讯错误时，此属性为空。

See Also

PtlDeviceErrorEventArgs Class
PtlDeviceErrorEventArgs Members


PtlDeviceErrorEventArgs.Exception Property

[image]

Pick To Light 设备通讯类库
PtlDeviceErrorEventArgs..::..Exception Property
PtlDeviceErrorEventArgs Class See Also Send Feedback
获取或设置异常信息。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Exception Exception { get; set; }
Visual Basic
Public Property Exception As Exception
    Get
    Set

Property Value

Type: Exception

Exceptions

Exception | Condition
System..::..ArgumentNullException | 设置时使用空值。

See Also

PtlDeviceErrorEventArgs Class
PtlDeviceErrorEventArgs Members


PtlDeviceExecuteProtocolEventArgs Class

[image]

Pick To Light 设备通讯类库
PtlDeviceExecuteProtocolEventArgs Class
Members See Also Send Feedback
设备协议被成功执行事件的事件参数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class PtlDeviceExecuteProtocolEventArgs : EventArgs
Visual Basic
<SerializableAttribute>
Public Class PtlDeviceExecuteProtocolEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Ptl.Device..::..PtlDeviceExecuteProtocolEventArgs

See Also

PtlDeviceExecuteProtocolEventArgs Members


PtlDeviceExecuteProtocolEventArgs Members

[image] [image]

Pick To Light 设备通讯类库
PtlDeviceExecuteProtocolEventArgs Members
PtlDeviceExecuteProtocolEventArgs Class Constructors Properties See Also Send Feedback

The PtlDeviceExecuteProtocolEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | PtlDeviceExecuteProtocolEventArgs | 初始化协议成功执行事件的事件参数。

Properties

 | Name | Description
Public property | BeginTime | 获取或设置开始时间。
Public property | CommunicationClient | 获取或设置通讯客户端。
Public property | EndTime | 获取或设置结束时间。
Public property | Protocol | 获取或设置协议。

See Also

PtlDeviceExecuteProtocolEventArgs Class


PtlDeviceExecuteProtocolEventArgs Constructor

[image]

Pick To Light 设备通讯类库
PtlDeviceExecuteProtocolEventArgs Constructor
PtlDeviceExecuteProtocolEventArgs Class See Also Send Feedback
初始化协议成功执行事件的事件参数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public PtlDeviceExecuteProtocolEventArgs(
    ICommunicationClient communicationClient,
    IUnicastProtocol protocol,
    DateTime beginTime,
    DateTime endTime
)
Visual Basic
Public Sub New (
    communicationClient As ICommunicationClient,
    protocol As IUnicastProtocol,
    beginTime As DateTime,
    endTime As DateTime
)

Parameters

communicationClient
Type: Ptl.Device.Communication..::..ICommunicationClient
通讯客户端。
protocol
Type: Ptl.Device.Communication.Protocol.Unicast..::..IUnicastProtocol
协议。
beginTime
Type: System..::..DateTime
开始时间。
endTime
Type: System..::..DateTime
结束时间。

Exceptions

Exception | Condition
System..::..ArgumentNullException | communicationClient 或 command 为空。

See Also

PtlDeviceExecuteProtocolEventArgs Class
PtlDeviceExecuteProtocolEventArgs Members


PtlDeviceExecuteProtocolEventArgs Properties

[image] [image]

Pick To Light 设备通讯类库
PtlDeviceExecuteProtocolEventArgs Properties
PtlDeviceExecuteProtocolEventArgs Class See Also Send Feedback

The PtlDeviceExecuteProtocolEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | BeginTime | 获取或设置开始时间。
Public property | CommunicationClient | 获取或设置通讯客户端。
Public property | EndTime | 获取或设置结束时间。
Public property | Protocol | 获取或设置协议。

See Also

PtlDeviceExecuteProtocolEventArgs Class


PtlDeviceExecuteProtocolEventArgs.BeginTime Property

[image]

Pick To Light 设备通讯类库
PtlDeviceExecuteProtocolEventArgs..::..BeginTime Property
PtlDeviceExecuteProtocolEventArgs Class See Also Send Feedback
获取或设置开始时间。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public DateTime BeginTime { get; set; }
Visual Basic
Public Property BeginTime As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

PtlDeviceExecuteProtocolEventArgs Class
PtlDeviceExecuteProtocolEventArgs Members


PtlDeviceExecuteProtocolEventArgs.CommunicationClient Property

[image]

Pick To Light 设备通讯类库
PtlDeviceExecuteProtocolEventArgs..::..CommunicationClient Property
PtlDeviceExecuteProtocolEventArgs Class See Also Send Feedback
获取或设置通讯客户端。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ICommunicationClient CommunicationClient { get; set; }
Visual Basic
Public Property CommunicationClient As ICommunicationClient
    Get
    Set

Property Value

Type: ICommunicationClient

Exceptions

Exception | Condition
System..::..ArgumentNullException | 设置时使用空值。

See Also

PtlDeviceExecuteProtocolEventArgs Class
PtlDeviceExecuteProtocolEventArgs Members


PtlDeviceExecuteProtocolEventArgs.EndTime Property

[image]

Pick To Light 设备通讯类库
PtlDeviceExecuteProtocolEventArgs..::..EndTime Property
PtlDeviceExecuteProtocolEventArgs Class See Also Send Feedback
获取或设置结束时间。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public DateTime EndTime { get; set; }
Visual Basic
Public Property EndTime As DateTime
    Get
    Set

Property Value

Type: DateTime

See Also

PtlDeviceExecuteProtocolEventArgs Class
PtlDeviceExecuteProtocolEventArgs Members


PtlDeviceExecuteProtocolEventArgs.Protocol Property

[image]

Pick To Light 设备通讯类库
PtlDeviceExecuteProtocolEventArgs..::..Protocol Property
PtlDeviceExecuteProtocolEventArgs Class See Also Send Feedback
获取或设置协议。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public IUnicastProtocol Protocol { get; set; }
Visual Basic
Public Property Protocol As IUnicastProtocol
    Get
    Set

Property Value

Type: IUnicastProtocol

Exceptions

Exception | Condition
System..::..ArgumentNullException | 设置时使用空值。

See Also

PtlDeviceExecuteProtocolEventArgs Class
PtlDeviceExecuteProtocolEventArgs Members


PtlDeviceType Enumeration

[image]

Pick To Light 设备通讯类库
PtlDeviceType Enumeration
See Also Send Feedback
PTL 设备类型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum PtlDeviceType
Visual Basic
Public Enumeration PtlDeviceType

Members

Member name | Value | Description
Ptl600U | 0 | 文本标签，常用于发布操作指示信息。
Ptl900U | 1 | 拣货标签，有 数量 概念。
PtlXIOPort | 2 | 提供扫描枪和灯塔的接入和控制。
PtlXMatrixPort | 3 | 提供扫描枪、灯塔、600U 的接入和控制。
PtlMXP1O5 | 4 | 提供扫描枪、灯塔、600U 的接入和控制。
PtlXDO10RFID | 5 | 提供 RFID、灯塔、600U 按钮的接入和控制。
PtlTera | 6 | 多灯指示型标签。

See Also


PtlIOPort Class

[image]

Pick To Light 设备通讯类库
PtlIOPort Class
Members See Also Send Feedback
提供扫描枪和灯塔的接入和控制功能。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public abstract class PtlIOPort : PtlDevice
Visual Basic
<SerializableAttribute>
Public MustInherit Class PtlIOPort
    Inherits PtlDevice

Remarks

扫描枪不受锁定操作影响。

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..PtlDevice
Ptl.Device..::..PtlIOPort
Ptl.Device..::..PtlIOPortWith600U
Ptl.Device..::..PtlXIOPort

See Also

PtlIOPort Members


PtlIOPort Members

[image] [image]

Pick To Light 设备通讯类库
PtlIOPort Members
PtlIOPort Class Constructors Methods Properties Events See Also Send Feedback

The PtlIOPort type exposes the following members.

Constructors

 | Name | Description
Protected method | PtlIOPort | Initializes a new instance of the PtlIOPort class

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列，包括其上挂接的设备的协议队列。 (Overrides PtlDevice..::..ClearCommandQueue()()()().)
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。 (Overrides PtlDevice..::..Initialize()()()().)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | Refresh | 刷新显示，包括其上挂接的设备。 (Overrides PtlDevice..::..Refresh()()()().)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计。 (Inherited from PtlDevice.)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

Properties

 | Name | Description
Public property | Address | 获取或设置站点号。 (Inherited from PtlDevice.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Overrides PtlDevice..::..CommandCount.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Public property | Lighthouses | 获取或设置灯塔输出口集合；设置时会改写 Lighthouse 的 Owner。
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | Scanner | 获取或设置扫描枪输入口；设置时会改写 Scanner 的 Owner。
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)

See Also

PtlIOPort Class


PtlIOPort Constructor

[image]

Pick To Light 设备通讯类库
PtlIOPort Constructor
PtlIOPort Class See Also Send Feedback
Initializes a new instance of the PtlIOPort class

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected PtlIOPort()
Visual Basic
Protected Sub New

See Also

PtlIOPort Class
PtlIOPort Members


PtlIOPort Methods

[image] [image]

Pick To Light 设备通讯类库
PtlIOPort Methods
PtlIOPort Class See Also Send Feedback

The PtlIOPort type exposes the following members.

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列，包括其上挂接的设备的协议队列。 (Overrides PtlDevice..::..ClearCommandQueue()()()().)
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。 (Overrides PtlDevice..::..Initialize()()()().)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | Refresh | 刷新显示，包括其上挂接的设备。 (Overrides PtlDevice..::..Refresh()()()().)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计。 (Inherited from PtlDevice.)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

See Also

PtlIOPort Class


PtlIOPort.ClearCommandQueue Method

[image]

Pick To Light 设备通讯类库
PtlIOPort..::..ClearCommandQueue Method
PtlIOPort Class See Also Send Feedback
清空协议队列，包括其上挂接的设备的协议队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override void ClearCommandQueue()
Visual Basic
Public Overrides Sub ClearCommandQueue

See Also

PtlIOPort Class
PtlIOPort Members


PtlIOPort.Initialize Method

[image]

Pick To Light 设备通讯类库
PtlIOPort..::..Initialize Method
PtlIOPort Class See Also Send Feedback
清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override void Initialize()
Visual Basic
Public Overrides Sub Initialize

See Also

PtlIOPort Class
PtlIOPort Members


PtlIOPort.Refresh Method

[image]

Pick To Light 设备通讯类库
PtlIOPort..::..Refresh Method
PtlIOPort Class See Also Send Feedback
刷新显示，包括其上挂接的设备。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override void Refresh()
Visual Basic
Public Overrides Sub Refresh

See Also

PtlIOPort Class
PtlIOPort Members


PtlIOPort Properties

[image] [image]

Pick To Light 设备通讯类库
PtlIOPort Properties
PtlIOPort Class See Also Send Feedback

The PtlIOPort type exposes the following members.

Properties

 | Name | Description
Public property | Address | 获取或设置站点号。 (Inherited from PtlDevice.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Overrides PtlDevice..::..CommandCount.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Public property | Lighthouses | 获取或设置灯塔输出口集合；设置时会改写 Lighthouse 的 Owner。
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | Scanner | 获取或设置扫描枪输入口；设置时会改写 Scanner 的 Owner。
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

See Also

PtlIOPort Class


PtlIOPort.CommandCount Property

[image]

Pick To Light 设备通讯类库
PtlIOPort..::..CommandCount Property
PtlIOPort Class See Also Send Feedback
获取队列中未完成的命令数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override int CommandCount { get; }
Visual Basic
Public Overrides ReadOnly Property CommandCount As Integer
    Get

Property Value

Type: Int32

See Also

PtlIOPort Class
PtlIOPort Members


PtlIOPort.Lighthouses Property

[image]

Pick To Light 设备通讯类库
PtlIOPort..::..Lighthouses Property
PtlIOPort Class See Also Send Feedback
获取或设置灯塔输出口集合；设置时会改写 Lighthouse 的 Owner。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public IOPortCollection<Lighthouse> Lighthouses { get; set; }
Visual Basic
Public Property Lighthouses As IOPortCollection(Of Lighthouse)
    Get
    Set

Property Value

Type: IOPortCollection <(Of <(<' Lighthouse >)>)>

Exceptions

Exception | Condition
System..::..ArgumentNullException | 设置时使用空值。

See Also

PtlIOPort Class
PtlIOPort Members


PtlIOPort.Scanner Property

[image]

Pick To Light 设备通讯类库
PtlIOPort..::..Scanner Property
PtlIOPort Class See Also Send Feedback
获取或设置扫描枪输入口；设置时会改写 Scanner 的 Owner。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Scanner Scanner { get; set; }
Visual Basic
Public Property Scanner As Scanner
    Get
    Set

Property Value

Type: Scanner

See Also

PtlIOPort Class
PtlIOPort Members


PtlIOPort Events

[image] [image]

Pick To Light 设备通讯类库
PtlIOPort Events
PtlIOPort Class See Also Send Feedback

The PtlIOPort type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)

See Also

PtlIOPort Class


PtlIOPortWith600U Class

[image]

Pick To Light 设备通讯类库
PtlIOPortWith600U Class
Members See Also Send Feedback
提供扫描枪、灯塔、600U 的接入和控制。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public abstract class PtlIOPortWith600U : PtlIOPort
Visual Basic
<SerializableAttribute>
Public MustInherit Class PtlIOPortWith600U
    Inherits PtlIOPort

Remarks

不可单独锁定解锁其上的 600U，即 PtlIOPortWith600U.Lock()/UnLock() 和 PtlIOPortWith600U.Ptl600U.Lock()/UnLock() 是一致的。 与此类似，PtlIOPortWith600U.Ptl600U.Clear(Clear600UMode.All) 也会额外清除宿主设备上的条码缓存、灯塔显示。

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..PtlDevice
Ptl.Device..::..PtlIOPort
Ptl.Device..::..PtlIOPortWith600U
Ptl.Device..::..PtlMXP1O5
Ptl.Device..::..PtlXDO10RFID
Ptl.Device..::..PtlXMatrixPort

See Also

PtlIOPortWith600U Members


PtlIOPortWith600U Members

[image] [image]

Pick To Light 设备通讯类库
PtlIOPortWith600U Members
PtlIOPortWith600U Class Constructors Methods Properties Events See Also Send Feedback

The PtlIOPortWith600U type exposes the following members.

Constructors

 | Name | Description
Protected method | PtlIOPortWith600U | 初始化链接器。

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列，包括其上挂接的设备的协议队列。 (Overrides PtlIOPort..::..ClearCommandQueue()()()().)
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。 (Overrides PtlIOPort..::..Initialize()()()().)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | Refresh | 刷新显示，包括其上挂接的设备。 (Overrides PtlIOPort..::..Refresh()()()().)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计，包括其上挂接的 Ptl600U。 (Overrides PtlDevice..::..ResetCommunicationStatistics()()()().)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

Properties

 | Name | Description
Public property | Address | 获取或设置站点号，会覆盖其下的 600U 站点号。 (Overrides PtlDevice..::..Address.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Overrides PtlIOPort..::..CommandCount.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Public property | Lighthouses | 获取或设置灯塔输出口集合；设置时会改写 Lighthouse 的 Owner。 (Inherited from PtlIOPort.)
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | Ptl600U | 获取 600U 单元。
Public property | Scanner | 获取或设置扫描枪输入口；设置时会改写 Scanner 的 Owner。 (Inherited from PtlIOPort.)
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)

See Also

PtlIOPortWith600U Class


PtlIOPortWith600U Constructor

[image]

Pick To Light 设备通讯类库
PtlIOPortWith600U Constructor
PtlIOPortWith600U Class See Also Send Feedback
初始化链接器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected PtlIOPortWith600U()
Visual Basic
Protected Sub New

See Also

PtlIOPortWith600U Class
PtlIOPortWith600U Members


PtlIOPortWith600U Methods

[image] [image]

Pick To Light 设备通讯类库
PtlIOPortWith600U Methods
PtlIOPortWith600U Class See Also Send Feedback

The PtlIOPortWith600U type exposes the following members.

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列，包括其上挂接的设备的协议队列。 (Overrides PtlIOPort..::..ClearCommandQueue()()()().)
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。 (Overrides PtlIOPort..::..Initialize()()()().)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | Refresh | 刷新显示，包括其上挂接的设备。 (Overrides PtlIOPort..::..Refresh()()()().)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计，包括其上挂接的 Ptl600U。 (Overrides PtlDevice..::..ResetCommunicationStatistics()()()().)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

See Also

PtlIOPortWith600U Class


PtlIOPortWith600U.ClearCommandQueue Method

[image]

Pick To Light 设备通讯类库
PtlIOPortWith600U..::..ClearCommandQueue Method
PtlIOPortWith600U Class See Also Send Feedback
清空协议队列，包括其上挂接的设备的协议队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override void ClearCommandQueue()
Visual Basic
Public Overrides Sub ClearCommandQueue

See Also

PtlIOPortWith600U Class
PtlIOPortWith600U Members


PtlIOPortWith600U.Initialize Method

[image]

Pick To Light 设备通讯类库
PtlIOPortWith600U..::..Initialize Method
PtlIOPortWith600U Class See Also Send Feedback
清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override void Initialize()
Visual Basic
Public Overrides Sub Initialize

See Also

PtlIOPortWith600U Class
PtlIOPortWith600U Members


PtlIOPortWith600U.Refresh Method

[image]

Pick To Light 设备通讯类库
PtlIOPortWith600U..::..Refresh Method
PtlIOPortWith600U Class See Also Send Feedback
刷新显示，包括其上挂接的设备。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override void Refresh()
Visual Basic
Public Overrides Sub Refresh

See Also

PtlIOPortWith600U Class
PtlIOPortWith600U Members


PtlIOPortWith600U.ResetCommunicationStatistics Method

[image]

Pick To Light 设备通讯类库
PtlIOPortWith600U..::..ResetCommunicationStatistics Method
PtlIOPortWith600U Class See Also Send Feedback
使用新的统计信息重新开始统计，包括其上挂接的 Ptl600U。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override void ResetCommunicationStatistics()
Visual Basic
Public Overrides Sub ResetCommunicationStatistics

See Also

PtlIOPortWith600U Class
PtlIOPortWith600U Members


PtlIOPortWith600U Properties

[image] [image]

Pick To Light 设备通讯类库
PtlIOPortWith600U Properties
PtlIOPortWith600U Class See Also Send Feedback

The PtlIOPortWith600U type exposes the following members.

Properties

 | Name | Description
Public property | Address | 获取或设置站点号，会覆盖其下的 600U 站点号。 (Overrides PtlDevice..::..Address.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Overrides PtlIOPort..::..CommandCount.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Public property | Lighthouses | 获取或设置灯塔输出口集合；设置时会改写 Lighthouse 的 Owner。 (Inherited from PtlIOPort.)
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | Ptl600U | 获取 600U 单元。
Public property | Scanner | 获取或设置扫描枪输入口；设置时会改写 Scanner 的 Owner。 (Inherited from PtlIOPort.)
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

See Also

PtlIOPortWith600U Class


PtlIOPortWith600U.Address Property

[image]

Pick To Light 设备通讯类库
PtlIOPortWith600U..::..Address Property
PtlIOPortWith600U Class See Also Send Feedback
获取或设置站点号，会覆盖其下的 600U 站点号。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override byte Address { get; set; }
Visual Basic
Public Overrides Property Address As Byte
    Get
    Set

Property Value

Type: Byte

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | 设置时 value 小于 1 或大于 255。

See Also

PtlIOPortWith600U Class
PtlIOPortWith600U Members


PtlIOPortWith600U.CommandCount Property

[image]

Pick To Light 设备通讯类库
PtlIOPortWith600U..::..CommandCount Property
PtlIOPortWith600U Class See Also Send Feedback
获取队列中未完成的命令数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override int CommandCount { get; }
Visual Basic
Public Overrides ReadOnly Property CommandCount As Integer
    Get

Property Value

Type: Int32

See Also

PtlIOPortWith600U Class
PtlIOPortWith600U Members


PtlIOPortWith600U.Ptl600U Property

[image]

Pick To Light 设备通讯类库
PtlIOPortWith600U..::..Ptl600U Property
PtlIOPortWith600U Class See Also Send Feedback
获取 600U 单元。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Ptl600U Ptl600U { get; }
Visual Basic
Public ReadOnly Property Ptl600U As Ptl600U
    Get

Property Value

Type: Ptl600U

See Also

PtlIOPortWith600U Class
PtlIOPortWith600U Members


PtlIOPortWith600U Events

[image] [image]

Pick To Light 设备通讯类库
PtlIOPortWith600U Events
PtlIOPortWith600U Class See Also Send Feedback

The PtlIOPortWith600U type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)

See Also

PtlIOPortWith600U Class


PtlMXP1O5 Class

[image]

Pick To Light 设备通讯类库
PtlMXP1O5 Class
Members See Also Send Feedback
提供扫描枪、灯塔、600U 的接入和控制。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class PtlMXP1O5 : PtlIOPortWith600U
Visual Basic
<SerializableAttribute>
Public Class PtlMXP1O5
    Inherits PtlIOPortWith600U

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..PtlDevice
Ptl.Device..::..PtlIOPort
Ptl.Device..::..PtlIOPortWith600U
Ptl.Device..::..PtlMXP1O5

See Also

PtlMXP1O5 Members


PtlMXP1O5 Members

[image] [image]

Pick To Light 设备通讯类库
PtlMXP1O5 Members
PtlMXP1O5 Class Constructors Methods Properties Events See Also Send Feedback

The PtlMXP1O5 type exposes the following members.

Constructors

 | Name | Description
Public method | PtlMXP1O5 | 初始化 MXP1O5。

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列，包括其上挂接的设备的协议队列。 (Inherited from PtlIOPortWith600U.)
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。 (Inherited from PtlIOPortWith600U.)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | Refresh | 刷新显示，包括其上挂接的设备。 (Inherited from PtlIOPortWith600U.)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计，包括其上挂接的 Ptl600U。 (Inherited from PtlIOPortWith600U.)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

Properties

 | Name | Description
Public property | Address | 获取或设置站点号，会覆盖其下的 600U 站点号。 (Inherited from PtlIOPortWith600U.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from PtlIOPortWith600U.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Public property | Lighthouses | 获取或设置灯塔输出口集合；设置时会改写 Lighthouse 的 Owner。 (Inherited from PtlIOPort.)
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
Public property | MinorType | 获取或设置小类型。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | Ptl600U | 获取 600U 单元。 (Inherited from PtlIOPortWith600U.)
Public property | Scanner | 获取或设置扫描枪输入口；设置时会改写 Scanner 的 Owner。 (Inherited from PtlIOPort.)
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)

See Also

PtlMXP1O5 Class


PtlMXP1O5 Constructor

[image]

Pick To Light 设备通讯类库
PtlMXP1O5 Constructor
PtlMXP1O5 Class See Also Send Feedback
初始化 MXP1O5。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public PtlMXP1O5()
Visual Basic
Public Sub New

See Also

PtlMXP1O5 Class
PtlMXP1O5 Members


PtlMXP1O5 Methods

[image] [image]

Pick To Light 设备通讯类库
PtlMXP1O5 Methods
PtlMXP1O5 Class See Also Send Feedback

The PtlMXP1O5 type exposes the following members.

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列，包括其上挂接的设备的协议队列。 (Inherited from PtlIOPortWith600U.)
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。 (Inherited from PtlIOPortWith600U.)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | Refresh | 刷新显示，包括其上挂接的设备。 (Inherited from PtlIOPortWith600U.)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计，包括其上挂接的 Ptl600U。 (Inherited from PtlIOPortWith600U.)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

See Also

PtlMXP1O5 Class


PtlMXP1O5 Properties

[image] [image]

Pick To Light 设备通讯类库
PtlMXP1O5 Properties
PtlMXP1O5 Class See Also Send Feedback

The PtlMXP1O5 type exposes the following members.

Properties

 | Name | Description
Public property | Address | 获取或设置站点号，会覆盖其下的 600U 站点号。 (Inherited from PtlIOPortWith600U.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from PtlIOPortWith600U.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Public property | Lighthouses | 获取或设置灯塔输出口集合；设置时会改写 Lighthouse 的 Owner。 (Inherited from PtlIOPort.)
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
Public property | MinorType | 获取或设置小类型。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | Ptl600U | 获取 600U 单元。 (Inherited from PtlIOPortWith600U.)
Public property | Scanner | 获取或设置扫描枪输入口；设置时会改写 Scanner 的 Owner。 (Inherited from PtlIOPort.)
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

See Also

PtlMXP1O5 Class


PtlMXP1O5.MinorType Property

[image]

Pick To Light 设备通讯类库
PtlMXP1O5..::..MinorType Property
PtlMXP1O5 Class See Also Send Feedback
获取或设置小类型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual PtlMXP1O5Type MinorType { get; set; }
Visual Basic
Public Overridable Property MinorType As PtlMXP1O5Type
    Get
    Set

Property Value

Type: PtlMXP1O5Type

See Also

PtlMXP1O5 Class
PtlMXP1O5 Members


PtlMXP1O5 Events

[image] [image]

Pick To Light 设备通讯类库
PtlMXP1O5 Events
PtlMXP1O5 Class See Also Send Feedback

The PtlMXP1O5 type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)

See Also

PtlMXP1O5 Class


PtlMXP1O5Type Enumeration

[image]

Pick To Light 设备通讯类库
PtlMXP1O5Type Enumeration
See Also Send Feedback
MXP1O5 的类型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum PtlMXP1O5Type
Visual Basic
Public Enumeration PtlMXP1O5Type

Members

Member name | Value | Description
M3 | 0 | 3 位数码管。
M8 | 1 | 8 位点阵。

See Also


PtlTera Class

[image]

Pick To Light 设备通讯类库
PtlTera Class
Members See Also Send Feedback
多灯指示型标签。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class PtlTera : PtlDevice
Visual Basic
<SerializableAttribute>
Public Class PtlTera
    Inherits PtlDevice

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..PtlDevice
Ptl.Device..::..PtlTera

See Also

PtlTera Members


PtlTera Members

[image] [image]

Pick To Light 设备通讯类库
PtlTera Members
PtlTera Class Constructors Methods Properties Events See Also Send Feedback

The PtlTera type exposes the following members.

Constructors

 | Name | Description
Public method | PtlTera | 初始化 PtlTera。

Methods

 | Name | Description
Public method | Clear | 熄灭指示灯。
Public method | ClearCommandQueue | 清空协议队列。 (Inherited from PtlDevice.)
Public method | Display(IList<(Of <<'(LightColor>)>>)) | 点亮指示灯。
Public method | Display(IList<(Of <<'(LightMode>)>>)) | 点亮指示灯。
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容。 (Overrides PtlDevice..::..Initialize()()()().)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | Refresh | 刷新显示。 (Overrides PtlDevice..::..Refresh()()()().)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计。 (Inherited from PtlDevice.)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

Properties

 | Name | Description
Public property | Address | 获取或设置站点号。 (Inherited from PtlDevice.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from PtlDevice.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | CurrentAppearance | 获取当前外观。
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
 | MaxLightsCount | 获取或设置指示灯的最大数量，默认 100。
Public property | MinorType | 获取或设置小类型。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)

See Also

PtlTera Class


PtlTera Constructor

[image]

Pick To Light 设备通讯类库
PtlTera Constructor
PtlTera Class See Also Send Feedback
初始化 PtlTera。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public PtlTera()
Visual Basic
Public Sub New

See Also

PtlTera Class
PtlTera Members


PtlTera Methods

[image] [image]

Pick To Light 设备通讯类库
PtlTera Methods
PtlTera Class See Also Send Feedback

The PtlTera type exposes the following members.

Methods

 | Name | Description
Public method | Clear | 熄灭指示灯。
Public method | ClearCommandQueue | 清空协议队列。 (Inherited from PtlDevice.)
Public method | Display(IList<(Of <<'(LightColor>)>>)) | 点亮指示灯。
Public method | Display(IList<(Of <<'(LightMode>)>>)) | 点亮指示灯。
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容。 (Overrides PtlDevice..::..Initialize()()()().)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | Refresh | 刷新显示。 (Overrides PtlDevice..::..Refresh()()()().)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计。 (Inherited from PtlDevice.)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

See Also

PtlTera Class


PtlTera.Clear Method

[image]

Pick To Light 设备通讯类库
PtlTera..::..Clear Method
PtlTera Class See Also Send Feedback
熄灭指示灯。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

PtlTera Class
PtlTera Members


PtlTera.Display Method

[image] [image]

Pick To Light 设备通讯类库
PtlTera..::..Display Method
PtlTera Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Display(IList<(Of <<'(LightColor>)>>)) | 点亮指示灯。
Public method | Display(IList<(Of <<'(LightMode>)>>)) | 点亮指示灯。

See Also

PtlTera Class
PtlTera Members


PtlTera.Display Method (IList(LightColor))

[image]

Pick To Light 设备通讯类库
PtlTera..::..Display Method (IList<(Of <(<'LightColor>)>)>)
PtlTera Class See Also Send Feedback
点亮指示灯。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Display(
    IList<LightColor> lightColors
)
Visual Basic
Public Sub Display (
    lightColors As IList(Of LightColor)
)

Parameters

lightColors
Type: System.Collections.Generic..::..IList <(Of <(<' LightColor >)>)>
所有指示灯的颜色。

See Also

PtlTera Class
PtlTera Members
Display Overload


PtlTera.Display Method (IList(LightMode))

[image]

Pick To Light 设备通讯类库
PtlTera..::..Display Method (IList<(Of <(<'LightMode>)>)>)
PtlTera Class See Also Send Feedback
点亮指示灯。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Display(
    IList<LightMode> lightModes
)
Visual Basic
Public Sub Display (
    lightModes As IList(Of LightMode)
)

Parameters

lightModes
Type: System.Collections.Generic..::..IList <(Of <(<' LightMode >)>)>
所有指示灯的亮灯模式。

See Also

PtlTera Class
PtlTera Members
Display Overload


PtlTera.Initialize Method

[image]

Pick To Light 设备通讯类库
PtlTera..::..Initialize Method
PtlTera Class See Also Send Feedback
清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override void Initialize()
Visual Basic
Public Overrides Sub Initialize

See Also

PtlTera Class
PtlTera Members


PtlTera.Refresh Method

[image]

Pick To Light 设备通讯类库
PtlTera..::..Refresh Method
PtlTera Class See Also Send Feedback
刷新显示。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override void Refresh()
Visual Basic
Public Overrides Sub Refresh

See Also

PtlTera Class
PtlTera Members


PtlTera Properties

[image] [image]

Pick To Light 设备通讯类库
PtlTera Properties
PtlTera Class See Also Send Feedback

The PtlTera type exposes the following members.

Properties

 | Name | Description
Public property | Address | 获取或设置站点号。 (Inherited from PtlDevice.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from PtlDevice.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | CurrentAppearance | 获取当前外观。
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
 | MaxLightsCount | 获取或设置指示灯的最大数量，默认 100。
Public property | MinorType | 获取或设置小类型。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

See Also

PtlTera Class


PtlTera.CurrentAppearance Property

[image]

Pick To Light 设备通讯类库
PtlTera..::..CurrentAppearance Property
PtlTera Class See Also Send Feedback
获取当前外观。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public PtlTeraAppearance CurrentAppearance { get; }
Visual Basic
Public ReadOnly Property CurrentAppearance As PtlTeraAppearance
    Get

Property Value

Type: PtlTeraAppearance

See Also

PtlTera Class
PtlTera Members


PtlTera.MaxLightsCount Property

[image]

Pick To Light 设备通讯类库
PtlTera..::..MaxLightsCount Property
PtlTera Class See Also Send Feedback
获取或设置指示灯的最大数量，默认 100。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static int MaxLightsCount { get; set; }
Visual Basic
Public Shared Property MaxLightsCount As Integer
    Get
    Set

Property Value

Type: Int32

See Also

PtlTera Class
PtlTera Members


PtlTera.MinorType Property

[image]

Pick To Light 设备通讯类库
PtlTera..::..MinorType Property
PtlTera Class See Also Send Feedback
获取或设置小类型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual PtlTeraType MinorType { get; set; }
Visual Basic
Public Overridable Property MinorType As PtlTeraType
    Get
    Set

Property Value

Type: PtlTeraType

See Also

PtlTera Class
PtlTera Members


PtlTera Events

[image] [image]

Pick To Light 设备通讯类库
PtlTera Events
PtlTera Class See Also Send Feedback

The PtlTera type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)

See Also

PtlTera Class


PtlTeraAppearance Class

[image]

Pick To Light 设备通讯类库
PtlTeraAppearance Class
Members See Also Send Feedback
Tera 的外观。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class PtlTeraAppearance
Visual Basic
<SerializableAttribute>
Public Class PtlTeraAppearance

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..PtlTeraAppearance

See Also

PtlTeraAppearance Members


PtlTeraAppearance Members

[image] [image]

Pick To Light 设备通讯类库
PtlTeraAppearance Members
PtlTeraAppearance Class Constructors Properties See Also Send Feedback

The PtlTeraAppearance type exposes the following members.

Constructors

 | Name | Description
Public method | PtlTeraAppearance | Initializes a new instance of the PtlTeraAppearance class

Properties

 | Name | Description
Public property | LightModes | 获取所有指示灯的亮灯模式的集合。

See Also

PtlTeraAppearance Class


PtlTeraAppearance Constructor

[image]

Pick To Light 设备通讯类库
PtlTeraAppearance Constructor
PtlTeraAppearance Class See Also Send Feedback
Initializes a new instance of the PtlTeraAppearance class

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public PtlTeraAppearance()
Visual Basic
Public Sub New

See Also

PtlTeraAppearance Class
PtlTeraAppearance Members


PtlTeraAppearance Properties

[image] [image]

Pick To Light 设备通讯类库
PtlTeraAppearance Properties
PtlTeraAppearance Class See Also Send Feedback

The PtlTeraAppearance type exposes the following members.

Properties

 | Name | Description
Public property | LightModes | 获取所有指示灯的亮灯模式的集合。

See Also

PtlTeraAppearance Class


PtlTeraAppearance.LightModes Property

[image]

Pick To Light 设备通讯类库
PtlTeraAppearance..::..LightModes Property
PtlTeraAppearance Class See Also Send Feedback
获取所有指示灯的亮灯模式的集合。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Collection<LightMode> LightModes { get; }
Visual Basic
Public ReadOnly Property LightModes As Collection(Of LightMode)
    Get

Property Value

Type: Collection <(Of <(<' LightMode >)>)>

See Also

PtlTeraAppearance Class
PtlTeraAppearance Members


PtlTeraType Enumeration

[image]

Pick To Light 设备通讯类库
PtlTeraType Enumeration
See Also Send Feedback
Tera 的类型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum PtlTeraType
Visual Basic
Public Enumeration PtlTeraType

Members

Member name | Value | Description
A_B04002 | 0 | 总长 40 厘米、间隔 2 厘米的长条型。

See Also


PtlXDO10RFID Class

[image]

Pick To Light 设备通讯类库
PtlXDO10RFID Class
Members See Also Send Feedback
提供 RFID、灯塔、600U 的接入和控制。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class PtlXDO10RFID : PtlIOPortWith600U
Visual Basic
<SerializableAttribute>
Public Class PtlXDO10RFID
    Inherits PtlIOPortWith600U

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..PtlDevice
Ptl.Device..::..PtlIOPort
Ptl.Device..::..PtlIOPortWith600U
Ptl.Device..::..PtlXDO10RFID

See Also

PtlXDO10RFID Members


PtlXDO10RFID Members

[image] [image]

Pick To Light 设备通讯类库
PtlXDO10RFID Members
PtlXDO10RFID Class Constructors Methods Properties Events See Also Send Feedback

The PtlXDO10RFID type exposes the following members.

Constructors

 | Name | Description
Public method | PtlXDO10RFID | 初始化 XDO10RFID。

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列，包括其上挂接的设备的协议队列。 (Inherited from PtlIOPortWith600U.)
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。 (Inherited from PtlIOPortWith600U.)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | Refresh | 刷新显示，包括其上挂接的设备。 (Inherited from PtlIOPortWith600U.)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计，包括其上挂接的 Ptl600U。 (Inherited from PtlIOPortWith600U.)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

Properties

 | Name | Description
Public property | Address | 获取或设置站点号，会覆盖其下的 600U 站点号。 (Inherited from PtlIOPortWith600U.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from PtlIOPortWith600U.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Public property | Lighthouses | 获取或设置灯塔输出口集合；设置时会改写 Lighthouse 的 Owner。 (Inherited from PtlIOPort.)
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
Public property | MinorType | 获取或设置小类型。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | Ptl600U | 获取 600U 单元。 (Inherited from PtlIOPortWith600U.)
Public property | Scanner | 获取或设置扫描枪输入口；设置时会改写 Scanner 的 Owner。 (Inherited from PtlIOPort.)
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)

See Also

PtlXDO10RFID Class


PtlXDO10RFID Constructor

[image]

Pick To Light 设备通讯类库
PtlXDO10RFID Constructor
PtlXDO10RFID Class See Also Send Feedback
初始化 XDO10RFID。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public PtlXDO10RFID()
Visual Basic
Public Sub New

See Also

PtlXDO10RFID Class
PtlXDO10RFID Members


PtlXDO10RFID Methods

[image] [image]

Pick To Light 设备通讯类库
PtlXDO10RFID Methods
PtlXDO10RFID Class See Also Send Feedback

The PtlXDO10RFID type exposes the following members.

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列，包括其上挂接的设备的协议队列。 (Inherited from PtlIOPortWith600U.)
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。 (Inherited from PtlIOPortWith600U.)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | Refresh | 刷新显示，包括其上挂接的设备。 (Inherited from PtlIOPortWith600U.)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计，包括其上挂接的 Ptl600U。 (Inherited from PtlIOPortWith600U.)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

See Also

PtlXDO10RFID Class


PtlXDO10RFID Properties

[image] [image]

Pick To Light 设备通讯类库
PtlXDO10RFID Properties
PtlXDO10RFID Class See Also Send Feedback

The PtlXDO10RFID type exposes the following members.

Properties

 | Name | Description
Public property | Address | 获取或设置站点号，会覆盖其下的 600U 站点号。 (Inherited from PtlIOPortWith600U.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from PtlIOPortWith600U.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Public property | Lighthouses | 获取或设置灯塔输出口集合；设置时会改写 Lighthouse 的 Owner。 (Inherited from PtlIOPort.)
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
Public property | MinorType | 获取或设置小类型。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | Ptl600U | 获取 600U 单元。 (Inherited from PtlIOPortWith600U.)
Public property | Scanner | 获取或设置扫描枪输入口；设置时会改写 Scanner 的 Owner。 (Inherited from PtlIOPort.)
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

See Also

PtlXDO10RFID Class


PtlXDO10RFID.MinorType Property

[image]

Pick To Light 设备通讯类库
PtlXDO10RFID..::..MinorType Property
PtlXDO10RFID Class See Also Send Feedback
获取或设置小类型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual PtlXDO10RFIDType MinorType { get; set; }
Visual Basic
Public Overridable Property MinorType As PtlXDO10RFIDType
    Get
    Set

Property Value

Type: PtlXDO10RFIDType

See Also

PtlXDO10RFID Class
PtlXDO10RFID Members


PtlXDO10RFID Events

[image] [image]

Pick To Light 设备通讯类库
PtlXDO10RFID Events
PtlXDO10RFID Class See Also Send Feedback

The PtlXDO10RFID type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)

See Also

PtlXDO10RFID Class


PtlXDO10RFIDType Enumeration

[image]

Pick To Light 设备通讯类库
PtlXDO10RFIDType Enumeration
See Also Send Feedback
XDO10RFID 的类型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum PtlXDO10RFIDType
Visual Basic
Public Enumeration PtlXDO10RFIDType

Members

Member name | Value | Description
Default | 0 | 默认类型。

See Also


PtlXIOPort Class

[image]

Pick To Light 设备通讯类库
PtlXIOPort Class
Members See Also Send Feedback
提供扫描枪和灯塔的接入和控制功能；灯塔不支持闪烁。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class PtlXIOPort : PtlIOPort
Visual Basic
<SerializableAttribute>
Public Class PtlXIOPort
    Inherits PtlIOPort

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..PtlDevice
Ptl.Device..::..PtlIOPort
Ptl.Device..::..PtlXIOPort

See Also

PtlXIOPort Members


PtlXIOPort Members

[image] [image]

Pick To Light 设备通讯类库
PtlXIOPort Members
PtlXIOPort Class Constructors Methods Properties Events See Also Send Feedback

The PtlXIOPort type exposes the following members.

Constructors

 | Name | Description
Public method | PtlXIOPort | 初始化 XIOPort。

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列，包括其上挂接的设备的协议队列。 (Inherited from PtlIOPort.)
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。 (Inherited from PtlIOPort.)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | Refresh | 刷新显示，包括其上挂接的设备。 (Inherited from PtlIOPort.)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计。 (Inherited from PtlDevice.)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

Properties

 | Name | Description
Public property | Address | 获取或设置站点号。 (Inherited from PtlDevice.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from PtlIOPort.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Public property | Lighthouses | 获取或设置灯塔输出口集合；设置时会改写 Lighthouse 的 Owner。 (Inherited from PtlIOPort.)
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
Public property | MinorType | 获取或设置小类型。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | Scanner | 获取或设置扫描枪输入口；设置时会改写 Scanner 的 Owner。 (Inherited from PtlIOPort.)
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)

See Also

PtlXIOPort Class


PtlXIOPort Constructor

[image]

Pick To Light 设备通讯类库
PtlXIOPort Constructor
PtlXIOPort Class See Also Send Feedback
初始化 XIOPort。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public PtlXIOPort()
Visual Basic
Public Sub New

See Also

PtlXIOPort Class
PtlXIOPort Members


PtlXIOPort Methods

[image] [image]

Pick To Light 设备通讯类库
PtlXIOPort Methods
PtlXIOPort Class See Also Send Feedback

The PtlXIOPort type exposes the following members.

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列，包括其上挂接的设备的协议队列。 (Inherited from PtlIOPort.)
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。 (Inherited from PtlIOPort.)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | Refresh | 刷新显示，包括其上挂接的设备。 (Inherited from PtlIOPort.)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计。 (Inherited from PtlDevice.)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

See Also

PtlXIOPort Class


PtlXIOPort Properties

[image] [image]

Pick To Light 设备通讯类库
PtlXIOPort Properties
PtlXIOPort Class See Also Send Feedback

The PtlXIOPort type exposes the following members.

Properties

 | Name | Description
Public property | Address | 获取或设置站点号。 (Inherited from PtlDevice.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from PtlIOPort.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Public property | Lighthouses | 获取或设置灯塔输出口集合；设置时会改写 Lighthouse 的 Owner。 (Inherited from PtlIOPort.)
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
Public property | MinorType | 获取或设置小类型。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | Scanner | 获取或设置扫描枪输入口；设置时会改写 Scanner 的 Owner。 (Inherited from PtlIOPort.)
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

See Also

PtlXIOPort Class


PtlXIOPort.MinorType Property

[image]

Pick To Light 设备通讯类库
PtlXIOPort..::..MinorType Property
PtlXIOPort Class See Also Send Feedback
获取或设置小类型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual PtlXIOPortType MinorType { get; set; }
Visual Basic
Public Overridable Property MinorType As PtlXIOPortType
    Get
    Set

Property Value

Type: PtlXIOPortType

See Also

PtlXIOPort Class
PtlXIOPort Members


PtlXIOPort Events

[image] [image]

Pick To Light 设备通讯类库
PtlXIOPort Events
PtlXIOPort Class See Also Send Feedback

The PtlXIOPort type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)

See Also

PtlXIOPort Class


PtlXIOPortType Enumeration

[image]

Pick To Light 设备通讯类库
PtlXIOPortType Enumeration
See Also Send Feedback
PtlXIOPort 的类型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum PtlXIOPortType
Visual Basic
Public Enumeration PtlXIOPortType

Members

Member name | Value | Description
P1L4 | 0 | 1 个扫描枪接口，4 个灯塔输出控制口。
P1 | 1 | 1 个扫描枪接口。
L4 | 2 | 4 个灯塔输出控制口。

See Also


PtlXMatrixPort Class

[image]

Pick To Light 设备通讯类库
PtlXMatrixPort Class
Members See Also Send Feedback
提供扫描枪、600U 的接入和控制。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class PtlXMatrixPort : PtlIOPortWith600U
Visual Basic
<SerializableAttribute>
Public Class PtlXMatrixPort
    Inherits PtlIOPortWith600U

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..PtlDevice
Ptl.Device..::..PtlIOPort
Ptl.Device..::..PtlIOPortWith600U
Ptl.Device..::..PtlXMatrixPort

See Also

PtlXMatrixPort Members


PtlXMatrixPort Members

[image] [image]

Pick To Light 设备通讯类库
PtlXMatrixPort Members
PtlXMatrixPort Class Constructors Methods Properties Events See Also Send Feedback

The PtlXMatrixPort type exposes the following members.

Constructors

 | Name | Description
Public method | PtlXMatrixPort | 初始化 XMatrixPort。

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列，包括其上挂接的设备的协议队列。 (Inherited from PtlIOPortWith600U.)
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。 (Inherited from PtlIOPortWith600U.)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | Refresh | 刷新显示，包括其上挂接的设备。 (Inherited from PtlIOPortWith600U.)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计，包括其上挂接的 Ptl600U。 (Inherited from PtlIOPortWith600U.)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

Properties

 | Name | Description
Public property | Address | 获取或设置站点号，会覆盖其下的 600U 站点号。 (Inherited from PtlIOPortWith600U.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from PtlIOPortWith600U.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Public property | Lighthouses | 获取或设置灯塔输出口集合；设置时会改写 Lighthouse 的 Owner。 (Inherited from PtlIOPort.)
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
Public property | MinorType | 获取或设置小类型。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | Ptl600U | 获取 600U 单元。 (Inherited from PtlIOPortWith600U.)
Public property | Scanner | 获取或设置扫描枪输入口；设置时会改写 Scanner 的 Owner。 (Inherited from PtlIOPort.)
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)

See Also

PtlXMatrixPort Class


PtlXMatrixPort Constructor

[image]

Pick To Light 设备通讯类库
PtlXMatrixPort Constructor
PtlXMatrixPort Class See Also Send Feedback
初始化 XMatrixPort。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public PtlXMatrixPort()
Visual Basic
Public Sub New

See Also

PtlXMatrixPort Class
PtlXMatrixPort Members


PtlXMatrixPort Methods

[image] [image]

Pick To Light 设备通讯类库
PtlXMatrixPort Methods
PtlXMatrixPort Class See Also Send Feedback

The PtlXMatrixPort type exposes the following members.

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列，包括其上挂接的设备的协议队列。 (Inherited from PtlIOPortWith600U.)
Public method | Initialize | 清空未完成的协议、清零通讯统计、解锁处于锁定状态的设备以及清空可能存在的显示内容和状态缓存。 (Inherited from PtlIOPortWith600U.)
Public method | Lock | 锁定设备按键。 (Inherited from PtlDevice.)
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Protected method | OnError | 引发设备错误事件。 (Inherited from PtlDevice.)
Protected method | OnExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Protected method | OnInErrorChanged | 引发设备错误状态更改事件。 (Inherited from PtlDevice.)
Protected method | OnIsLockedChanged | 引发设备锁定状态更改事件。 (Inherited from PtlDevice.)
Public method | PerformAppearanceChanged | 引发设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public method | PerformError | 引发设备错误事件。 (Inherited from PtlDevice.)
Public method | PerformExecuteProtocol | 引发设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public method | Refresh | 刷新显示，包括其上挂接的设备。 (Inherited from PtlIOPortWith600U.)
Protected method | RemoveHeartbeat | 移除心跳命令。 (Inherited from PtlDevice.)
Public method | ResetCommunicationStatistics | 使用新的统计信息重新开始统计，包括其上挂接的 Ptl600U。 (Inherited from PtlIOPortWith600U.)
Public method | TryAddHeartbeat | 尝试加入心跳命令，只在命令队列为空时才会加入。 (Inherited from PtlDevice.)
Public method | Unlock | 解锁设备按键。 (Inherited from PtlDevice.)

See Also

PtlXMatrixPort Class


PtlXMatrixPort Properties

[image] [image]

Pick To Light 设备通讯类库
PtlXMatrixPort Properties
PtlXMatrixPort Class See Also Send Feedback

The PtlXMatrixPort type exposes the following members.

Properties

 | Name | Description
Public property | Address | 获取或设置站点号，会覆盖其下的 600U 站点号。 (Inherited from PtlIOPortWith600U.)
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from PtlIOPortWith600U.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from PtlDevice.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from PtlDevice.)
Public property | CommunicationStatistics | 获取通讯统计信息。 (Inherited from PtlDevice.)
Public property | InError | 获取设备是否处于错误状态。 (Inherited from PtlDevice.)
Public property | IsLocked | 获取设备是否锁定。 (Inherited from PtlDevice.)
Public property | Lighthouses | 获取或设置灯塔输出口集合；设置时会改写 Lighthouse 的 Owner。 (Inherited from PtlIOPort.)
Protected property | LockUnlockCommandQueue | 获取 加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | MajorType | 获取或设置大类型。 (Inherited from PtlDevice.)
Public property | MinorType | 获取或设置小类型。
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from PtlDevice.)
Public property | Ptl600U | 获取 600U 单元。 (Inherited from PtlIOPortWith600U.)
Public property | Scanner | 获取或设置扫描枪输入口；设置时会改写 Scanner 的 Owner。 (Inherited from PtlIOPort.)
Public property | Tag | 获取或设置相关联数据。 (Inherited from PtlDevice.)

See Also

PtlXMatrixPort Class


PtlXMatrixPort.MinorType Property

[image]

Pick To Light 设备通讯类库
PtlXMatrixPort..::..MinorType Property
PtlXMatrixPort Class See Also Send Feedback
获取或设置小类型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual PtlXMatrixPortType MinorType { get; set; }
Visual Basic
Public Overridable Property MinorType As PtlXMatrixPortType
    Get
    Set

Property Value

Type: PtlXMatrixPortType

See Also

PtlXMatrixPort Class
PtlXMatrixPort Members


PtlXMatrixPort Events

[image] [image]

Pick To Light 设备通讯类库
PtlXMatrixPort Events
PtlXMatrixPort Class See Also Send Feedback

The PtlXMatrixPort type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。 (Inherited from PtlDevice.)
Public event | Error | 设备错误事件。 (Inherited from PtlDevice.)
Public event | ExecuteProtocol | 设备协议被成功执行事件。 (Inherited from PtlDevice.)
Public event | InErrorChanged | 设备错误状态更改事件。 (Inherited from PtlDevice.)
Public event | IsLockedChanged | 设备锁定状态更改事件。 (Inherited from PtlDevice.)

See Also

PtlXMatrixPort Class


PtlXMatrixPortType Enumeration

[image]

Pick To Light 设备通讯类库
PtlXMatrixPortType Enumeration
See Also Send Feedback
PtlXMatrixPort 的类型。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum PtlXMatrixPortType
Visual Basic
Public Enumeration PtlXMatrixPortType

Members

Member name | Value | Description
Default | 0 | 默认类型。

See Also


RS485Bus Class

[image]

Pick To Light 设备通讯类库
RS485Bus Class
Members See Also Send Feedback
RS485 总线，上可挂接多个设备。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class RS485Bus : IXmlSerializable
Visual Basic
<SerializableAttribute>
Public Class RS485Bus
    Implements IXmlSerializable

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..RS485Bus

See Also

RS485Bus Members


RS485Bus Members

[image] [image]

Pick To Light 设备通讯类库
RS485Bus Members
RS485Bus Class Constructors Methods Properties See Also Send Feedback

The RS485Bus type exposes the following members.

Constructors

 | Name | Description
Public method | RS485Bus()()()() | 初始化总线。
Public method | RS485Bus(Byte) | 使用指定的端口序号初始化总线。

Methods

 | Name | Description
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | MulticastClear900U | 组播清除 900U，且使用单播清除命令来确保成功。
Public method | MulticastDisplay900U(ICollection<(Of <<'(Byte>)>>), Ptl900UType, Display900UItem, LightMode) | 组播显示并采集 900U，设备的小类型需一致。
Public method | MulticastDisplay900U(ICollection<(Of <<'(Byte>)>>), Ptl900UType, Display900UItem, LightMode, SoundMode, SurfaceBackground, Boolean, Boolean, Int32) | 组播显示 900U，设备的小类型需一致。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | StartUnicastCommandQueue | 开始执行当前总线上的所有设备的协议队列。
Public method | StopUnicastCommandQueue()()()() | 停止执行当前总线上的所有设备的协议队列，但不等待执行线程退出。
Public method | StopUnicastCommandQueue(Boolean) | 停止执行当前总线上的所有设备的协议队列。
Public method | WriteXml | 将对象转换为其 XML 表示形式。

Properties

 | Name | Description
Public property | CommunicationClient | 获取通讯客户端，非通讯时此值为空。
Public property | Devices | 获取其上的设备集合。
Public property | Index | 获取或设置所在端口序号。

See Also

RS485Bus Class


RS485Bus Constructor

[image] [image]

Pick To Light 设备通讯类库
RS485Bus Constructor
RS485Bus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RS485Bus()()()() | 初始化总线。
Public method | RS485Bus(Byte) | 使用指定的端口序号初始化总线。

See Also

RS485Bus Class
RS485Bus Members


RS485Bus Constructor

[image]

Pick To Light 设备通讯类库
RS485Bus Constructor
RS485Bus Class See Also Send Feedback
初始化总线。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public RS485Bus()
Visual Basic
Public Sub New

See Also

RS485Bus Class
RS485Bus Members
RS485Bus Overload


RS485Bus Constructor (Byte)

[image]

Pick To Light 设备通讯类库
RS485Bus Constructor (Byte)
RS485Bus Class See Also Send Feedback
使用指定的端口序号初始化总线。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public RS485Bus(
    byte index
)
Visual Basic
Public Sub New (
    index As Byte
)

Parameters

index
Type: System..::..Byte
端口序号。

See Also

RS485Bus Class
RS485Bus Members
RS485Bus Overload


RS485Bus Methods

[image] [image]

Pick To Light 设备通讯类库
RS485Bus Methods
RS485Bus Class See Also Send Feedback

The RS485Bus type exposes the following members.

Methods

 | Name | Description
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | MulticastClear900U | 组播清除 900U，且使用单播清除命令来确保成功。
Public method | MulticastDisplay900U(ICollection<(Of <<'(Byte>)>>), Ptl900UType, Display900UItem, LightMode) | 组播显示并采集 900U，设备的小类型需一致。
Public method | MulticastDisplay900U(ICollection<(Of <<'(Byte>)>>), Ptl900UType, Display900UItem, LightMode, SoundMode, SurfaceBackground, Boolean, Boolean, Int32) | 组播显示 900U，设备的小类型需一致。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | StartUnicastCommandQueue | 开始执行当前总线上的所有设备的协议队列。
Public method | StopUnicastCommandQueue()()()() | 停止执行当前总线上的所有设备的协议队列，但不等待执行线程退出。
Public method | StopUnicastCommandQueue(Boolean) | 停止执行当前总线上的所有设备的协议队列。
Public method | WriteXml | 将对象转换为其 XML 表示形式。

See Also

RS485Bus Class


RS485Bus.GetSchema Method

[image]

Pick To Light 设备通讯类库
RS485Bus..::..GetSchema Method
RS485Bus Class See Also Send Feedback
此方法是保留方法，请不要使用。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XmlSchema GetSchema()
Visual Basic
Public Function GetSchema As XmlSchema

Return Value

Type: XmlSchema
始终返回空。

Implements

IXmlSerializable..::..GetSchema()()()()

See Also

RS485Bus Class
RS485Bus Members


RS485Bus.MulticastClear900U Method

[image]

Pick To Light 设备通讯类库
RS485Bus..::..MulticastClear900U Method
RS485Bus Class See Also Send Feedback
组播清除 900U，且使用单播清除命令来确保成功。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void MulticastClear900U(
    ICollection<byte> addresses
)
Visual Basic
Public Sub MulticastClear900U (
    addresses As ICollection(Of Byte)
)

Parameters

addresses
Type: System.Collections.Generic..::..ICollection <(Of <(<' Byte >)>)>
需组播的地址集。

Remarks

调用者需确保在组播期间不会执行任何单播命令。

See Also

RS485Bus Class
RS485Bus Members


RS485Bus.MulticastDisplay900U Method

[image] [image]

Pick To Light 设备通讯类库
RS485Bus..::..MulticastDisplay900U Method
RS485Bus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MulticastDisplay900U(ICollection<(Of <<'(Byte>)>>), Ptl900UType, Display900UItem, LightMode) | 组播显示并采集 900U，设备的小类型需一致。
Public method | MulticastDisplay900U(ICollection<(Of <<'(Byte>)>>), Ptl900UType, Display900UItem, LightMode, SoundMode, SurfaceBackground, Boolean, Boolean, Int32) | 组播显示 900U，设备的小类型需一致。

See Also

RS485Bus Class
RS485Bus Members


RS485Bus.MulticastDisplay900U Method (ICollection(Byte), Ptl900UType, Display900UItem, LightMode)

[image]

Pick To Light 设备通讯类库
RS485Bus..::..MulticastDisplay900U Method (ICollection<(Of <(<'Byte>)>)>, Ptl900UType, Display900UItem, LightMode)
RS485Bus Class See Also Send Feedback
组播显示并采集 900U，设备的小类型需一致。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void MulticastDisplay900U(
    ICollection<byte> addresses,
    Ptl900UType deviceType,
    Display900UItem displayItem,
    LightMode lightMode
)
Visual Basic
Public Sub MulticastDisplay900U (
    addresses As ICollection(Of Byte),
    deviceType As Ptl900UType,
    displayItem As Display900UItem,
    lightMode As LightMode
)

Parameters

addresses
Type: System.Collections.Generic..::..ICollection <(Of <(<' Byte >)>)>
需组播的地址集。
deviceType
Type: Ptl.Device..::..Ptl900UType
小类型。
displayItem
Type: Ptl.Device.Communication.Command..::..Display900UItem
显示信息。
lightMode
Type: Ptl.Device.Communication.Command..::..LightMode
OK 按钮灯色。

Remarks

调用者需确保在组播期间不会执行任何单播命令。

Exceptions

Exception | Condition
System..::..InvalidOperationException | 没有调用 StartUnicastCommandQueue 方法来启动通讯。

See Also

RS485Bus Class
RS485Bus Members
MulticastDisplay900U Overload


RS485Bus.MulticastDisplay900U Method (ICollection(Byte), Ptl900UType, Display900UItem, LightMode, SoundMode, SurfaceBackground, Boolean, Boolean, Int32)

[image]

Pick To Light 设备通讯类库
RS485Bus..::..MulticastDisplay900U Method (ICollection<(Of <(<'Byte>)>)>, Ptl900UType, Display900UItem, LightMode, SoundMode, SurfaceBackground, Boolean, Boolean, Int32)
RS485Bus Class See Also Send Feedback
组播显示 900U，设备的小类型需一致。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void MulticastDisplay900U(
    ICollection<byte> addresses,
    Ptl900UType deviceType,
    Display900UItem displayItem,
    LightMode lightMode,
    SoundMode sound,
    SurfaceBackground background,
    bool mustCollect,
    bool enableF1OkColorAfterPress,
    int waitMillisecondsForDisplay
)
Visual Basic
Public Sub MulticastDisplay900U (
    addresses As ICollection(Of Byte),
    deviceType As Ptl900UType,
    displayItem As Display900UItem,
    lightMode As LightMode,
    sound As SoundMode,
    background As SurfaceBackground,
    mustCollect As Boolean,
    enableF1OkColorAfterPress As Boolean,
    waitMillisecondsForDisplay As Integer
)

Parameters

addresses
Type: System.Collections.Generic..::..ICollection <(Of <(<' Byte >)>)>
需组播的地址集。
deviceType
Type: Ptl.Device..::..Ptl900UType
小类型。
displayItem
Type: Ptl.Device.Communication.Command..::..Display900UItem
显示信息。
lightMode
Type: Ptl.Device.Communication.Command..::..LightMode
OK 按钮灯色。
sound
Type: Ptl.Device.Communication.Command..::..SoundMode
声音。
background
Type: Ptl.Device.Communication.Command..::..SurfaceBackground
彩屏背景。
mustCollect
Type: System..::..Boolean
是否必须采集 OK 按钮按下动作。
enableF1OkColorAfterPress
Type: System..::..Boolean
是否启用 F1 功能。
waitMillisecondsForDisplay
Type: System..::..Int32
等待屏幕显示的时间，用于等待 TFT 屏显示。

Remarks

调用者需确保在组播期间不会执行任何单播命令。

Exceptions

Exception | Condition
System..::..InvalidOperationException | 没有调用 StartUnicastCommandQueue 方法来启动通讯。

See Also

RS485Bus Class
RS485Bus Members
MulticastDisplay900U Overload


RS485Bus.ReadXml Method

[image]

Pick To Light 设备通讯类库
RS485Bus..::..ReadXml Method
RS485Bus Class See Also Send Feedback
从对象的 XML 表示形式生成该对象。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void ReadXml(
    XmlReader reader
)
Visual Basic
Public Sub ReadXml (
    reader As XmlReader
)

Parameters

reader
Type: System.Xml..::..XmlReader
对象从中进行反序列化的 System.Xml.XmlReader 流。

Implements

IXmlSerializable..::..ReadXml(XmlReader)

Exceptions

Exception | Condition
System..::..ArgumentNullException | reader 为空。

See Also

RS485Bus Class
RS485Bus Members


RS485Bus.StartUnicastCommandQueue Method

[image]

Pick To Light 设备通讯类库
RS485Bus..::..StartUnicastCommandQueue Method
RS485Bus Class See Also Send Feedback
开始执行当前总线上的所有设备的协议队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void StartUnicastCommandQueue(
    ICommunicationClient communicationClient
)
Visual Basic
Public Sub StartUnicastCommandQueue (
    communicationClient As ICommunicationClient
)

Parameters

communicationClient
Type: Ptl.Device.Communication..::..ICommunicationClient
通讯客户端。

Exceptions

Exception | Condition
System..::..ArgumentNullException | communicationClient 为空。

See Also

RS485Bus Class
RS485Bus Members


RS485Bus.StopUnicastCommandQueue Method

[image] [image]

Pick To Light 设备通讯类库
RS485Bus..::..StopUnicastCommandQueue Method
RS485Bus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StopUnicastCommandQueue()()()() | 停止执行当前总线上的所有设备的协议队列，但不等待执行线程退出。
Public method | StopUnicastCommandQueue(Boolean) | 停止执行当前总线上的所有设备的协议队列。

See Also

RS485Bus Class
RS485Bus Members


RS485Bus.StopUnicastCommandQueue Method

[image]

Pick To Light 设备通讯类库
RS485Bus..::..StopUnicastCommandQueue Method
RS485Bus Class See Also Send Feedback
停止执行当前总线上的所有设备的协议队列，但不等待执行线程退出。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void StopUnicastCommandQueue()
Visual Basic
Public Sub StopUnicastCommandQueue

See Also

RS485Bus Class
RS485Bus Members
StopUnicastCommandQueue Overload


RS485Bus.StopUnicastCommandQueue Method (Boolean)

[image]

Pick To Light 设备通讯类库
RS485Bus..::..StopUnicastCommandQueue Method (Boolean)
RS485Bus Class See Also Send Feedback
停止执行当前总线上的所有设备的协议队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void StopUnicastCommandQueue(
    bool waitExecuteThreadQuit
)
Visual Basic
Public Sub StopUnicastCommandQueue (
    waitExecuteThreadQuit As Boolean
)

Parameters

waitExecuteThreadQuit
Type: System..::..Boolean
是否等待执行线程退出。

See Also

RS485Bus Class
RS485Bus Members
StopUnicastCommandQueue Overload


RS485Bus.WriteXml Method

[image]

Pick To Light 设备通讯类库
RS485Bus..::..WriteXml Method
RS485Bus Class See Also Send Feedback
将对象转换为其 XML 表示形式。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void WriteXml(
    XmlWriter writer
)
Visual Basic
Public Sub WriteXml (
    writer As XmlWriter
)

Parameters

writer
Type: System.Xml..::..XmlWriter
对象要序列化为的 System.Xml.XmlWriter 流。

Implements

IXmlSerializable..::..WriteXml(XmlWriter)

Exceptions

Exception | Condition
System..::..ArgumentNullException | writer 为空。

See Also

RS485Bus Class
RS485Bus Members


RS485Bus Properties

[image] [image]

Pick To Light 设备通讯类库
RS485Bus Properties
RS485Bus Class See Also Send Feedback

The RS485Bus type exposes the following members.

Properties

 | Name | Description
Public property | CommunicationClient | 获取通讯客户端，非通讯时此值为空。
Public property | Devices | 获取其上的设备集合。
Public property | Index | 获取或设置所在端口序号。

See Also

RS485Bus Class


RS485Bus.CommunicationClient Property

[image]

Pick To Light 设备通讯类库
RS485Bus..::..CommunicationClient Property
RS485Bus Class See Also Send Feedback
获取通讯客户端，非通讯时此值为空。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ICommunicationClient CommunicationClient { get; }
Visual Basic
Public ReadOnly Property CommunicationClient As ICommunicationClient
    Get

Property Value

Type: ICommunicationClient

Remarks

在 StartUnicastCommandQueue 方法内赋值，在 StopUnicastCommandQueue 方法内清空； 即只在通讯时此属性非空。

See Also

RS485Bus Class
RS485Bus Members


RS485Bus.Devices Property

[image]

Pick To Light 设备通讯类库
RS485Bus..::..Devices Property
RS485Bus Class See Also Send Feedback
获取其上的设备集合。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public PtlDeviceCollection Devices { get; }
Visual Basic
Public ReadOnly Property Devices As PtlDeviceCollection
    Get

Property Value

Type: PtlDeviceCollection

See Also

RS485Bus Class
RS485Bus Members


RS485Bus.Index Property

[image]

Pick To Light 设备通讯类库
RS485Bus..::..Index Property
RS485Bus Class See Also Send Feedback
获取或设置所在端口序号。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte Index { get; }
Visual Basic
Public ReadOnly Property Index As Byte
    Get

Property Value

Type: Byte

See Also

RS485Bus Class
RS485Bus Members


RS485BusCollection Class

[image]

Pick To Light 设备通讯类库
RS485BusCollection Class
Members See Also Send Feedback
XGate 中的 RS485 总线集合。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class RS485BusCollection : IEnumerable<RS485Bus>,
    IEnumerable, IXmlSerializable
Visual Basic
<SerializableAttribute>
Public Class RS485BusCollection
    Implements IEnumerable(Of RS485Bus), IEnumerable,
    IXmlSerializable

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..RS485BusCollection

See Also

RS485BusCollection Members


RS485BusCollection Members

[image] [image]

Pick To Light 设备通讯类库
RS485BusCollection Members
RS485BusCollection Class Constructors Methods Properties See Also Send Feedback

The RS485BusCollection type exposes the following members.

Constructors

 | Name | Description
Public method | RS485BusCollection()()()() | 使用默认总线数 2 初始化 RS485 总线集合。
Public method | RS485BusCollection(Byte) | 初始化 RS485 总线集合。

Methods

 | Name | Description
Public method | GetEnumerator | 获取迭代器。
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | WriteXml | 将对象转换为其 XML 表示形式。

Properties

 | Name | Description
Public property | Count | 获取总线数量。
Public property | Item | 按接插口获取总线。

See Also

RS485BusCollection Class


RS485BusCollection Constructor

[image] [image]

Pick To Light 设备通讯类库
RS485BusCollection Constructor
RS485BusCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RS485BusCollection()()()() | 使用默认总线数 2 初始化 RS485 总线集合。
Public method | RS485BusCollection(Byte) | 初始化 RS485 总线集合。

See Also

RS485BusCollection Class
RS485BusCollection Members


RS485BusCollection Constructor

[image]

Pick To Light 设备通讯类库
RS485BusCollection Constructor
RS485BusCollection Class See Also Send Feedback
使用默认总线数 2 初始化 RS485 总线集合。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public RS485BusCollection()
Visual Basic
Public Sub New

See Also

RS485BusCollection Class
RS485BusCollection Members
RS485BusCollection Overload


RS485BusCollection Constructor (Byte)

[image]

Pick To Light 设备通讯类库
RS485BusCollection Constructor (Byte)
RS485BusCollection Class See Also Send Feedback
初始化 RS485 总线集合。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public RS485BusCollection(
    byte count
)
Visual Basic
Public Sub New (
    count As Byte
)

Parameters

count
Type: System..::..Byte
集合大小。

See Also

RS485BusCollection Class
RS485BusCollection Members
RS485BusCollection Overload


RS485BusCollection Methods

[image] [image]

Pick To Light 设备通讯类库
RS485BusCollection Methods
RS485BusCollection Class See Also Send Feedback

The RS485BusCollection type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator | 获取迭代器。
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | WriteXml | 将对象转换为其 XML 表示形式。

See Also

RS485BusCollection Class


RS485BusCollection.GetEnumerator Method

[image]

Pick To Light 设备通讯类库
RS485BusCollection..::..GetEnumerator Method
RS485BusCollection Class See Also Send Feedback
获取迭代器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public IEnumerator<RS485Bus> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of RS485Bus)

Return Value

Type: IEnumerator <(Of <(<' RS485Bus >)>)>
可用于按接插口正序循环访问集合的 System.Collections.Generic.IEnumerator<RS485Bus>。

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

RS485BusCollection Class
RS485BusCollection Members


RS485BusCollection.GetSchema Method

[image]

Pick To Light 设备通讯类库
RS485BusCollection..::..GetSchema Method
RS485BusCollection Class See Also Send Feedback
此方法是保留方法，请不要使用。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XmlSchema GetSchema()
Visual Basic
Public Function GetSchema As XmlSchema

Return Value

Type: XmlSchema
始终返回空。

Implements

IXmlSerializable..::..GetSchema()()()()

See Also

RS485BusCollection Class
RS485BusCollection Members


RS485BusCollection.ReadXml Method

[image]

Pick To Light 设备通讯类库
RS485BusCollection..::..ReadXml Method
RS485BusCollection Class See Also Send Feedback
从对象的 XML 表示形式生成该对象。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void ReadXml(
    XmlReader reader
)
Visual Basic
Public Sub ReadXml (
    reader As XmlReader
)

Parameters

reader
Type: System.Xml..::..XmlReader
对象从中进行反序列化的 System.Xml.XmlReader 流。

Implements

IXmlSerializable..::..ReadXml(XmlReader)

Exceptions

Exception | Condition
System..::..ArgumentNullException | reader 为空。

See Also

RS485BusCollection Class
RS485BusCollection Members


RS485BusCollection.WriteXml Method

[image]

Pick To Light 设备通讯类库
RS485BusCollection..::..WriteXml Method
RS485BusCollection Class See Also Send Feedback
将对象转换为其 XML 表示形式。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void WriteXml(
    XmlWriter writer
)
Visual Basic
Public Sub WriteXml (
    writer As XmlWriter
)

Parameters

writer
Type: System.Xml..::..XmlWriter
对象要序列化为的 System.Xml.XmlWriter 流。

Implements

IXmlSerializable..::..WriteXml(XmlWriter)

Exceptions

Exception | Condition
System..::..ArgumentNullException | writer 为空。

See Also

RS485BusCollection Class
RS485BusCollection Members


RS485BusCollection Properties

[image] [image]

Pick To Light 设备通讯类库
RS485BusCollection Properties
RS485BusCollection Class See Also Send Feedback

The RS485BusCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | 获取总线数量。
Public property | Item | 按接插口获取总线。

See Also

RS485BusCollection Class


RS485BusCollection.Count Property

[image]

Pick To Light 设备通讯类库
RS485BusCollection..::..Count Property
RS485BusCollection Class See Also Send Feedback
获取总线数量。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

See Also

RS485BusCollection Class
RS485BusCollection Members


RS485BusCollection.Item Property

[image]

Pick To Light 设备通讯类库
RS485BusCollection..::..Item Property
RS485BusCollection Class See Also Send Feedback
按接插口获取总线。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public RS485Bus this[
    byte index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Byte
) As RS485Bus
    Get

Parameters

index
Type: System..::..Byte
基于 0 的总线索引。

Property Value

Type: RS485Bus

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index 大于等于集合大小。

See Also

RS485BusCollection Class
RS485BusCollection Members


ScannedBarcodeEventArgs Class

[image]

Pick To Light 设备通讯类库
ScannedBarcodeEventArgs Class
Members See Also Send Feedback
为 Scanner.ScannedBarcode 事件提供事件参数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class ScannedBarcodeEventArgs : EventArgs
Visual Basic
<SerializableAttribute>
Public Class ScannedBarcodeEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Ptl.Device..::..ScannedBarcodeEventArgs

See Also

ScannedBarcodeEventArgs Members


ScannedBarcodeEventArgs Members

[image] [image]

Pick To Light 设备通讯类库
ScannedBarcodeEventArgs Members
ScannedBarcodeEventArgs Class Constructors Properties See Also Send Feedback

The ScannedBarcodeEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ScannedBarcodeEventArgs | 使用指定的条码初始化扫到条码事件的事件参数。

Properties

 | Name | Description
Public property | Barcode | 获取或设置扫描到的条码。

See Also

ScannedBarcodeEventArgs Class


ScannedBarcodeEventArgs Constructor

[image]

Pick To Light 设备通讯类库
ScannedBarcodeEventArgs Constructor
ScannedBarcodeEventArgs Class See Also Send Feedback
使用指定的条码初始化扫到条码事件的事件参数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ScannedBarcodeEventArgs(
    string barcode
)
Visual Basic
Public Sub New (
    barcode As String
)

Parameters

barcode
Type: System..::..String
条码。

Exceptions

Exception | Condition
System..::..ArgumentNullException | barcode 为空或空字符串。

See Also

ScannedBarcodeEventArgs Class
ScannedBarcodeEventArgs Members


ScannedBarcodeEventArgs Properties

[image] [image]

Pick To Light 设备通讯类库
ScannedBarcodeEventArgs Properties
ScannedBarcodeEventArgs Class See Also Send Feedback

The ScannedBarcodeEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Barcode | 获取或设置扫描到的条码。

See Also

ScannedBarcodeEventArgs Class


ScannedBarcodeEventArgs.Barcode Property

[image]

Pick To Light 设备通讯类库
ScannedBarcodeEventArgs..::..Barcode Property
ScannedBarcodeEventArgs Class See Also Send Feedback
获取或设置扫描到的条码。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Barcode { get; set; }
Visual Basic
Public Property Barcode As String
    Get
    Set

Property Value

Type: String

Exceptions

Exception | Condition
System..::..ArgumentNullException | 设置时使用空值或空字符串。

See Also

ScannedBarcodeEventArgs Class
ScannedBarcodeEventArgs Members


Scanner Class

[image]

Pick To Light 设备通讯类库
Scanner Class
Members See Also Send Feedback
扫描枪输入口。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class Scanner : IOPort
Visual Basic
<SerializableAttribute>
Public Class Scanner
    Inherits IOPort

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..IOPort
Ptl.Device..::..Scanner

See Also

Scanner Members


Scanner Members

[image] [image]

Pick To Light 设备通讯类库
Scanner Members
Scanner Class Constructors Methods Properties Events See Also Send Feedback

The Scanner type exposes the following members.

Constructors

 | Name | Description
Public method | Scanner | Initializes a new instance of the Scanner class

Methods

 | Name | Description
Public method | Clear | 显式清空条码缓存。
Public method | ClearCommandQueue | 清空协议队列。 (Inherited from IOPort.)
Public method | Initialize | 清空未完成协议以及清空可能存在的显示内容和状态缓存。 (Overrides IOPort..::..Initialize()()()().)
Protected method | OnAppearanceChanged | 引发端口的当前外观更改事件。 (Inherited from IOPort.)
Protected method | OnScannedBarcode | 引发 ScannedBarcode 事件。
Public method | PerformAppearanceChanged | 引发端口的当前外观更改事件。 (Inherited from IOPort.)
Public method | PerformScannedBarcode | 引发 ScannedBarcode 事件。
Public method | Refresh | 刷新显示。 (Inherited from IOPort.)

Properties

 | Name | Description
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from IOPort.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from IOPort.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from IOPort.)
Public property | EnableCollect | 获取或设置是否需要采集条码。
Public property | Index | 获取或设置端口序号。 (Inherited from IOPort.)
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from IOPort.)
Public property | Owner | 获取或设置所属 Ptl 设备。 (Inherited from IOPort.)
Public property | Tag | 获取或设置相关联数据。 (Inherited from IOPort.)

Events

 | Name | Description
Public event | AppearanceChanged | 端口的当前外观更改事件。 (Inherited from IOPort.)
Public event | ScannedBarcode | 扫描枪扫到条码事件。

See Also

Scanner Class


Scanner Constructor

[image]

Pick To Light 设备通讯类库
Scanner Constructor
Scanner Class See Also Send Feedback
Initializes a new instance of the Scanner class

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Scanner()
Visual Basic
Public Sub New

See Also

Scanner Class
Scanner Members


Scanner Methods

[image] [image]

Pick To Light 设备通讯类库
Scanner Methods
Scanner Class See Also Send Feedback

The Scanner type exposes the following members.

Methods

 | Name | Description
Public method | Clear | 显式清空条码缓存。
Public method | ClearCommandQueue | 清空协议队列。 (Inherited from IOPort.)
Public method | Initialize | 清空未完成协议以及清空可能存在的显示内容和状态缓存。 (Overrides IOPort..::..Initialize()()()().)
Protected method | OnAppearanceChanged | 引发端口的当前外观更改事件。 (Inherited from IOPort.)
Protected method | OnScannedBarcode | 引发 ScannedBarcode 事件。
Public method | PerformAppearanceChanged | 引发端口的当前外观更改事件。 (Inherited from IOPort.)
Public method | PerformScannedBarcode | 引发 ScannedBarcode 事件。
Public method | Refresh | 刷新显示。 (Inherited from IOPort.)

See Also

Scanner Class


Scanner.Clear Method

[image]

Pick To Light 设备通讯类库
Scanner..::..Clear Method
Scanner Class See Also Send Feedback
显式清空条码缓存。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear

See Also

Scanner Class
Scanner Members


Scanner.Initialize Method

[image]

Pick To Light 设备通讯类库
Scanner..::..Initialize Method
Scanner Class See Also Send Feedback
清空未完成协议以及清空可能存在的显示内容和状态缓存。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override void Initialize()
Visual Basic
Public Overrides Sub Initialize

See Also

Scanner Class
Scanner Members


Scanner.OnScannedBarcode Method

[image]

Pick To Light 设备通讯类库
Scanner..::..OnScannedBarcode Method
Scanner Class See Also Send Feedback
引发 ScannedBarcode 事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void OnScannedBarcode(
    ScannedBarcodeEventArgs e
)
Visual Basic
Protected Overridable Sub OnScannedBarcode (
    e As ScannedBarcodeEventArgs
)

Parameters

e
Type: Ptl.Device..::..ScannedBarcodeEventArgs
事件参数。

See Also

Scanner Class
Scanner Members


Scanner.PerformScannedBarcode Method

[image]

Pick To Light 设备通讯类库
Scanner..::..PerformScannedBarcode Method
Scanner Class See Also Send Feedback
引发 ScannedBarcode 事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void PerformScannedBarcode(
    ScannedBarcodeEventArgs e
)
Visual Basic
Public Sub PerformScannedBarcode (
    e As ScannedBarcodeEventArgs
)

Parameters

e
Type: Ptl.Device..::..ScannedBarcodeEventArgs
事件参数。

See Also

Scanner Class
Scanner Members


Scanner Properties

[image] [image]

Pick To Light 设备通讯类库
Scanner Properties
Scanner Class See Also Send Feedback

The Scanner type exposes the following members.

Properties

 | Name | Description
Public property | CommandCount | 获取队列中未完成的命令数。 (Inherited from IOPort.)
Protected property | CommandQueueSyncRoot | 获取协议队列的同步根。 (Inherited from IOPort.)
Protected property | CommunicateSyncRoot | 获取通讯操作的同步根。 (Inherited from IOPort.)
Public property | EnableCollect | 获取或设置是否需要采集条码。
Public property | Index | 获取或设置端口序号。 (Inherited from IOPort.)
Protected property | NormalCommandQueue | 获取 非加锁解锁协议 队列。 (Inherited from IOPort.)
Public property | Owner | 获取或设置所属 Ptl 设备。 (Inherited from IOPort.)
Public property | Tag | 获取或设置相关联数据。 (Inherited from IOPort.)

See Also

Scanner Class


Scanner.EnableCollect Property

[image]

Pick To Light 设备通讯类库
Scanner..::..EnableCollect Property
Scanner Class See Also Send Feedback
获取或设置是否需要采集条码。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual bool EnableCollect { get; set; }
Visual Basic
Public Overridable Property EnableCollect As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

采集成功后，会自动清除设备中的条码缓存。

See Also

Scanner Class
Scanner Members


Scanner Events

[image] [image]

Pick To Light 设备通讯类库
Scanner Events
Scanner Class See Also Send Feedback

The Scanner type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | 端口的当前外观更改事件。 (Inherited from IOPort.)
Public event | ScannedBarcode | 扫描枪扫到条码事件。

See Also

Scanner Class


Scanner.ScannedBarcode Event

[image]

Pick To Light 设备通讯类库
Scanner..::..ScannedBarcode Event
Scanner Class See Also Send Feedback
扫描枪扫到条码事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public event EventHandler<ScannedBarcodeEventArgs> ScannedBarcode
Visual Basic
Public Event ScannedBarcode As EventHandler(Of ScannedBarcodeEventArgs)

Value

Type: System..::..EventHandler <(Of <(<' ScannedBarcodeEventArgs >)>)>

See Also

Scanner Class
Scanner Members


UnhandledEventExceptionEventArgs Class

[image]

Pick To Light 设备通讯类库
UnhandledEventExceptionEventArgs Class
Members See Also Send Feedback
为 EventSubscriber.UnhandledException 事件提供事件参数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class UnhandledEventExceptionEventArgs : EventArgs
Visual Basic
<SerializableAttribute>
Public Class UnhandledEventExceptionEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Ptl.Device..::..UnhandledEventExceptionEventArgs

See Also

UnhandledEventExceptionEventArgs Members


UnhandledEventExceptionEventArgs Members

[image] [image]

Pick To Light 设备通讯类库
UnhandledEventExceptionEventArgs Members
UnhandledEventExceptionEventArgs Class Constructors Properties See Also Send Feedback

The UnhandledEventExceptionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | UnhandledEventExceptionEventArgs | 使用指定的异常信息初始化未捕获的异常事件的事件参数。

Properties

 | Name | Description
Public property | Exception | 获取或设置异常信息。
Public property | SourceEventArgs | 获取或设置源事件的事件参数。
Public property | SourceSender | 获取或设置源事件发送者。

See Also

UnhandledEventExceptionEventArgs Class


UnhandledEventExceptionEventArgs Constructor

[image]

Pick To Light 设备通讯类库
UnhandledEventExceptionEventArgs Constructor
UnhandledEventExceptionEventArgs Class See Also Send Feedback
使用指定的异常信息初始化未捕获的异常事件的事件参数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public UnhandledEventExceptionEventArgs(
    Object sourceSender,
    EventArgs sourceEventArgs,
    Exception exception
)
Visual Basic
Public Sub New (
    sourceSender As Object,
    sourceEventArgs As EventArgs,
    exception As Exception
)

Parameters

sourceSender
Type: System..::..Object
源事件发送者。
sourceEventArgs
Type: System..::..EventArgs
源事件的事件参数。
exception
Type: System..::..Exception
异常信息。

Exceptions

Exception | Condition
System..::..ArgumentNullException | exception 为空。

See Also

UnhandledEventExceptionEventArgs Class
UnhandledEventExceptionEventArgs Members


UnhandledEventExceptionEventArgs Properties

[image] [image]

Pick To Light 设备通讯类库
UnhandledEventExceptionEventArgs Properties
UnhandledEventExceptionEventArgs Class See Also Send Feedback

The UnhandledEventExceptionEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Exception | 获取或设置异常信息。
Public property | SourceEventArgs | 获取或设置源事件的事件参数。
Public property | SourceSender | 获取或设置源事件发送者。

See Also

UnhandledEventExceptionEventArgs Class


UnhandledEventExceptionEventArgs.Exception Property

[image]

Pick To Light 设备通讯类库
UnhandledEventExceptionEventArgs..::..Exception Property
UnhandledEventExceptionEventArgs Class See Also Send Feedback
获取或设置异常信息。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Exception Exception { get; set; }
Visual Basic
Public Property Exception As Exception
    Get
    Set

Property Value

Type: Exception

Exceptions

Exception | Condition
System..::..ArgumentNullException | 设置时使用空值。

See Also

UnhandledEventExceptionEventArgs Class
UnhandledEventExceptionEventArgs Members


UnhandledEventExceptionEventArgs.SourceEventArgs Property

[image]

Pick To Light 设备通讯类库
UnhandledEventExceptionEventArgs..::..SourceEventArgs Property
UnhandledEventExceptionEventArgs Class See Also Send Feedback
获取或设置源事件的事件参数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public EventArgs SourceEventArgs { get; set; }
Visual Basic
Public Property SourceEventArgs As EventArgs
    Get
    Set

Property Value

Type: EventArgs

Exceptions

Exception | Condition
System..::..ArgumentNullException | 设置时使用空值。

See Also

UnhandledEventExceptionEventArgs Class
UnhandledEventExceptionEventArgs Members


UnhandledEventExceptionEventArgs.SourceSender Property

[image]

Pick To Light 设备通讯类库
UnhandledEventExceptionEventArgs..::..SourceSender Property
UnhandledEventExceptionEventArgs Class See Also Send Feedback
获取或设置源事件发送者。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Object SourceSender { get; set; }
Visual Basic
Public Property SourceSender As Object
    Get
    Set

Property Value

Type: Object

See Also

UnhandledEventExceptionEventArgs Class
UnhandledEventExceptionEventArgs Members


XConverter Class

[image]

Pick To Light 设备通讯类库
XConverter Class
Members See Also Send Feedback
RS232 与 RS485 协议转换器，连接单条 RS485 总线。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class XConverter : IXmlSerializable, IDisposable
Visual Basic
<SerializableAttribute>
Public Class XConverter
    Implements IXmlSerializable, IDisposable

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..XConverter

See Also

XConverter Members


XConverter Members

[image] [image]

Pick To Light 设备通讯类库
XConverter Members
XConverter Class Constructors Methods Properties See Also Send Feedback

The XConverter type exposes the following members.

Constructors

 | Name | Description
Public method | XConverter(String) | 使用默认的初始化控制器。
Public method | XConverter(String, Int32, Parity, Int32, StopBits, Int32, Int32) | 使用指定的通讯参数初始化控制器。
Public method | XConverter(String, Int32, Parity, Int32, StopBits, Int32, Int32, Int32) | 使用指定的通讯参数初始化控制器。

Methods

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。
Protected method | Finalize | 释放非托管资源。 (Overrides Object..::..Finalize()()()().)
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | StartUnicastCommandQueue | 开始执行总线上的所有设备的协议队列。
Public method | StopUnicastCommandQueue()()()() | 停止执行总线上的所有设备的协议队列，但不等待执行线程退出。
Public method | StopUnicastCommandQueue(Boolean) | 停止执行总线上的所有设备的协议队列。
Public method | ToString | 返回对象的字符串表示。 (Overrides Object..::..ToString()()()().)
Public method | WriteXml | 将对象转换为其 XML 表示形式。

Properties

 | Name | Description
Public property | BroadcastCommunicationClient | 获取广播协议执行客户端。
Public property | Broadcaster | 获取广播协议执行者。
Public property | Bus | 获取 RS485 总线。
Public property | HeartbeatGenerator | 获取设备心跳发生器。
Public property | PortName | 获取串口名。

See Also

XConverter Class


XConverter Constructor

[image] [image]

Pick To Light 设备通讯类库
XConverter Constructor
XConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | XConverter(String) | 使用默认的初始化控制器。
Public method | XConverter(String, Int32, Parity, Int32, StopBits, Int32, Int32) | 使用指定的通讯参数初始化控制器。
Public method | XConverter(String, Int32, Parity, Int32, StopBits, Int32, Int32, Int32) | 使用指定的通讯参数初始化控制器。

See Also

XConverter Class
XConverter Members


XConverter Constructor (String)

[image]

Pick To Light 设备通讯类库
XConverter Constructor (String)
XConverter Class See Also Send Feedback
使用默认的初始化控制器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XConverter(
    string portName
)
Visual Basic
Public Sub New (
    portName As String
)

Parameters

portName
Type: System..::..String
端口名称。

See Also

XConverter Class
XConverter Members
XConverter Overload


XConverter Constructor (String, Int32, Parity, Int32, StopBits, Int32, Int32)

[image]

Pick To Light 设备通讯类库
XConverter Constructor (String, Int32, Parity, Int32, StopBits, Int32, Int32)
XConverter Class See Also Send Feedback
使用指定的通讯参数初始化控制器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XConverter(
    string portName,
    int baudRate,
    Parity parity,
    int dataBits,
    StopBits stopBits,
    int writeTimeoutInMilliseconds,
    int readTimeoutInMilliseconds
)
Visual Basic
Public Sub New (
    portName As String,
    baudRate As Integer,
    parity As Parity,
    dataBits As Integer,
    stopBits As StopBits,
    writeTimeoutInMilliseconds As Integer,
    readTimeoutInMilliseconds As Integer
)

Parameters

portName
Type: System..::..String
端口名称。
baudRate
Type: System..::..Int32
波特率。
parity
Type: System.IO.Ports..::..Parity
校验位。
dataBits
Type: System..::..Int32
数据位。
stopBits
Type: System.IO.Ports..::..StopBits
停止位。
writeTimeoutInMilliseconds
Type: System..::..Int32
发送超时时间。
readTimeoutInMilliseconds
Type: System..::..Int32
接收超时时间。

See Also

XConverter Class
XConverter Members
XConverter Overload


XConverter Constructor (String, Int32, Parity, Int32, StopBits, Int32, Int32, Int32)

[image]

Pick To Light 设备通讯类库
XConverter Constructor (String, Int32, Parity, Int32, StopBits, Int32, Int32, Int32)
XConverter Class See Also Send Feedback
使用指定的通讯参数初始化控制器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XConverter(
    string portName,
    int baudRate,
    Parity parity,
    int dataBits,
    StopBits stopBits,
    int writeTimeoutInMilliseconds,
    int readTimeoutInMilliseconds,
    int interframeDelayInMilliseconds
)
Visual Basic
Public Sub New (
    portName As String,
    baudRate As Integer,
    parity As Parity,
    dataBits As Integer,
    stopBits As StopBits,
    writeTimeoutInMilliseconds As Integer,
    readTimeoutInMilliseconds As Integer,
    interframeDelayInMilliseconds As Integer
)

Parameters

portName
Type: System..::..String
端口名称。
baudRate
Type: System..::..Int32
波特率。
parity
Type: System.IO.Ports..::..Parity
校验位。
dataBits
Type: System..::..Int32
数据位。
stopBits
Type: System.IO.Ports..::..StopBits
停止位。
writeTimeoutInMilliseconds
Type: System..::..Int32
发送超时时间。
readTimeoutInMilliseconds
Type: System..::..Int32
接收超时时间。
interframeDelayInMilliseconds
Type: System..::..Int32
帧间延时，用于无返回值的命令之后。

Exceptions

Exception | Condition
System..::..ArgumentNullException | portName 为空或为 System.String.Empty。

See Also

XConverter Class
XConverter Members
XConverter Overload


XConverter Methods

[image] [image]

Pick To Light 设备通讯类库
XConverter Methods
XConverter Class See Also Send Feedback

The XConverter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。
Protected method | Finalize | 释放非托管资源。 (Overrides Object..::..Finalize()()()().)
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | StartUnicastCommandQueue | 开始执行总线上的所有设备的协议队列。
Public method | StopUnicastCommandQueue()()()() | 停止执行总线上的所有设备的协议队列，但不等待执行线程退出。
Public method | StopUnicastCommandQueue(Boolean) | 停止执行总线上的所有设备的协议队列。
Public method | ToString | 返回对象的字符串表示。 (Overrides Object..::..ToString()()()().)
Public method | WriteXml | 将对象转换为其 XML 表示形式。

See Also

XConverter Class


XConverter.Dispose Method

[image] [image]

Pick To Light 设备通讯类库
XConverter..::..Dispose Method
XConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。

See Also

XConverter Class
XConverter Members


XConverter.Dispose Method

[image]

Pick To Light 设备通讯类库
XConverter..::..Dispose Method
XConverter Class See Also Send Feedback
释放托管和非托管资源。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

XConverter Class
XConverter Members
Dispose Overload


XConverter.Dispose Method (Boolean)

[image]

Pick To Light 设备通讯类库
XConverter..::..Dispose Method (Boolean)
XConverter Class See Also Send Feedback
释放非托管资源并可选地释放托管资源。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: System..::..Boolean
是否释放托管资源。

See Also

XConverter Class
XConverter Members
Dispose Overload


XConverter.Finalize Method

[image]

Pick To Light 设备通讯类库
XConverter..::..Finalize Method
XConverter Class See Also Send Feedback
释放非托管资源。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize

See Also

XConverter Class
XConverter Members


XConverter.GetSchema Method

[image]

Pick To Light 设备通讯类库
XConverter..::..GetSchema Method
XConverter Class See Also Send Feedback
此方法是保留方法，请不要使用。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XmlSchema GetSchema()
Visual Basic
Public Function GetSchema As XmlSchema

Return Value

Type: XmlSchema
始终返回空。

Implements

IXmlSerializable..::..GetSchema()()()()

See Also

XConverter Class
XConverter Members


XConverter.ReadXml Method

[image]

Pick To Light 设备通讯类库
XConverter..::..ReadXml Method
XConverter Class See Also Send Feedback
从对象的 XML 表示形式生成该对象。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void ReadXml(
    XmlReader reader
)
Visual Basic
Public Sub ReadXml (
    reader As XmlReader
)

Parameters

reader
Type: System.Xml..::..XmlReader
对象从中进行反序列化的 System.Xml.XmlReader 流。

Implements

IXmlSerializable..::..ReadXml(XmlReader)

Exceptions

Exception | Condition
System..::..ArgumentNullException | reader 为空。

See Also

XConverter Class
XConverter Members


XConverter.StartUnicastCommandQueue Method

[image]

Pick To Light 设备通讯类库
XConverter..::..StartUnicastCommandQueue Method
XConverter Class See Also Send Feedback
开始执行总线上的所有设备的协议队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void StartUnicastCommandQueue()
Visual Basic
Public Sub StartUnicastCommandQueue

See Also

XConverter Class
XConverter Members


XConverter.StopUnicastCommandQueue Method

[image] [image]

Pick To Light 设备通讯类库
XConverter..::..StopUnicastCommandQueue Method
XConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StopUnicastCommandQueue()()()() | 停止执行总线上的所有设备的协议队列，但不等待执行线程退出。
Public method | StopUnicastCommandQueue(Boolean) | 停止执行总线上的所有设备的协议队列。

See Also

XConverter Class
XConverter Members


XConverter.StopUnicastCommandQueue Method

[image]

Pick To Light 设备通讯类库
XConverter..::..StopUnicastCommandQueue Method
XConverter Class See Also Send Feedback
停止执行总线上的所有设备的协议队列，但不等待执行线程退出。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void StopUnicastCommandQueue()
Visual Basic
Public Sub StopUnicastCommandQueue

See Also

XConverter Class
XConverter Members
StopUnicastCommandQueue Overload


XConverter.StopUnicastCommandQueue Method (Boolean)

[image]

Pick To Light 设备通讯类库
XConverter..::..StopUnicastCommandQueue Method (Boolean)
XConverter Class See Also Send Feedback
停止执行总线上的所有设备的协议队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void StopUnicastCommandQueue(
    bool waitExecuteThreadQuit
)
Visual Basic
Public Sub StopUnicastCommandQueue (
    waitExecuteThreadQuit As Boolean
)

Parameters

waitExecuteThreadQuit
Type: System..::..Boolean
是否等待执行线程退出。

See Also

XConverter Class
XConverter Members
StopUnicastCommandQueue Overload


XConverter.ToString Method

[image]

Pick To Light 设备通讯类库
XConverter..::..ToString Method
XConverter Class See Also Send Feedback
返回对象的字符串表示。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
串口名。

See Also

XConverter Class
XConverter Members


XConverter.WriteXml Method

[image]

Pick To Light 设备通讯类库
XConverter..::..WriteXml Method
XConverter Class See Also Send Feedback
将对象转换为其 XML 表示形式。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void WriteXml(
    XmlWriter writer
)
Visual Basic
Public Sub WriteXml (
    writer As XmlWriter
)

Parameters

writer
Type: System.Xml..::..XmlWriter
对象要序列化为的 System.Xml.XmlWriter 流。

Implements

IXmlSerializable..::..WriteXml(XmlWriter)

Exceptions

Exception | Condition
System..::..ArgumentNullException | writer 为空。

See Also

XConverter Class
XConverter Members


XConverter Properties

[image] [image]

Pick To Light 设备通讯类库
XConverter Properties
XConverter Class See Also Send Feedback

The XConverter type exposes the following members.

Properties

 | Name | Description
Public property | BroadcastCommunicationClient | 获取广播协议执行客户端。
Public property | Broadcaster | 获取广播协议执行者。
Public property | Bus | 获取 RS485 总线。
Public property | HeartbeatGenerator | 获取设备心跳发生器。
Public property | PortName | 获取串口名。

See Also

XConverter Class


XConverter.BroadcastCommunicationClient Property

[image]

Pick To Light 设备通讯类库
XConverter..::..BroadcastCommunicationClient Property
XConverter Class See Also Send Feedback
获取广播协议执行客户端。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public SerialPortClient BroadcastCommunicationClient { get; }
Visual Basic
Public ReadOnly Property BroadcastCommunicationClient As SerialPortClient
    Get

Property Value

Type: SerialPortClient

See Also

XConverter Class
XConverter Members


XConverter.Broadcaster Property

[image]

Pick To Light 设备通讯类库
XConverter..::..Broadcaster Property
XConverter Class See Also Send Feedback
获取广播协议执行者。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Broadcaster Broadcaster { get; }
Visual Basic
Public ReadOnly Property Broadcaster As Broadcaster
    Get

Property Value

Type: Broadcaster

See Also

XConverter Class
XConverter Members


XConverter.Bus Property

[image]

Pick To Light 设备通讯类库
XConverter..::..Bus Property
XConverter Class See Also Send Feedback
获取 RS485 总线。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public RS485Bus Bus { get; }
Visual Basic
Public ReadOnly Property Bus As RS485Bus
    Get

Property Value

Type: RS485Bus

See Also

XConverter Class
XConverter Members


XConverter.HeartbeatGenerator Property

[image]

Pick To Light 设备通讯类库
XConverter..::..HeartbeatGenerator Property
XConverter Class See Also Send Feedback
获取设备心跳发生器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public HeartbeatGenerator HeartbeatGenerator { get; }
Visual Basic
Public ReadOnly Property HeartbeatGenerator As HeartbeatGenerator
    Get

Property Value

Type: HeartbeatGenerator

See Also

XConverter Class
XConverter Members


XConverter.PortName Property

[image]

Pick To Light 设备通讯类库
XConverter..::..PortName Property
XConverter Class See Also Send Feedback
获取串口名。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string PortName { get; }
Visual Basic
Public ReadOnly Property PortName As String
    Get

Property Value

Type: String

See Also

XConverter Class
XConverter Members


XGate Class

[image]

Pick To Light 设备通讯类库
XGate Class
Members See Also Send Feedback

Modbus TCP 与 Modbus RTU/ASCII 协议转换器，可接插多条 RS485 总线。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class XGate : IXmlSerializable, IDisposable
Visual Basic
<SerializableAttribute>
Public Class XGate
    Implements IXmlSerializable, IDisposable

Remarks

设备在断网后自行决定显示内容，此时的外观不能被跟踪。

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..XGate

See Also

XGate Members


XGate Members

[image] [image]

Pick To Light 设备通讯类库
XGate Members
XGate Class Constructors Methods Fields Properties Events See Also Send Feedback

The XGate type exposes the following members.

Constructors

 | Name | Description
Public method | XGate()()()() | 使用默认的 IP 192.168.0.10、端口 502 和总线数 4 初始化控制器。
Public method | XGate(IPAddress) | 使用指定的 IP，默认的端口 502 和总线数 4 初始化控制器。
Public method | XGate(String) | 使用指定的 IP，默认的端口 502 和总线数 4 初始化控制器。
Public method | XGate(IPAddress, Byte) | 使用指定的 IP，默认的端口 502 和指定的总线数量初始化控制器。
Public method | XGate(IPEndPoint, Byte) | 使用指定的 IP 终结点和总线数量初始化控制器。

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列。
Public method | ClearLight | 清除前面板灯。
Public method | ClearOutputPort | 清除指定的输出口。
Public method | DisplayLight | 显示前面板灯。
Public method | DisplayOutputPort | 点亮指定的输出口。
Public method | Dispose()()()() | 释放托管和非托管资源。
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。
Protected method | Finalize | 释放非托管资源。 (Overrides Object..::..Finalize()()()().)
Public method | GetInputPortStatuses | 获取所有输入口状态的集合。
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | Initialize | 清空未完成的协议、清空可能存在的显示内容和状态缓存。
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。
Protected method | OnInputPortStatusChanged | 引发输入口状态改变事件。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | Refresh | 刷新显示面板。
Public method | SetOutputPort | 设置指定的输出口。
Public method | StartUnicastCommandQueue()()()() | 开始执行自己及所有总线上的所有设备的协议队列。
Public method | StartUnicastCommandQueue(Int32, Int32, Int32) | 开始执行自己及所有总线上的所有设备的协议队列。
Public method | StartUnicastCommandQueue(Int32, Int32, Int32, MapRS485Address) | 开始执行自己及所有总线上的所有设备的协议队列。
Public method | StopUnicastCommandQueue()()()() | 停止执行自己及所有总线上的所有设备的协议队列，但不等待执行线程退出。
Public method | StopUnicastCommandQueue(Boolean) | 停止执行自己及所有总线上的所有设备的协议队列。
Public method | ToString | 返回对象的字符串表示。 (Overrides Object..::..ToString()()()().)
Public method | WriteXml | 将对象转换为其 XML 表示形式。

Fields

Name | Description
DefaultIPAddress | 默认的 IP 地址：192.168.0.10。
DefaultIPEndPointPort | 默认的 IP 终结点端口：502。

Properties

 | Name | Description
Public property | BroadcastCommunicationClient | 获取广播协议执行客户端。
Public property | Broadcaster | 获取广播协议执行者。
Public property | Buses | 获取 RS485 总线集合。
Public property | CommandCount | 获取队列中未完成的命令数。
Public property | CurrentAppearance | 获取当前外观。
Public property | DefaultRS485AddressMapper | 获取或设置默认的 RS485 地址映射方式。
Public property | EnableLight | 获取或设置是否启用前面板灯。
Public property | InputPortsCount | 获取或设置是否启用输入口。
Public property | IPEndPoint | 获取或设置控制器的 IP 终结点。
Public property | OutputPortsCount | 获取或设置是否启用输出口。
Public property | SettingsExecutor | 获取设置协议执行者。
Public property | SettingsExecutorCommunicationClient | 获取设置协议执行客户端。
Public property | XGateUnicastCommunicationClient | 获取单播协议执行客户端。

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。
Public event | InputPortStatusChanged | 输入口状态改变事件。

See Also

XGate Class


XGate Constructor

[image] [image]

Pick To Light 设备通讯类库
XGate Constructor
XGate Class See Also Send Feedback

Overload List

 | Name | Description
Public method | XGate()()()() | 使用默认的 IP 192.168.0.10、端口 502 和总线数 4 初始化控制器。
Public method | XGate(IPAddress) | 使用指定的 IP，默认的端口 502 和总线数 4 初始化控制器。
Public method | XGate(String) | 使用指定的 IP，默认的端口 502 和总线数 4 初始化控制器。
Public method | XGate(IPAddress, Byte) | 使用指定的 IP，默认的端口 502 和指定的总线数量初始化控制器。
Public method | XGate(IPEndPoint, Byte) | 使用指定的 IP 终结点和总线数量初始化控制器。

See Also

XGate Class
XGate Members


XGate Constructor

[image]

Pick To Light 设备通讯类库
XGate Constructor
XGate Class See Also Send Feedback
使用默认的 IP 192.168.0.10、端口 502 和总线数 4 初始化控制器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGate()
Visual Basic
Public Sub New

See Also

XGate Class
XGate Members
XGate Overload


XGate Constructor (IPAddress)

[image]

Pick To Light 设备通讯类库
XGate Constructor (IPAddress)
XGate Class See Also Send Feedback
使用指定的 IP，默认的端口 502 和总线数 4 初始化控制器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGate(
    IPAddress ipAddress
)
Visual Basic
Public Sub New (
    ipAddress As IPAddress
)

Parameters

ipAddress
Type: System.Net..::..IPAddress
IP 地址。

See Also

XGate Class
XGate Members
XGate Overload


XGate Constructor (String)

[image]

Pick To Light 设备通讯类库
XGate Constructor (String)
XGate Class See Also Send Feedback
使用指定的 IP，默认的端口 502 和总线数 4 初始化控制器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGate(
    string ip
)
Visual Basic
Public Sub New (
    ip As String
)

Parameters

ip
Type: System..::..String
IP 地址。

See Also

XGate Class
XGate Members
XGate Overload


XGate Constructor (IPAddress, Byte)

[image]

Pick To Light 设备通讯类库
XGate Constructor (IPAddress, Byte)
XGate Class See Also Send Feedback
使用指定的 IP，默认的端口 502 和指定的总线数量初始化控制器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGate(
    IPAddress ipAddress,
    byte busCount
)
Visual Basic
Public Sub New (
    ipAddress As IPAddress,
    busCount As Byte
)

Parameters

ipAddress
Type: System.Net..::..IPAddress
IP 地址。
busCount
Type: System..::..Byte
总线数量。

See Also

XGate Class
XGate Members
XGate Overload


XGate Constructor (IPEndPoint, Byte)

[image]

Pick To Light 设备通讯类库
XGate Constructor (IPEndPoint, Byte)
XGate Class See Also Send Feedback
使用指定的 IP 终结点和总线数量初始化控制器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGate(
    IPEndPoint ipEndPoint,
    byte busCount
)
Visual Basic
Public Sub New (
    ipEndPoint As IPEndPoint,
    busCount As Byte
)

Parameters

ipEndPoint
Type: System.Net..::..IPEndPoint
IP 终结点。
busCount
Type: System..::..Byte
总线数量。

Exceptions

Exception | Condition
System..::..ArgumentNullException | ipEndPoint 为空。

See Also

XGate Class
XGate Members
XGate Overload


XGate Fields

[image] [image]

Pick To Light 设备通讯类库
XGate Fields
XGate Class See Also Send Feedback

The XGate type exposes the following members.

Fields

Name | Description
DefaultIPAddress | 默认的 IP 地址：192.168.0.10。
DefaultIPEndPointPort | 默认的 IP 终结点端口：502。

See Also

XGate Class


XGate.DefaultIPAddress Field

[image]

Pick To Light 设备通讯类库
XGate..::..DefaultIPAddress Field
XGate Class See Also Send Feedback
默认的 IP 地址：192.168.0.10。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public const string DefaultIPAddress
Visual Basic
Public Const DefaultIPAddress As String

Field Value

Type: String

See Also

XGate Class
XGate Members


XGate.DefaultIPEndPointPort Field

[image]

Pick To Light 设备通讯类库
XGate..::..DefaultIPEndPointPort Field
XGate Class See Also Send Feedback
默认的 IP 终结点端口：502。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public const int DefaultIPEndPointPort
Visual Basic
Public Const DefaultIPEndPointPort As Integer

Field Value

Type: Int32

See Also

XGate Class
XGate Members


XGate Methods

[image] [image]

Pick To Light 设备通讯类库
XGate Methods
XGate Class See Also Send Feedback

The XGate type exposes the following members.

Methods

 | Name | Description
Public method | ClearCommandQueue | 清空协议队列。
Public method | ClearLight | 清除前面板灯。
Public method | ClearOutputPort | 清除指定的输出口。
Public method | DisplayLight | 显示前面板灯。
Public method | DisplayOutputPort | 点亮指定的输出口。
Public method | Dispose()()()() | 释放托管和非托管资源。
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。
Protected method | Finalize | 释放非托管资源。 (Overrides Object..::..Finalize()()()().)
Public method | GetInputPortStatuses | 获取所有输入口状态的集合。
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | Initialize | 清空未完成的协议、清空可能存在的显示内容和状态缓存。
Protected method | OnAppearanceChanged | 引发设备的当前外观更改事件。
Protected method | OnInputPortStatusChanged | 引发输入口状态改变事件。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | Refresh | 刷新显示面板。
Public method | SetOutputPort | 设置指定的输出口。
Public method | StartUnicastCommandQueue()()()() | 开始执行自己及所有总线上的所有设备的协议队列。
Public method | StartUnicastCommandQueue(Int32, Int32, Int32) | 开始执行自己及所有总线上的所有设备的协议队列。
Public method | StartUnicastCommandQueue(Int32, Int32, Int32, MapRS485Address) | 开始执行自己及所有总线上的所有设备的协议队列。
Public method | StopUnicastCommandQueue()()()() | 停止执行自己及所有总线上的所有设备的协议队列，但不等待执行线程退出。
Public method | StopUnicastCommandQueue(Boolean) | 停止执行自己及所有总线上的所有设备的协议队列。
Public method | ToString | 返回对象的字符串表示。 (Overrides Object..::..ToString()()()().)
Public method | WriteXml | 将对象转换为其 XML 表示形式。

See Also

XGate Class


XGate.ClearCommandQueue Method

[image]

Pick To Light 设备通讯类库
XGate..::..ClearCommandQueue Method
XGate Class See Also Send Feedback
清空协议队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void ClearCommandQueue()
Visual Basic
Public Sub ClearCommandQueue

See Also

XGate Class
XGate Members


XGate.ClearLight Method

[image]

Pick To Light 设备通讯类库
XGate..::..ClearLight Method
XGate Class See Also Send Feedback
清除前面板灯。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void ClearLight()
Visual Basic
Public Sub ClearLight

See Also

XGate Class
XGate Members


XGate.ClearOutputPort Method

[image]

Pick To Light 设备通讯类库
XGate..::..ClearOutputPort Method
XGate Class See Also Send Feedback
清除指定的输出口。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void ClearOutputPort(
    byte portIndex
)
Visual Basic
Public Sub ClearOutputPort (
    portIndex As Byte
)

Parameters

portIndex
Type: System..::..Byte
基于 0 的索引。

See Also

XGate Class
XGate Members


XGate.DisplayLight Method

[image]

Pick To Light 设备通讯类库
XGate..::..DisplayLight Method
XGate Class See Also Send Feedback
显示前面板灯。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void DisplayLight(
    LightMode lightMode
)
Visual Basic
Public Sub DisplayLight (
    lightMode As LightMode
)

Parameters

lightMode
Type: Ptl.Device.Communication.Command..::..LightMode
点亮模式。

See Also

XGate Class
XGate Members


XGate.DisplayOutputPort Method

[image]

Pick To Light 设备通讯类库
XGate..::..DisplayOutputPort Method
XGate Class See Also Send Feedback
点亮指定的输出口。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void DisplayOutputPort(
    byte portIndex,
    LightOnOffPeriod onOffPeriod,
    LightOnOffRatio onOffRatio
)
Visual Basic
Public Sub DisplayOutputPort (
    portIndex As Byte,
    onOffPeriod As LightOnOffPeriod,
    onOffRatio As LightOnOffRatio
)

Parameters

portIndex
Type: System..::..Byte
基于 0 的索引。
onOffPeriod
Type: Ptl.Device.Communication.Command..::..LightOnOffPeriod
亮灭周期。
onOffRatio
Type: Ptl.Device.Communication.Command..::..LightOnOffRatio
亮灭比例。

See Also

XGate Class
XGate Members


XGate.Dispose Method

[image] [image]

Pick To Light 设备通讯类库
XGate..::..Dispose Method
XGate Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。

See Also

XGate Class
XGate Members


XGate.Dispose Method

[image]

Pick To Light 设备通讯类库
XGate..::..Dispose Method
XGate Class See Also Send Feedback
释放托管和非托管资源。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

XGate Class
XGate Members
Dispose Overload


XGate.Dispose Method (Boolean)

[image]

Pick To Light 设备通讯类库
XGate..::..Dispose Method (Boolean)
XGate Class See Also Send Feedback
释放非托管资源并可选地释放托管资源。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: System..::..Boolean
是否释放托管资源。

See Also

XGate Class
XGate Members
Dispose Overload


XGate.Finalize Method

[image]

Pick To Light 设备通讯类库
XGate..::..Finalize Method
XGate Class See Also Send Feedback
释放非托管资源。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize

See Also

XGate Class
XGate Members


XGate.GetInputPortStatuses Method

[image]

Pick To Light 设备通讯类库
XGate..::..GetInputPortStatuses Method
XGate Class See Also Send Feedback
获取所有输入口状态的集合。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Collection<Nullable<bool>> GetInputPortStatuses()
Visual Basic
Public Function GetInputPortStatuses As Collection(Of Nullable(Of Boolean))

Return Value

Type: Collection <(Of <(<' Nullable <(Of <(<' Boolean >)>)>>)>)>
所有输入口状态的集合。

See Also

XGate Class
XGate Members


XGate.GetSchema Method

[image]

Pick To Light 设备通讯类库
XGate..::..GetSchema Method
XGate Class See Also Send Feedback
此方法是保留方法，请不要使用。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XmlSchema GetSchema()
Visual Basic
Public Function GetSchema As XmlSchema

Return Value

Type: XmlSchema
始终返回空。

Implements

IXmlSerializable..::..GetSchema()()()()

See Also

XGate Class
XGate Members


XGate.Initialize Method

[image]

Pick To Light 设备通讯类库
XGate..::..Initialize Method
XGate Class See Also Send Feedback
清空未完成的协议、清空可能存在的显示内容和状态缓存。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Initialize()
Visual Basic
Public Sub Initialize

See Also

XGate Class
XGate Members


XGate.OnAppearanceChanged Method

[image]

Pick To Light 设备通讯类库
XGate..::..OnAppearanceChanged Method
XGate Class See Also Send Feedback
引发设备的当前外观更改事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void OnAppearanceChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnAppearanceChanged (
    e As EventArgs
)

Parameters

e
Type: System..::..EventArgs
事件参数。

See Also

XGate Class
XGate Members


XGate.OnInputPortStatusChanged Method

[image]

Pick To Light 设备通讯类库
XGate..::..OnInputPortStatusChanged Method
XGate Class See Also Send Feedback
引发输入口状态改变事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void OnInputPortStatusChanged(
    InputPortStatusChangedEventArgs e
)
Visual Basic
Protected Overridable Sub OnInputPortStatusChanged (
    e As InputPortStatusChangedEventArgs
)

Parameters

e
Type: Ptl.Device..::..InputPortStatusChangedEventArgs
事件参数。

See Also

XGate Class
XGate Members


XGate.ReadXml Method

[image]

Pick To Light 设备通讯类库
XGate..::..ReadXml Method
XGate Class See Also Send Feedback
从对象的 XML 表示形式生成该对象。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void ReadXml(
    XmlReader reader
)
Visual Basic
Public Sub ReadXml (
    reader As XmlReader
)

Parameters

reader
Type: System.Xml..::..XmlReader
对象从中进行反序列化的 System.Xml.XmlReader 流。

Implements

IXmlSerializable..::..ReadXml(XmlReader)

Exceptions

Exception | Condition
System..::..ArgumentNullException | reader 为空。

See Also

XGate Class
XGate Members


XGate.Refresh Method

[image]

Pick To Light 设备通讯类库
XGate..::..Refresh Method
XGate Class See Also Send Feedback
刷新显示面板。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Refresh()
Visual Basic
Public Sub Refresh

See Also

XGate Class
XGate Members


XGate.SetOutputPort Method

[image]

Pick To Light 设备通讯类库
XGate..::..SetOutputPort Method
XGate Class See Also Send Feedback
设置指定的输出口。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void SetOutputPort(
    byte portIndex,
    OutputPortStatus status
)
Visual Basic
Public Sub SetOutputPort (
    portIndex As Byte,
    status As OutputPortStatus
)

Parameters

portIndex
Type: System..::..Byte
基于 0 的索引。
status
Type: Ptl.Device.Communication.XGateSettings..::..OutputPortStatus
状态。

See Also

XGate Class
XGate Members


XGate.StartUnicastCommandQueue Method

[image] [image]

Pick To Light 设备通讯类库
XGate..::..StartUnicastCommandQueue Method
XGate Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartUnicastCommandQueue()()()() | 开始执行自己及所有总线上的所有设备的协议队列。
Public method | StartUnicastCommandQueue(Int32, Int32, Int32) | 开始执行自己及所有总线上的所有设备的协议队列。
Public method | StartUnicastCommandQueue(Int32, Int32, Int32, MapRS485Address) | 开始执行自己及所有总线上的所有设备的协议队列。

See Also

XGate Class
XGate Members


XGate.StartUnicastCommandQueue Method

[image]

Pick To Light 设备通讯类库
XGate..::..StartUnicastCommandQueue Method
XGate Class See Also Send Feedback
开始执行自己及所有总线上的所有设备的协议队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void StartUnicastCommandQueue()
Visual Basic
Public Sub StartUnicastCommandQueue

See Also

XGate Class
XGate Members
StartUnicastCommandQueue Overload


XGate.StartUnicastCommandQueue Method (Int32, Int32, Int32)

[image]

Pick To Light 设备通讯类库
XGate..::..StartUnicastCommandQueue Method (Int32, Int32, Int32)
XGate Class See Also Send Feedback
开始执行自己及所有总线上的所有设备的协议队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void StartUnicastCommandQueue(
    int connectTimeoutInMilliseconds,
    int sendTimeoutInMilliseconds,
    int receivedTimeoutInMilliseconds
)
Visual Basic
Public Sub StartUnicastCommandQueue (
    connectTimeoutInMilliseconds As Integer,
    sendTimeoutInMilliseconds As Integer,
    receivedTimeoutInMilliseconds As Integer
)

Parameters

connectTimeoutInMilliseconds
Type: System..::..Int32
连接超时时间。
sendTimeoutInMilliseconds
Type: System..::..Int32
发送超时毫秒数。
receivedTimeoutInMilliseconds
Type: System..::..Int32
接收超时毫秒数。

See Also

XGate Class
XGate Members
StartUnicastCommandQueue Overload


XGate.StartUnicastCommandQueue Method (Int32, Int32, Int32, MapRS485Address)

[image]

Pick To Light 设备通讯类库
XGate..::..StartUnicastCommandQueue Method (Int32, Int32, Int32, MapRS485Address)
XGate Class See Also Send Feedback
开始执行自己及所有总线上的所有设备的协议队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void StartUnicastCommandQueue(
    int connectTimeoutInMilliseconds,
    int sendTimeoutInMilliseconds,
    int receivedTimeoutInMilliseconds,
    MapRS485Address mapAddress
)
Visual Basic
Public Sub StartUnicastCommandQueue (
    connectTimeoutInMilliseconds As Integer,
    sendTimeoutInMilliseconds As Integer,
    receivedTimeoutInMilliseconds As Integer,
    mapAddress As MapRS485Address
)

Parameters

connectTimeoutInMilliseconds
Type: System..::..Int32
连接超时时间。
sendTimeoutInMilliseconds
Type: System..::..Int32
发送超时毫秒数。
receivedTimeoutInMilliseconds
Type: System..::..Int32
接收超时毫秒数。
mapAddress
Type: Ptl.Device.Communication..::..MapRS485Address
RS485 地址映射方法。

See Also

XGate Class
XGate Members
StartUnicastCommandQueue Overload


XGate.StopUnicastCommandQueue Method

[image] [image]

Pick To Light 设备通讯类库
XGate..::..StopUnicastCommandQueue Method
XGate Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StopUnicastCommandQueue()()()() | 停止执行自己及所有总线上的所有设备的协议队列，但不等待执行线程退出。
Public method | StopUnicastCommandQueue(Boolean) | 停止执行自己及所有总线上的所有设备的协议队列。

See Also

XGate Class
XGate Members


XGate.StopUnicastCommandQueue Method

[image]

Pick To Light 设备通讯类库
XGate..::..StopUnicastCommandQueue Method
XGate Class See Also Send Feedback
停止执行自己及所有总线上的所有设备的协议队列，但不等待执行线程退出。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void StopUnicastCommandQueue()
Visual Basic
Public Sub StopUnicastCommandQueue

See Also

XGate Class
XGate Members
StopUnicastCommandQueue Overload


XGate.StopUnicastCommandQueue Method (Boolean)

[image]

Pick To Light 设备通讯类库
XGate..::..StopUnicastCommandQueue Method (Boolean)
XGate Class See Also Send Feedback
停止执行自己及所有总线上的所有设备的协议队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void StopUnicastCommandQueue(
    bool waitExecuteThreadQuit
)
Visual Basic
Public Sub StopUnicastCommandQueue (
    waitExecuteThreadQuit As Boolean
)

Parameters

waitExecuteThreadQuit
Type: System..::..Boolean
是否等待执行线程退出。

See Also

XGate Class
XGate Members
StopUnicastCommandQueue Overload


XGate.ToString Method

[image]

Pick To Light 设备通讯类库
XGate..::..ToString Method
XGate Class See Also Send Feedback
返回对象的字符串表示。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
IP 终结点。

See Also

XGate Class
XGate Members


XGate.WriteXml Method

[image]

Pick To Light 设备通讯类库
XGate..::..WriteXml Method
XGate Class See Also Send Feedback
将对象转换为其 XML 表示形式。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void WriteXml(
    XmlWriter writer
)
Visual Basic
Public Sub WriteXml (
    writer As XmlWriter
)

Parameters

writer
Type: System.Xml..::..XmlWriter
对象要序列化为的 System.Xml.XmlWriter 流。

Implements

IXmlSerializable..::..WriteXml(XmlWriter)

Exceptions

Exception | Condition
System..::..ArgumentNullException | writer 为空。

See Also

XGate Class
XGate Members


XGate Properties

[image] [image]

Pick To Light 设备通讯类库
XGate Properties
XGate Class See Also Send Feedback

The XGate type exposes the following members.

Properties

 | Name | Description
Public property | BroadcastCommunicationClient | 获取广播协议执行客户端。
Public property | Broadcaster | 获取广播协议执行者。
Public property | Buses | 获取 RS485 总线集合。
Public property | CommandCount | 获取队列中未完成的命令数。
Public property | CurrentAppearance | 获取当前外观。
Public property | DefaultRS485AddressMapper | 获取或设置默认的 RS485 地址映射方式。
Public property | EnableLight | 获取或设置是否启用前面板灯。
Public property | InputPortsCount | 获取或设置是否启用输入口。
Public property | IPEndPoint | 获取或设置控制器的 IP 终结点。
Public property | OutputPortsCount | 获取或设置是否启用输出口。
Public property | SettingsExecutor | 获取设置协议执行者。
Public property | SettingsExecutorCommunicationClient | 获取设置协议执行客户端。
Public property | XGateUnicastCommunicationClient | 获取单播协议执行客户端。

See Also

XGate Class


XGate.BroadcastCommunicationClient Property

[image]

Pick To Light 设备通讯类库
XGate..::..BroadcastCommunicationClient Property
XGate Class See Also Send Feedback
获取广播协议执行客户端。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ModbusClient BroadcastCommunicationClient { get; }
Visual Basic
Public ReadOnly Property BroadcastCommunicationClient As ModbusClient
    Get

Property Value

Type: ModbusClient

See Also

XGate Class
XGate Members


XGate.Broadcaster Property

[image]

Pick To Light 设备通讯类库
XGate..::..Broadcaster Property
XGate Class See Also Send Feedback
获取广播协议执行者。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Broadcaster Broadcaster { get; }
Visual Basic
Public ReadOnly Property Broadcaster As Broadcaster
    Get

Property Value

Type: Broadcaster

See Also

XGate Class
XGate Members


XGate.Buses Property

[image]

Pick To Light 设备通讯类库
XGate..::..Buses Property
XGate Class See Also Send Feedback
获取 RS485 总线集合。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public RS485BusCollection Buses { get; }
Visual Basic
Public ReadOnly Property Buses As RS485BusCollection
    Get

Property Value

Type: RS485BusCollection

See Also

XGate Class
XGate Members


XGate.CommandCount Property

[image]

Pick To Light 设备通讯类库
XGate..::..CommandCount Property
XGate Class See Also Send Feedback
获取队列中未完成的命令数。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int CommandCount { get; }
Visual Basic
Public ReadOnly Property CommandCount As Integer
    Get

Property Value

Type: Int32

See Also

XGate Class
XGate Members


XGate.CurrentAppearance Property

[image]

Pick To Light 设备通讯类库
XGate..::..CurrentAppearance Property
XGate Class See Also Send Feedback
获取当前外观。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGateAppearance CurrentAppearance { get; }
Visual Basic
Public ReadOnly Property CurrentAppearance As XGateAppearance
    Get

Property Value

Type: XGateAppearance

See Also

XGate Class
XGate Members


XGate.DefaultRS485AddressMapper Property

[image]

Pick To Light 设备通讯类库
XGate..::..DefaultRS485AddressMapper Property
XGate Class See Also Send Feedback
获取或设置默认的 RS485 地址映射方式。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public DefaultRS485AddressMapper DefaultRS485AddressMapper { get; set; }
Visual Basic
Public Property DefaultRS485AddressMapper As DefaultRS485AddressMapper
    Get
    Set

Property Value

Type: DefaultRS485AddressMapper

See Also

XGate Class
XGate Members


XGate.EnableLight Property

[image]

Pick To Light 设备通讯类库
XGate..::..EnableLight Property
XGate Class See Also Send Feedback
获取或设置是否启用前面板灯。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool EnableLight { get; set; }
Visual Basic
Public Property EnableLight As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

XGate Class
XGate Members


XGate.InputPortsCount Property

[image]

Pick To Light 设备通讯类库
XGate..::..InputPortsCount Property
XGate Class See Also Send Feedback
获取或设置是否启用输入口。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte InputPortsCount { get; set; }
Visual Basic
Public Property InputPortsCount As Byte
    Get
    Set

Property Value

Type: Byte

See Also

XGate Class
XGate Members


XGate.IPEndPoint Property

[image]

Pick To Light 设备通讯类库
XGate..::..IPEndPoint Property
XGate Class See Also Send Feedback
获取或设置控制器的 IP 终结点。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public IPEndPoint IPEndPoint { get; set; }
Visual Basic
Public Property IPEndPoint As IPEndPoint
    Get
    Set

Property Value

Type: IPEndPoint

See Also

XGate Class
XGate Members


XGate.OutputPortsCount Property

[image]

Pick To Light 设备通讯类库
XGate..::..OutputPortsCount Property
XGate Class See Also Send Feedback
获取或设置是否启用输出口。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte OutputPortsCount { get; set; }
Visual Basic
Public Property OutputPortsCount As Byte
    Get
    Set

Property Value

Type: Byte

See Also

XGate Class
XGate Members


XGate.SettingsExecutor Property

[image]

Pick To Light 设备通讯类库
XGate..::..SettingsExecutor Property
XGate Class See Also Send Feedback
获取设置协议执行者。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGateSettingsExecutor SettingsExecutor { get; }
Visual Basic
Public ReadOnly Property SettingsExecutor As XGateSettingsExecutor
    Get

Property Value

Type: XGateSettingsExecutor

See Also

XGate Class
XGate Members


XGate.SettingsExecutorCommunicationClient Property

[image]

Pick To Light 设备通讯类库
XGate..::..SettingsExecutorCommunicationClient Property
XGate Class See Also Send Feedback
获取设置协议执行客户端。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ModbusClient SettingsExecutorCommunicationClient { get; }
Visual Basic
Public ReadOnly Property SettingsExecutorCommunicationClient As ModbusClient
    Get

Property Value

Type: ModbusClient

See Also

XGate Class
XGate Members


XGate.XGateUnicastCommunicationClient Property

[image]

Pick To Light 设备通讯类库
XGate..::..XGateUnicastCommunicationClient Property
XGate Class See Also Send Feedback
获取单播协议执行客户端。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ModbusClient XGateUnicastCommunicationClient { get; }
Visual Basic
Public ReadOnly Property XGateUnicastCommunicationClient As ModbusClient
    Get

Property Value

Type: ModbusClient

See Also

XGate Class
XGate Members


XGate Events

[image] [image]

Pick To Light 设备通讯类库
XGate Events
XGate Class See Also Send Feedback

The XGate type exposes the following members.

Events

 | Name | Description
Public event | AppearanceChanged | 设备的当前外观更改事件。
Public event | InputPortStatusChanged | 输入口状态改变事件。

See Also

XGate Class


XGate.AppearanceChanged Event

[image]

Pick To Light 设备通讯类库
XGate..::..AppearanceChanged Event
XGate Class See Also Send Feedback
设备的当前外观更改事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public event EventHandler AppearanceChanged
Visual Basic
Public Event AppearanceChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

XGate Class
XGate Members


XGate.InputPortStatusChanged Event

[image]

Pick To Light 设备通讯类库
XGate..::..InputPortStatusChanged Event
XGate Class See Also Send Feedback
输入口状态改变事件。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public event EventHandler<InputPortStatusChangedEventArgs> InputPortStatusChanged
Visual Basic
Public Event InputPortStatusChanged As EventHandler(Of InputPortStatusChangedEventArgs)

Value

Type: System..::..EventHandler <(Of <(<' InputPortStatusChangedEventArgs >)>)>

See Also

XGate Class
XGate Members


XGateAppearance Class

[image]

Pick To Light 设备通讯类库
XGateAppearance Class
Members See Also Send Feedback
XGate 的外观。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class XGateAppearance
Visual Basic
<SerializableAttribute>
Public Class XGateAppearance

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..XGateAppearance

See Also

XGateAppearance Members


XGateAppearance Members

[image] [image]

Pick To Light 设备通讯类库
XGateAppearance Members
XGateAppearance Class Constructors Properties See Also Send Feedback

The XGateAppearance type exposes the following members.

Constructors

 | Name | Description
Public method | XGateAppearance | Initializes a new instance of the XGateAppearance class

Properties

 | Name | Description
Public property | InputPortStatuses | 获取所有输入口状态的集合.
Public property | Light | 获取或设置亮灯模式。
Public property | OutputPortStatuses | 获取所有输出口状态的集合.

See Also

XGateAppearance Class


XGateAppearance Constructor

[image]

Pick To Light 设备通讯类库
XGateAppearance Constructor
XGateAppearance Class See Also Send Feedback
Initializes a new instance of the XGateAppearance class

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGateAppearance()
Visual Basic
Public Sub New

See Also

XGateAppearance Class
XGateAppearance Members


XGateAppearance Properties

[image] [image]

Pick To Light 设备通讯类库
XGateAppearance Properties
XGateAppearance Class See Also Send Feedback

The XGateAppearance type exposes the following members.

Properties

 | Name | Description
Public property | InputPortStatuses | 获取所有输入口状态的集合.
Public property | Light | 获取或设置亮灯模式。
Public property | OutputPortStatuses | 获取所有输出口状态的集合.

See Also

XGateAppearance Class


XGateAppearance.InputPortStatuses Property

[image]

Pick To Light 设备通讯类库
XGateAppearance..::..InputPortStatuses Property
XGateAppearance Class See Also Send Feedback
获取所有输入口状态的集合.

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Collection<Nullable<bool>> InputPortStatuses { get; }
Visual Basic
Public ReadOnly Property InputPortStatuses As Collection(Of Nullable(Of Boolean))
    Get

Property Value

Type: Collection <(Of <(<' Nullable <(Of <(<' Boolean >)>)>>)>)>

See Also

XGateAppearance Class
XGateAppearance Members


XGateAppearance.Light Property

[image]

Pick To Light 设备通讯类库
XGateAppearance..::..Light Property
XGateAppearance Class See Also Send Feedback
获取或设置亮灯模式。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public LightMode Light { get; set; }
Visual Basic
Public Property Light As LightMode
    Get
    Set

Property Value

Type: LightMode
为空时会被 LightMode.Default 取代。

See Also

XGateAppearance Class
XGateAppearance Members


XGateAppearance.OutputPortStatuses Property

[image]

Pick To Light 设备通讯类库
XGateAppearance..::..OutputPortStatuses Property
XGateAppearance Class See Also Send Feedback
获取所有输出口状态的集合.

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Collection<OutputPortStatus> OutputPortStatuses { get; }
Visual Basic
Public ReadOnly Property OutputPortStatuses As Collection(Of OutputPortStatus)
    Get

Property Value

Type: Collection <(Of <(<' OutputPortStatus >)>)>

See Also

XGateAppearance Class
XGateAppearance Members


XGateCollection Class

[image]

Pick To Light 设备通讯类库
XGateCollection Class
Members See Also Send Feedback
XGate 集合。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class XGateCollection : IEnumerable<XGate>,
    IEnumerable, IXmlSerializable
Visual Basic
<SerializableAttribute>
Public Class XGateCollection
    Implements IEnumerable(Of XGate), IEnumerable,
    IXmlSerializable

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..XGateCollection

See Also

XGateCollection Members


XGateCollection Members

[image] [image]

Pick To Light 设备通讯类库
XGateCollection Members
XGateCollection Class Constructors Methods Properties See Also Send Feedback

The XGateCollection type exposes the following members.

Constructors

 | Name | Description
Public method | XGateCollection | Initializes a new instance of the XGateCollection class

Methods

 | Name | Description
Public method | AddOrUpdate | 添加或按 IP 终结点更新 XGate。
Public method | GetEnumerator | 获取迭代器。
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | Remove(IPAddress) | 按 IP 地址和默认端口 502 删除 XGate。
Public method | Remove(IPEndPoint) | 按 IP 终结点删除 XGate。
Public method | Remove(String) | 按 IP 地址和默认端口 502 删除 XGate。
Public method | Remove(XGate) | 删除 XGate。
Public method | WriteXml | 将对象转换为其 XML 表示形式。

Properties

 | Name | Description
Public property | Count | 获取 XGate 数量。
Public property | Item[([( IPAddress])]) | 按 IP 地址和默认端口 502 获取 XGate 。
Public property | Item[([( IPEndPoint])]) | 按 IP 终结点获取 XGate 。
Public property | Item[([( String])]) | 按 IP 地址和默认端口 502 获取 XGate 。

See Also

XGateCollection Class


XGateCollection Constructor

[image]

Pick To Light 设备通讯类库
XGateCollection Constructor
XGateCollection Class See Also Send Feedback
Initializes a new instance of the XGateCollection class

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGateCollection()
Visual Basic
Public Sub New

See Also

XGateCollection Class
XGateCollection Members


XGateCollection Methods

[image] [image]

Pick To Light 设备通讯类库
XGateCollection Methods
XGateCollection Class See Also Send Feedback

The XGateCollection type exposes the following members.

Methods

 | Name | Description
Public method | AddOrUpdate | 添加或按 IP 终结点更新 XGate。
Public method | GetEnumerator | 获取迭代器。
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | Remove(IPAddress) | 按 IP 地址和默认端口 502 删除 XGate。
Public method | Remove(IPEndPoint) | 按 IP 终结点删除 XGate。
Public method | Remove(String) | 按 IP 地址和默认端口 502 删除 XGate。
Public method | Remove(XGate) | 删除 XGate。
Public method | WriteXml | 将对象转换为其 XML 表示形式。

See Also

XGateCollection Class


XGateCollection.AddOrUpdate Method

[image]

Pick To Light 设备通讯类库
XGateCollection..::..AddOrUpdate Method
XGateCollection Class See Also Send Feedback
添加或按 IP 终结点更新 XGate。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void AddOrUpdate(
    XGate xgate
)
Visual Basic
Public Sub AddOrUpdate (
    xgate As XGate
)

Parameters

xgate
Type: Ptl.Device..::..XGate
待加入的 XGate。

Exceptions

Exception | Condition
System..::..ArgumentNullException | xgate 为空。

See Also

XGateCollection Class
XGateCollection Members


XGateCollection.GetEnumerator Method

[image]

Pick To Light 设备通讯类库
XGateCollection..::..GetEnumerator Method
XGateCollection Class See Also Send Feedback
获取迭代器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public IEnumerator<XGate> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of XGate)

Return Value

Type: IEnumerator <(Of <(<' XGate >)>)>
可用于按接插口正序循环访问集合的 System.Collections.Generic.IEnumerator<XGate>。

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

XGateCollection Class
XGateCollection Members


XGateCollection.GetSchema Method

[image]

Pick To Light 设备通讯类库
XGateCollection..::..GetSchema Method
XGateCollection Class See Also Send Feedback
此方法是保留方法，请不要使用。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XmlSchema GetSchema()
Visual Basic
Public Function GetSchema As XmlSchema

Return Value

Type: XmlSchema
始终返回空。

Implements

IXmlSerializable..::..GetSchema()()()()

See Also

XGateCollection Class
XGateCollection Members


XGateCollection.ReadXml Method

[image]

Pick To Light 设备通讯类库
XGateCollection..::..ReadXml Method
XGateCollection Class See Also Send Feedback
从对象的 XML 表示形式生成该对象。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void ReadXml(
    XmlReader reader
)
Visual Basic
Public Sub ReadXml (
    reader As XmlReader
)

Parameters

reader
Type: System.Xml..::..XmlReader
对象从中进行反序列化的 System.Xml.XmlReader 流。

Implements

IXmlSerializable..::..ReadXml(XmlReader)

Exceptions

Exception | Condition
System..::..ArgumentNullException | reader 为空。

See Also

XGateCollection Class
XGateCollection Members


XGateCollection.Remove Method

[image] [image]

Pick To Light 设备通讯类库
XGateCollection..::..Remove Method
XGateCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(IPAddress) | 按 IP 地址和默认端口 502 删除 XGate。
Public method | Remove(IPEndPoint) | 按 IP 终结点删除 XGate。
Public method | Remove(String) | 按 IP 地址和默认端口 502 删除 XGate。
Public method | Remove(XGate) | 删除 XGate。

See Also

XGateCollection Class
XGateCollection Members


XGateCollection.Remove Method (IPAddress)

[image]

Pick To Light 设备通讯类库
XGateCollection..::..Remove Method (IPAddress)
XGateCollection Class See Also Send Feedback
按 IP 地址和默认端口 502 删除 XGate。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool Remove(
    IPAddress ip
)
Visual Basic
Public Function Remove (
    ip As IPAddress
) As Boolean

Parameters

ip
Type: System.Net..::..IPAddress
待删除 XGate 的 IP 地址。

Return Value

Type: Boolean
是否成功删除。

Exceptions

Exception | Condition
System..::..ArgumentNullException | ip 为空。

See Also

XGateCollection Class
XGateCollection Members
Remove Overload


XGateCollection.Remove Method (IPEndPoint)

[image]

Pick To Light 设备通讯类库
XGateCollection..::..Remove Method (IPEndPoint)
XGateCollection Class See Also Send Feedback
按 IP 终结点删除 XGate。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool Remove(
    IPEndPoint ipEndPoint
)
Visual Basic
Public Function Remove (
    ipEndPoint As IPEndPoint
) As Boolean

Parameters

ipEndPoint
Type: System.Net..::..IPEndPoint
待删除 XGate 的 IP 终结点。

Return Value

Type: Boolean
是否成功删除。

Exceptions

Exception | Condition
System..::..ArgumentNullException | ipEndPoint 为空。

See Also

XGateCollection Class
XGateCollection Members
Remove Overload


XGateCollection.Remove Method (String)

[image]

Pick To Light 设备通讯类库
XGateCollection..::..Remove Method (String)
XGateCollection Class See Also Send Feedback
按 IP 地址和默认端口 502 删除 XGate。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool Remove(
    string ip
)
Visual Basic
Public Function Remove (
    ip As String
) As Boolean

Parameters

ip
Type: System..::..String
待删除 XGate 的 IP 地址。

Return Value

Type: Boolean
是否成功删除。

Exceptions

Exception | Condition
System..::..ArgumentNullException | ip 为空。

See Also

XGateCollection Class
XGateCollection Members
Remove Overload


XGateCollection.Remove Method (XGate)

[image]

Pick To Light 设备通讯类库
XGateCollection..::..Remove Method (XGate)
XGateCollection Class See Also Send Feedback
删除 XGate。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool Remove(
    XGate xgate
)
Visual Basic
Public Function Remove (
    xgate As XGate
) As Boolean

Parameters

xgate
Type: Ptl.Device..::..XGate
待删除的 XGate。

Return Value

Type: Boolean
是否成功删除。

Exceptions

Exception | Condition
System..::..ArgumentNullException | xgate 为空。

See Also

XGateCollection Class
XGateCollection Members
Remove Overload


XGateCollection.WriteXml Method

[image]

Pick To Light 设备通讯类库
XGateCollection..::..WriteXml Method
XGateCollection Class See Also Send Feedback
将对象转换为其 XML 表示形式。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void WriteXml(
    XmlWriter writer
)
Visual Basic
Public Sub WriteXml (
    writer As XmlWriter
)

Parameters

writer
Type: System.Xml..::..XmlWriter
对象要序列化为的 System.Xml.XmlWriter 流。

Implements

IXmlSerializable..::..WriteXml(XmlWriter)

Exceptions

Exception | Condition
System..::..ArgumentNullException | writer 为空。

See Also

XGateCollection Class
XGateCollection Members


XGateCollection Properties

[image] [image]

Pick To Light 设备通讯类库
XGateCollection Properties
XGateCollection Class See Also Send Feedback

The XGateCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | 获取 XGate 数量。
Public property | Item[([( IPAddress])]) | 按 IP 地址和默认端口 502 获取 XGate 。
Public property | Item[([( IPEndPoint])]) | 按 IP 终结点获取 XGate 。
Public property | Item[([( String])]) | 按 IP 地址和默认端口 502 获取 XGate 。

See Also

XGateCollection Class


XGateCollection.Count Property

[image]

Pick To Light 设备通讯类库
XGateCollection..::..Count Property
XGateCollection Class See Also Send Feedback
获取 XGate 数量。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

See Also

XGateCollection Class
XGateCollection Members


XGateCollection.Item Property

[image] [image]

Pick To Light 设备通讯类库
XGateCollection..::..Item Property
XGateCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( IPAddress])]) | 按 IP 地址和默认端口 502 获取 XGate 。
Public property | Item[([( IPEndPoint])]) | 按 IP 终结点获取 XGate 。
Public property | Item[([( String])]) | 按 IP 地址和默认端口 502 获取 XGate 。

See Also

XGateCollection Class
XGateCollection Members


XGateCollection.Item Property (IPAddress)

[image]

Pick To Light 设备通讯类库
XGateCollection..::..Item Property (IPAddress)
XGateCollection Class See Also Send Feedback
按 IP 地址和默认端口 502 获取 XGate 。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGate this[
    IPAddress ip
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    ip As IPAddress
) As XGate
    Get

Parameters

ip
Type: System.Net..::..IPAddress
IP 地址。

Property Value

Type: XGate

Exceptions

Exception | Condition
System..::..ArgumentNullException | ip 为空。

See Also

XGateCollection Class
XGateCollection Members
Item Overload


XGateCollection.Item Property (IPEndPoint)

[image]

Pick To Light 设备通讯类库
XGateCollection..::..Item Property (IPEndPoint)
XGateCollection Class See Also Send Feedback
按 IP 终结点获取 XGate 。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGate this[
    IPEndPoint ipEndPoint
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    ipEndPoint As IPEndPoint
) As XGate
    Get

Parameters

ipEndPoint
Type: System.Net..::..IPEndPoint
IP 终结点。

Property Value

Type: XGate

Exceptions

Exception | Condition
System..::..ArgumentNullException | ipEndPoint 为空。

See Also

XGateCollection Class
XGateCollection Members
Item Overload


XGateCollection.Item Property (String)

[image]

Pick To Light 设备通讯类库
XGateCollection..::..Item Property (String)
XGateCollection Class See Also Send Feedback
按 IP 地址和默认端口 502 获取 XGate 。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGate this[
    string ip
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    ip As String
) As XGate
    Get

Parameters

ip
Type: System..::..String
IP 地址。

Property Value

Type: XGate

Exceptions

Exception | Condition
System..::..ArgumentNullException | ip 为空。

See Also

XGateCollection Class
XGateCollection Members
Item Overload


XRelay Class

[image]

Pick To Light 设备通讯类库
XRelay Class
Members See Also Send Feedback
TCP-RS232/485 透传中继器，连接单条 RS485 总线。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class XRelay : IXmlSerializable, IDisposable
Visual Basic
<SerializableAttribute>
Public Class XRelay
    Implements IXmlSerializable, IDisposable

Inheritance Hierarchy

System..::..Object
Ptl.Device..::..XRelay

See Also

XRelay Members


XRelay Members

[image] [image]

Pick To Light 设备通讯类库
XRelay Members
XRelay Class Constructors Methods Properties See Also Send Feedback

The XRelay type exposes the following members.

Constructors

 | Name | Description
Public method | XRelay(IPEndPoint) | 使用指定的通讯参数初始化中继器。
Public method | XRelay(IPAddress, Int32) | 使用指定的通讯参数初始化中继器。
Public method | XRelay(String, Int32) | 使用指定的通讯参数初始化中继器。
Public method | XRelay(IPEndPoint, Int32, Int32, Int32, Int32) | 使用指定的通讯参数初始化中继器。

Methods

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。
Protected method | Finalize | 释放非托管资源。 (Overrides Object..::..Finalize()()()().)
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | StartUnicastCommandQueue | 开始执行总线上的所有设备的协议队列。
Public method | StopUnicastCommandQueue()()()() | 停止执行总线上的所有设备的协议队列，但不等待执行线程退出。
Public method | StopUnicastCommandQueue(Boolean) | 停止执行总线上的所有设备的协议队列。
Public method | ToString | 返回对象的字符串表示。 (Overrides Object..::..ToString()()()().)
Public method | WriteXml | 将对象转换为其 XML 表示形式。

Properties

 | Name | Description
Public property | BroadcastCommunicationClient | 获取广播协议执行客户端。
Public property | Broadcaster | 获取广播协议执行者。
Public property | Bus | 获取 RS485 总线。
Public property | IPEndPoint | 获取或设置中继器的 IP 终结点。

See Also

XRelay Class


XRelay Constructor

[image] [image]

Pick To Light 设备通讯类库
XRelay Constructor
XRelay Class See Also Send Feedback

Overload List

 | Name | Description
Public method | XRelay(IPEndPoint) | 使用指定的通讯参数初始化中继器。
Public method | XRelay(IPAddress, Int32) | 使用指定的通讯参数初始化中继器。
Public method | XRelay(String, Int32) | 使用指定的通讯参数初始化中继器。
Public method | XRelay(IPEndPoint, Int32, Int32, Int32, Int32) | 使用指定的通讯参数初始化中继器。

See Also

XRelay Class
XRelay Members


XRelay Constructor (IPEndPoint)

[image]

Pick To Light 设备通讯类库
XRelay Constructor (IPEndPoint)
XRelay Class See Also Send Feedback
使用指定的通讯参数初始化中继器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XRelay(
    IPEndPoint ipEndPoint
)
Visual Basic
Public Sub New (
    ipEndPoint As IPEndPoint
)

Parameters

ipEndPoint
Type: System.Net..::..IPEndPoint
IP 终结点。

See Also

XRelay Class
XRelay Members
XRelay Overload


XRelay Constructor (IPAddress, Int32)

[image]

Pick To Light 设备通讯类库
XRelay Constructor (IPAddress, Int32)
XRelay Class See Also Send Feedback
使用指定的通讯参数初始化中继器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XRelay(
    IPAddress iPAddress,
    int port
)
Visual Basic
Public Sub New (
    iPAddress As IPAddress,
    port As Integer
)

Parameters

iPAddress
Type: System.Net..::..IPAddress
IP 地址。
port
Type: System..::..Int32
TCP 端口。

See Also

XRelay Class
XRelay Members
XRelay Overload


XRelay Constructor (String, Int32)

[image]

Pick To Light 设备通讯类库
XRelay Constructor (String, Int32)
XRelay Class See Also Send Feedback
使用指定的通讯参数初始化中继器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XRelay(
    string ip,
    int port
)
Visual Basic
Public Sub New (
    ip As String,
    port As Integer
)

Parameters

ip
Type: System..::..String
IP 地址。
port
Type: System..::..Int32
TCP 端口。

See Also

XRelay Class
XRelay Members
XRelay Overload


XRelay Constructor (IPEndPoint, Int32, Int32, Int32, Int32)

[image]

Pick To Light 设备通讯类库
XRelay Constructor (IPEndPoint, Int32, Int32, Int32, Int32)
XRelay Class See Also Send Feedback
使用指定的通讯参数初始化中继器。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XRelay(
    IPEndPoint ipEndPoint,
    int connectTimeoutInMilliseconds,
    int sendTimeoutInMilliseconds,
    int receiveTimeoutInMilliseconds,
    int interframeDelayInMilliseconds
)
Visual Basic
Public Sub New (
    ipEndPoint As IPEndPoint,
    connectTimeoutInMilliseconds As Integer,
    sendTimeoutInMilliseconds As Integer,
    receiveTimeoutInMilliseconds As Integer,
    interframeDelayInMilliseconds As Integer
)

Parameters

ipEndPoint
Type: System.Net..::..IPEndPoint
IP 终结点。
connectTimeoutInMilliseconds
Type: System..::..Int32
连接超时时间。
sendTimeoutInMilliseconds
Type: System..::..Int32
发送超时时间。
receiveTimeoutInMilliseconds
Type: System..::..Int32
接收超时时间。
interframeDelayInMilliseconds
Type: System..::..Int32
帧间延时，用于无返回值的命令之后。

Exceptions

Exception | Condition
System..::..ArgumentNullException | ipEndPoint 为空。

See Also

XRelay Class
XRelay Members
XRelay Overload


XRelay Methods

[image] [image]

Pick To Light 设备通讯类库
XRelay Methods
XRelay Class See Also Send Feedback

The XRelay type exposes the following members.

Methods

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。
Protected method | Finalize | 释放非托管资源。 (Overrides Object..::..Finalize()()()().)
Public method | GetSchema | 此方法是保留方法，请不要使用。
Public method | ReadXml | 从对象的 XML 表示形式生成该对象。
Public method | StartUnicastCommandQueue | 开始执行总线上的所有设备的协议队列。
Public method | StopUnicastCommandQueue()()()() | 停止执行总线上的所有设备的协议队列，但不等待执行线程退出。
Public method | StopUnicastCommandQueue(Boolean) | 停止执行总线上的所有设备的协议队列。
Public method | ToString | 返回对象的字符串表示。 (Overrides Object..::..ToString()()()().)
Public method | WriteXml | 将对象转换为其 XML 表示形式。

See Also

XRelay Class


XRelay.Dispose Method

[image] [image]

Pick To Light 设备通讯类库
XRelay..::..Dispose Method
XRelay Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。

See Also

XRelay Class
XRelay Members


XRelay.Dispose Method

[image]

Pick To Light 设备通讯类库
XRelay..::..Dispose Method
XRelay Class See Also Send Feedback
释放托管和非托管资源。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

XRelay Class
XRelay Members
Dispose Overload


XRelay.Dispose Method (Boolean)

[image]

Pick To Light 设备通讯类库
XRelay..::..Dispose Method (Boolean)
XRelay Class See Also Send Feedback
释放非托管资源并可选地释放托管资源。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: System..::..Boolean
是否释放托管资源。

See Also

XRelay Class
XRelay Members
Dispose Overload


XRelay.Finalize Method

[image]

Pick To Light 设备通讯类库
XRelay..::..Finalize Method
XRelay Class See Also Send Feedback
释放非托管资源。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize

See Also

XRelay Class
XRelay Members


XRelay.GetSchema Method

[image]

Pick To Light 设备通讯类库
XRelay..::..GetSchema Method
XRelay Class See Also Send Feedback
此方法是保留方法，请不要使用。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XmlSchema GetSchema()
Visual Basic
Public Function GetSchema As XmlSchema

Return Value

Type: XmlSchema
始终返回空。

Implements

IXmlSerializable..::..GetSchema()()()()

See Also

XRelay Class
XRelay Members


XRelay.ReadXml Method

[image]

Pick To Light 设备通讯类库
XRelay..::..ReadXml Method
XRelay Class See Also Send Feedback
从对象的 XML 表示形式生成该对象。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void ReadXml(
    XmlReader reader
)
Visual Basic
Public Sub ReadXml (
    reader As XmlReader
)

Parameters

reader
Type: System.Xml..::..XmlReader
对象从中进行反序列化的 System.Xml.XmlReader 流。

Implements

IXmlSerializable..::..ReadXml(XmlReader)

Exceptions

Exception | Condition
System..::..ArgumentNullException | reader 为空。

See Also

XRelay Class
XRelay Members


XRelay.StartUnicastCommandQueue Method

[image]

Pick To Light 设备通讯类库
XRelay..::..StartUnicastCommandQueue Method
XRelay Class See Also Send Feedback
开始执行总线上的所有设备的协议队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void StartUnicastCommandQueue()
Visual Basic
Public Sub StartUnicastCommandQueue

See Also

XRelay Class
XRelay Members


XRelay.StopUnicastCommandQueue Method

[image] [image]

Pick To Light 设备通讯类库
XRelay..::..StopUnicastCommandQueue Method
XRelay Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StopUnicastCommandQueue()()()() | 停止执行总线上的所有设备的协议队列，但不等待执行线程退出。
Public method | StopUnicastCommandQueue(Boolean) | 停止执行总线上的所有设备的协议队列。

See Also

XRelay Class
XRelay Members


XRelay.StopUnicastCommandQueue Method

[image]

Pick To Light 设备通讯类库
XRelay..::..StopUnicastCommandQueue Method
XRelay Class See Also Send Feedback
停止执行总线上的所有设备的协议队列，但不等待执行线程退出。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void StopUnicastCommandQueue()
Visual Basic
Public Sub StopUnicastCommandQueue

See Also

XRelay Class
XRelay Members
StopUnicastCommandQueue Overload


XRelay.StopUnicastCommandQueue Method (Boolean)

[image]

Pick To Light 设备通讯类库
XRelay..::..StopUnicastCommandQueue Method (Boolean)
XRelay Class See Also Send Feedback
停止执行总线上的所有设备的协议队列。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void StopUnicastCommandQueue(
    bool waitExecuteThreadQuit
)
Visual Basic
Public Sub StopUnicastCommandQueue (
    waitExecuteThreadQuit As Boolean
)

Parameters

waitExecuteThreadQuit
Type: System..::..Boolean
是否等待执行线程退出。

See Also

XRelay Class
XRelay Members
StopUnicastCommandQueue Overload


XRelay.ToString Method

[image]

Pick To Light 设备通讯类库
XRelay..::..ToString Method
XRelay Class See Also Send Feedback
返回对象的字符串表示。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
IP 终结点。

See Also

XRelay Class
XRelay Members


XRelay.WriteXml Method

[image]

Pick To Light 设备通讯类库
XRelay..::..WriteXml Method
XRelay Class See Also Send Feedback
将对象转换为其 XML 表示形式。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void WriteXml(
    XmlWriter writer
)
Visual Basic
Public Sub WriteXml (
    writer As XmlWriter
)

Parameters

writer
Type: System.Xml..::..XmlWriter
对象要序列化为的 System.Xml.XmlWriter 流。

Implements

IXmlSerializable..::..WriteXml(XmlWriter)

Exceptions

Exception | Condition
System..::..ArgumentNullException | writer 为空。

See Also

XRelay Class
XRelay Members


XRelay Properties

[image] [image]

Pick To Light 设备通讯类库
XRelay Properties
XRelay Class See Also Send Feedback

The XRelay type exposes the following members.

Properties

 | Name | Description
Public property | BroadcastCommunicationClient | 获取广播协议执行客户端。
Public property | Broadcaster | 获取广播协议执行者。
Public property | Bus | 获取 RS485 总线。
Public property | IPEndPoint | 获取或设置中继器的 IP 终结点。

See Also

XRelay Class


XRelay.BroadcastCommunicationClient Property

[image]

Pick To Light 设备通讯类库
XRelay..::..BroadcastCommunicationClient Property
XRelay Class See Also Send Feedback
获取广播协议执行客户端。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public TcpTransparentClient BroadcastCommunicationClient { get; }
Visual Basic
Public ReadOnly Property BroadcastCommunicationClient As TcpTransparentClient
    Get

Property Value

Type: TcpTransparentClient

See Also

XRelay Class
XRelay Members


XRelay.Broadcaster Property

[image]

Pick To Light 设备通讯类库
XRelay..::..Broadcaster Property
XRelay Class See Also Send Feedback
获取广播协议执行者。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Broadcaster Broadcaster { get; }
Visual Basic
Public ReadOnly Property Broadcaster As Broadcaster
    Get

Property Value

Type: Broadcaster

See Also

XRelay Class
XRelay Members


XRelay.Bus Property

[image]

Pick To Light 设备通讯类库
XRelay..::..Bus Property
XRelay Class See Also Send Feedback
获取 RS485 总线。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public RS485Bus Bus { get; }
Visual Basic
Public ReadOnly Property Bus As RS485Bus
    Get

Property Value

Type: RS485Bus

See Also

XRelay Class
XRelay Members


XRelay.IPEndPoint Property

[image]

Pick To Light 设备通讯类库
XRelay..::..IPEndPoint Property
XRelay Class See Also Send Feedback
获取或设置中继器的 IP 终结点。

Namespace: Ptl.Device
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public IPEndPoint IPEndPoint { get; set; }
Visual Basic
Public Property IPEndPoint As IPEndPoint
    Get
    Set

Property Value

Type: IPEndPoint

See Also

XRelay Class
XRelay Members


Ptl.Device.Communication Namespace

[image]

Pick To Light 设备通讯类库
Ptl.Device.Communication Namespace
Send Feedback
ModbusClient、SerialPortClient 以及 TcpTransparentClient 实现与设备的通讯。

Classes

 | Class | Description
Public class | Broadcaster | 广播协议执行者。
Public class | CommunicationClientBase | 通讯客户端基类。
Public class | CommunicationClientConnectException | 通讯客户端连接异常，用于显式区分出通讯通道成功建立前的异常。
Public class | ConnectionErrorEventArgs | 为 ICommunicationClient.ConnectionError 事件提供事件参数。
Public class | Crc | 提供 Crc 的计算功能。
Public class | DefaultRS485AddressMapperImplements | 预设的 RS485 地址映射方法实现。
Public class | HeartbeatGenerator | 设备心跳发生器，为指定的所有 PTL 设备定时生成心跳命令。
Public class | ModbusClient | Modbus Tcp 通讯客户端。
Public class | ModbusTcpTransactionIdGenerator | Modbus Tcp 事务编号生成器。
Public class | ProtocolInterceptorAdditionalDataEventArgs | 为 InterceptorPrefixReceived 和 InterceptorSuffixReceived 事件提供事件参数。
Public class | ProtocolInterceptorPreparedWrapDatas | 协议拦截器为请求准备的包装数据。
Public class | SerialPortClient | 串口通讯客户端。
Public class | TcpTransparentClient | TCP-RS232/485 透传通讯客户端。

Interfaces

 | Interface | Description
Public interface | ICommunicationClient | 表示可执行协议的通讯客户端。
Public interface | IProtocolInterceptor | 为协议提供拦截功能。

Delegates

 | Delegate | Description
Public delegate | MapRS485Address | 提供 RS485 地址的映射功能。

Enumerations

 | Enumeration | Description
Public enumeration | DefaultRS485AddressMapper | 预设的 RS485 地址映射方法枚举。


Broadcaster Class

[image]

Pick To Light 设备通讯类库
Broadcaster Class
Members See Also Send Feedback
广播协议执行者。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public class Broadcaster
Visual Basic
Public Class Broadcaster

Remarks

广播会影响通道下的所有设备，推荐只在设备安装时使用。

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication..::..Broadcaster

See Also

Broadcaster Members
Ptl.Device.Communication Namespace


Broadcaster Members

[image] [image]

Pick To Light 设备通讯类库
Broadcaster Members
Broadcaster Class Constructors Methods See Also Send Feedback

The Broadcaster type exposes the following members.

Constructors

 | Name | Description
Public method | Broadcaster | 初始化广播协议执行者。

Methods

 | Name | Description
Public method | ClearAll | 清空所有显示。
Public method | CollectSuggestAddress | 采集建议地址判断是否已确认。
Public method | DisplayAll | 显示所有内容。
Public method | SetAddressZero | 地址清零。
Public method | SetF1OkColorAfterPress | 设置 OK 按钮按下后的按钮灯色。
Public method | SetF2ProgressBarTimeSpan | 设置多任务间的进度条时间。
Public method | SetF3FnLongPressResult | 设置长按 Fn 键的结果。
Public method | SetF4Display900UCommandType | 设置 900U 显示协议的类型。
Public method | SetF5OkColorAfterPress | 设置无任务时 OK 按钮按下后的按钮灯色。
Public method | SetF6TouchSensitivity | 设置触摸灵敏度。
Public method | SetF7InfraredDistanceSensitivity | 设置红外距离灵敏度。
Public method | SetF8OkUsability | 设置 OK 按钮可用性。
Public method | SetF9InfraredTimeSensitivities | 设置红外时间灵敏度。
Public method | SetXIOPortAddress | 设置 PtlXIOPort 的地址。
Public method | SuggestAddress | 建议地址。

See Also

Broadcaster Class
Ptl.Device.Communication Namespace


Broadcaster Constructor

[image]

Pick To Light 设备通讯类库
Broadcaster Constructor
Broadcaster Class See Also Send Feedback
初始化广播协议执行者。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Broadcaster(
    ICommunicationClient client
)
Visual Basic
Public Sub New (
    client As ICommunicationClient
)

Parameters

client
Type: Ptl.Device.Communication..::..ICommunicationClient
通讯客户端。

Exceptions

Exception | Condition
System..::..ArgumentNullException | client 为空。

See Also

Broadcaster Class
Broadcaster Members
Ptl.Device.Communication Namespace


Broadcaster Methods

[image] [image]

Pick To Light 设备通讯类库
Broadcaster Methods
Broadcaster Class See Also Send Feedback

The Broadcaster type exposes the following members.

Methods

 | Name | Description
Public method | ClearAll | 清空所有显示。
Public method | CollectSuggestAddress | 采集建议地址判断是否已确认。
Public method | DisplayAll | 显示所有内容。
Public method | SetAddressZero | 地址清零。
Public method | SetF1OkColorAfterPress | 设置 OK 按钮按下后的按钮灯色。
Public method | SetF2ProgressBarTimeSpan | 设置多任务间的进度条时间。
Public method | SetF3FnLongPressResult | 设置长按 Fn 键的结果。
Public method | SetF4Display900UCommandType | 设置 900U 显示协议的类型。
Public method | SetF5OkColorAfterPress | 设置无任务时 OK 按钮按下后的按钮灯色。
Public method | SetF6TouchSensitivity | 设置触摸灵敏度。
Public method | SetF7InfraredDistanceSensitivity | 设置红外距离灵敏度。
Public method | SetF8OkUsability | 设置 OK 按钮可用性。
Public method | SetF9InfraredTimeSensitivities | 设置红外时间灵敏度。
Public method | SetXIOPortAddress | 设置 PtlXIOPort 的地址。
Public method | SuggestAddress | 建议地址。

See Also

Broadcaster Class
Ptl.Device.Communication Namespace


Broadcaster.ClearAll Method

[image]

Pick To Light 设备通讯类库
Broadcaster..::..ClearAll Method
Broadcaster Class See Also Send Feedback
清空所有显示。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void ClearAll()
Visual Basic
Public Sub ClearAll

See Also

Broadcaster Class
Broadcaster Members
Ptl.Device.Communication Namespace


Broadcaster.CollectSuggestAddress Method

[image]

Pick To Light 设备通讯类库
Broadcaster..::..CollectSuggestAddress Method
Broadcaster Class See Also Send Feedback
采集建议地址判断是否已确认。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool CollectSuggestAddress(
    byte mappedAddress
)
Visual Basic
Public Function CollectSuggestAddress (
    mappedAddress As Byte
) As Boolean

Parameters

mappedAddress
Type: System..::..Byte
建议的地址。

Return Value

Type: Boolean
是否有设备采用了建议的地址。

Remarks

这是一个单播协议，但使用广播通讯客户端，所以参数传入映射后的地址。

See Also

Broadcaster Class
Broadcaster Members
Ptl.Device.Communication Namespace


Broadcaster.DisplayAll Method

[image]

Pick To Light 设备通讯类库
Broadcaster..::..DisplayAll Method
Broadcaster Class See Also Send Feedback
显示所有内容。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void DisplayAll(
    DisplayAllTextType textType
)
Visual Basic
Public Sub DisplayAll (
    textType As DisplayAllTextType
)

Parameters

textType
Type: Ptl.Device.Communication.Command..::..DisplayAllTextType
文本内容的类型。

See Also

Broadcaster Class
Broadcaster Members
Ptl.Device.Communication Namespace


Broadcaster.SetAddressZero Method

[image]

Pick To Light 设备通讯类库
Broadcaster..::..SetAddressZero Method
Broadcaster Class See Also Send Feedback
地址清零。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void SetAddressZero()
Visual Basic
Public Sub SetAddressZero

See Also

Broadcaster Class
Broadcaster Members
Ptl.Device.Communication Namespace


Broadcaster.SetF1OkColorAfterPress Method

[image]

Pick To Light 设备通讯类库
Broadcaster..::..SetF1OkColorAfterPress Method
Broadcaster Class See Also Send Feedback
设置 OK 按钮按下后的按钮灯色。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void SetF1OkColorAfterPress(
    F1OkColorAfterPress color
)
Visual Basic
Public Sub SetF1OkColorAfterPress (
    color As F1OkColorAfterPress
)

Parameters

color
Type: Ptl.Device.Communication.Command..::..F1OkColorAfterPress
OK 按钮按下后的按钮灯色。

See Also

Broadcaster Class
Broadcaster Members
Ptl.Device.Communication Namespace


Broadcaster.SetF2ProgressBarTimeSpan Method

[image]

Pick To Light 设备通讯类库
Broadcaster..::..SetF2ProgressBarTimeSpan Method
Broadcaster Class See Also Send Feedback
设置多任务间的进度条时间。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void SetF2ProgressBarTimeSpan(
    int timeSpanInMilliseconds
)
Visual Basic
Public Sub SetF2ProgressBarTimeSpan (
    timeSpanInMilliseconds As Integer
)

Parameters

timeSpanInMilliseconds
Type: System..::..Int32
多任务间的进度条时间。

See Also

Broadcaster Class
Broadcaster Members
Ptl.Device.Communication Namespace


Broadcaster.SetF3FnLongPressResult Method

[image]

Pick To Light 设备通讯类库
Broadcaster..::..SetF3FnLongPressResult Method
Broadcaster Class See Also Send Feedback
设置长按 Fn 键的结果。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void SetF3FnLongPressResult(
    F3FnLongPressResult result
)
Visual Basic
Public Sub SetF3FnLongPressResult (
    result As F3FnLongPressResult
)

Parameters

result
Type: Ptl.Device.Communication.Command..::..F3FnLongPressResult
长按 Fn 键的结果。

See Also

Broadcaster Class
Broadcaster Members
Ptl.Device.Communication Namespace


Broadcaster.SetF4Display900UCommandType Method

[image]

Pick To Light 设备通讯类库
Broadcaster..::..SetF4Display900UCommandType Method
Broadcaster Class See Also Send Feedback
设置 900U 显示协议的类型。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void SetF4Display900UCommandType(
    F4Display900UCommandType commandType
)
Visual Basic
Public Sub SetF4Display900UCommandType (
    commandType As F4Display900UCommandType
)

Parameters

commandType
Type: Ptl.Device.Communication.Command..::..F4Display900UCommandType
900U 显示协议的类型。

See Also

Broadcaster Class
Broadcaster Members
Ptl.Device.Communication Namespace


Broadcaster.SetF5OkColorAfterPress Method

[image]

Pick To Light 设备通讯类库
Broadcaster..::..SetF5OkColorAfterPress Method
Broadcaster Class See Also Send Feedback
设置无任务时 OK 按钮按下后的按钮灯色。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void SetF5OkColorAfterPress(
    F5OkColorAfterPress color
)
Visual Basic
Public Sub SetF5OkColorAfterPress (
    color As F5OkColorAfterPress
)

Parameters

color
Type: Ptl.Device.Communication.Command..::..F5OkColorAfterPress
无任务时 OK 按钮按下后的按钮灯色。

See Also

Broadcaster Class
Broadcaster Members
Ptl.Device.Communication Namespace


Broadcaster.SetF6TouchSensitivity Method

[image]

Pick To Light 设备通讯类库
Broadcaster..::..SetF6TouchSensitivity Method
Broadcaster Class See Also Send Feedback
设置触摸灵敏度。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void SetF6TouchSensitivity(
    byte sensitivity
)
Visual Basic
Public Sub SetF6TouchSensitivity (
    sensitivity As Byte
)

Parameters

sensitivity
Type: System..::..Byte
触摸灵敏度。

See Also

Broadcaster Class
Broadcaster Members
Ptl.Device.Communication Namespace


Broadcaster.SetF7InfraredDistanceSensitivity Method

[image]

Pick To Light 设备通讯类库
Broadcaster..::..SetF7InfraredDistanceSensitivity Method
Broadcaster Class See Also Send Feedback
设置红外距离灵敏度。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void SetF7InfraredDistanceSensitivity(
    byte sensitivity
)
Visual Basic
Public Sub SetF7InfraredDistanceSensitivity (
    sensitivity As Byte
)

Parameters

sensitivity
Type: System..::..Byte
距离灵敏度。

See Also

Broadcaster Class
Broadcaster Members
Ptl.Device.Communication Namespace


Broadcaster.SetF8OkUsability Method

[image]

Pick To Light 设备通讯类库
Broadcaster..::..SetF8OkUsability Method
Broadcaster Class See Also Send Feedback
设置 OK 按钮可用性。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void SetF8OkUsability(
    bool isEnabled
)
Visual Basic
Public Sub SetF8OkUsability (
    isEnabled As Boolean
)

Parameters

isEnabled
Type: System..::..Boolean
是否可用。

See Also

Broadcaster Class
Broadcaster Members
Ptl.Device.Communication Namespace


Broadcaster.SetF9InfraredTimeSensitivities Method

[image]

Pick To Light 设备通讯类库
Broadcaster..::..SetF9InfraredTimeSensitivities Method
Broadcaster Class See Also Send Feedback
设置红外时间灵敏度。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void SetF9InfraredTimeSensitivities(
    F9InfraredTimeSensitivities sensitivities
)
Visual Basic
Public Sub SetF9InfraredTimeSensitivities (
    sensitivities As F9InfraredTimeSensitivities
)

Parameters

sensitivities
Type: Ptl.Device.Communication.Command..::..F9InfraredTimeSensitivities
时间灵敏度。

Exceptions

Exception | Condition
System..::..ArgumentNullException | settings 为空。

See Also

Broadcaster Class
Broadcaster Members
Ptl.Device.Communication Namespace


Broadcaster.SetXIOPortAddress Method

[image]

Pick To Light 设备通讯类库
Broadcaster..::..SetXIOPortAddress Method
Broadcaster Class See Also Send Feedback
设置 PtlXIOPort 的地址。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool SetXIOPortAddress(
    byte address
)
Visual Basic
Public Function SetXIOPortAddress (
    address As Byte
) As Boolean

Parameters

address
Type: System..::..Byte
新地址。

Return Value

Type: Boolean
是否收到并成功执行协议。

See Also

Broadcaster Class
Broadcaster Members
Ptl.Device.Communication Namespace


Broadcaster.SuggestAddress Method

[image]

Pick To Light 设备通讯类库
Broadcaster..::..SuggestAddress Method
Broadcaster Class See Also Send Feedback
建议地址。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void SuggestAddress(
    byte address
)
Visual Basic
Public Sub SuggestAddress (
    address As Byte
)

Parameters

address
Type: System..::..Byte
建议的地址。

See Also

Broadcaster Class
Broadcaster Members
Ptl.Device.Communication Namespace


CommunicationClientBase Class

[image]

Pick To Light 设备通讯类库
CommunicationClientBase Class
Members See Also Send Feedback
通讯客户端基类。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public abstract class CommunicationClientBase : ICommunicationClient,
    IDisposable
Visual Basic
Public MustInherit Class CommunicationClientBase
    Implements ICommunicationClient, IDisposable

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication..::..CommunicationClientBase
Ptl.Device.Communication..::..ModbusClient
Ptl.Device.Communication..::..SerialPortClient
Ptl.Device.Communication..::..TcpTransparentClient

See Also

CommunicationClientBase Members
Ptl.Device.Communication Namespace


CommunicationClientBase Members

[image] [image]

Pick To Light 设备通讯类库
CommunicationClientBase Members
CommunicationClientBase Class Constructors Methods Properties Events See Also Send Feedback

The CommunicationClientBase type exposes the following members.

Constructors

 | Name | Description
Protected method | CommunicationClientBase | Initializes a new instance of the CommunicationClientBase class

Methods

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。
Protected method | DoExecute | 执行协议。
Public method | Execute(IBroadcastProtocol) | 执行无返回值的广播协议。
Public method | Execute(IMulticastProtocol) | 执行无返回值的组播协议。
Public method | Execute(Byte, IUnicastProtocol) | 执行无返回值的单播协议。
Public method | Execute<(Of <<'(TResult>)>>)(IBroadcastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的广播协议。
Public method | Execute<(Of <<'(TResult>)>>)(IMulticastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的组播协议。
Public method | Execute<(Of <<'(TResult>)>>)(Byte, IUnicastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的单播协议。
Protected method | OnConnectedChanged | 引发连接状态更改事件。
Protected method | OnConnectionError | 引发通讯连接出错事件。
Protected method | OnInterceptorPrefixReceived | 引发协议前缀收到事件。
Protected method | OnInterceptorSuffixReceived | 引发协议后缀收到事件。

Properties

 | Name | Description
Public property | Connected | 获取是否处于已连接状态。
Public property | Name | 获取客户端名称。
Public property | ProtocolInterceptor | 获取或设置协议拦截器。

Events

 | Name | Description
Public event | ConnectedChanged | 连接状态更改事件。
Public event | ConnectionError | 通讯连接出错事件。
Public event | InterceptorPrefixReceived | 在拦截器收到协议前缀时引发。
Public event | InterceptorSuffixReceived | 在拦截器收到协议后缀时引发。

See Also

CommunicationClientBase Class
Ptl.Device.Communication Namespace


CommunicationClientBase Constructor

[image]

Pick To Light 设备通讯类库
CommunicationClientBase Constructor
CommunicationClientBase Class See Also Send Feedback
Initializes a new instance of the CommunicationClientBase class

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected CommunicationClientBase()
Visual Basic
Protected Sub New

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Ptl.Device.Communication Namespace


CommunicationClientBase Methods

[image] [image]

Pick To Light 设备通讯类库
CommunicationClientBase Methods
CommunicationClientBase Class See Also Send Feedback

The CommunicationClientBase type exposes the following members.

Methods

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。
Protected method | DoExecute | 执行协议。
Public method | Execute(IBroadcastProtocol) | 执行无返回值的广播协议。
Public method | Execute(IMulticastProtocol) | 执行无返回值的组播协议。
Public method | Execute(Byte, IUnicastProtocol) | 执行无返回值的单播协议。
Public method | Execute<(Of <<'(TResult>)>>)(IBroadcastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的广播协议。
Public method | Execute<(Of <<'(TResult>)>>)(IMulticastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的组播协议。
Public method | Execute<(Of <<'(TResult>)>>)(Byte, IUnicastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的单播协议。
Protected method | OnConnectedChanged | 引发连接状态更改事件。
Protected method | OnConnectionError | 引发通讯连接出错事件。
Protected method | OnInterceptorPrefixReceived | 引发协议前缀收到事件。
Protected method | OnInterceptorSuffixReceived | 引发协议后缀收到事件。

See Also

CommunicationClientBase Class
Ptl.Device.Communication Namespace


CommunicationClientBase.Dispose Method

[image] [image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..Dispose Method
CommunicationClientBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Ptl.Device.Communication Namespace


CommunicationClientBase.Dispose Method

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..Dispose Method
CommunicationClientBase Class See Also Send Feedback
释放托管和非托管资源。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Dispose Overload
Ptl.Device.Communication Namespace


CommunicationClientBase.Dispose Method (Boolean)

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..Dispose Method (Boolean)
CommunicationClientBase Class See Also Send Feedback
释放非托管资源并可选地释放托管资源。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: System..::..Boolean
是否释放托管资源。

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Dispose Overload
Ptl.Device.Communication Namespace


CommunicationClientBase.DoExecute Method

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..DoExecute Method
CommunicationClientBase Class See Also Send Feedback
执行协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected abstract byte[] DoExecute(
    byte address,
    IProtocol protocol,
    bool hasResponse
)
Visual Basic
Protected MustOverride Function DoExecute (
    address As Byte,
    protocol As IProtocol,
    hasResponse As Boolean
) As Byte()

Parameters

address
Type: System..::..Byte
设备地址。
protocol
Type: Ptl.Device.Communication.Protocol..::..IProtocol
协议。
hasResponse
Type: System..::..Boolean
设备是否有返回。

Return Value

Type: array< Byte >[]()[][]
设备有返回时的返回值。

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Ptl.Device.Communication Namespace


CommunicationClientBase.Execute Method

[image] [image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..Execute Method
CommunicationClientBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Execute(IBroadcastProtocol) | 执行无返回值的广播协议。
Public method | Execute<(Of <<'(TResult>)>>)(IBroadcastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的广播协议。
Public method | Execute(IMulticastProtocol) | 执行无返回值的组播协议。
Public method | Execute<(Of <<'(TResult>)>>)(IMulticastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的组播协议。
Public method | Execute(Byte, IUnicastProtocol) | 执行无返回值的单播协议。
Public method | Execute<(Of <<'(TResult>)>>)(Byte, IUnicastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的单播协议。

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Ptl.Device.Communication Namespace


CommunicationClientBase.Execute Method (IBroadcastProtocol)

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..Execute Method (IBroadcastProtocol)
CommunicationClientBase Class See Also Send Feedback
执行无返回值的广播协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Execute(
    IBroadcastProtocol protocol
)
Visual Basic
Public Sub Execute (
    protocol As IBroadcastProtocol
)

Parameters

protocol
Type: Ptl.Device.Communication.Protocol.Broadcast..::..IBroadcastProtocol
无返回值的广播协议。

Implements

ICommunicationClient..::..Execute(IBroadcastProtocol)

Exceptions

Exception | Condition
System..::..ArgumentNullException | protocol 为空。

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Execute Overload
Ptl.Device.Communication Namespace


CommunicationClientBase.Execute(TResult) Method (IBroadcastProtocol(TResult))

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..Execute<(Of <(<'TResult>)>)> Method (IBroadcastProtocol<(Of <(<'TResult>)>)>)
CommunicationClientBase Class See Also Send Feedback
执行有返回值的广播协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public TResult Execute<TResult>(
    IBroadcastProtocol<TResult> protocol
)
Visual Basic
Public Function Execute(Of TResult) (
    protocol As IBroadcastProtocol(Of TResult)
) As TResult

Parameters

protocol
Type: Ptl.Device.Communication.Protocol.Broadcast..::..IBroadcastProtocol <(Of <(<'TResult>)>)>
有返回值的广播协议。

Type Parameters

TResult
返回值类型。

Return Value

Type: TResult
协议的执行结果。

Implements

ICommunicationClient..::..Execute<(Of <<'(TResult>)>>)(IBroadcastProtocol<(Of <<'(TResult>)>>))

Exceptions

Exception | Condition
System..::..ArgumentNullException | protocol 为空。

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Execute Overload
Ptl.Device.Communication Namespace


CommunicationClientBase.Execute Method (IMulticastProtocol)

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..Execute Method (IMulticastProtocol)
CommunicationClientBase Class See Also Send Feedback
执行无返回值的组播协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Execute(
    IMulticastProtocol protocol
)
Visual Basic
Public Sub Execute (
    protocol As IMulticastProtocol
)

Parameters

protocol
Type: Ptl.Device.Communication.Protocol.Multicast..::..IMulticastProtocol
无返回值的组播协议。

Implements

ICommunicationClient..::..Execute(IMulticastProtocol)

Exceptions

Exception | Condition
System..::..ArgumentNullException | protocol 为空。

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Execute Overload
Ptl.Device.Communication Namespace


CommunicationClientBase.Execute(TResult) Method (IMulticastProtocol(TResult))

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..Execute<(Of <(<'TResult>)>)> Method (IMulticastProtocol<(Of <(<'TResult>)>)>)
CommunicationClientBase Class See Also Send Feedback
执行有返回值的组播协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public TResult Execute<TResult>(
    IMulticastProtocol<TResult> protocol
)
Visual Basic
Public Function Execute(Of TResult) (
    protocol As IMulticastProtocol(Of TResult)
) As TResult

Parameters

protocol
Type: Ptl.Device.Communication.Protocol.Multicast..::..IMulticastProtocol <(Of <(<'TResult>)>)>
有返回值的组播协议。

Type Parameters

TResult
返回值类型。

Return Value

Type: TResult
协议的执行结果。

Implements

ICommunicationClient..::..Execute<(Of <<'(TResult>)>>)(IMulticastProtocol<(Of <<'(TResult>)>>))

Exceptions

Exception | Condition
System..::..ArgumentNullException | protocol 为空。

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Execute Overload
Ptl.Device.Communication Namespace


CommunicationClientBase.Execute Method (Byte, IUnicastProtocol)

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..Execute Method (Byte, IUnicastProtocol)
CommunicationClientBase Class See Also Send Feedback
执行无返回值的单播协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Execute(
    byte address,
    IUnicastProtocol protocol
)
Visual Basic
Public Sub Execute (
    address As Byte,
    protocol As IUnicastProtocol
)

Parameters

address
Type: System..::..Byte
设备地址。
protocol
Type: Ptl.Device.Communication.Protocol.Unicast..::..IUnicastProtocol
无返回值的单播协议。

Implements

ICommunicationClient..::..Execute(Byte, IUnicastProtocol)

Exceptions

Exception | Condition
System..::..ArgumentNullException | protocol 为空。

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Execute Overload
Ptl.Device.Communication Namespace


CommunicationClientBase.Execute(TResult) Method (Byte, IUnicastProtocol(TResult))

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..Execute<(Of <(<'TResult>)>)> Method (Byte, IUnicastProtocol<(Of <(<'TResult>)>)>)
CommunicationClientBase Class See Also Send Feedback
执行有返回值的单播协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public TResult Execute<TResult>(
    byte address,
    IUnicastProtocol<TResult> protocol
)
Visual Basic
Public Function Execute(Of TResult) (
    address As Byte,
    protocol As IUnicastProtocol(Of TResult)
) As TResult

Parameters

address
Type: System..::..Byte
设备地址。
protocol
Type: Ptl.Device.Communication.Protocol.Unicast..::..IUnicastProtocol <(Of <(<'TResult>)>)>
有返回值的单播协议。

Type Parameters

TResult
返回值类型。

Return Value

Type: TResult
协议的执行结果。

Implements

ICommunicationClient..::..Execute<(Of <<'(TResult>)>>)(Byte, IUnicastProtocol<(Of <<'(TResult>)>>))

Exceptions

Exception | Condition
System..::..ArgumentNullException | protocol 为空。

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Execute Overload
Ptl.Device.Communication Namespace


CommunicationClientBase.OnConnectedChanged Method

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..OnConnectedChanged Method
CommunicationClientBase Class See Also Send Feedback
引发连接状态更改事件。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void OnConnectedChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnConnectedChanged (
    e As EventArgs
)

Parameters

e
Type: System..::..EventArgs
事件参数。

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Ptl.Device.Communication Namespace


CommunicationClientBase.OnConnectionError Method

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..OnConnectionError Method
CommunicationClientBase Class See Also Send Feedback
引发通讯连接出错事件。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void OnConnectionError(
    ConnectionErrorEventArgs e
)
Visual Basic
Protected Overridable Sub OnConnectionError (
    e As ConnectionErrorEventArgs
)

Parameters

e
Type: Ptl.Device.Communication..::..ConnectionErrorEventArgs
事件参数。

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Ptl.Device.Communication Namespace


CommunicationClientBase.OnInterceptorPrefixReceived Method

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..OnInterceptorPrefixReceived Method
CommunicationClientBase Class See Also Send Feedback
引发协议前缀收到事件。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void OnInterceptorPrefixReceived(
    ProtocolInterceptorAdditionalDataEventArgs e
)
Visual Basic
Protected Overridable Sub OnInterceptorPrefixReceived (
    e As ProtocolInterceptorAdditionalDataEventArgs
)

Parameters

e
Type: Ptl.Device.Communication..::..ProtocolInterceptorAdditionalDataEventArgs
事件参数。

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Ptl.Device.Communication Namespace


CommunicationClientBase.OnInterceptorSuffixReceived Method

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..OnInterceptorSuffixReceived Method
CommunicationClientBase Class See Also Send Feedback
引发协议后缀收到事件。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected virtual void OnInterceptorSuffixReceived(
    ProtocolInterceptorAdditionalDataEventArgs e
)
Visual Basic
Protected Overridable Sub OnInterceptorSuffixReceived (
    e As ProtocolInterceptorAdditionalDataEventArgs
)

Parameters

e
Type: Ptl.Device.Communication..::..ProtocolInterceptorAdditionalDataEventArgs
事件参数。

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Ptl.Device.Communication Namespace


CommunicationClientBase Properties

[image] [image]

Pick To Light 设备通讯类库
CommunicationClientBase Properties
CommunicationClientBase Class See Also Send Feedback

The CommunicationClientBase type exposes the following members.

Properties

 | Name | Description
Public property | Connected | 获取是否处于已连接状态。
Public property | Name | 获取客户端名称。
Public property | ProtocolInterceptor | 获取或设置协议拦截器。

See Also

CommunicationClientBase Class
Ptl.Device.Communication Namespace


CommunicationClientBase.Connected Property

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..Connected Property
CommunicationClientBase Class See Also Send Feedback
获取是否处于已连接状态。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Nullable<bool> Connected { get; protected set; }
Visual Basic
Public Property Connected As Nullable(Of Boolean)
    Get
    Protected Set

Property Value

Type: Nullable <(Of <(<' Boolean >)>)>

Implements

ICommunicationClient..::..Connected

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Ptl.Device.Communication Namespace


CommunicationClientBase.Name Property

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..Name Property
CommunicationClientBase Class See Also Send Feedback
获取客户端名称。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public abstract string Name { get; }
Visual Basic
Public MustOverride ReadOnly Property Name As String
    Get

Property Value

Type: String

Implements

ICommunicationClient..::..Name

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Ptl.Device.Communication Namespace


CommunicationClientBase.ProtocolInterceptor Property

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..ProtocolInterceptor Property
CommunicationClientBase Class See Also Send Feedback
获取或设置协议拦截器。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public IProtocolInterceptor ProtocolInterceptor { get; set; }
Visual Basic
Public Property ProtocolInterceptor As IProtocolInterceptor
    Get
    Set

Property Value

Type: IProtocolInterceptor

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Ptl.Device.Communication Namespace


CommunicationClientBase Events

[image] [image]

Pick To Light 设备通讯类库
CommunicationClientBase Events
CommunicationClientBase Class See Also Send Feedback

The CommunicationClientBase type exposes the following members.

Events

 | Name | Description
Public event | ConnectedChanged | 连接状态更改事件。
Public event | ConnectionError | 通讯连接出错事件。
Public event | InterceptorPrefixReceived | 在拦截器收到协议前缀时引发。
Public event | InterceptorSuffixReceived | 在拦截器收到协议后缀时引发。

See Also

CommunicationClientBase Class
Ptl.Device.Communication Namespace


CommunicationClientBase.ConnectedChanged Event

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..ConnectedChanged Event
CommunicationClientBase Class See Also Send Feedback
连接状态更改事件。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public event EventHandler ConnectedChanged
Visual Basic
Public Event ConnectedChanged As EventHandler

Value

Type: System..::..EventHandler

Implements

ICommunicationClient..::..ConnectedChanged

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Ptl.Device.Communication Namespace


CommunicationClientBase.ConnectionError Event

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..ConnectionError Event
CommunicationClientBase Class See Also Send Feedback
通讯连接出错事件。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public event EventHandler<ConnectionErrorEventArgs> ConnectionError
Visual Basic
Public Event ConnectionError As EventHandler(Of ConnectionErrorEventArgs)

Value

Type: System..::..EventHandler <(Of <(<' ConnectionErrorEventArgs >)>)>

Implements

ICommunicationClient..::..ConnectionError

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Ptl.Device.Communication Namespace


CommunicationClientBase.InterceptorPrefixReceived Event

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..InterceptorPrefixReceived Event
CommunicationClientBase Class See Also Send Feedback
在拦截器收到协议前缀时引发。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public event EventHandler<ProtocolInterceptorAdditionalDataEventArgs> InterceptorPrefixReceived
Visual Basic
Public Event InterceptorPrefixReceived As EventHandler(Of ProtocolInterceptorAdditionalDataEventArgs)

Value

Type: System..::..EventHandler <(Of <(<' ProtocolInterceptorAdditionalDataEventArgs >)>)>

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Ptl.Device.Communication Namespace


CommunicationClientBase.InterceptorSuffixReceived Event

[image]

Pick To Light 设备通讯类库
CommunicationClientBase..::..InterceptorSuffixReceived Event
CommunicationClientBase Class See Also Send Feedback
在拦截器收到协议后缀时引发。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public event EventHandler<ProtocolInterceptorAdditionalDataEventArgs> InterceptorSuffixReceived
Visual Basic
Public Event InterceptorSuffixReceived As EventHandler(Of ProtocolInterceptorAdditionalDataEventArgs)

Value

Type: System..::..EventHandler <(Of <(<' ProtocolInterceptorAdditionalDataEventArgs >)>)>

See Also

CommunicationClientBase Class
CommunicationClientBase Members
Ptl.Device.Communication Namespace


CommunicationClientConnectException Class

[image]

Pick To Light 设备通讯类库
CommunicationClientConnectException Class
Members See Also Send Feedback
通讯客户端连接异常，用于显式区分出通讯通道成功建立前的异常。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class CommunicationClientConnectException : Exception
Visual Basic
<SerializableAttribute>
Public Class CommunicationClientConnectException
    Inherits Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Ptl.Device.Communication..::..CommunicationClientConnectException

See Also

CommunicationClientConnectException Members
Ptl.Device.Communication Namespace


CommunicationClientConnectException Members

[image] [image]

Pick To Light 设备通讯类库
CommunicationClientConnectException Members
CommunicationClientConnectException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | CommunicationClientConnectException()()()() | 初始化新实例。
Public method | CommunicationClientConnectException(String) | 使用指定的错误消息初始化新实例。
Protected method | CommunicationClientConnectException(SerializationInfo, StreamingContext) | 用序列化数据初始化新实例。
Public method | CommunicationClientConnectException(String, Exception) | 使用指定错误消息和对作为此异常原因的内部异常的引用来初始化新实例。

See Also

CommunicationClientConnectException Class
Ptl.Device.Communication Namespace


CommunicationClientConnectException Constructor

[image] [image]

Pick To Light 设备通讯类库
CommunicationClientConnectException Constructor
CommunicationClientConnectException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CommunicationClientConnectException()()()() | 初始化新实例。
Public method | CommunicationClientConnectException(String) | 使用指定的错误消息初始化新实例。
Protected method | CommunicationClientConnectException(SerializationInfo, StreamingContext) | 用序列化数据初始化新实例。
Public method | CommunicationClientConnectException(String, Exception) | 使用指定错误消息和对作为此异常原因的内部异常的引用来初始化新实例。

See Also

CommunicationClientConnectException Class
CommunicationClientConnectException Members
Ptl.Device.Communication Namespace


CommunicationClientConnectException Constructor

[image]

Pick To Light 设备通讯类库
CommunicationClientConnectException Constructor
CommunicationClientConnectException Class See Also Send Feedback
初始化新实例。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public CommunicationClientConnectException()
Visual Basic
Public Sub New

See Also

CommunicationClientConnectException Class
CommunicationClientConnectException Members
CommunicationClientConnectException Overload
Ptl.Device.Communication Namespace


CommunicationClientConnectException Constructor (String)

[image]

Pick To Light 设备通讯类库
CommunicationClientConnectException Constructor (String)
CommunicationClientConnectException Class See Also Send Feedback
使用指定的错误消息初始化新实例。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public CommunicationClientConnectException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)

Parameters

message
Type: System..::..String
描述错误的消息。

See Also

CommunicationClientConnectException Class
CommunicationClientConnectException Members
CommunicationClientConnectException Overload
Ptl.Device.Communication Namespace


CommunicationClientConnectException Constructor (SerializationInfo, StreamingContext)

[image]

Pick To Light 设备通讯类库
CommunicationClientConnectException Constructor (SerializationInfo, StreamingContext)
CommunicationClientConnectException Class See Also Send Feedback
用序列化数据初始化新实例。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected CommunicationClientConnectException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
存有有关所引发异常的序列化的对象数据。
context
Type: System.Runtime.Serialization..::..StreamingContext
包含有关源或目标的上下文信息。

See Also

CommunicationClientConnectException Class
CommunicationClientConnectException Members
CommunicationClientConnectException Overload
Ptl.Device.Communication Namespace


CommunicationClientConnectException Constructor (String, Exception)

[image]

Pick To Light 设备通讯类库
CommunicationClientConnectException Constructor (String, Exception)
CommunicationClientConnectException Class See Also Send Feedback
使用指定错误消息和对作为此异常原因的内部异常的引用来初始化新实例。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public CommunicationClientConnectException(
    string message,
    Exception inner
)
Visual Basic
Public Sub New (
    message As String,
    inner As Exception
)

Parameters

message
Type: System..::..String
解释异常原因的错误消息。
inner
Type: System..::..Exception
导致当前异常的异常。

See Also

CommunicationClientConnectException Class
CommunicationClientConnectException Members
CommunicationClientConnectException Overload
Ptl.Device.Communication Namespace


ConnectionErrorEventArgs Class

[image]

Pick To Light 设备通讯类库
ConnectionErrorEventArgs Class
Members See Also Send Feedback
为 ICommunicationClient.ConnectionError 事件提供事件参数。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class ConnectionErrorEventArgs : EventArgs
Visual Basic
<SerializableAttribute>
Public Class ConnectionErrorEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Ptl.Device.Communication..::..ConnectionErrorEventArgs

See Also

ConnectionErrorEventArgs Members
Ptl.Device.Communication Namespace


ConnectionErrorEventArgs Members

[image] [image]

Pick To Light 设备通讯类库
ConnectionErrorEventArgs Members
ConnectionErrorEventArgs Class Constructors Properties See Also Send Feedback

The ConnectionErrorEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectionErrorEventArgs | 使用指定的异常信息初始化通讯连接出错事件的事件参数。

Properties

 | Name | Description
Public property | Exception | 获取或设置异常信息。

See Also

ConnectionErrorEventArgs Class
Ptl.Device.Communication Namespace


ConnectionErrorEventArgs Constructor

[image]

Pick To Light 设备通讯类库
ConnectionErrorEventArgs Constructor
ConnectionErrorEventArgs Class See Also Send Feedback
使用指定的异常信息初始化通讯连接出错事件的事件参数。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ConnectionErrorEventArgs(
    Exception exception
)
Visual Basic
Public Sub New (
    exception As Exception
)

Parameters

exception
Type: System..::..Exception
异常信息。

Exceptions

Exception | Condition
System..::..ArgumentNullException | exception 为空。

See Also

ConnectionErrorEventArgs Class
ConnectionErrorEventArgs Members
Ptl.Device.Communication Namespace


ConnectionErrorEventArgs Properties

[image] [image]

Pick To Light 设备通讯类库
ConnectionErrorEventArgs Properties
ConnectionErrorEventArgs Class See Also Send Feedback

The ConnectionErrorEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Exception | 获取或设置异常信息。

See Also

ConnectionErrorEventArgs Class
Ptl.Device.Communication Namespace


ConnectionErrorEventArgs.Exception Property

[image]

Pick To Light 设备通讯类库
ConnectionErrorEventArgs..::..Exception Property
ConnectionErrorEventArgs Class See Also Send Feedback
获取或设置异常信息。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Exception Exception { get; set; }
Visual Basic
Public Property Exception As Exception
    Get
    Set

Property Value

Type: Exception

Exceptions

Exception | Condition
System..::..ArgumentNullException | 设置时使用空值。

See Also

ConnectionErrorEventArgs Class
ConnectionErrorEventArgs Members
Ptl.Device.Communication Namespace


Crc Class

[image]

Pick To Light 设备通讯类库
Crc Class
Members See Also Send Feedback
提供 Crc 的计算功能。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static class Crc
Visual Basic
Public NotInheritable Class Crc

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication..::..Crc

See Also

Crc Members
Ptl.Device.Communication Namespace


Crc Members

[image] [image]

Pick To Light 设备通讯类库
Crc Members
Crc Class Methods See Also Send Feedback

The Crc type exposes the following members.

Methods

Name | Description
Calculate | 计算 CRC。

See Also

Crc Class
Ptl.Device.Communication Namespace


Crc Methods

[image] [image]

Pick To Light 设备通讯类库
Crc Methods
Crc Class See Also Send Feedback

The Crc type exposes the following members.

Methods

Name | Description
Calculate | 计算 CRC。

See Also

Crc Class
Ptl.Device.Communication Namespace


Crc.Calculate Method

[image]

Pick To Light 设备通讯类库
Crc..::..Calculate Method
Crc Class See Also Send Feedback
计算 CRC。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static byte[] Calculate(
    byte[] data,
    int index,
    int count
)
Visual Basic
Public Shared Function Calculate (
    data As Byte(),
    index As Integer,
    count As Integer
) As Byte()

Parameters

data
Type: array< System..::..Byte >[]()[][]
待计算的源。
index
Type: System..::..Int32
计算的开始处。
count
Type: System..::..Int32
计算的字节数。

Return Value

Type: array< Byte >[]()[][]
计算后的 CRC。

Exceptions

Exception | Condition
System..::..ArgumentNullException | data 为空。
System..::..ArgumentOutOfRangeException | index 小于零或大于等于 data 的长度；count 小于零或大于剩余的可计算字节数。

See Also

Crc Class
Crc Members
Ptl.Device.Communication Namespace


DefaultRS485AddressMapper Enumeration

[image]

Pick To Light 设备通讯类库
DefaultRS485AddressMapper Enumeration
See Also Send Feedback
预设的 RS485 地址映射方法枚举。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum DefaultRS485AddressMapper
Visual Basic
Public Enumeration DefaultRS485AddressMapper

Members

Member name | Value | Description
Original | 0 | 按原样返回真实地址。
SplittedBy50 | 1 | 按 50 分割的地址映射方法。
SplittedBy100 | 2 | 按 100 分割的地址映射方法。

See Also

Ptl.Device.Communication Namespace


DefaultRS485AddressMapperImplements Class

[image]

Pick To Light 设备通讯类库
DefaultRS485AddressMapperImplements Class
Members See Also Send Feedback
预设的 RS485 地址映射方法实现。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static class DefaultRS485AddressMapperImplements
Visual Basic
Public NotInheritable Class DefaultRS485AddressMapperImplements

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication..::..DefaultRS485AddressMapperImplements

See Also

DefaultRS485AddressMapperImplements Members
Ptl.Device.Communication Namespace


DefaultRS485AddressMapperImplements Members

[image] [image]

Pick To Light 设备通讯类库
DefaultRS485AddressMapperImplements Members
DefaultRS485AddressMapperImplements Class Methods See Also Send Feedback

The DefaultRS485AddressMapperImplements type exposes the following members.

Methods

Name | Description
Get | 按预设的枚举类型获取映射方法。

See Also

DefaultRS485AddressMapperImplements Class
Ptl.Device.Communication Namespace


DefaultRS485AddressMapperImplements Methods

[image] [image]

Pick To Light 设备通讯类库
DefaultRS485AddressMapperImplements Methods
DefaultRS485AddressMapperImplements Class See Also Send Feedback

The DefaultRS485AddressMapperImplements type exposes the following members.

Methods

Name | Description
Get | 按预设的枚举类型获取映射方法。

See Also

DefaultRS485AddressMapperImplements Class
Ptl.Device.Communication Namespace


DefaultRS485AddressMapperImplements.Get Method

[image]

Pick To Light 设备通讯类库
DefaultRS485AddressMapperImplements..::..Get Method
DefaultRS485AddressMapperImplements Class See Also Send Feedback
按预设的枚举类型获取映射方法。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static MapRS485Address Get(
    DefaultRS485AddressMapper name
)
Visual Basic
Public Shared Function Get (
    name As DefaultRS485AddressMapper
) As MapRS485Address

Parameters

name
Type: Ptl.Device.Communication..::..DefaultRS485AddressMapper
预设的枚举类型。

Return Value

Type: MapRS485Address
映射方法。

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | name 不是预设的。

See Also

DefaultRS485AddressMapperImplements Class
DefaultRS485AddressMapperImplements Members
Ptl.Device.Communication Namespace


HeartbeatGenerator Class

[image]

Pick To Light 设备通讯类库
HeartbeatGenerator Class
Members See Also Send Feedback
设备心跳发生器，为指定的所有 PTL 设备定时生成心跳命令。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public class HeartbeatGenerator
Visual Basic
Public Class HeartbeatGenerator

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication..::..HeartbeatGenerator

See Also

HeartbeatGenerator Members
Ptl.Device.Communication Namespace


HeartbeatGenerator Members

[image] [image]

Pick To Light 设备通讯类库
HeartbeatGenerator Members
HeartbeatGenerator Class Constructors Properties See Also Send Feedback

The HeartbeatGenerator type exposes the following members.

Constructors

 | Name | Description
Public method | HeartbeatGenerator(InstallProject) | 使用安装工程中所有的设备初始化新实例。
Public method | HeartbeatGenerator(IEnumerable<(Of <<'(PtlDevice>)>>)) | 使用指定的所有设备初始化新实例。
Public method | HeartbeatGenerator(XConverter) | 使用 RS232/RS485 协议转换器上所有的设备初始化新实例。

Properties

 | Name | Description
Public property | Enable | 获取或设置是否启用心跳。
Public property | Period | 获取或设置心跳周期。

See Also

HeartbeatGenerator Class
Ptl.Device.Communication Namespace


HeartbeatGenerator Constructor

[image] [image]

Pick To Light 设备通讯类库
HeartbeatGenerator Constructor
HeartbeatGenerator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HeartbeatGenerator(InstallProject) | 使用安装工程中所有的设备初始化新实例。
Public method | HeartbeatGenerator(IEnumerable<(Of <<'(PtlDevice>)>>)) | 使用指定的所有设备初始化新实例。
Public method | HeartbeatGenerator(XConverter) | 使用 RS232/RS485 协议转换器上所有的设备初始化新实例。

See Also

HeartbeatGenerator Class
HeartbeatGenerator Members
Ptl.Device.Communication Namespace


HeartbeatGenerator Constructor (InstallProject)

[image]

Pick To Light 设备通讯类库
HeartbeatGenerator Constructor (InstallProject)
HeartbeatGenerator Class See Also Send Feedback
使用安装工程中所有的设备初始化新实例。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public HeartbeatGenerator(
    InstallProject project
)
Visual Basic
Public Sub New (
    project As InstallProject
)

Parameters

project
Type: Ptl.Device..::..InstallProject
安装工程。

See Also

HeartbeatGenerator Class
HeartbeatGenerator Members
HeartbeatGenerator Overload
Ptl.Device.Communication Namespace


HeartbeatGenerator Constructor (IEnumerable(PtlDevice))

[image]

Pick To Light 设备通讯类库
HeartbeatGenerator Constructor (IEnumerable<(Of <(<'PtlDevice>)>)>)
HeartbeatGenerator Class See Also Send Feedback
使用指定的所有设备初始化新实例。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public HeartbeatGenerator(
    IEnumerable<PtlDevice> devices
)
Visual Basic
Public Sub New (
    devices As IEnumerable(Of PtlDevice)
)

Parameters

devices
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' PtlDevice >)>)>
需执行心跳的设备列表。

See Also

HeartbeatGenerator Class
HeartbeatGenerator Members
HeartbeatGenerator Overload
Ptl.Device.Communication Namespace


HeartbeatGenerator Constructor (XConverter)

[image]

Pick To Light 设备通讯类库
HeartbeatGenerator Constructor (XConverter)
HeartbeatGenerator Class See Also Send Feedback
使用 RS232/RS485 协议转换器上所有的设备初始化新实例。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public HeartbeatGenerator(
    XConverter xConverter
)
Visual Basic
Public Sub New (
    xConverter As XConverter
)

Parameters

xConverter
Type: Ptl.Device..::..XConverter
RS232/RS485 协议转换器。

See Also

HeartbeatGenerator Class
HeartbeatGenerator Members
HeartbeatGenerator Overload
Ptl.Device.Communication Namespace


HeartbeatGenerator Properties

[image] [image]

Pick To Light 设备通讯类库
HeartbeatGenerator Properties
HeartbeatGenerator Class See Also Send Feedback

The HeartbeatGenerator type exposes the following members.

Properties

 | Name | Description
Public property | Enable | 获取或设置是否启用心跳。
Public property | Period | 获取或设置心跳周期。

See Also

HeartbeatGenerator Class
Ptl.Device.Communication Namespace


HeartbeatGenerator.Enable Property

[image]

Pick To Light 设备通讯类库
HeartbeatGenerator..::..Enable Property
HeartbeatGenerator Class See Also Send Feedback
获取或设置是否启用心跳。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool Enable { get; set; }
Visual Basic
Public Property Enable As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

HeartbeatGenerator Class
HeartbeatGenerator Members
Ptl.Device.Communication Namespace


HeartbeatGenerator.Period Property

[image]

Pick To Light 设备通讯类库
HeartbeatGenerator..::..Period Property
HeartbeatGenerator Class See Also Send Feedback
获取或设置心跳周期。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public TimeSpan Period { get; set; }
Visual Basic
Public Property Period As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan

See Also

HeartbeatGenerator Class
HeartbeatGenerator Members
Ptl.Device.Communication Namespace


ICommunicationClient Interface

[image]

Pick To Light 设备通讯类库
ICommunicationClient Interface
Members See Also Send Feedback
表示可执行协议的通讯客户端。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public interface ICommunicationClient : IDisposable
Visual Basic
Public Interface ICommunicationClient
    Inherits IDisposable

See Also

ICommunicationClient Members
Ptl.Device.Communication Namespace


ICommunicationClient Members

[image] [image]

Pick To Light 设备通讯类库
ICommunicationClient Members
ICommunicationClient Interface Methods Properties Events See Also Send Feedback

The ICommunicationClient type exposes the following members.

Methods

 | Name | Description
Public method | Execute(IBroadcastProtocol) | 执行无返回值的广播协议。
Public method | Execute(IMulticastProtocol) | 执行无返回值的组播协议。
Public method | Execute(Byte, IUnicastProtocol) | 执行无返回值的单播协议。
Public method | Execute<(Of <<'(TResult>)>>)(IBroadcastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的广播协议。
Public method | Execute<(Of <<'(TResult>)>>)(IMulticastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的组播协议。
Public method | Execute<(Of <<'(TResult>)>>)(Byte, IUnicastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的单播协议。

Properties

 | Name | Description
Public property | Connected | 获取是否处于已连接状态。
Public property | Name | 获取客户端名称。

Events

 | Name | Description
Public event | ConnectedChanged | 连接状态更改事件。
Public event | ConnectionError | 通讯连接出错事件。

See Also

ICommunicationClient Interface
Ptl.Device.Communication Namespace


ICommunicationClient Methods

[image] [image]

Pick To Light 设备通讯类库
ICommunicationClient Methods
ICommunicationClient Interface See Also Send Feedback

Methods

 | Name | Description
Public method | Execute(IBroadcastProtocol) | 执行无返回值的广播协议。
Public method | Execute(IMulticastProtocol) | 执行无返回值的组播协议。
Public method | Execute(Byte, IUnicastProtocol) | 执行无返回值的单播协议。
Public method | Execute<(Of <<'(TResult>)>>)(IBroadcastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的广播协议。
Public method | Execute<(Of <<'(TResult>)>>)(IMulticastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的组播协议。
Public method | Execute<(Of <<'(TResult>)>>)(Byte, IUnicastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的单播协议。

See Also

ICommunicationClient Interface
Ptl.Device.Communication Namespace


ICommunicationClient.Execute Method

[image] [image]

Pick To Light 设备通讯类库
ICommunicationClient..::..Execute Method
ICommunicationClient Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | Execute(IBroadcastProtocol) | 执行无返回值的广播协议。
Public method | Execute<(Of <<'(TResult>)>>)(IBroadcastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的广播协议。
Public method | Execute(IMulticastProtocol) | 执行无返回值的组播协议。
Public method | Execute<(Of <<'(TResult>)>>)(IMulticastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的组播协议。
Public method | Execute(Byte, IUnicastProtocol) | 执行无返回值的单播协议。
Public method | Execute<(Of <<'(TResult>)>>)(Byte, IUnicastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的单播协议。

See Also

ICommunicationClient Interface
ICommunicationClient Members
Ptl.Device.Communication Namespace


ICommunicationClient.Execute Method (IBroadcastProtocol)

[image]

Pick To Light 设备通讯类库
ICommunicationClient..::..Execute Method (IBroadcastProtocol)
ICommunicationClient Interface See Also Send Feedback
执行无返回值的广播协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
void Execute(
    IBroadcastProtocol protocol
)
Visual Basic
Sub Execute (
    protocol As IBroadcastProtocol
)

Parameters

protocol
Type: Ptl.Device.Communication.Protocol.Broadcast..::..IBroadcastProtocol
无返回值的广播协议。

See Also

ICommunicationClient Interface
ICommunicationClient Members
Execute Overload
Ptl.Device.Communication Namespace


ICommunicationClient.Execute(TResult) Method (IBroadcastProtocol(TResult))

[image]

Pick To Light 设备通讯类库
ICommunicationClient..::..Execute<(Of <(<'TResult>)>)> Method (IBroadcastProtocol<(Of <(<'TResult>)>)>)
ICommunicationClient Interface See Also Send Feedback
执行有返回值的广播协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
TResult Execute<TResult>(
    IBroadcastProtocol<TResult> protocol
)
Visual Basic
Function Execute(Of TResult) (
    protocol As IBroadcastProtocol(Of TResult)
) As TResult

Parameters

protocol
Type: Ptl.Device.Communication.Protocol.Broadcast..::..IBroadcastProtocol <(Of <(<'TResult>)>)>
有返回值的广播协议。

Type Parameters

TResult
返回值类型。

Return Value

Type: TResult
协议的执行结果。

See Also

ICommunicationClient Interface
ICommunicationClient Members
Execute Overload
Ptl.Device.Communication Namespace


ICommunicationClient.Execute Method (IMulticastProtocol)

[image]

Pick To Light 设备通讯类库
ICommunicationClient..::..Execute Method (IMulticastProtocol)
ICommunicationClient Interface See Also Send Feedback
执行无返回值的组播协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
void Execute(
    IMulticastProtocol protocol
)
Visual Basic
Sub Execute (
    protocol As IMulticastProtocol
)

Parameters

protocol
Type: Ptl.Device.Communication.Protocol.Multicast..::..IMulticastProtocol
无返回值的组播协议。

See Also

ICommunicationClient Interface
ICommunicationClient Members
Execute Overload
Ptl.Device.Communication Namespace


ICommunicationClient.Execute(TResult) Method (IMulticastProtocol(TResult))

[image]

Pick To Light 设备通讯类库
ICommunicationClient..::..Execute<(Of <(<'TResult>)>)> Method (IMulticastProtocol<(Of <(<'TResult>)>)>)
ICommunicationClient Interface See Also Send Feedback
执行有返回值的组播协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
TResult Execute<TResult>(
    IMulticastProtocol<TResult> protocol
)
Visual Basic
Function Execute(Of TResult) (
    protocol As IMulticastProtocol(Of TResult)
) As TResult

Parameters

protocol
Type: Ptl.Device.Communication.Protocol.Multicast..::..IMulticastProtocol <(Of <(<'TResult>)>)>
有返回值的组播协议。

Type Parameters

TResult
返回值类型。

Return Value

Type: TResult
协议的执行结果。

See Also

ICommunicationClient Interface
ICommunicationClient Members
Execute Overload
Ptl.Device.Communication Namespace


ICommunicationClient.Execute Method (Byte, IUnicastProtocol)

[image]

Pick To Light 设备通讯类库
ICommunicationClient..::..Execute Method (Byte, IUnicastProtocol)
ICommunicationClient Interface See Also Send Feedback
执行无返回值的单播协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
void Execute(
    byte address,
    IUnicastProtocol protocol
)
Visual Basic
Sub Execute (
    address As Byte,
    protocol As IUnicastProtocol
)

Parameters

address
Type: System..::..Byte
设备地址。
protocol
Type: Ptl.Device.Communication.Protocol.Unicast..::..IUnicastProtocol
无返回值的单播协议。

See Also

ICommunicationClient Interface
ICommunicationClient Members
Execute Overload
Ptl.Device.Communication Namespace


ICommunicationClient.Execute(TResult) Method (Byte, IUnicastProtocol(TResult))

[image]

Pick To Light 设备通讯类库
ICommunicationClient..::..Execute<(Of <(<'TResult>)>)> Method (Byte, IUnicastProtocol<(Of <(<'TResult>)>)>)
ICommunicationClient Interface See Also Send Feedback
执行有返回值的单播协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
TResult Execute<TResult>(
    byte address,
    IUnicastProtocol<TResult> protocol
)
Visual Basic
Function Execute(Of TResult) (
    address As Byte,
    protocol As IUnicastProtocol(Of TResult)
) As TResult

Parameters

address
Type: System..::..Byte
设备地址。
protocol
Type: Ptl.Device.Communication.Protocol.Unicast..::..IUnicastProtocol <(Of <(<'TResult>)>)>
有返回值的单播协议。

Type Parameters

TResult
返回值类型。

Return Value

Type: TResult
协议的执行结果。

See Also

ICommunicationClient Interface
ICommunicationClient Members
Execute Overload
Ptl.Device.Communication Namespace


ICommunicationClient Properties

[image] [image]

Pick To Light 设备通讯类库
ICommunicationClient Properties
ICommunicationClient Interface See Also Send Feedback

The ICommunicationClient type exposes the following members.

Properties

 | Name | Description
Public property | Connected | 获取是否处于已连接状态。
Public property | Name | 获取客户端名称。

See Also

ICommunicationClient Interface
Ptl.Device.Communication Namespace


ICommunicationClient.Connected Property

[image]

Pick To Light 设备通讯类库
ICommunicationClient..::..Connected Property
ICommunicationClient Interface See Also Send Feedback
获取是否处于已连接状态。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
Nullable<bool> Connected { get; }
Visual Basic
ReadOnly Property Connected As Nullable(Of Boolean)
    Get

Property Value

Type: Nullable <(Of <(<' Boolean >)>)>

See Also

ICommunicationClient Interface
ICommunicationClient Members
Ptl.Device.Communication Namespace


ICommunicationClient.Name Property

[image]

Pick To Light 设备通讯类库
ICommunicationClient..::..Name Property
ICommunicationClient Interface See Also Send Feedback
获取客户端名称。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get

Property Value

Type: String

See Also

ICommunicationClient Interface
ICommunicationClient Members
Ptl.Device.Communication Namespace


ICommunicationClient Events

[image] [image]

Pick To Light 设备通讯类库
ICommunicationClient Events
ICommunicationClient Interface See Also Send Feedback

The ICommunicationClient type exposes the following members.

Events

 | Name | Description
Public event | ConnectedChanged | 连接状态更改事件。
Public event | ConnectionError | 通讯连接出错事件。

See Also

ICommunicationClient Interface
Ptl.Device.Communication Namespace


ICommunicationClient.ConnectedChanged Event

[image]

Pick To Light 设备通讯类库
ICommunicationClient..::..ConnectedChanged Event
ICommunicationClient Interface See Also Send Feedback
连接状态更改事件。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
event EventHandler ConnectedChanged
Visual Basic
Event ConnectedChanged As EventHandler

Value

Type: System..::..EventHandler

See Also

ICommunicationClient Interface
ICommunicationClient Members
Ptl.Device.Communication Namespace


ICommunicationClient.ConnectionError Event

[image]

Pick To Light 设备通讯类库
ICommunicationClient..::..ConnectionError Event
ICommunicationClient Interface See Also Send Feedback
通讯连接出错事件。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
event EventHandler<ConnectionErrorEventArgs> ConnectionError
Visual Basic
Event ConnectionError As EventHandler(Of ConnectionErrorEventArgs)

Value

Type: System..::..EventHandler <(Of <(<' ConnectionErrorEventArgs >)>)>

See Also

ICommunicationClient Interface
ICommunicationClient Members
Ptl.Device.Communication Namespace


IProtocolInterceptor Interface

[image]

Pick To Light 设备通讯类库
IProtocolInterceptor Interface
Members See Also Send Feedback
为协议提供拦截功能。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public interface IProtocolInterceptor
Visual Basic
Public Interface IProtocolInterceptor

See Also

IProtocolInterceptor Members
Ptl.Device.Communication Namespace


IProtocolInterceptor Members

[image] [image]

Pick To Light 设备通讯类库
IProtocolInterceptor Members
IProtocolInterceptor Interface Methods See Also Send Feedback

The IProtocolInterceptor type exposes the following members.

Methods

 | Name | Description
Public method | GetResponsePrefixLength | 获取响应数据的前缀长度。
Public method | GetResponseSuffixLength | 获取响应数据的后缀长度。
Public method | PrepareForWrapRequest | 为原始请求数据准备好包装信息。

See Also

IProtocolInterceptor Interface
Ptl.Device.Communication Namespace


IProtocolInterceptor Methods

[image] [image]

Pick To Light 设备通讯类库
IProtocolInterceptor Methods
IProtocolInterceptor Interface See Also Send Feedback

The IProtocolInterceptor type exposes the following members.

Methods

 | Name | Description
Public method | GetResponsePrefixLength | 获取响应数据的前缀长度。
Public method | GetResponseSuffixLength | 获取响应数据的后缀长度。
Public method | PrepareForWrapRequest | 为原始请求数据准备好包装信息。

See Also

IProtocolInterceptor Interface
Ptl.Device.Communication Namespace


IProtocolInterceptor.GetResponsePrefixLength Method

[image]

Pick To Light 设备通讯类库
IProtocolInterceptor..::..GetResponsePrefixLength Method
IProtocolInterceptor Interface See Also Send Feedback
获取响应数据的前缀长度。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
int GetResponsePrefixLength(
    int requestDataLength,
    ProtocolInterceptorPreparedWrapDatas requestWrapDatas
)
Visual Basic
Function GetResponsePrefixLength (
    requestDataLength As Integer,
    requestWrapDatas As ProtocolInterceptorPreparedWrapDatas
) As Integer

Parameters

requestDataLength
Type: System..::..Int32
原始请求数据的长度。
requestWrapDatas
Type: Ptl.Device.Communication..::..ProtocolInterceptorPreparedWrapDatas
为请求准备的包装数据。

Return Value

Type: Int32
响应数据的前缀长度。

See Also

IProtocolInterceptor Interface
IProtocolInterceptor Members
Ptl.Device.Communication Namespace


IProtocolInterceptor.GetResponseSuffixLength Method

[image]

Pick To Light 设备通讯类库
IProtocolInterceptor..::..GetResponseSuffixLength Method
IProtocolInterceptor Interface See Also Send Feedback
获取响应数据的后缀长度。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
int GetResponseSuffixLength(
    int requestDataLength,
    ProtocolInterceptorPreparedWrapDatas requestWrapDatas
)
Visual Basic
Function GetResponseSuffixLength (
    requestDataLength As Integer,
    requestWrapDatas As ProtocolInterceptorPreparedWrapDatas
) As Integer

Parameters

requestDataLength
Type: System..::..Int32
原始请求数据的长度。
requestWrapDatas
Type: Ptl.Device.Communication..::..ProtocolInterceptorPreparedWrapDatas
为请求准备的包装数据。

Return Value

Type: Int32
响应数据的后缀长度。

See Also

IProtocolInterceptor Interface
IProtocolInterceptor Members
Ptl.Device.Communication Namespace


IProtocolInterceptor.PrepareForWrapRequest Method

[image]

Pick To Light 设备通讯类库
IProtocolInterceptor..::..PrepareForWrapRequest Method
IProtocolInterceptor Interface See Also Send Feedback
为原始请求数据准备好包装信息。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
ProtocolInterceptorPreparedWrapDatas PrepareForWrapRequest(
    int requestDataLength
)
Visual Basic
Function PrepareForWrapRequest (
    requestDataLength As Integer
) As ProtocolInterceptorPreparedWrapDatas

Parameters

requestDataLength
Type: System..::..Int32
原始请求数据的长度。

Return Value

Type: ProtocolInterceptorPreparedWrapDatas
为请求准备的包装数据。

See Also

IProtocolInterceptor Interface
IProtocolInterceptor Members
Ptl.Device.Communication Namespace


MapRS485Address Delegate

[image]

Pick To Light 设备通讯类库
MapRS485Address Delegate
See Also Send Feedback
提供 RS485 地址的映射功能。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public delegate byte MapRS485Address(
    byte busIndex,
    byte actualAddress
)
Visual Basic
Public Delegate Function MapRS485Address (
    busIndex As Byte,
    actualAddress As Byte
) As Byte

Parameters

busIndex
Type: System..::..Byte
总线端口。
actualAddress
Type: System..::..Byte
真实地址。

Return Value

Type: Byte
映射后的地址。

Remarks

Modbus 服务器下可能有多个 RS485 总线，ModbusClient 使用映射后的地址通讯。

See Also

Ptl.Device.Communication Namespace


ModbusClient Class

[image]

Pick To Light 设备通讯类库
ModbusClient Class
Members See Also Send Feedback
Modbus Tcp 通讯客户端。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public class ModbusClient : CommunicationClientBase
Visual Basic
Public Class ModbusClient
    Inherits CommunicationClientBase

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication..::..CommunicationClientBase
Ptl.Device.Communication..::..ModbusClient

See Also

ModbusClient Members
Ptl.Device.Communication Namespace


ModbusClient Members

[image] [image]

Pick To Light 设备通讯类库
ModbusClient Members
ModbusClient Class Constructors Methods Properties Events See Also Send Feedback

The ModbusClient type exposes the following members.

Constructors

 | Name | Description
Public method | ModbusClient(IPEndPoint) | 初始化 Modbus 客户端。
Public method | ModbusClient(IPEndPoint, Byte) | 初始化 Modbus 客户端。
Public method | ModbusClient(IPEndPoint, Byte, Int32, Int32, Int32) | 初始化 Modbus 客户端。
Public method | ModbusClient(IPEndPoint, Byte, Int32, Int32, Int32, MapRS485Address) | 初始化 Modbus 客户端。

Methods

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。 (Inherited from CommunicationClientBase.)
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。 (Overrides CommunicationClientBase..::..Dispose(Boolean).)
Protected method | DoExecute | 执行协议。 (Overrides CommunicationClientBase..::..DoExecute(Byte, IProtocol, Boolean).)
Public method | Execute(IBroadcastProtocol) | 执行无返回值的广播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute(IMulticastProtocol) | 执行无返回值的组播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute(IXGateProtocol) | 执行无返回值的 XGate 单播协议。
Public method | Execute(Byte, IUnicastProtocol) | 执行无返回值的单播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(IBroadcastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的广播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(IMulticastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的组播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(IXGateProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的 XGate 单播协议。
Public method | Execute<(Of <<'(TResult>)>>)(Byte, IUnicastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的单播协议。 (Inherited from CommunicationClientBase.)
Protected method | Finalize | 释放非托管资源。 (Overrides Object..::..Finalize()()()().)
Protected method | OnConnectedChanged | 引发连接状态更改事件。 (Inherited from CommunicationClientBase.)
Protected method | OnConnectionError | 引发通讯连接出错事件。 (Inherited from CommunicationClientBase.)
Protected method | OnInterceptorPrefixReceived | 引发协议前缀收到事件。 (Inherited from CommunicationClientBase.)
Protected method | OnInterceptorSuffixReceived | 引发协议后缀收到事件。 (Inherited from CommunicationClientBase.)

Properties

 | Name | Description
Public property | BusIndex | 获取总线的端口。
Public property | Connected | 获取是否处于已连接状态。 (Inherited from CommunicationClientBase.)
Public property | ConnectTimeout | 获取连接超时时间。
Public property | IPEndPoint | 获取远程端 IP 终结点。
Public property | MapAddress | 获取地址映射方法。
Public property | Name | 返回 IP 终结点及总线端口。 (Overrides CommunicationClientBase..::..Name.)
Public property | ProtocolInterceptor | 获取或设置协议拦截器。 (Inherited from CommunicationClientBase.)
Public property | ReceiveTimeout | 获取接收超时时间。
Public property | SendTimeout | 获取发送超时时间。
Public property | TransactionIdGenerator | 获取或设置事务编号发生器。

Events

 | Name | Description
Public event | ConnectedChanged | 连接状态更改事件。 (Inherited from CommunicationClientBase.)
Public event | ConnectionError | 通讯连接出错事件。 (Inherited from CommunicationClientBase.)
Public event | InterceptorPrefixReceived | 在拦截器收到协议前缀时引发。 (Inherited from CommunicationClientBase.)
Public event | InterceptorSuffixReceived | 在拦截器收到协议后缀时引发。 (Inherited from CommunicationClientBase.)

See Also

ModbusClient Class
Ptl.Device.Communication Namespace


ModbusClient Constructor

[image] [image]

Pick To Light 设备通讯类库
ModbusClient Constructor
ModbusClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ModbusClient(IPEndPoint) | 初始化 Modbus 客户端。
Public method | ModbusClient(IPEndPoint, Byte) | 初始化 Modbus 客户端。
Public method | ModbusClient(IPEndPoint, Byte, Int32, Int32, Int32) | 初始化 Modbus 客户端。
Public method | ModbusClient(IPEndPoint, Byte, Int32, Int32, Int32, MapRS485Address) | 初始化 Modbus 客户端。

See Also

ModbusClient Class
ModbusClient Members
Ptl.Device.Communication Namespace


ModbusClient Constructor (IPEndPoint)

[image]

Pick To Light 设备通讯类库
ModbusClient Constructor (IPEndPoint)
ModbusClient Class See Also Send Feedback
初始化 Modbus 客户端。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ModbusClient(
    IPEndPoint ipEndPoint
)
Visual Basic
Public Sub New (
    ipEndPoint As IPEndPoint
)

Parameters

ipEndPoint
Type: System.Net..::..IPEndPoint
IP 终结点。

See Also

ModbusClient Class
ModbusClient Members
ModbusClient Overload
Ptl.Device.Communication Namespace


ModbusClient Constructor (IPEndPoint, Byte)

[image]

Pick To Light 设备通讯类库
ModbusClient Constructor (IPEndPoint, Byte)
ModbusClient Class See Also Send Feedback
初始化 Modbus 客户端。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ModbusClient(
    IPEndPoint ipEndPoint,
    byte busIndex
)
Visual Basic
Public Sub New (
    ipEndPoint As IPEndPoint,
    busIndex As Byte
)

Parameters

ipEndPoint
Type: System.Net..::..IPEndPoint
IP 终结点。
busIndex
Type: System..::..Byte
总线端口。

See Also

ModbusClient Class
ModbusClient Members
ModbusClient Overload
Ptl.Device.Communication Namespace


ModbusClient Constructor (IPEndPoint, Byte, Int32, Int32, Int32)

[image]

Pick To Light 设备通讯类库
ModbusClient Constructor (IPEndPoint, Byte, Int32, Int32, Int32)
ModbusClient Class See Also Send Feedback
初始化 Modbus 客户端。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ModbusClient(
    IPEndPoint ipEndPoint,
    byte busIndex,
    int connectTimeoutInMilliseconds,
    int sendTimeoutInMilliseconds,
    int receiveTimeoutInMilliseconds
)
Visual Basic
Public Sub New (
    ipEndPoint As IPEndPoint,
    busIndex As Byte,
    connectTimeoutInMilliseconds As Integer,
    sendTimeoutInMilliseconds As Integer,
    receiveTimeoutInMilliseconds As Integer
)

Parameters

ipEndPoint
Type: System.Net..::..IPEndPoint
IP 终结点。
busIndex
Type: System..::..Byte
总线端口。
connectTimeoutInMilliseconds
Type: System..::..Int32
连接超时时间。
sendTimeoutInMilliseconds
Type: System..::..Int32
发送超时时间。
receiveTimeoutInMilliseconds
Type: System..::..Int32
接收超时时间。

See Also

ModbusClient Class
ModbusClient Members
ModbusClient Overload
Ptl.Device.Communication Namespace


ModbusClient Constructor (IPEndPoint, Byte, Int32, Int32, Int32, MapRS485Address)

[image]

Pick To Light 设备通讯类库
ModbusClient Constructor (IPEndPoint, Byte, Int32, Int32, Int32, MapRS485Address)
ModbusClient Class See Also Send Feedback
初始化 Modbus 客户端。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ModbusClient(
    IPEndPoint ipEndPoint,
    byte busIndex,
    int connectTimeoutInMilliseconds,
    int sendTimeoutInMilliseconds,
    int receiveTimeoutInMilliseconds,
    MapRS485Address mapAddress
)
Visual Basic
Public Sub New (
    ipEndPoint As IPEndPoint,
    busIndex As Byte,
    connectTimeoutInMilliseconds As Integer,
    sendTimeoutInMilliseconds As Integer,
    receiveTimeoutInMilliseconds As Integer,
    mapAddress As MapRS485Address
)

Parameters

ipEndPoint
Type: System.Net..::..IPEndPoint
IP 终结点。
busIndex
Type: System..::..Byte
总线端口。
connectTimeoutInMilliseconds
Type: System..::..Int32
连接超时时间。
sendTimeoutInMilliseconds
Type: System..::..Int32
发送超时时间。
receiveTimeoutInMilliseconds
Type: System..::..Int32
接收超时时间。
mapAddress
Type: Ptl.Device.Communication..::..MapRS485Address
RS485 地址映射方法。

Exceptions

Exception | Condition
System..::..ArgumentNullException | ipEndPoint 或 mapAddress 为空。

See Also

ModbusClient Class
ModbusClient Members
ModbusClient Overload
Ptl.Device.Communication Namespace


ModbusClient Methods

[image] [image]

Pick To Light 设备通讯类库
ModbusClient Methods
ModbusClient Class See Also Send Feedback

The ModbusClient type exposes the following members.

Methods

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。 (Inherited from CommunicationClientBase.)
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。 (Overrides CommunicationClientBase..::..Dispose(Boolean).)
Protected method | DoExecute | 执行协议。 (Overrides CommunicationClientBase..::..DoExecute(Byte, IProtocol, Boolean).)
Public method | Execute(IBroadcastProtocol) | 执行无返回值的广播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute(IMulticastProtocol) | 执行无返回值的组播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute(IXGateProtocol) | 执行无返回值的 XGate 单播协议。
Public method | Execute(Byte, IUnicastProtocol) | 执行无返回值的单播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(IBroadcastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的广播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(IMulticastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的组播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(IXGateProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的 XGate 单播协议。
Public method | Execute<(Of <<'(TResult>)>>)(Byte, IUnicastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的单播协议。 (Inherited from CommunicationClientBase.)
Protected method | Finalize | 释放非托管资源。 (Overrides Object..::..Finalize()()()().)
Protected method | OnConnectedChanged | 引发连接状态更改事件。 (Inherited from CommunicationClientBase.)
Protected method | OnConnectionError | 引发通讯连接出错事件。 (Inherited from CommunicationClientBase.)
Protected method | OnInterceptorPrefixReceived | 引发协议前缀收到事件。 (Inherited from CommunicationClientBase.)
Protected method | OnInterceptorSuffixReceived | 引发协议后缀收到事件。 (Inherited from CommunicationClientBase.)

See Also

ModbusClient Class
Ptl.Device.Communication Namespace


ModbusClient.Dispose Method

[image] [image]

Pick To Light 设备通讯类库
ModbusClient..::..Dispose Method
ModbusClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。 (Inherited from CommunicationClientBase.)
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。 (Overrides CommunicationClientBase..::..Dispose(Boolean).)

See Also

ModbusClient Class
ModbusClient Members
Ptl.Device.Communication Namespace


ModbusClient.Dispose Method (Boolean)

[image]

Pick To Light 设备通讯类库
ModbusClient..::..Dispose Method (Boolean)
ModbusClient Class See Also Send Feedback
释放非托管资源并可选地释放托管资源。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: System..::..Boolean
是否释放托管资源。

See Also

ModbusClient Class
ModbusClient Members
Dispose Overload
Ptl.Device.Communication Namespace


ModbusClient.DoExecute Method

[image]

Pick To Light 设备通讯类库
ModbusClient..::..DoExecute Method
ModbusClient Class See Also Send Feedback
执行协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected override byte[] DoExecute(
    byte address,
    IProtocol protocol,
    bool hasResponse
)
Visual Basic
Protected Overrides Function DoExecute (
    address As Byte,
    protocol As IProtocol,
    hasResponse As Boolean
) As Byte()

Parameters

address
Type: System..::..Byte
设备地址。
protocol
Type: Ptl.Device.Communication.Protocol..::..IProtocol
协议。
hasResponse
Type: System..::..Boolean
设备是否有返回。

Return Value

Type: array< Byte >[]()[][]
设备有返回时的返回值。

See Also

ModbusClient Class
ModbusClient Members
Ptl.Device.Communication Namespace


ModbusClient.Execute Method

[image] [image]

Pick To Light 设备通讯类库
ModbusClient..::..Execute Method
ModbusClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Execute(IBroadcastProtocol) | 执行无返回值的广播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(IBroadcastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的广播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute(IMulticastProtocol) | 执行无返回值的组播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(IMulticastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的组播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute(IXGateProtocol) | 执行无返回值的 XGate 单播协议。
Public method | Execute<(Of <<'(TResult>)>>)(IXGateProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的 XGate 单播协议。
Public method | Execute(Byte, IUnicastProtocol) | 执行无返回值的单播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(Byte, IUnicastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的单播协议。 (Inherited from CommunicationClientBase.)

See Also

ModbusClient Class
ModbusClient Members
Ptl.Device.Communication Namespace


ModbusClient.Execute Method (IXGateProtocol)

[image]

Pick To Light 设备通讯类库
ModbusClient..::..Execute Method (IXGateProtocol)
ModbusClient Class See Also Send Feedback
执行无返回值的 XGate 单播协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Execute(
    IXGateProtocol protocol
)
Visual Basic
Public Sub Execute (
    protocol As IXGateProtocol
)

Parameters

protocol
Type: Ptl.Device.Communication.Protocol.XGateProtocols..::..IXGateProtocol
无返回值的单播协议。

Exceptions

Exception | Condition
System..::..ArgumentNullException | protocol 为空。

See Also

ModbusClient Class
ModbusClient Members
Execute Overload
Ptl.Device.Communication Namespace


ModbusClient.Execute(TResult) Method (IXGateProtocol(TResult))

[image]

Pick To Light 设备通讯类库
ModbusClient..::..Execute<(Of <(<'TResult>)>)> Method (IXGateProtocol<(Of <(<'TResult>)>)>)
ModbusClient Class See Also Send Feedback
执行有返回值的 XGate 单播协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public TResult Execute<TResult>(
    IXGateProtocol<TResult> protocol
)
Visual Basic
Public Function Execute(Of TResult) (
    protocol As IXGateProtocol(Of TResult)
) As TResult

Parameters

protocol
Type: Ptl.Device.Communication.Protocol.XGateProtocols..::..IXGateProtocol <(Of <(<'TResult>)>)>
有返回值的单播协议。

Type Parameters

TResult
返回值类型。

Return Value

Type: TResult
协议的执行结果。

Exceptions

Exception | Condition
System..::..ArgumentNullException | protocol 为空。

See Also

ModbusClient Class
ModbusClient Members
Execute Overload
Ptl.Device.Communication Namespace


ModbusClient.Finalize Method

[image]

Pick To Light 设备通讯类库
ModbusClient..::..Finalize Method
ModbusClient Class See Also Send Feedback
释放非托管资源。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize

See Also

ModbusClient Class
ModbusClient Members
Ptl.Device.Communication Namespace


ModbusClient Properties

[image] [image]

Pick To Light 设备通讯类库
ModbusClient Properties
ModbusClient Class See Also Send Feedback

The ModbusClient type exposes the following members.

Properties

 | Name | Description
Public property | BusIndex | 获取总线的端口。
Public property | Connected | 获取是否处于已连接状态。 (Inherited from CommunicationClientBase.)
Public property | ConnectTimeout | 获取连接超时时间。
Public property | IPEndPoint | 获取远程端 IP 终结点。
Public property | MapAddress | 获取地址映射方法。
Public property | Name | 返回 IP 终结点及总线端口。 (Overrides CommunicationClientBase..::..Name.)
Public property | ProtocolInterceptor | 获取或设置协议拦截器。 (Inherited from CommunicationClientBase.)
Public property | ReceiveTimeout | 获取接收超时时间。
Public property | SendTimeout | 获取发送超时时间。
Public property | TransactionIdGenerator | 获取或设置事务编号发生器。

See Also

ModbusClient Class
Ptl.Device.Communication Namespace


ModbusClient.BusIndex Property

[image]

Pick To Light 设备通讯类库
ModbusClient..::..BusIndex Property
ModbusClient Class See Also Send Feedback
获取总线的端口。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte BusIndex { get; }
Visual Basic
Public ReadOnly Property BusIndex As Byte
    Get

Property Value

Type: Byte

See Also

ModbusClient Class
ModbusClient Members
Ptl.Device.Communication Namespace


ModbusClient.ConnectTimeout Property

[image]

Pick To Light 设备通讯类库
ModbusClient..::..ConnectTimeout Property
ModbusClient Class See Also Send Feedback
获取连接超时时间。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int ConnectTimeout { get; }
Visual Basic
Public ReadOnly Property ConnectTimeout As Integer
    Get

Property Value

Type: Int32

See Also

ModbusClient Class
ModbusClient Members
Ptl.Device.Communication Namespace


ModbusClient.IPEndPoint Property

[image]

Pick To Light 设备通讯类库
ModbusClient..::..IPEndPoint Property
ModbusClient Class See Also Send Feedback
获取远程端 IP 终结点。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public IPEndPoint IPEndPoint { get; }
Visual Basic
Public ReadOnly Property IPEndPoint As IPEndPoint
    Get

Property Value

Type: IPEndPoint

See Also

ModbusClient Class
ModbusClient Members
Ptl.Device.Communication Namespace


ModbusClient.MapAddress Property

[image]

Pick To Light 设备通讯类库
ModbusClient..::..MapAddress Property
ModbusClient Class See Also Send Feedback
获取地址映射方法。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public MapRS485Address MapAddress { get; }
Visual Basic
Public ReadOnly Property MapAddress As MapRS485Address
    Get

Property Value

Type: MapRS485Address

See Also

ModbusClient Class
ModbusClient Members
Ptl.Device.Communication Namespace


ModbusClient.Name Property

[image]

Pick To Light 设备通讯类库
ModbusClient..::..Name Property
ModbusClient Class See Also Send Feedback
返回 IP 终结点及总线端口。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get

Property Value

Type: String

Implements

ICommunicationClient..::..Name

See Also

ModbusClient Class
ModbusClient Members
Ptl.Device.Communication Namespace


ModbusClient.ReceiveTimeout Property

[image]

Pick To Light 设备通讯类库
ModbusClient..::..ReceiveTimeout Property
ModbusClient Class See Also Send Feedback
获取接收超时时间。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int ReceiveTimeout { get; }
Visual Basic
Public ReadOnly Property ReceiveTimeout As Integer
    Get

Property Value

Type: Int32

See Also

ModbusClient Class
ModbusClient Members
Ptl.Device.Communication Namespace


ModbusClient.SendTimeout Property

[image]

Pick To Light 设备通讯类库
ModbusClient..::..SendTimeout Property
ModbusClient Class See Also Send Feedback
获取发送超时时间。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int SendTimeout { get; }
Visual Basic
Public ReadOnly Property SendTimeout As Integer
    Get

Property Value

Type: Int32

See Also

ModbusClient Class
ModbusClient Members
Ptl.Device.Communication Namespace


ModbusClient.TransactionIdGenerator Property

[image]

Pick To Light 设备通讯类库
ModbusClient..::..TransactionIdGenerator Property
ModbusClient Class See Also Send Feedback
获取或设置事务编号发生器。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ModbusTcpTransactionIdGenerator TransactionIdGenerator { get; set; }
Visual Basic
Public Property TransactionIdGenerator As ModbusTcpTransactionIdGenerator
    Get
    Set

Property Value

Type: ModbusTcpTransactionIdGenerator

Exceptions

Exception | Condition
System..::..ArgumentNullException | 设置时使用空值。

See Also

ModbusClient Class
ModbusClient Members
Ptl.Device.Communication Namespace


ModbusClient Events

[image] [image]

Pick To Light 设备通讯类库
ModbusClient Events
ModbusClient Class See Also Send Feedback

The ModbusClient type exposes the following members.

Events

 | Name | Description
Public event | ConnectedChanged | 连接状态更改事件。 (Inherited from CommunicationClientBase.)
Public event | ConnectionError | 通讯连接出错事件。 (Inherited from CommunicationClientBase.)
Public event | InterceptorPrefixReceived | 在拦截器收到协议前缀时引发。 (Inherited from CommunicationClientBase.)
Public event | InterceptorSuffixReceived | 在拦截器收到协议后缀时引发。 (Inherited from CommunicationClientBase.)

See Also

ModbusClient Class
Ptl.Device.Communication Namespace


ModbusTcpTransactionIdGenerator Class

[image]

Pick To Light 设备通讯类库
ModbusTcpTransactionIdGenerator Class
Members See Also Send Feedback
Modbus Tcp 事务编号生成器。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public class ModbusTcpTransactionIdGenerator
Visual Basic
Public Class ModbusTcpTransactionIdGenerator

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication..::..ModbusTcpTransactionIdGenerator

See Also

ModbusTcpTransactionIdGenerator Members
Ptl.Device.Communication Namespace


ModbusTcpTransactionIdGenerator Members

[image] [image]

Pick To Light 设备通讯类库
ModbusTcpTransactionIdGenerator Members
ModbusTcpTransactionIdGenerator Class Constructors Methods See Also Send Feedback

The ModbusTcpTransactionIdGenerator type exposes the following members.

Constructors

 | Name | Description
Public method | ModbusTcpTransactionIdGenerator | Initializes a new instance of the ModbusTcpTransactionIdGenerator class

Methods

 | Name | Description
Public method | NextTransactionId | 获取下一个事务编号。
Public method | Reset | 重置计数，以便下次获取新编号时从 1 开始。

See Also

ModbusTcpTransactionIdGenerator Class
Ptl.Device.Communication Namespace


ModbusTcpTransactionIdGenerator Constructor

[image]

Pick To Light 设备通讯类库
ModbusTcpTransactionIdGenerator Constructor
ModbusTcpTransactionIdGenerator Class See Also Send Feedback
Initializes a new instance of the ModbusTcpTransactionIdGenerator class

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ModbusTcpTransactionIdGenerator()
Visual Basic
Public Sub New

See Also

ModbusTcpTransactionIdGenerator Class
ModbusTcpTransactionIdGenerator Members
Ptl.Device.Communication Namespace


ModbusTcpTransactionIdGenerator Methods

[image] [image]

Pick To Light 设备通讯类库
ModbusTcpTransactionIdGenerator Methods
ModbusTcpTransactionIdGenerator Class See Also Send Feedback

The ModbusTcpTransactionIdGenerator type exposes the following members.

Methods

 | Name | Description
Public method | NextTransactionId | 获取下一个事务编号。
Public method | Reset | 重置计数，以便下次获取新编号时从 1 开始。

See Also

ModbusTcpTransactionIdGenerator Class
Ptl.Device.Communication Namespace


ModbusTcpTransactionIdGenerator.NextTransactionId Method

[image]

Pick To Light 设备通讯类库
ModbusTcpTransactionIdGenerator..::..NextTransactionId Method
ModbusTcpTransactionIdGenerator Class See Also Send Feedback
获取下一个事务编号。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ushort NextTransactionId()
Visual Basic
Public Function NextTransactionId As UShort

Return Value

Type: UInt16
值域：[1, 65535]。

See Also

ModbusTcpTransactionIdGenerator Class
ModbusTcpTransactionIdGenerator Members
Ptl.Device.Communication Namespace


ModbusTcpTransactionIdGenerator.Reset Method

[image]

Pick To Light 设备通讯类库
ModbusTcpTransactionIdGenerator..::..Reset Method
ModbusTcpTransactionIdGenerator Class See Also Send Feedback
重置计数，以便下次获取新编号时从 1 开始。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

See Also

ModbusTcpTransactionIdGenerator Class
ModbusTcpTransactionIdGenerator Members
Ptl.Device.Communication Namespace


ProtocolInterceptorAdditionalDataEventArgs Class

[image]

Pick To Light 设备通讯类库
ProtocolInterceptorAdditionalDataEventArgs Class
Members See Also Send Feedback
为 InterceptorPrefixReceived 和 InterceptorSuffixReceived 事件提供事件参数。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public class ProtocolInterceptorAdditionalDataEventArgs : EventArgs
Visual Basic
Public Class ProtocolInterceptorAdditionalDataEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Ptl.Device.Communication..::..ProtocolInterceptorAdditionalDataEventArgs

See Also

ProtocolInterceptorAdditionalDataEventArgs Members
Ptl.Device.Communication Namespace


ProtocolInterceptorAdditionalDataEventArgs Members

[image] [image]

Pick To Light 设备通讯类库
ProtocolInterceptorAdditionalDataEventArgs Members
ProtocolInterceptorAdditionalDataEventArgs Class Constructors Properties See Also Send Feedback

The ProtocolInterceptorAdditionalDataEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ProtocolInterceptorAdditionalDataEventArgs | 使用指定的附加数据初始化事件参数。

Properties

 | Name | Description
Public property | AdditionalData | 获取附加数据。

See Also

ProtocolInterceptorAdditionalDataEventArgs Class
Ptl.Device.Communication Namespace


ProtocolInterceptorAdditionalDataEventArgs Constructor

[image]

Pick To Light 设备通讯类库
ProtocolInterceptorAdditionalDataEventArgs Constructor
ProtocolInterceptorAdditionalDataEventArgs Class See Also Send Feedback
使用指定的附加数据初始化事件参数。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ProtocolInterceptorAdditionalDataEventArgs(
    byte[] additionalData
)
Visual Basic
Public Sub New (
    additionalData As Byte()
)

Parameters

additionalData
Type: array< System..::..Byte >[]()[][]
附加数据。

See Also

ProtocolInterceptorAdditionalDataEventArgs Class
ProtocolInterceptorAdditionalDataEventArgs Members
Ptl.Device.Communication Namespace


ProtocolInterceptorAdditionalDataEventArgs Properties

[image] [image]

Pick To Light 设备通讯类库
ProtocolInterceptorAdditionalDataEventArgs Properties
ProtocolInterceptorAdditionalDataEventArgs Class See Also Send Feedback

The ProtocolInterceptorAdditionalDataEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalData | 获取附加数据。

See Also

ProtocolInterceptorAdditionalDataEventArgs Class
Ptl.Device.Communication Namespace


ProtocolInterceptorAdditionalDataEventArgs.AdditionalData Property

[image]

Pick To Light 设备通讯类库
ProtocolInterceptorAdditionalDataEventArgs..::..AdditionalData Property
ProtocolInterceptorAdditionalDataEventArgs Class See Also Send Feedback
获取附加数据。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte[] AdditionalData { get; }
Visual Basic
Public ReadOnly Property AdditionalData As Byte()
    Get

Property Value

Type: array< Byte >[]()[][]

See Also

ProtocolInterceptorAdditionalDataEventArgs Class
ProtocolInterceptorAdditionalDataEventArgs Members
Ptl.Device.Communication Namespace


ProtocolInterceptorPreparedWrapDatas Class

[image]

Pick To Light 设备通讯类库
ProtocolInterceptorPreparedWrapDatas Class
Members See Also Send Feedback
协议拦截器为请求准备的包装数据。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public class ProtocolInterceptorPreparedWrapDatas
Visual Basic
Public Class ProtocolInterceptorPreparedWrapDatas

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication..::..ProtocolInterceptorPreparedWrapDatas

See Also

ProtocolInterceptorPreparedWrapDatas Members
Ptl.Device.Communication Namespace


ProtocolInterceptorPreparedWrapDatas Members

[image] [image]

Pick To Light 设备通讯类库
ProtocolInterceptorPreparedWrapDatas Members
ProtocolInterceptorPreparedWrapDatas Class Constructors Properties See Also Send Feedback

The ProtocolInterceptorPreparedWrapDatas type exposes the following members.

Constructors

 | Name | Description
Public method | ProtocolInterceptorPreparedWrapDatas | Initializes a new instance of the ProtocolInterceptorPreparedWrapDatas class

Properties

 | Name | Description
Public property | Prefix | 获取或设置附加到原始协议前面的前缀。
Public property | Suffix | 获取或设置附加到原始协议后面的后缀。
Public property | Tag | 获取或设置与当前协议关联的自定义数据。

See Also

ProtocolInterceptorPreparedWrapDatas Class
Ptl.Device.Communication Namespace


ProtocolInterceptorPreparedWrapDatas Constructor

[image]

Pick To Light 设备通讯类库
ProtocolInterceptorPreparedWrapDatas Constructor
ProtocolInterceptorPreparedWrapDatas Class See Also Send Feedback
Initializes a new instance of the ProtocolInterceptorPreparedWrapDatas class

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ProtocolInterceptorPreparedWrapDatas()
Visual Basic
Public Sub New

See Also

ProtocolInterceptorPreparedWrapDatas Class
ProtocolInterceptorPreparedWrapDatas Members
Ptl.Device.Communication Namespace


ProtocolInterceptorPreparedWrapDatas Properties

[image] [image]

Pick To Light 设备通讯类库
ProtocolInterceptorPreparedWrapDatas Properties
ProtocolInterceptorPreparedWrapDatas Class See Also Send Feedback

The ProtocolInterceptorPreparedWrapDatas type exposes the following members.

Properties

 | Name | Description
Public property | Prefix | 获取或设置附加到原始协议前面的前缀。
Public property | Suffix | 获取或设置附加到原始协议后面的后缀。
Public property | Tag | 获取或设置与当前协议关联的自定义数据。

See Also

ProtocolInterceptorPreparedWrapDatas Class
Ptl.Device.Communication Namespace


ProtocolInterceptorPreparedWrapDatas.Prefix Property

[image]

Pick To Light 设备通讯类库
ProtocolInterceptorPreparedWrapDatas..::..Prefix Property
ProtocolInterceptorPreparedWrapDatas Class See Also Send Feedback
获取或设置附加到原始协议前面的前缀。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte[] Prefix { get; set; }
Visual Basic
Public Property Prefix As Byte()
    Get
    Set

Property Value

Type: array< Byte >[]()[][]

See Also

ProtocolInterceptorPreparedWrapDatas Class
ProtocolInterceptorPreparedWrapDatas Members
Ptl.Device.Communication Namespace


ProtocolInterceptorPreparedWrapDatas.Suffix Property

[image]

Pick To Light 设备通讯类库
ProtocolInterceptorPreparedWrapDatas..::..Suffix Property
ProtocolInterceptorPreparedWrapDatas Class See Also Send Feedback
获取或设置附加到原始协议后面的后缀。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte[] Suffix { get; set; }
Visual Basic
Public Property Suffix As Byte()
    Get
    Set

Property Value

Type: array< Byte >[]()[][]

See Also

ProtocolInterceptorPreparedWrapDatas Class
ProtocolInterceptorPreparedWrapDatas Members
Ptl.Device.Communication Namespace


ProtocolInterceptorPreparedWrapDatas.Tag Property

[image]

Pick To Light 设备通讯类库
ProtocolInterceptorPreparedWrapDatas..::..Tag Property
ProtocolInterceptorPreparedWrapDatas Class See Also Send Feedback
获取或设置与当前协议关联的自定义数据。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Object Tag { get; set; }
Visual Basic
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object

See Also

ProtocolInterceptorPreparedWrapDatas Class
ProtocolInterceptorPreparedWrapDatas Members
Ptl.Device.Communication Namespace


SerialPortClient Class

[image]

Pick To Light 设备通讯类库
SerialPortClient Class
Members See Also Send Feedback
串口通讯客户端。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public class SerialPortClient : CommunicationClientBase
Visual Basic
Public Class SerialPortClient
    Inherits CommunicationClientBase

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication..::..CommunicationClientBase
Ptl.Device.Communication..::..SerialPortClient

See Also

SerialPortClient Members
Ptl.Device.Communication Namespace


SerialPortClient Members

[image] [image]

Pick To Light 设备通讯类库
SerialPortClient Members
SerialPortClient Class Constructors Methods Properties Events See Also Send Feedback

The SerialPortClient type exposes the following members.

Constructors

 | Name | Description
Public method | SerialPortClient(String) | 初始化串口通讯客户端。
Public method | SerialPortClient(String, Int32, Parity, Int32, StopBits, Int32, Int32, Int32) | 初始化串口通讯客户端。

Methods

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。 (Inherited from CommunicationClientBase.)
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。 (Overrides CommunicationClientBase..::..Dispose(Boolean).)
Protected method | DoExecute | 执行协议。 (Overrides CommunicationClientBase..::..DoExecute(Byte, IProtocol, Boolean).)
Public method | Execute(IBroadcastProtocol) | 执行无返回值的广播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute(IMulticastProtocol) | 执行无返回值的组播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute(Byte, IUnicastProtocol) | 执行无返回值的单播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(IBroadcastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的广播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(IMulticastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的组播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(Byte, IUnicastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的单播协议。 (Inherited from CommunicationClientBase.)
Protected method | Finalize | 释放非托管资源。 (Overrides Object..::..Finalize()()()().)
Protected method | OnConnectedChanged | 引发连接状态更改事件。 (Inherited from CommunicationClientBase.)
Protected method | OnConnectionError | 引发通讯连接出错事件。 (Inherited from CommunicationClientBase.)
Protected method | OnInterceptorPrefixReceived | 引发协议前缀收到事件。 (Inherited from CommunicationClientBase.)
Protected method | OnInterceptorSuffixReceived | 引发协议后缀收到事件。 (Inherited from CommunicationClientBase.)

Properties

 | Name | Description
Public property | BaudRate | 获取波特率。
Public property | Connected | 获取是否处于已连接状态。 (Inherited from CommunicationClientBase.)
Public property | DataBits | 获取数据位数。
Public property | InterframeDelay | 获取帧间延时，用于无返回值的命令之后。
Public property | Name | 返回串口名称。 (Overrides CommunicationClientBase..::..Name.)
Public property | Parity | 获取奇偶校验位。
Public property | PortName | 获取串口名。
Public property | ProtocolInterceptor | 获取或设置协议拦截器。 (Inherited from CommunicationClientBase.)
Public property | ReadTimeout | 获取读取超时时间。
Public property | StopBits | 获取停止位数。
Public property | WriteTimeout | 获取写入超时时间。

Events

 | Name | Description
Public event | ConnectedChanged | 连接状态更改事件。 (Inherited from CommunicationClientBase.)
Public event | ConnectionError | 通讯连接出错事件。 (Inherited from CommunicationClientBase.)
Public event | InterceptorPrefixReceived | 在拦截器收到协议前缀时引发。 (Inherited from CommunicationClientBase.)
Public event | InterceptorSuffixReceived | 在拦截器收到协议后缀时引发。 (Inherited from CommunicationClientBase.)

See Also

SerialPortClient Class
Ptl.Device.Communication Namespace


SerialPortClient Constructor

[image] [image]

Pick To Light 设备通讯类库
SerialPortClient Constructor
SerialPortClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SerialPortClient(String) | 初始化串口通讯客户端。
Public method | SerialPortClient(String, Int32, Parity, Int32, StopBits, Int32, Int32, Int32) | 初始化串口通讯客户端。

See Also

SerialPortClient Class
SerialPortClient Members
Ptl.Device.Communication Namespace


SerialPortClient Constructor (String)

[image]

Pick To Light 设备通讯类库
SerialPortClient Constructor (String)
SerialPortClient Class See Also Send Feedback
初始化串口通讯客户端。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public SerialPortClient(
    string portName
)
Visual Basic
Public Sub New (
    portName As String
)

Parameters

portName
Type: System..::..String
端口名称。

See Also

SerialPortClient Class
SerialPortClient Members
SerialPortClient Overload
Ptl.Device.Communication Namespace


SerialPortClient Constructor (String, Int32, Parity, Int32, StopBits, Int32, Int32, Int32)

[image]

Pick To Light 设备通讯类库
SerialPortClient Constructor (String, Int32, Parity, Int32, StopBits, Int32, Int32, Int32)
SerialPortClient Class See Also Send Feedback
初始化串口通讯客户端。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public SerialPortClient(
    string portName,
    int baudRate,
    Parity parity,
    int dataBits,
    StopBits stopBits,
    int writeTimeoutInMilliseconds,
    int readTimeoutInMilliseconds,
    int interframeDelayInMilliseconds
)
Visual Basic
Public Sub New (
    portName As String,
    baudRate As Integer,
    parity As Parity,
    dataBits As Integer,
    stopBits As StopBits,
    writeTimeoutInMilliseconds As Integer,
    readTimeoutInMilliseconds As Integer,
    interframeDelayInMilliseconds As Integer
)

Parameters

portName
Type: System..::..String
端口名称。
baudRate
Type: System..::..Int32
波特率。
parity
Type: System.IO.Ports..::..Parity
校验位。
dataBits
Type: System..::..Int32
数据位。
stopBits
Type: System.IO.Ports..::..StopBits
停止位。
writeTimeoutInMilliseconds
Type: System..::..Int32
发送超时时间。
readTimeoutInMilliseconds
Type: System..::..Int32
接收超时时间。
interframeDelayInMilliseconds
Type: System..::..Int32
帧间延时，用于无返回值的命令之后。

Exceptions

Exception | Condition
System..::..ArgumentNullException | portName 为空或为 System.String.Empty。

See Also

SerialPortClient Class
SerialPortClient Members
SerialPortClient Overload
Ptl.Device.Communication Namespace


SerialPortClient Methods

[image] [image]

Pick To Light 设备通讯类库
SerialPortClient Methods
SerialPortClient Class See Also Send Feedback

The SerialPortClient type exposes the following members.

Methods

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。 (Inherited from CommunicationClientBase.)
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。 (Overrides CommunicationClientBase..::..Dispose(Boolean).)
Protected method | DoExecute | 执行协议。 (Overrides CommunicationClientBase..::..DoExecute(Byte, IProtocol, Boolean).)
Public method | Execute(IBroadcastProtocol) | 执行无返回值的广播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute(IMulticastProtocol) | 执行无返回值的组播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute(Byte, IUnicastProtocol) | 执行无返回值的单播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(IBroadcastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的广播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(IMulticastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的组播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(Byte, IUnicastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的单播协议。 (Inherited from CommunicationClientBase.)
Protected method | Finalize | 释放非托管资源。 (Overrides Object..::..Finalize()()()().)
Protected method | OnConnectedChanged | 引发连接状态更改事件。 (Inherited from CommunicationClientBase.)
Protected method | OnConnectionError | 引发通讯连接出错事件。 (Inherited from CommunicationClientBase.)
Protected method | OnInterceptorPrefixReceived | 引发协议前缀收到事件。 (Inherited from CommunicationClientBase.)
Protected method | OnInterceptorSuffixReceived | 引发协议后缀收到事件。 (Inherited from CommunicationClientBase.)

See Also

SerialPortClient Class
Ptl.Device.Communication Namespace


SerialPortClient.Dispose Method

[image] [image]

Pick To Light 设备通讯类库
SerialPortClient..::..Dispose Method
SerialPortClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。 (Inherited from CommunicationClientBase.)
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。 (Overrides CommunicationClientBase..::..Dispose(Boolean).)

See Also

SerialPortClient Class
SerialPortClient Members
Ptl.Device.Communication Namespace


SerialPortClient.Dispose Method (Boolean)

[image]

Pick To Light 设备通讯类库
SerialPortClient..::..Dispose Method (Boolean)
SerialPortClient Class See Also Send Feedback
释放非托管资源并可选地释放托管资源。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: System..::..Boolean
是否释放托管资源。

See Also

SerialPortClient Class
SerialPortClient Members
Dispose Overload
Ptl.Device.Communication Namespace


SerialPortClient.DoExecute Method

[image]

Pick To Light 设备通讯类库
SerialPortClient..::..DoExecute Method
SerialPortClient Class See Also Send Feedback
执行协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected override byte[] DoExecute(
    byte address,
    IProtocol protocol,
    bool hasResponse
)
Visual Basic
Protected Overrides Function DoExecute (
    address As Byte,
    protocol As IProtocol,
    hasResponse As Boolean
) As Byte()

Parameters

address
Type: System..::..Byte
设备地址。
protocol
Type: Ptl.Device.Communication.Protocol..::..IProtocol
协议。
hasResponse
Type: System..::..Boolean
设备是否有返回。

Return Value

Type: array< Byte >[]()[][]
设备有返回时的返回值。

See Also

SerialPortClient Class
SerialPortClient Members
Ptl.Device.Communication Namespace


SerialPortClient.Finalize Method

[image]

Pick To Light 设备通讯类库
SerialPortClient..::..Finalize Method
SerialPortClient Class See Also Send Feedback
释放非托管资源。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize

See Also

SerialPortClient Class
SerialPortClient Members
Ptl.Device.Communication Namespace


SerialPortClient Properties

[image] [image]

Pick To Light 设备通讯类库
SerialPortClient Properties
SerialPortClient Class See Also Send Feedback

The SerialPortClient type exposes the following members.

Properties

 | Name | Description
Public property | BaudRate | 获取波特率。
Public property | Connected | 获取是否处于已连接状态。 (Inherited from CommunicationClientBase.)
Public property | DataBits | 获取数据位数。
Public property | InterframeDelay | 获取帧间延时，用于无返回值的命令之后。
Public property | Name | 返回串口名称。 (Overrides CommunicationClientBase..::..Name.)
Public property | Parity | 获取奇偶校验位。
Public property | PortName | 获取串口名。
Public property | ProtocolInterceptor | 获取或设置协议拦截器。 (Inherited from CommunicationClientBase.)
Public property | ReadTimeout | 获取读取超时时间。
Public property | StopBits | 获取停止位数。
Public property | WriteTimeout | 获取写入超时时间。

See Also

SerialPortClient Class
Ptl.Device.Communication Namespace


SerialPortClient.BaudRate Property

[image]

Pick To Light 设备通讯类库
SerialPortClient..::..BaudRate Property
SerialPortClient Class See Also Send Feedback
获取波特率。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int BaudRate { get; }
Visual Basic
Public ReadOnly Property BaudRate As Integer
    Get

Property Value

Type: Int32

See Also

SerialPortClient Class
SerialPortClient Members
Ptl.Device.Communication Namespace


SerialPortClient.DataBits Property

[image]

Pick To Light 设备通讯类库
SerialPortClient..::..DataBits Property
SerialPortClient Class See Also Send Feedback
获取数据位数。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int DataBits { get; }
Visual Basic
Public ReadOnly Property DataBits As Integer
    Get

Property Value

Type: Int32

See Also

SerialPortClient Class
SerialPortClient Members
Ptl.Device.Communication Namespace


SerialPortClient.InterframeDelay Property

[image]

Pick To Light 设备通讯类库
SerialPortClient..::..InterframeDelay Property
SerialPortClient Class See Also Send Feedback
获取帧间延时，用于无返回值的命令之后。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int InterframeDelay { get; }
Visual Basic
Public ReadOnly Property InterframeDelay As Integer
    Get

Property Value

Type: Int32

See Also

SerialPortClient Class
SerialPortClient Members
Ptl.Device.Communication Namespace


SerialPortClient.Name Property

[image]

Pick To Light 设备通讯类库
SerialPortClient..::..Name Property
SerialPortClient Class See Also Send Feedback
返回串口名称。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get

Property Value

Type: String

Implements

ICommunicationClient..::..Name

See Also

SerialPortClient Class
SerialPortClient Members
Ptl.Device.Communication Namespace


SerialPortClient.Parity Property

[image]

Pick To Light 设备通讯类库
SerialPortClient..::..Parity Property
SerialPortClient Class See Also Send Feedback
获取奇偶校验位。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Parity Parity { get; }
Visual Basic
Public ReadOnly Property Parity As Parity
    Get

Property Value

Type: Parity

See Also

SerialPortClient Class
SerialPortClient Members
Ptl.Device.Communication Namespace


SerialPortClient.PortName Property

[image]

Pick To Light 设备通讯类库
SerialPortClient..::..PortName Property
SerialPortClient Class See Also Send Feedback
获取串口名。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string PortName { get; }
Visual Basic
Public ReadOnly Property PortName As String
    Get

Property Value

Type: String

See Also

SerialPortClient Class
SerialPortClient Members
Ptl.Device.Communication Namespace


SerialPortClient.ReadTimeout Property

[image]

Pick To Light 设备通讯类库
SerialPortClient..::..ReadTimeout Property
SerialPortClient Class See Also Send Feedback
获取读取超时时间。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int ReadTimeout { get; }
Visual Basic
Public ReadOnly Property ReadTimeout As Integer
    Get

Property Value

Type: Int32

See Also

SerialPortClient Class
SerialPortClient Members
Ptl.Device.Communication Namespace


SerialPortClient.StopBits Property

[image]

Pick To Light 设备通讯类库
SerialPortClient..::..StopBits Property
SerialPortClient Class See Also Send Feedback
获取停止位数。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public StopBits StopBits { get; }
Visual Basic
Public ReadOnly Property StopBits As StopBits
    Get

Property Value

Type: StopBits

See Also

SerialPortClient Class
SerialPortClient Members
Ptl.Device.Communication Namespace


SerialPortClient.WriteTimeout Property

[image]

Pick To Light 设备通讯类库
SerialPortClient..::..WriteTimeout Property
SerialPortClient Class See Also Send Feedback
获取写入超时时间。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int WriteTimeout { get; }
Visual Basic
Public ReadOnly Property WriteTimeout As Integer
    Get

Property Value

Type: Int32

See Also

SerialPortClient Class
SerialPortClient Members
Ptl.Device.Communication Namespace


SerialPortClient Events

[image] [image]

Pick To Light 设备通讯类库
SerialPortClient Events
SerialPortClient Class See Also Send Feedback

The SerialPortClient type exposes the following members.

Events

 | Name | Description
Public event | ConnectedChanged | 连接状态更改事件。 (Inherited from CommunicationClientBase.)
Public event | ConnectionError | 通讯连接出错事件。 (Inherited from CommunicationClientBase.)
Public event | InterceptorPrefixReceived | 在拦截器收到协议前缀时引发。 (Inherited from CommunicationClientBase.)
Public event | InterceptorSuffixReceived | 在拦截器收到协议后缀时引发。 (Inherited from CommunicationClientBase.)

See Also

SerialPortClient Class
Ptl.Device.Communication Namespace


TcpTransparentClient Class

[image]

Pick To Light 设备通讯类库
TcpTransparentClient Class
Members See Also Send Feedback
TCP-RS232/485 透传通讯客户端。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public class TcpTransparentClient : CommunicationClientBase
Visual Basic
Public Class TcpTransparentClient
    Inherits CommunicationClientBase

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication..::..CommunicationClientBase
Ptl.Device.Communication..::..TcpTransparentClient

See Also

TcpTransparentClient Members
Ptl.Device.Communication Namespace


TcpTransparentClient Members

[image] [image]

Pick To Light 设备通讯类库
TcpTransparentClient Members
TcpTransparentClient Class Constructors Methods Properties Events See Also Send Feedback

The TcpTransparentClient type exposes the following members.

Constructors

 | Name | Description
Public method | TcpTransparentClient(IPEndPoint) | 初始化 TCP-RS232/485 透传通讯客户端。
Public method | TcpTransparentClient(IPEndPoint, Int32, Int32, Int32, Int32) | 初始化 TCP-RS232/485 透传通讯客户端。

Methods

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。 (Inherited from CommunicationClientBase.)
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。 (Overrides CommunicationClientBase..::..Dispose(Boolean).)
Protected method | DoExecute | 执行协议。 (Overrides CommunicationClientBase..::..DoExecute(Byte, IProtocol, Boolean).)
Public method | Execute(IBroadcastProtocol) | 执行无返回值的广播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute(IMulticastProtocol) | 执行无返回值的组播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute(Byte, IUnicastProtocol) | 执行无返回值的单播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(IBroadcastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的广播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(IMulticastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的组播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(Byte, IUnicastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的单播协议。 (Inherited from CommunicationClientBase.)
Protected method | Finalize | 释放非托管资源。 (Overrides Object..::..Finalize()()()().)
Protected method | OnConnectedChanged | 引发连接状态更改事件。 (Inherited from CommunicationClientBase.)
Protected method | OnConnectionError | 引发通讯连接出错事件。 (Inherited from CommunicationClientBase.)
Protected method | OnInterceptorPrefixReceived | 引发协议前缀收到事件。 (Inherited from CommunicationClientBase.)
Protected method | OnInterceptorSuffixReceived | 引发协议后缀收到事件。 (Inherited from CommunicationClientBase.)

Properties

 | Name | Description
Public property | Connected | 获取是否处于已连接状态。 (Inherited from CommunicationClientBase.)
Public property | ConnectTimeout | 获取连接超时时间。
Public property | InterframeDelay | 获取帧间延时，用于无返回值的命令之后。
Public property | IPEndPoint | 获取远程端 IP 终结点。
Public property | Name | 返回 IP 终结点。 (Overrides CommunicationClientBase..::..Name.)
Public property | ProtocolInterceptor | 获取或设置协议拦截器。 (Inherited from CommunicationClientBase.)
Public property | ReceiveTimeout | 获取接收超时时间。
Public property | SendTimeout | 获取发送超时时间。

Events

 | Name | Description
Public event | ConnectedChanged | 连接状态更改事件。 (Inherited from CommunicationClientBase.)
Public event | ConnectionError | 通讯连接出错事件。 (Inherited from CommunicationClientBase.)
Public event | InterceptorPrefixReceived | 在拦截器收到协议前缀时引发。 (Inherited from CommunicationClientBase.)
Public event | InterceptorSuffixReceived | 在拦截器收到协议后缀时引发。 (Inherited from CommunicationClientBase.)

See Also

TcpTransparentClient Class
Ptl.Device.Communication Namespace


TcpTransparentClient Constructor

[image] [image]

Pick To Light 设备通讯类库
TcpTransparentClient Constructor
TcpTransparentClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TcpTransparentClient(IPEndPoint) | 初始化 TCP-RS232/485 透传通讯客户端。
Public method | TcpTransparentClient(IPEndPoint, Int32, Int32, Int32, Int32) | 初始化 TCP-RS232/485 透传通讯客户端。

See Also

TcpTransparentClient Class
TcpTransparentClient Members
Ptl.Device.Communication Namespace


TcpTransparentClient Constructor (IPEndPoint)

[image]

Pick To Light 设备通讯类库
TcpTransparentClient Constructor (IPEndPoint)
TcpTransparentClient Class See Also Send Feedback
初始化 TCP-RS232/485 透传通讯客户端。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public TcpTransparentClient(
    IPEndPoint ipEndPoint
)
Visual Basic
Public Sub New (
    ipEndPoint As IPEndPoint
)

Parameters

ipEndPoint
Type: System.Net..::..IPEndPoint
IP 终结点。

See Also

TcpTransparentClient Class
TcpTransparentClient Members
TcpTransparentClient Overload
Ptl.Device.Communication Namespace


TcpTransparentClient Constructor (IPEndPoint, Int32, Int32, Int32, Int32)

[image]

Pick To Light 设备通讯类库
TcpTransparentClient Constructor (IPEndPoint, Int32, Int32, Int32, Int32)
TcpTransparentClient Class See Also Send Feedback
初始化 TCP-RS232/485 透传通讯客户端。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public TcpTransparentClient(
    IPEndPoint ipEndPoint,
    int connectTimeoutInMilliseconds,
    int sendTimeoutInMilliseconds,
    int receiveTimeoutInMilliseconds,
    int interframeDelayInMilliseconds
)
Visual Basic
Public Sub New (
    ipEndPoint As IPEndPoint,
    connectTimeoutInMilliseconds As Integer,
    sendTimeoutInMilliseconds As Integer,
    receiveTimeoutInMilliseconds As Integer,
    interframeDelayInMilliseconds As Integer
)

Parameters

ipEndPoint
Type: System.Net..::..IPEndPoint
IP 终结点。
connectTimeoutInMilliseconds
Type: System..::..Int32
连接超时时间。
sendTimeoutInMilliseconds
Type: System..::..Int32
发送超时时间。
receiveTimeoutInMilliseconds
Type: System..::..Int32
接收超时时间。
interframeDelayInMilliseconds
Type: System..::..Int32
帧间延时，用于无返回值的命令之后。

Exceptions

Exception | Condition
System..::..ArgumentNullException | ipEndPoint 为空。

See Also

TcpTransparentClient Class
TcpTransparentClient Members
TcpTransparentClient Overload
Ptl.Device.Communication Namespace


TcpTransparentClient Methods

[image] [image]

Pick To Light 设备通讯类库
TcpTransparentClient Methods
TcpTransparentClient Class See Also Send Feedback

The TcpTransparentClient type exposes the following members.

Methods

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。 (Inherited from CommunicationClientBase.)
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。 (Overrides CommunicationClientBase..::..Dispose(Boolean).)
Protected method | DoExecute | 执行协议。 (Overrides CommunicationClientBase..::..DoExecute(Byte, IProtocol, Boolean).)
Public method | Execute(IBroadcastProtocol) | 执行无返回值的广播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute(IMulticastProtocol) | 执行无返回值的组播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute(Byte, IUnicastProtocol) | 执行无返回值的单播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(IBroadcastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的广播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(IMulticastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的组播协议。 (Inherited from CommunicationClientBase.)
Public method | Execute<(Of <<'(TResult>)>>)(Byte, IUnicastProtocol<(Of <<'(TResult>)>>)) | 执行有返回值的单播协议。 (Inherited from CommunicationClientBase.)
Protected method | Finalize | 释放非托管资源。 (Overrides Object..::..Finalize()()()().)
Protected method | OnConnectedChanged | 引发连接状态更改事件。 (Inherited from CommunicationClientBase.)
Protected method | OnConnectionError | 引发通讯连接出错事件。 (Inherited from CommunicationClientBase.)
Protected method | OnInterceptorPrefixReceived | 引发协议前缀收到事件。 (Inherited from CommunicationClientBase.)
Protected method | OnInterceptorSuffixReceived | 引发协议后缀收到事件。 (Inherited from CommunicationClientBase.)

See Also

TcpTransparentClient Class
Ptl.Device.Communication Namespace


TcpTransparentClient.Dispose Method

[image] [image]

Pick To Light 设备通讯类库
TcpTransparentClient..::..Dispose Method
TcpTransparentClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | 释放托管和非托管资源。 (Inherited from CommunicationClientBase.)
Protected method | Dispose(Boolean) | 释放非托管资源并可选地释放托管资源。 (Overrides CommunicationClientBase..::..Dispose(Boolean).)

See Also

TcpTransparentClient Class
TcpTransparentClient Members
Ptl.Device.Communication Namespace


TcpTransparentClient.Dispose Method (Boolean)

[image]

Pick To Light 设备通讯类库
TcpTransparentClient..::..Dispose Method (Boolean)
TcpTransparentClient Class See Also Send Feedback
释放非托管资源并可选地释放托管资源。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: System..::..Boolean
是否释放托管资源。

See Also

TcpTransparentClient Class
TcpTransparentClient Members
Dispose Overload
Ptl.Device.Communication Namespace


TcpTransparentClient.DoExecute Method

[image]

Pick To Light 设备通讯类库
TcpTransparentClient..::..DoExecute Method
TcpTransparentClient Class See Also Send Feedback
执行协议。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected override byte[] DoExecute(
    byte address,
    IProtocol protocol,
    bool hasResponse
)
Visual Basic
Protected Overrides Function DoExecute (
    address As Byte,
    protocol As IProtocol,
    hasResponse As Boolean
) As Byte()

Parameters

address
Type: System..::..Byte
设备地址。
protocol
Type: Ptl.Device.Communication.Protocol..::..IProtocol
协议。
hasResponse
Type: System..::..Boolean
设备是否有返回。

Return Value

Type: array< Byte >[]()[][]
设备有返回时的返回值。

See Also

TcpTransparentClient Class
TcpTransparentClient Members
Ptl.Device.Communication Namespace


TcpTransparentClient.Finalize Method

[image]

Pick To Light 设备通讯类库
TcpTransparentClient..::..Finalize Method
TcpTransparentClient Class See Also Send Feedback
释放非托管资源。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize

See Also

TcpTransparentClient Class
TcpTransparentClient Members
Ptl.Device.Communication Namespace


TcpTransparentClient Properties

[image] [image]

Pick To Light 设备通讯类库
TcpTransparentClient Properties
TcpTransparentClient Class See Also Send Feedback

The TcpTransparentClient type exposes the following members.

Properties

 | Name | Description
Public property | Connected | 获取是否处于已连接状态。 (Inherited from CommunicationClientBase.)
Public property | ConnectTimeout | 获取连接超时时间。
Public property | InterframeDelay | 获取帧间延时，用于无返回值的命令之后。
Public property | IPEndPoint | 获取远程端 IP 终结点。
Public property | Name | 返回 IP 终结点。 (Overrides CommunicationClientBase..::..Name.)
Public property | ProtocolInterceptor | 获取或设置协议拦截器。 (Inherited from CommunicationClientBase.)
Public property | ReceiveTimeout | 获取接收超时时间。
Public property | SendTimeout | 获取发送超时时间。

See Also

TcpTransparentClient Class
Ptl.Device.Communication Namespace


TcpTransparentClient.ConnectTimeout Property

[image]

Pick To Light 设备通讯类库
TcpTransparentClient..::..ConnectTimeout Property
TcpTransparentClient Class See Also Send Feedback
获取连接超时时间。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int ConnectTimeout { get; }
Visual Basic
Public ReadOnly Property ConnectTimeout As Integer
    Get

Property Value

Type: Int32

See Also

TcpTransparentClient Class
TcpTransparentClient Members
Ptl.Device.Communication Namespace


TcpTransparentClient.InterframeDelay Property

[image]

Pick To Light 设备通讯类库
TcpTransparentClient..::..InterframeDelay Property
TcpTransparentClient Class See Also Send Feedback
获取帧间延时，用于无返回值的命令之后。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int InterframeDelay { get; }
Visual Basic
Public ReadOnly Property InterframeDelay As Integer
    Get

Property Value

Type: Int32

See Also

TcpTransparentClient Class
TcpTransparentClient Members
Ptl.Device.Communication Namespace


TcpTransparentClient.IPEndPoint Property

[image]

Pick To Light 设备通讯类库
TcpTransparentClient..::..IPEndPoint Property
TcpTransparentClient Class See Also Send Feedback
获取远程端 IP 终结点。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public IPEndPoint IPEndPoint { get; }
Visual Basic
Public ReadOnly Property IPEndPoint As IPEndPoint
    Get

Property Value

Type: IPEndPoint

See Also

TcpTransparentClient Class
TcpTransparentClient Members
Ptl.Device.Communication Namespace


TcpTransparentClient.Name Property

[image]

Pick To Light 设备通讯类库
TcpTransparentClient..::..Name Property
TcpTransparentClient Class See Also Send Feedback
返回 IP 终结点。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get

Property Value

Type: String

Implements

ICommunicationClient..::..Name

See Also

TcpTransparentClient Class
TcpTransparentClient Members
Ptl.Device.Communication Namespace


TcpTransparentClient.ReceiveTimeout Property

[image]

Pick To Light 设备通讯类库
TcpTransparentClient..::..ReceiveTimeout Property
TcpTransparentClient Class See Also Send Feedback
获取接收超时时间。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int ReceiveTimeout { get; }
Visual Basic
Public ReadOnly Property ReceiveTimeout As Integer
    Get

Property Value

Type: Int32

See Also

TcpTransparentClient Class
TcpTransparentClient Members
Ptl.Device.Communication Namespace


TcpTransparentClient.SendTimeout Property

[image]

Pick To Light 设备通讯类库
TcpTransparentClient..::..SendTimeout Property
TcpTransparentClient Class See Also Send Feedback
获取发送超时时间。

Namespace: Ptl.Device.Communication
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int SendTimeout { get; }
Visual Basic
Public ReadOnly Property SendTimeout As Integer
    Get

Property Value

Type: Int32

See Also

TcpTransparentClient Class
TcpTransparentClient Members
Ptl.Device.Communication Namespace


TcpTransparentClient Events

[image] [image]

Pick To Light 设备通讯类库
TcpTransparentClient Events
TcpTransparentClient Class See Also Send Feedback

The TcpTransparentClient type exposes the following members.

Events

 | Name | Description
Public event | ConnectedChanged | 连接状态更改事件。 (Inherited from CommunicationClientBase.)
Public event | ConnectionError | 通讯连接出错事件。 (Inherited from CommunicationClientBase.)
Public event | InterceptorPrefixReceived | 在拦截器收到协议前缀时引发。 (Inherited from CommunicationClientBase.)
Public event | InterceptorSuffixReceived | 在拦截器收到协议后缀时引发。 (Inherited from CommunicationClientBase.)

See Also

TcpTransparentClient Class
Ptl.Device.Communication Namespace


Ptl.Device.Communication.Command Namespace

[image]

Pick To Light 设备通讯类库
Ptl.Device.Communication.Command Namespace
Send Feedback
设备控制时用到的枚举和基础类型。

Classes

 | Class | Description
Public class | CommandBase | 表示针对 PTL 设备和输入输出口的命令。
Public class | Display600UContent | 600U 的显示内容。
Public class | Display900UItem | 900U 的显示项。
Public class | F9InfraredTimeSensitivities | 红外时间灵敏度。
Public class | LightMode | 标签上 OK 按钮的亮灯模式。

Enumerations

 | Enumeration | Description
Public enumeration | Clear600UMode | 600U 的清空方式。
Public enumeration | Direction | 物品在标签的方向。
Public enumeration | DisplayAllTextType | 广播 DisplayAll 协议中指定的显示内容的类型。
Public enumeration | F1OkColorAfterPress | OK 按钮按下后的按钮灯色和文本保留。
Public enumeration | F3FnLongPressResult | 长按 Fn 键的结果。
Public enumeration | F4Display900UCommandType | 900U 显示命令的类型。
Public enumeration | F5OkColorAfterPress | 无任务时 OK 按钮按下后的按钮灯色。
Public enumeration | LightColor | 灯色。
Public enumeration | LightOnOffPeriod | 亮灭周期。
Public enumeration | LightOnOffRatio | 亮灭比例。
Public enumeration | SoundMode | 声音模式。
Public enumeration | SurfaceBackground | 彩屏标签背景。
Public enumeration | SurfacePicture | 彩屏标签图片。


Clear600UMode Enumeration

[image]

Pick To Light 设备通讯类库
Clear600UMode Enumeration
See Also Send Feedback
600U 的清空方式。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum Clear600UMode
Visual Basic
Public Enumeration Clear600UMode

Members

Member name | Value | Description
All | 0 | Obsolete. 所有。
FirstRow | 1 | Obsolete. 第一行。
SecondRow | 2 | Obsolete. 第二行。
Sound | 3 | 蜂鸣，暂不支持。
Button | 16 | 按钮事件缓存。

See Also

Ptl.Device.Communication.Command Namespace


CommandBase Class

[image]

Pick To Light 设备通讯类库
CommandBase Class
Members See Also Send Feedback
表示针对 PTL 设备和输入输出口的命令。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public abstract class CommandBase
Visual Basic
<SerializableAttribute>
Public MustInherit Class CommandBase

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication.Command..::..CommandBase

See Also

CommandBase Members
Ptl.Device.Communication.Command Namespace


CommandBase Members

[image] [image]

Pick To Light 设备通讯类库
CommandBase Members
CommandBase Class Constructors See Also Send Feedback

The CommandBase type exposes the following members.

Constructors

 | Name | Description
Protected method | CommandBase | Initializes a new instance of the CommandBase class

See Also

CommandBase Class
Ptl.Device.Communication.Command Namespace


CommandBase Constructor

[image]

Pick To Light 设备通讯类库
CommandBase Constructor
CommandBase Class See Also Send Feedback
Initializes a new instance of the CommandBase class

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
protected CommandBase()
Visual Basic
Protected Sub New

See Also

CommandBase Class
CommandBase Members
Ptl.Device.Communication.Command Namespace


Direction Enumeration

[image]

Pick To Light 设备通讯类库
Direction Enumeration
See Also Send Feedback
物品在标签的方向。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum Direction
Visual Basic
Public Enumeration Direction

Members

Member name | Value | Description
None | 0 | 不启用。
Center | 1 | 中间。
Top | 2 | 上方。
TopRight | 3 | 右上角。
Right | 4 | 右边。
BottomRight | 5 | 右下角。
Bottom | 6 | 下方。
BottomLeft | 7 | 左下角。
Left | 8 | 左边。
TopLeft | 9 | 左上角。

See Also

Ptl.Device.Communication.Command Namespace


Display600UContent Class

[image]

Pick To Light 设备通讯类库
Display600UContent Class
Members See Also Send Feedback
600U 的显示内容。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class Display600UContent
Visual Basic
<SerializableAttribute>
Public Class Display600UContent

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication.Command..::..Display600UContent

See Also

Display600UContent Members
Ptl.Device.Communication.Command Namespace


Display600UContent Members

[image] [image]

Pick To Light 设备通讯类库
Display600UContent Members
Display600UContent Class Constructors Properties See Also Send Feedback

The Display600UContent type exposes the following members.

Constructors

 | Name | Description
Public method | Display600UContent | Initializes a new instance of the Display600UContent class

Properties

 | Name | Description
Public property | Background | 获取或设置彩屏背景。
Public property | Description | 获取或设置描述，可中文。
Public property | Picture | 获取或设置图片。
Public property | RowIndex | 获取或设置基于 0 的行序号，用于多行点阵标签。
Public property | SubTitle | 获取或设置副标题，可中文。
Public property | Tag | 获取或设置相关联数据。
Public property | Text | 获取或设置 ASCII 文本。
Public property | Title | 获取或设置标题，可中文。

See Also

Display600UContent Class
Ptl.Device.Communication.Command Namespace


Display600UContent Constructor

[image]

Pick To Light 设备通讯类库
Display600UContent Constructor
Display600UContent Class See Also Send Feedback
Initializes a new instance of the Display600UContent class

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Display600UContent()
Visual Basic
Public Sub New

See Also

Display600UContent Class
Display600UContent Members
Ptl.Device.Communication.Command Namespace


Display600UContent Properties

[image] [image]

Pick To Light 设备通讯类库
Display600UContent Properties
Display600UContent Class See Also Send Feedback

The Display600UContent type exposes the following members.

Properties

 | Name | Description
Public property | Background | 获取或设置彩屏背景。
Public property | Description | 获取或设置描述，可中文。
Public property | Picture | 获取或设置图片。
Public property | RowIndex | 获取或设置基于 0 的行序号，用于多行点阵标签。
Public property | SubTitle | 获取或设置副标题，可中文。
Public property | Tag | 获取或设置相关联数据。
Public property | Text | 获取或设置 ASCII 文本。
Public property | Title | 获取或设置标题，可中文。

See Also

Display600UContent Class
Ptl.Device.Communication.Command Namespace


Display600UContent.Background Property

[image]

Pick To Light 设备通讯类库
Display600UContent..::..Background Property
Display600UContent Class See Also Send Feedback
获取或设置彩屏背景。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public SurfaceBackground Background { get; set; }
Visual Basic
Public Property Background As SurfaceBackground
    Get
    Set

Property Value

Type: SurfaceBackground

See Also

Display600UContent Class
Display600UContent Members
Ptl.Device.Communication.Command Namespace


Display600UContent.Description Property

[image]

Pick To Light 设备通讯类库
Display600UContent..::..Description Property
Display600UContent Class See Also Send Feedback
获取或设置描述，可中文。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String
为空时会被 System.String.Empty 取代，超出长度会被截断。

See Also

Display600UContent Class
Display600UContent Members
Ptl.Device.Communication.Command Namespace


Display600UContent.Picture Property

[image]

Pick To Light 设备通讯类库
Display600UContent..::..Picture Property
Display600UContent Class See Also Send Feedback
获取或设置图片。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public SurfacePicture Picture { get; set; }
Visual Basic
Public Property Picture As SurfacePicture
    Get
    Set

Property Value

Type: SurfacePicture

Remarks

此属性本质上是一组图片的索引，值域为 [0, 255]。

See Also

Display600UContent Class
Display600UContent Members
Ptl.Device.Communication.Command Namespace


Display600UContent.RowIndex Property

[image]

Pick To Light 设备通讯类库
Display600UContent..::..RowIndex Property
Display600UContent Class See Also Send Feedback
获取或设置基于 0 的行序号，用于多行点阵标签。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte RowIndex { get; set; }
Visual Basic
Public Property RowIndex As Byte
    Get
    Set

Property Value

Type: Byte

See Also

Display600UContent Class
Display600UContent Members
Ptl.Device.Communication.Command Namespace


Display600UContent.SubTitle Property

[image]

Pick To Light 设备通讯类库
Display600UContent..::..SubTitle Property
Display600UContent Class See Also Send Feedback
获取或设置副标题，可中文。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string SubTitle { get; set; }
Visual Basic
Public Property SubTitle As String
    Get
    Set

Property Value

Type: String
为空时会被 System.String.Empty 取代，超出长度会被截断。

See Also

Display600UContent Class
Display600UContent Members
Ptl.Device.Communication.Command Namespace


Display600UContent.Tag Property

[image]

Pick To Light 设备通讯类库
Display600UContent..::..Tag Property
Display600UContent Class See Also Send Feedback
获取或设置相关联数据。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Object Tag { get; set; }
Visual Basic
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object

See Also

Display600UContent Class
Display600UContent Members
Ptl.Device.Communication.Command Namespace


Display600UContent.Text Property

[image]

Pick To Light 设备通讯类库
Display600UContent..::..Text Property
Display600UContent Class See Also Send Feedback
获取或设置 ASCII 文本。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set

Property Value

Type: String
为空时会被 System.String.Empty 取代，超出长度会被截断。

See Also

Display600UContent Class
Display600UContent Members
Ptl.Device.Communication.Command Namespace


Display600UContent.Title Property

[image]

Pick To Light 设备通讯类库
Display600UContent..::..Title Property
Display600UContent Class See Also Send Feedback
获取或设置标题，可中文。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set

Property Value

Type: String
为空时会被 System.String.Empty 取代，超出长度会被截断。

See Also

Display600UContent Class
Display600UContent Members
Ptl.Device.Communication.Command Namespace


Display900UItem Class

[image]

Pick To Light 设备通讯类库
Display900UItem Class
Members See Also Send Feedback
900U 的显示项。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class Display900UItem
Visual Basic
<SerializableAttribute>
Public Class Display900UItem

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication.Command..::..Display900UItem

See Also

Display900UItem Members
Ptl.Device.Communication.Command Namespace


Display900UItem Members

[image] [image]

Pick To Light 设备通讯类库
Display900UItem Members
Display900UItem Class Constructors Properties See Also Send Feedback

The Display900UItem type exposes the following members.

Constructors

 | Name | Description
Public method | Display900UItem | Initializes a new instance of the Display900UItem class

Properties

 | Name | Description
Public property | BatchCode | 获取或设置批号，常用于 H424 的前段。
Public property | Count | 获取或设置数量。
Public property | Description | 获取或设置描述，可中文。
Public property | Direction | 获取或设置物品相对于标签的方向。
Public property | LongSubLocation | 获取或设置长行列码，最多 4 个 ASCII 字符。
Public property | Name | 获取或设置品名，可中文。
Public property | SubLocation | 获取或设置行列码，十六进制显示。
Public property | Tag | 获取或设置相关联数据。
Public property | Unit | 获取或设置单位，可中文。

See Also

Display900UItem Class
Ptl.Device.Communication.Command Namespace


Display900UItem Constructor

[image]

Pick To Light 设备通讯类库
Display900UItem Constructor
Display900UItem Class See Also Send Feedback
Initializes a new instance of the Display900UItem class

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Display900UItem()
Visual Basic
Public Sub New

See Also

Display900UItem Class
Display900UItem Members
Ptl.Device.Communication.Command Namespace


Display900UItem Properties

[image] [image]

Pick To Light 设备通讯类库
Display900UItem Properties
Display900UItem Class See Also Send Feedback

The Display900UItem type exposes the following members.

Properties

 | Name | Description
Public property | BatchCode | 获取或设置批号，常用于 H424 的前段。
Public property | Count | 获取或设置数量。
Public property | Description | 获取或设置描述，可中文。
Public property | Direction | 获取或设置物品相对于标签的方向。
Public property | LongSubLocation | 获取或设置长行列码，最多 4 个 ASCII 字符。
Public property | Name | 获取或设置品名，可中文。
Public property | SubLocation | 获取或设置行列码，十六进制显示。
Public property | Tag | 获取或设置相关联数据。
Public property | Unit | 获取或设置单位，可中文。

See Also

Display900UItem Class
Ptl.Device.Communication.Command Namespace


Display900UItem.BatchCode Property

[image]

Pick To Light 设备通讯类库
Display900UItem..::..BatchCode Property
Display900UItem Class See Also Send Feedback
获取或设置批号，常用于 H424 的前段。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string BatchCode { get; set; }
Visual Basic
Public Property BatchCode As String
    Get
    Set

Property Value

Type: String
为空时会被 System.String.Empty 取代，超出长度会被截断。

See Also

Display900UItem Class
Display900UItem Members
Ptl.Device.Communication.Command Namespace


Display900UItem.Count Property

[image]

Pick To Light 设备通讯类库
Display900UItem..::..Count Property
Display900UItem Class See Also Send Feedback
获取或设置数量。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public ushort Count { get; set; }
Visual Basic
Public Property Count As UShort
    Get
    Set

Property Value

Type: UInt16

See Also

Display900UItem Class
Display900UItem Members
Ptl.Device.Communication.Command Namespace


Display900UItem.Description Property

[image]

Pick To Light 设备通讯类库
Display900UItem..::..Description Property
Display900UItem Class See Also Send Feedback
获取或设置描述，可中文。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Property Value

Type: String
为空时会被 System.String.Empty 取代，超出长度会被截断。

See Also

Display900UItem Class
Display900UItem Members
Ptl.Device.Communication.Command Namespace


Display900UItem.Direction Property

[image]

Pick To Light 设备通讯类库
Display900UItem..::..Direction Property
Display900UItem Class See Also Send Feedback
获取或设置物品相对于标签的方向。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Direction Direction { get; set; }
Visual Basic
Public Property Direction As Direction
    Get
    Set

Property Value

Type: Direction

Remarks

此属性本质上是一组图片的索引，值域为 [0, 255]； 其中 0~9 已在 Direction 枚举中定义，另外还有：16-多规，17-看似，18-听似，19-看听。

See Also

Display900UItem Class
Display900UItem Members
Ptl.Device.Communication.Command Namespace


Display900UItem.LongSubLocation Property

[image]

Pick To Light 设备通讯类库
Display900UItem..::..LongSubLocation Property
Display900UItem Class See Also Send Feedback
获取或设置长行列码，最多 4 个 ASCII 字符。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string LongSubLocation { get; set; }
Visual Basic
Public Property LongSubLocation As String
    Get
    Set

Property Value

Type: String
为空时会被 System.String.Empty 取代，超出长度会被截断，长度不足后补空格。

See Also

Display900UItem Class
Display900UItem Members
Ptl.Device.Communication.Command Namespace


Display900UItem.Name Property

[image]

Pick To Light 设备通讯类库
Display900UItem..::..Name Property
Display900UItem Class See Also Send Feedback
获取或设置品名，可中文。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String
为空时会被 System.String.Empty 取代，超出长度会被截断。

See Also

Display900UItem Class
Display900UItem Members
Ptl.Device.Communication.Command Namespace


Display900UItem.SubLocation Property

[image]

Pick To Light 设备通讯类库
Display900UItem..::..SubLocation Property
Display900UItem Class See Also Send Feedback
获取或设置行列码，十六进制显示。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte SubLocation { get; set; }
Visual Basic
Public Property SubLocation As Byte
    Get
    Set

Property Value

Type: Byte

Remarks

空白使用 Ptl900U.EmptySubLocation = 0xFF 表示。

See Also

Display900UItem Class
Display900UItem Members
Ptl.Device.Communication.Command Namespace


Display900UItem.Tag Property

[image]

Pick To Light 设备通讯类库
Display900UItem..::..Tag Property
Display900UItem Class See Also Send Feedback
获取或设置相关联数据。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Object Tag { get; set; }
Visual Basic
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object

See Also

Display900UItem Class
Display900UItem Members
Ptl.Device.Communication.Command Namespace


Display900UItem.Unit Property

[image]

Pick To Light 设备通讯类库
Display900UItem..::..Unit Property
Display900UItem Class See Also Send Feedback
获取或设置单位，可中文。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Unit { get; set; }
Visual Basic
Public Property Unit As String
    Get
    Set

Property Value

Type: String
为空时会被 System.String.Empty 取代，超出长度会被截断，长度不足后补空格。

See Also

Display900UItem Class
Display900UItem Members
Ptl.Device.Communication.Command Namespace


DisplayAllTextType Enumeration

[image]

Pick To Light 设备通讯类库
DisplayAllTextType Enumeration
See Also Send Feedback
广播 DisplayAll 协议中指定的显示内容的类型。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum DisplayAllTextType
Visual Basic
Public Enumeration DisplayAllTextType

Members

Member name | Value | Description
Address | 0 | 地址。
F1OkColorAfterPress | 10001 | F1 值（OK 按钮按下后的按钮灯色）。
F2ProgressBarTimeSpan | 10002 | F2 值（多任务间的进度条时间）。
F3FnLongPressResult | 10003 | F3 值（长按 Fn 键的结果）。
F4Display900UCommandType | 10004 | F4 值（900U 显示协议的类型）。
F5OkColorAfterPress | 10005 | F5 值（无任务时 OK 按钮按下后的按钮灯色）。
F6TouchSensitivity | 10006 | F6 值（触摸灵敏度）。
F7InfraredDistanceSensitivity | 10007 | F7 值（红外距离灵敏度）。
F8OkUsability | 10008 | F8 值（OK 按钮可用性）。
F9InfraredTimeSensitivities | 10009 | F7 值（红外时间灵敏度）。

See Also

Ptl.Device.Communication.Command Namespace


F1OkColorAfterPress Enumeration

[image]

Pick To Light 设备通讯类库
F1OkColorAfterPress Enumeration
See Also Send Feedback
OK 按钮按下后的按钮灯色和文本保留。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum F1OkColorAfterPress
Visual Basic
Public Enumeration F1OkColorAfterPress

Members

Member name | Value | Description
Off | 0 | 熄灭。
Red | 1 | 红色。
Green | 2 | 绿色。
Blue | 3 | 蓝色。
Yellow | 4 | 黄色。
Magenta | 5 | 品红。
Cyan | 6 | 青色。
White | 7 | 白色；因功耗限制，不推荐使用。
Text | 16 | 保留文本。
TextAndRed | 17 | 保留文本和红色。
TextAndGreen | 18 | 保留文本和绿色。
TextAndBlue | 19 | 保留文本和蓝色。
TextAndYellow | 20 | 保留文本和黄色。
TextAndMagenta | 21 | 保留文本和品红。
TextAndCyan | 22 | 保留文本和青色。
TextAndWhite | 23 | 保留文本和白色；因功耗限制，不推荐使用。

See Also

Ptl.Device.Communication.Command Namespace


F3FnLongPressResult Enumeration

[image]

Pick To Light 设备通讯类库
F3FnLongPressResult Enumeration
See Also Send Feedback
长按 Fn 键的结果。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum F3FnLongPressResult
Visual Basic
Public Enumeration F3FnLongPressResult

Members

Member name | Value | Description
None | 0 | 未设置。
Break | 1 | 显示进度条并中断后备任务的显示。

See Also

Ptl.Device.Communication.Command Namespace


F4Display900UCommandType Enumeration

[image]

Pick To Light 设备通讯类库
F4Display900UCommandType Enumeration
See Also Send Feedback
900U 显示命令的类型。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum F4Display900UCommandType
Visual Basic
Public Enumeration F4Display900UCommandType

Members

Member name | Value | Description
Task | 0 | 常规任务型。
Text | 1 | 文本型，即被当作 Ptl900UType.H424 并显示 Display900UItem.BatchCode。
ExtendedCount | 2 | 数码管标签行列码位置被扩展到数量。
SingleTaskVertical | 16 | 中文标签单任务竖屏。
DoubleTaskHorizontal | 32 | 中文标签双任务横屏。
DoubleTaskVertical | 48 | 中文标签双任务竖屏。

See Also

Ptl.Device.Communication.Command Namespace


F5OkColorAfterPress Enumeration

[image]

Pick To Light 设备通讯类库
F5OkColorAfterPress Enumeration
See Also Send Feedback
无任务时 OK 按钮按下后的按钮灯色。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum F5OkColorAfterPress
Visual Basic
Public Enumeration F5OkColorAfterPress

Members

Member name | Value | Description
Off | 0 | 熄灭。
Red | 1 | 红色。
Green | 2 | 绿色。
Blue | 3 | 蓝色。
Yellow | 4 | 黄色。
Magenta | 5 | 品红。
Cyan | 6 | 青色。
White | 7 | 白色；因功耗限制，不推荐使用。
DifferentFromTheLatest | 8 | 不同于最近出现的灯色。

See Also

Ptl.Device.Communication.Command Namespace


F9InfraredTimeSensitivities Class

[image]

Pick To Light 设备通讯类库
F9InfraredTimeSensitivities Class
Members See Also Send Feedback
红外时间灵敏度。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class F9InfraredTimeSensitivities
Visual Basic
<SerializableAttribute>
Public Class F9InfraredTimeSensitivities

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication.Command..::..F9InfraredTimeSensitivities

See Also

F9InfraredTimeSensitivities Members
Ptl.Device.Communication.Command Namespace


F9InfraredTimeSensitivities Members

[image] [image]

Pick To Light 设备通讯类库
F9InfraredTimeSensitivities Members
F9InfraredTimeSensitivities Class Constructors Properties See Also Send Feedback

The F9InfraredTimeSensitivities type exposes the following members.

Constructors

 | Name | Description
Public method | F9InfraredTimeSensitivities | Initializes a new instance of the F9InfraredTimeSensitivities class

Properties

 | Name | Description
Public property | EnterSensitivity | 获取或设置进入遮挡灵敏度。
Public property | ExitSensitivity | 获取或设置离开无遮挡灵敏度。

See Also

F9InfraredTimeSensitivities Class
Ptl.Device.Communication.Command Namespace


F9InfraredTimeSensitivities Constructor

[image]

Pick To Light 设备通讯类库
F9InfraredTimeSensitivities Constructor
F9InfraredTimeSensitivities Class See Also Send Feedback
Initializes a new instance of the F9InfraredTimeSensitivities class

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public F9InfraredTimeSensitivities()
Visual Basic
Public Sub New

See Also

F9InfraredTimeSensitivities Class
F9InfraredTimeSensitivities Members
Ptl.Device.Communication.Command Namespace


F9InfraredTimeSensitivities Properties

[image] [image]

Pick To Light 设备通讯类库
F9InfraredTimeSensitivities Properties
F9InfraredTimeSensitivities Class See Also Send Feedback

The F9InfraredTimeSensitivities type exposes the following members.

Properties

 | Name | Description
Public property | EnterSensitivity | 获取或设置进入遮挡灵敏度。
Public property | ExitSensitivity | 获取或设置离开无遮挡灵敏度。

See Also

F9InfraredTimeSensitivities Class
Ptl.Device.Communication.Command Namespace


F9InfraredTimeSensitivities.EnterSensitivity Property

[image]

Pick To Light 设备通讯类库
F9InfraredTimeSensitivities..::..EnterSensitivity Property
F9InfraredTimeSensitivities Class See Also Send Feedback
获取或设置进入遮挡灵敏度。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte EnterSensitivity { get; set; }
Visual Basic
Public Property EnterSensitivity As Byte
    Get
    Set

Property Value

Type: Byte
取值范围：0~9；超出范围会被截断。

See Also

F9InfraredTimeSensitivities Class
F9InfraredTimeSensitivities Members
Ptl.Device.Communication.Command Namespace


F9InfraredTimeSensitivities.ExitSensitivity Property

[image]

Pick To Light 设备通讯类库
F9InfraredTimeSensitivities..::..ExitSensitivity Property
F9InfraredTimeSensitivities Class See Also Send Feedback
获取或设置离开无遮挡灵敏度。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte ExitSensitivity { get; set; }
Visual Basic
Public Property ExitSensitivity As Byte
    Get
    Set

Property Value

Type: Byte
取值范围：0~9；超出范围会被截断。

See Also

F9InfraredTimeSensitivities Class
F9InfraredTimeSensitivities Members
Ptl.Device.Communication.Command Namespace


LightColor Enumeration

[image]

Pick To Light 设备通讯类库
LightColor Enumeration
See Also Send Feedback
灯色。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum LightColor
Visual Basic
Public Enumeration LightColor

Members

Member name | Value | Description
Off | 0 | 不亮。
Red | 32 | 红色。
Green | 64 | 绿色。
Blue | 96 | 蓝色。
Yellow | 128 | 黄色。
Magenta | 160 | 品红。
Cyan | 192 | 青色。
White | 224 | 白色；因功耗限制，不推荐使用。

See Also

Ptl.Device.Communication.Command Namespace


LightMode Class

[image]

Pick To Light 设备通讯类库
LightMode Class
Members See Also Send Feedback
标签上 OK 按钮的亮灯模式。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class LightMode
Visual Basic
<SerializableAttribute>
Public Class LightMode

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication.Command..::..LightMode

See Also

LightMode Members
Ptl.Device.Communication.Command Namespace


LightMode Members

[image] [image]

Pick To Light 设备通讯类库
LightMode Members
LightMode Class Constructors Methods Properties See Also Send Feedback

The LightMode type exposes the following members.

Constructors

 | Name | Description
Public method | LightMode | Initializes a new instance of the LightMode class

Methods

 | Name | Description
 | FromByte | 从指定字节中解析亮灯模式。
Public method | ToByte | 转换成单个字节。

Properties

 | Name | Description
Public property | Color | 获取或设置灯色。
 | Default | 默认模式，即不亮。
Public property | Period | 获取或设置亮灭周期。
Public property | Ratio | 获取或设置亮灭比例。

See Also

LightMode Class
Ptl.Device.Communication.Command Namespace


LightMode Constructor

[image]

Pick To Light 设备通讯类库
LightMode Constructor
LightMode Class See Also Send Feedback
Initializes a new instance of the LightMode class

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public LightMode()
Visual Basic
Public Sub New

See Also

LightMode Class
LightMode Members
Ptl.Device.Communication.Command Namespace


LightMode Methods

[image] [image]

Pick To Light 设备通讯类库
LightMode Methods
LightMode Class See Also Send Feedback

The LightMode type exposes the following members.

Methods

 | Name | Description
 | FromByte | 从指定字节中解析亮灯模式。
Public method | ToByte | 转换成单个字节。

See Also

LightMode Class
Ptl.Device.Communication.Command Namespace


LightMode.FromByte Method

[image]

Pick To Light 设备通讯类库
LightMode..::..FromByte Method
LightMode Class See Also Send Feedback
从指定字节中解析亮灯模式。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static LightMode FromByte(
    byte data
)
Visual Basic
Public Shared Function FromByte (
    data As Byte
) As LightMode

Parameters

data
Type: System..::..Byte
高三位：LightColor，中两位：LightOnOffPerio，第三位：LightOnOffRatio。

Return Value

Type: LightMode
亮灯模式。

See Also

LightMode Class
LightMode Members
Ptl.Device.Communication.Command Namespace


LightMode.ToByte Method

[image]

Pick To Light 设备通讯类库
LightMode..::..ToByte Method
LightMode Class See Also Send Feedback
转换成单个字节。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte ToByte()
Visual Basic
Public Function ToByte As Byte

Return Value

Type: Byte
高三位：LightColor，中两位：LightOnOffPerio，第三位：LightOnOffRatio。

See Also

LightMode Class
LightMode Members
Ptl.Device.Communication.Command Namespace


LightMode Properties

[image] [image]

Pick To Light 设备通讯类库
LightMode Properties
LightMode Class See Also Send Feedback

The LightMode type exposes the following members.

Properties

 | Name | Description
Public property | Color | 获取或设置灯色。
 | Default | 默认模式，即不亮。
Public property | Period | 获取或设置亮灭周期。
Public property | Ratio | 获取或设置亮灭比例。

See Also

LightMode Class
Ptl.Device.Communication.Command Namespace


LightMode.Color Property

[image]

Pick To Light 设备通讯类库
LightMode..::..Color Property
LightMode Class See Also Send Feedback
获取或设置灯色。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public LightColor Color { get; set; }
Visual Basic
Public Property Color As LightColor
    Get
    Set

Property Value

Type: LightColor

See Also

LightMode Class
LightMode Members
Ptl.Device.Communication.Command Namespace


LightMode.Default Property

[image]

Pick To Light 设备通讯类库
LightMode..::..Default Property
LightMode Class See Also Send Feedback
默认模式，即不亮。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static LightMode Default { get; }
Visual Basic
Public Shared ReadOnly Property Default As LightMode
    Get

Property Value

Type: LightMode

See Also

LightMode Class
LightMode Members
Ptl.Device.Communication.Command Namespace


LightMode.Period Property

[image]

Pick To Light 设备通讯类库
LightMode..::..Period Property
LightMode Class See Also Send Feedback
获取或设置亮灭周期。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public LightOnOffPeriod Period { get; set; }
Visual Basic
Public Property Period As LightOnOffPeriod
    Get
    Set

Property Value

Type: LightOnOffPeriod

See Also

LightMode Class
LightMode Members
Ptl.Device.Communication.Command Namespace


LightMode.Ratio Property

[image]

Pick To Light 设备通讯类库
LightMode..::..Ratio Property
LightMode Class See Also Send Feedback
获取或设置亮灭比例。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public LightOnOffRatio Ratio { get; set; }
Visual Basic
Public Property Ratio As LightOnOffRatio
    Get
    Set

Property Value

Type: LightOnOffRatio

See Also

LightMode Class
LightMode Members
Ptl.Device.Communication.Command Namespace


LightOnOffPeriod Enumeration

[image]

Pick To Light 设备通讯类库
LightOnOffPeriod Enumeration
See Also Send Feedback
亮灭周期。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum LightOnOffPeriod
Visual Basic
Public Enumeration LightOnOffPeriod

Members

Member name | Value | Description
Period100 | 0 | 100 ms。
Period200 | 8 | 200 ms。
Period500 | 16 | 500 ms。
Period1000 | 24 | 1000 ms。

See Also

Ptl.Device.Communication.Command Namespace


LightOnOffRatio Enumeration

[image]

Pick To Light 设备通讯类库
LightOnOffRatio Enumeration
See Also Send Feedback
亮灭比例。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum LightOnOffRatio
Visual Basic
Public Enumeration LightOnOffRatio

Members

Member name | Value | Description
RatioP1V0 | 0 | 不闪烁。
RatioP1V1 | 1 | 亮 1 灭 1。
RatioP1V2 | 2 | 亮 1 灭 2。
RatioP1V5 | 3 | 亮 1 灭 5。
RatioP1V10 | 4 | 亮 1 灭 10。
RatioP2V1 | 5 | 亮 2 灭 1。
RatioP5V1 | 6 | 亮 5 灭 1。
RatioP10V1 | 7 | 亮 10 灭 1。

See Also

Ptl.Device.Communication.Command Namespace


SoundMode Enumeration

[image]

Pick To Light 设备通讯类库
SoundMode Enumeration
See Also Send Feedback
声音模式。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum SoundMode
Visual Basic
Public Enumeration SoundMode

Members

Member name | Value | Description
Silent | 0 | 无声。

See Also

Ptl.Device.Communication.Command Namespace


SurfaceBackground Enumeration

[image]

Pick To Light 设备通讯类库
SurfaceBackground Enumeration
See Also Send Feedback
彩屏标签背景。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum SurfaceBackground
Visual Basic
Public Enumeration SurfaceBackground

Members

Member name | Value | Description
Default | 0 | 默认，蓝色背景图。
RedImage | 1 | 红色背景图。
GreenImage | 2 | 绿色背景图。
BlueImage | 3 | 蓝色背景图。
YellowImage | 4 | 黄色背景图。
MagentaImage | 5 | 品红背景图。
CyanImage | 6 | 青色背景图。
GrayImage | 7 | 灰色背景图。
Red | 16 | 红色。
Green | 32 | 绿色。
Blue | 48 | 蓝色。
Yellow | 64 | 黄色。
Magenta | 80 | 品红。
Cyan | 96 | 青色。
Gray | 112 | 灰色。

See Also

Ptl.Device.Communication.Command Namespace


SurfacePicture Enumeration

[image]

Pick To Light 设备通讯类库
SurfacePicture Enumeration
See Also Send Feedback
彩屏标签图片。

Namespace: Ptl.Device.Communication.Command
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum SurfacePicture
Visual Basic
Public Enumeration SurfacePicture

Members

Member name | Value | Description
None | 0 | 无图片。
Information | 1 | 一般信息。
Free | 2 | 空闲。
Orders | 3 | 订单。
User | 4 | 操作员。
LogOn | 5 | 登录。
LogOff | 6 | 注销。
BarCode | 7 | 条码。
QRCode | 8 | 二维码。
Card | 9 | 卡片。
Press | 10 | 按。
Cart | 11 | 购物车。
CartFull | 12 | 购物车满。
CartAdd | 13 | 添加购物车。
Back | 14 | 后退。
Forward | 15 | 前进。
Good | 16 | 好。
Timeout | 17 | 超时。
Assemble | 18 | 汇集。
Package | 19 | 打包。
Refresh | 20 | 刷新。
Lock | 21 | 锁定。
Unlock | 22 | 解锁。
Voice | 23 | 耳机声音。
VolumnOn | 24 | 音量开。
VolumnOff | 25 | 静音。
In | 26 | 入。
Out | 27 | 出。
CheckList | 28 | 核对。
Loop | 29 | 循环。

See Also

Ptl.Device.Communication.Command Namespace


Ptl.Device.Communication.Protocol Namespace

[image]

Pick To Light 设备通讯类库
Ptl.Device.Communication.Protocol Namespace
Send Feedback
下有多个子级命名空间分组定义了协议。

Interfaces

 | Interface | Description
Public interface | IProtocol | 表示无返回值的协议。
Public interface | IProtocol<(Of <(<'TResult>)>)> | 表示有返回值的协议。


IProtocol Interface

[image]

Pick To Light 设备通讯类库
IProtocol Interface
Members See Also Send Feedback
表示无返回值的协议。

Namespace: Ptl.Device.Communication.Protocol
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public interface IProtocol
Visual Basic
Public Interface IProtocol

See Also

IProtocol Members
Ptl.Device.Communication.Protocol Namespace


IProtocol Members

[image] [image]

Pick To Light 设备通讯类库
IProtocol Members
IProtocol Interface Methods See Also Send Feedback

The IProtocol type exposes the following members.

Methods

 | Name | Description
Public method | ToSendData | 协议信息转换到协议数据。

See Also

IProtocol Interface
Ptl.Device.Communication.Protocol Namespace


IProtocol Methods

[image] [image]

Pick To Light 设备通讯类库
IProtocol Methods
IProtocol Interface See Also Send Feedback

The IProtocol type exposes the following members.

Methods

 | Name | Description
Public method | ToSendData | 协议信息转换到协议数据。

See Also

IProtocol Interface
Ptl.Device.Communication.Protocol Namespace


IProtocol.ToSendData Method

[image]

Pick To Light 设备通讯类库
IProtocol..::..ToSendData Method
IProtocol Interface See Also Send Feedback
协议信息转换到协议数据。

Namespace: Ptl.Device.Communication.Protocol
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
byte[] ToSendData()
Visual Basic
Function ToSendData As Byte()

Return Value

Type: array< Byte >[]()[][]
协议数据，不包含地址和 CRC。

See Also

IProtocol Interface
IProtocol Members
Ptl.Device.Communication.Protocol Namespace


IProtocol(TResult) Interface

[image]

Pick To Light 设备通讯类库
IProtocol<(Of <(<'TResult>)>)> Interface
Members See Also Send Feedback
表示有返回值的协议。

Namespace: Ptl.Device.Communication.Protocol
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public interface IProtocol<TResult> : IProtocol
Visual Basic
Public Interface IProtocol(Of TResult)
    Inherits IProtocol

Type Parameters

TResult
返回值类型。

See Also

IProtocol<(Of <(<'TResult>)>)> Members
Ptl.Device.Communication.Protocol Namespace


IProtocol(TResult) Members

[image] [image]

Pick To Light 设备通讯类库
IProtocol<(Of <(<'TResult>)>)> Members
IProtocol<(Of <(<'TResult>)>)> Interface Methods See Also Send Feedback

The IProtocol<(Of <(<'TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | FromReceivedData | 从返回的协议数据解析出返回值。
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IProtocol<(Of <(<'TResult>)>)> Interface
Ptl.Device.Communication.Protocol Namespace


IProtocol(TResult) Methods

[image] [image]

Pick To Light 设备通讯类库
IProtocol<(Of <(<'TResult>)>)> Methods
IProtocol<(Of <(<'TResult>)>)> Interface See Also Send Feedback

The IProtocol<(Of <(<'TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | FromReceivedData | 从返回的协议数据解析出返回值。
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IProtocol<(Of <(<'TResult>)>)> Interface
Ptl.Device.Communication.Protocol Namespace


IProtocol(TResult).FromReceivedData Method

[image]

Pick To Light 设备通讯类库
IProtocol<(Of <(<'TResult>)>)>..::..FromReceivedData Method
IProtocol<(Of <(<'TResult>)>)> Interface See Also Send Feedback
从返回的协议数据解析出返回值。

Namespace: Ptl.Device.Communication.Protocol
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
TResult FromReceivedData(
    byte[] data
)
Visual Basic
Function FromReceivedData (
    data As Byte()
) As TResult

Parameters

data
Type: array< System..::..Byte >[]()[][]
移除了头和尾的协议数据，不包含地址和 CRC。

Return Value

Type: TResult
解析结果。

See Also

IProtocol<(Of <(<'TResult>)>)> Interface
IProtocol<(Of <(<'TResult>)>)> Members
Ptl.Device.Communication.Protocol Namespace


Ptl.Device.Communication.Protocol.Broadcast Namespace

[image]

Pick To Light 设备通讯类库
Ptl.Device.Communication.Protocol.Broadcast Namespace
Send Feedback
广播协议。

Interfaces

 | Interface | Description
Public interface | IBroadcastProtocol | 表示广播协议。
Public interface | IBroadcastProtocol<(Of <(<'TResult>)>)> | 表示有返回值的广播协议，此时只应挂载一个设备。


IBroadcastProtocol Interface

[image]

Pick To Light 设备通讯类库
IBroadcastProtocol Interface
Members See Also Send Feedback
表示广播协议。

Namespace: Ptl.Device.Communication.Protocol.Broadcast
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public interface IBroadcastProtocol : IProtocol
Visual Basic
Public Interface IBroadcastProtocol
    Inherits IProtocol

See Also

IBroadcastProtocol Members
Ptl.Device.Communication.Protocol.Broadcast Namespace


IBroadcastProtocol Members

[image] [image]

Pick To Light 设备通讯类库
IBroadcastProtocol Members
IBroadcastProtocol Interface Methods See Also Send Feedback

The IBroadcastProtocol type exposes the following members.

Methods

 | Name | Description
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IBroadcastProtocol Interface
Ptl.Device.Communication.Protocol.Broadcast Namespace


IBroadcastProtocol Methods

[image] [image]

Pick To Light 设备通讯类库
IBroadcastProtocol Methods
IBroadcastProtocol Interface See Also Send Feedback

The IBroadcastProtocol type exposes the following members.

Methods

 | Name | Description
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IBroadcastProtocol Interface
Ptl.Device.Communication.Protocol.Broadcast Namespace


IBroadcastProtocol(TResult) Interface

[image]

Pick To Light 设备通讯类库
IBroadcastProtocol<(Of <(<'TResult>)>)> Interface
Members See Also Send Feedback
表示有返回值的广播协议，此时只应挂载一个设备。

Namespace: Ptl.Device.Communication.Protocol.Broadcast
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public interface IBroadcastProtocol<TResult> : IBroadcastProtocol,
    IProtocol<TResult>, IProtocol
Visual Basic
Public Interface IBroadcastProtocol(Of TResult)
    Inherits IBroadcastProtocol, IProtocol(Of TResult), IProtocol

Type Parameters

TResult
返回值类型。

See Also

IBroadcastProtocol<(Of <(<'TResult>)>)> Members
Ptl.Device.Communication.Protocol.Broadcast Namespace


IBroadcastProtocol(TResult) Members

[image] [image]

Pick To Light 设备通讯类库
IBroadcastProtocol<(Of <(<'TResult>)>)> Members
IBroadcastProtocol<(Of <(<'TResult>)>)> Interface Methods See Also Send Feedback

The IBroadcastProtocol<(Of <(<'TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | FromReceivedData | 从返回的协议数据解析出返回值。 (Inherited from IProtocol<(Of <(<'TResult>)>)>.)
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IBroadcastProtocol<(Of <(<'TResult>)>)> Interface
Ptl.Device.Communication.Protocol.Broadcast Namespace


IBroadcastProtocol(TResult) Methods

[image] [image]

Pick To Light 设备通讯类库
IBroadcastProtocol<(Of <(<'TResult>)>)> Methods
IBroadcastProtocol<(Of <(<'TResult>)>)> Interface See Also Send Feedback

The IBroadcastProtocol<(Of <(<'TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | FromReceivedData | 从返回的协议数据解析出返回值。 (Inherited from IProtocol<(Of <(<'TResult>)>)>.)
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IBroadcastProtocol<(Of <(<'TResult>)>)> Interface
Ptl.Device.Communication.Protocol.Broadcast Namespace


Ptl.Device.Communication.Protocol.Multicast Namespace

[image]

Pick To Light 设备通讯类库
Ptl.Device.Communication.Protocol.Multicast Namespace
Send Feedback
组播协议。

Interfaces

 | Interface | Description
Public interface | IMulticastProtocol | 表示组播协议。
Public interface | IMulticastProtocol<(Of <(<'TResult>)>)> | 表示有返回值的组播协议，此时只应挂载一个设备。


IMulticastProtocol Interface

[image]

Pick To Light 设备通讯类库
IMulticastProtocol Interface
Members See Also Send Feedback
表示组播协议。

Namespace: Ptl.Device.Communication.Protocol.Multicast
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public interface IMulticastProtocol : IProtocol
Visual Basic
Public Interface IMulticastProtocol
    Inherits IProtocol

See Also

IMulticastProtocol Members
Ptl.Device.Communication.Protocol.Multicast Namespace


IMulticastProtocol Members

[image] [image]

Pick To Light 设备通讯类库
IMulticastProtocol Members
IMulticastProtocol Interface Methods See Also Send Feedback

The IMulticastProtocol type exposes the following members.

Methods

 | Name | Description
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IMulticastProtocol Interface
Ptl.Device.Communication.Protocol.Multicast Namespace


IMulticastProtocol Methods

[image] [image]

Pick To Light 设备通讯类库
IMulticastProtocol Methods
IMulticastProtocol Interface See Also Send Feedback

The IMulticastProtocol type exposes the following members.

Methods

 | Name | Description
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IMulticastProtocol Interface
Ptl.Device.Communication.Protocol.Multicast Namespace


IMulticastProtocol(TResult) Interface

[image]

Pick To Light 设备通讯类库
IMulticastProtocol<(Of <(<'TResult>)>)> Interface
Members See Also Send Feedback
表示有返回值的组播协议，此时只应挂载一个设备。

Namespace: Ptl.Device.Communication.Protocol.Multicast
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public interface IMulticastProtocol<TResult> : IMulticastProtocol,
    IProtocol<TResult>, IProtocol
Visual Basic
Public Interface IMulticastProtocol(Of TResult)
    Inherits IMulticastProtocol, IProtocol(Of TResult), IProtocol

Type Parameters

TResult
返回值类型。

See Also

IMulticastProtocol<(Of <(<'TResult>)>)> Members
Ptl.Device.Communication.Protocol.Multicast Namespace


IMulticastProtocol(TResult) Members

[image] [image]

Pick To Light 设备通讯类库
IMulticastProtocol<(Of <(<'TResult>)>)> Members
IMulticastProtocol<(Of <(<'TResult>)>)> Interface Methods See Also Send Feedback

The IMulticastProtocol<(Of <(<'TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | FromReceivedData | 从返回的协议数据解析出返回值。 (Inherited from IProtocol<(Of <(<'TResult>)>)>.)
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IMulticastProtocol<(Of <(<'TResult>)>)> Interface
Ptl.Device.Communication.Protocol.Multicast Namespace


IMulticastProtocol(TResult) Methods

[image] [image]

Pick To Light 设备通讯类库
IMulticastProtocol<(Of <(<'TResult>)>)> Methods
IMulticastProtocol<(Of <(<'TResult>)>)> Interface See Also Send Feedback

The IMulticastProtocol<(Of <(<'TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | FromReceivedData | 从返回的协议数据解析出返回值。 (Inherited from IProtocol<(Of <(<'TResult>)>)>.)
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IMulticastProtocol<(Of <(<'TResult>)>)> Interface
Ptl.Device.Communication.Protocol.Multicast Namespace


Ptl.Device.Communication.Protocol.Unicast Namespace

[image]

Pick To Light 设备通讯类库
Ptl.Device.Communication.Protocol.Unicast Namespace
Send Feedback
单播协议。

Interfaces

 | Interface | Description
Public interface | IUnicastProtocol | 表示无返回值的单播协议。
Public interface | IUnicastProtocol<(Of <(<'TResult>)>)> | 表示有返回值的单播协议。


IUnicastProtocol Interface

[image]

Pick To Light 设备通讯类库
IUnicastProtocol Interface
Members See Also Send Feedback
表示无返回值的单播协议。

Namespace: Ptl.Device.Communication.Protocol.Unicast
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public interface IUnicastProtocol : IProtocol
Visual Basic
Public Interface IUnicastProtocol
    Inherits IProtocol

See Also

IUnicastProtocol Members
Ptl.Device.Communication.Protocol.Unicast Namespace


IUnicastProtocol Members

[image] [image]

Pick To Light 设备通讯类库
IUnicastProtocol Members
IUnicastProtocol Interface Methods See Also Send Feedback

The IUnicastProtocol type exposes the following members.

Methods

 | Name | Description
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IUnicastProtocol Interface
Ptl.Device.Communication.Protocol.Unicast Namespace


IUnicastProtocol Methods

[image] [image]

Pick To Light 设备通讯类库
IUnicastProtocol Methods
IUnicastProtocol Interface See Also Send Feedback

The IUnicastProtocol type exposes the following members.

Methods

 | Name | Description
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IUnicastProtocol Interface
Ptl.Device.Communication.Protocol.Unicast Namespace


IUnicastProtocol(TResult) Interface

[image]

Pick To Light 设备通讯类库
IUnicastProtocol<(Of <(<'TResult>)>)> Interface
Members See Also Send Feedback
表示有返回值的单播协议。

Namespace: Ptl.Device.Communication.Protocol.Unicast
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public interface IUnicastProtocol<TResult> : IUnicastProtocol,
    IProtocol<TResult>, IProtocol
Visual Basic
Public Interface IUnicastProtocol(Of TResult)
    Inherits IUnicastProtocol, IProtocol(Of TResult), IProtocol

Type Parameters

TResult
返回值类型。

See Also

IUnicastProtocol<(Of <(<'TResult>)>)> Members
Ptl.Device.Communication.Protocol.Unicast Namespace


IUnicastProtocol(TResult) Members

[image] [image]

Pick To Light 设备通讯类库
IUnicastProtocol<(Of <(<'TResult>)>)> Members
IUnicastProtocol<(Of <(<'TResult>)>)> Interface Methods See Also Send Feedback

The IUnicastProtocol<(Of <(<'TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | FromReceivedData | 从返回的协议数据解析出返回值。 (Inherited from IProtocol<(Of <(<'TResult>)>)>.)
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IUnicastProtocol<(Of <(<'TResult>)>)> Interface
Ptl.Device.Communication.Protocol.Unicast Namespace


IUnicastProtocol(TResult) Methods

[image] [image]

Pick To Light 设备通讯类库
IUnicastProtocol<(Of <(<'TResult>)>)> Methods
IUnicastProtocol<(Of <(<'TResult>)>)> Interface See Also Send Feedback

The IUnicastProtocol<(Of <(<'TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | FromReceivedData | 从返回的协议数据解析出返回值。 (Inherited from IProtocol<(Of <(<'TResult>)>)>.)
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IUnicastProtocol<(Of <(<'TResult>)>)> Interface
Ptl.Device.Communication.Protocol.Unicast Namespace


Ptl.Device.Communication.Protocol.XGateProtocols Namespace

[image]

Pick To Light 设备通讯类库
Ptl.Device.Communication.Protocol.XGateProtocols Namespace
Send Feedback
XGate 协议。

Interfaces

 | Interface | Description
Public interface | IXGateProtocol | 表示 XGate 协议。
Public interface | IXGateProtocol<(Of <(<'TResult>)>)> | 表示有返回值的 XGate 协议。


IXGateProtocol Interface

[image]

Pick To Light 设备通讯类库
IXGateProtocol Interface
Members See Also Send Feedback
表示 XGate 协议。

Namespace: Ptl.Device.Communication.Protocol.XGateProtocols
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public interface IXGateProtocol : IProtocol
Visual Basic
Public Interface IXGateProtocol
    Inherits IProtocol

See Also

IXGateProtocol Members
Ptl.Device.Communication.Protocol.XGateProtocols Namespace


IXGateProtocol Members

[image] [image]

Pick To Light 设备通讯类库
IXGateProtocol Members
IXGateProtocol Interface Methods See Also Send Feedback

The IXGateProtocol type exposes the following members.

Methods

 | Name | Description
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IXGateProtocol Interface
Ptl.Device.Communication.Protocol.XGateProtocols Namespace


IXGateProtocol Methods

[image] [image]

Pick To Light 设备通讯类库
IXGateProtocol Methods
IXGateProtocol Interface See Also Send Feedback

The IXGateProtocol type exposes the following members.

Methods

 | Name | Description
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IXGateProtocol Interface
Ptl.Device.Communication.Protocol.XGateProtocols Namespace


IXGateProtocol(TResult) Interface

[image]

Pick To Light 设备通讯类库
IXGateProtocol<(Of <(<'TResult>)>)> Interface
Members See Also Send Feedback
表示有返回值的 XGate 协议。

Namespace: Ptl.Device.Communication.Protocol.XGateProtocols
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public interface IXGateProtocol<TResult> : IXGateProtocol,
    IProtocol<TResult>, IProtocol
Visual Basic
Public Interface IXGateProtocol(Of TResult)
    Inherits IXGateProtocol, IProtocol(Of TResult), IProtocol

Type Parameters

TResult
返回值类型。

See Also

IXGateProtocol<(Of <(<'TResult>)>)> Members
Ptl.Device.Communication.Protocol.XGateProtocols Namespace


IXGateProtocol(TResult) Members

[image] [image]

Pick To Light 设备通讯类库
IXGateProtocol<(Of <(<'TResult>)>)> Members
IXGateProtocol<(Of <(<'TResult>)>)> Interface Methods See Also Send Feedback

The IXGateProtocol<(Of <(<'TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | FromReceivedData | 从返回的协议数据解析出返回值。 (Inherited from IProtocol<(Of <(<'TResult>)>)>.)
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IXGateProtocol<(Of <(<'TResult>)>)> Interface
Ptl.Device.Communication.Protocol.XGateProtocols Namespace


IXGateProtocol(TResult) Methods

[image] [image]

Pick To Light 设备通讯类库
IXGateProtocol<(Of <(<'TResult>)>)> Methods
IXGateProtocol<(Of <(<'TResult>)>)> Interface See Also Send Feedback

The IXGateProtocol<(Of <(<'TResult>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | FromReceivedData | 从返回的协议数据解析出返回值。 (Inherited from IProtocol<(Of <(<'TResult>)>)>.)
Public method | ToSendData | 协议信息转换到协议数据。 (Inherited from IProtocol.)

See Also

IXGateProtocol<(Of <(<'TResult>)>)> Interface
Ptl.Device.Communication.Protocol.XGateProtocols Namespace


Ptl.Device.Communication.XGateConfig Namespace

[image]

Pick To Light 设备通讯类库
Ptl.Device.Communication.XGateConfig Namespace
Send Feedback
XGate 连接信息配置。

Classes

 | Class | Description
Public class | WifiXGateConfigEntity | 无线 XGate 的配置时信息。
Public class | WifiXGateConfigExecutor | 无线 XGate 配置协议执行者。
Public class | WifiXGateConstants | 无线 XGate 相关常量。
Public class | XGateConfigEntity | XGate 的配置时信息。
Public class | XGateConfigExecutor | XGate 组播配置协议执行者。


WifiXGateConfigEntity Class

[image]

Pick To Light 设备通讯类库
WifiXGateConfigEntity Class
Members See Also Send Feedback
无线 XGate 的配置时信息。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class WifiXGateConfigEntity
Visual Basic
<SerializableAttribute>
Public Class WifiXGateConfigEntity

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication.XGateConfig..::..WifiXGateConfigEntity

See Also

WifiXGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigEntity Members

[image] [image]

Pick To Light 设备通讯类库
WifiXGateConfigEntity Members
WifiXGateConfigEntity Class Constructors Properties See Also Send Feedback

The WifiXGateConfigEntity type exposes the following members.

Constructors

 | Name | Description
Public method | WifiXGateConfigEntity | Initializes a new instance of the WifiXGateConfigEntity class

Properties

 | Name | Description
Public property | ApPassword | 获取或设置接入点的密码。
Public property | ApSsid | 获取或设置接入点的名称。
Public property | Gateway | 获取或设置默认网关。
Public property | Mask | 获取或设置子网掩码。
Public property | NewIP | 获取或设置 IP。
Public property | NewPassword | 获取或设置新密码。
Public property | OldIP | 获取或设置老 IP。
Public property | OldPassword | 获取或设置老密码。

See Also

WifiXGateConfigEntity Class
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigEntity Constructor

[image]

Pick To Light 设备通讯类库
WifiXGateConfigEntity Constructor
WifiXGateConfigEntity Class See Also Send Feedback
Initializes a new instance of the WifiXGateConfigEntity class

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public WifiXGateConfigEntity()
Visual Basic
Public Sub New

See Also

WifiXGateConfigEntity Class
WifiXGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigEntity Properties

[image] [image]

Pick To Light 设备通讯类库
WifiXGateConfigEntity Properties
WifiXGateConfigEntity Class See Also Send Feedback

The WifiXGateConfigEntity type exposes the following members.

Properties

 | Name | Description
Public property | ApPassword | 获取或设置接入点的密码。
Public property | ApSsid | 获取或设置接入点的名称。
Public property | Gateway | 获取或设置默认网关。
Public property | Mask | 获取或设置子网掩码。
Public property | NewIP | 获取或设置 IP。
Public property | NewPassword | 获取或设置新密码。
Public property | OldIP | 获取或设置老 IP。
Public property | OldPassword | 获取或设置老密码。

See Also

WifiXGateConfigEntity Class
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigEntity.ApPassword Property

[image]

Pick To Light 设备通讯类库
WifiXGateConfigEntity..::..ApPassword Property
WifiXGateConfigEntity Class See Also Send Feedback
获取或设置接入点的密码。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string ApPassword { get; set; }
Visual Basic
Public Property ApPassword As String
    Get
    Set

Property Value

Type: String

See Also

WifiXGateConfigEntity Class
WifiXGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigEntity.ApSsid Property

[image]

Pick To Light 设备通讯类库
WifiXGateConfigEntity..::..ApSsid Property
WifiXGateConfigEntity Class See Also Send Feedback
获取或设置接入点的名称。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string ApSsid { get; set; }
Visual Basic
Public Property ApSsid As String
    Get
    Set

Property Value

Type: String

See Also

WifiXGateConfigEntity Class
WifiXGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigEntity.Gateway Property

[image]

Pick To Light 设备通讯类库
WifiXGateConfigEntity..::..Gateway Property
WifiXGateConfigEntity Class See Also Send Feedback
获取或设置默认网关。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Gateway { get; set; }
Visual Basic
Public Property Gateway As String
    Get
    Set

Property Value

Type: String

See Also

WifiXGateConfigEntity Class
WifiXGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigEntity.Mask Property

[image]

Pick To Light 设备通讯类库
WifiXGateConfigEntity..::..Mask Property
WifiXGateConfigEntity Class See Also Send Feedback
获取或设置子网掩码。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Mask { get; set; }
Visual Basic
Public Property Mask As String
    Get
    Set

Property Value

Type: String

See Also

WifiXGateConfigEntity Class
WifiXGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigEntity.NewIP Property

[image]

Pick To Light 设备通讯类库
WifiXGateConfigEntity..::..NewIP Property
WifiXGateConfigEntity Class See Also Send Feedback
获取或设置 IP。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string NewIP { get; set; }
Visual Basic
Public Property NewIP As String
    Get
    Set

Property Value

Type: String

See Also

WifiXGateConfigEntity Class
WifiXGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigEntity.NewPassword Property

[image]

Pick To Light 设备通讯类库
WifiXGateConfigEntity..::..NewPassword Property
WifiXGateConfigEntity Class See Also Send Feedback
获取或设置新密码。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string NewPassword { get; set; }
Visual Basic
Public Property NewPassword As String
    Get
    Set

Property Value

Type: String

See Also

WifiXGateConfigEntity Class
WifiXGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigEntity.OldIP Property

[image]

Pick To Light 设备通讯类库
WifiXGateConfigEntity..::..OldIP Property
WifiXGateConfigEntity Class See Also Send Feedback
获取或设置老 IP。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string OldIP { get; set; }
Visual Basic
Public Property OldIP As String
    Get
    Set

Property Value

Type: String

See Also

WifiXGateConfigEntity Class
WifiXGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigEntity.OldPassword Property

[image]

Pick To Light 设备通讯类库
WifiXGateConfigEntity..::..OldPassword Property
WifiXGateConfigEntity Class See Also Send Feedback
获取或设置老密码。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string OldPassword { get; set; }
Visual Basic
Public Property OldPassword As String
    Get
    Set

Property Value

Type: String

See Also

WifiXGateConfigEntity Class
WifiXGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigExecutor Class

[image]

Pick To Light 设备通讯类库
WifiXGateConfigExecutor Class
Members See Also Send Feedback
无线 XGate 配置协议执行者。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public class WifiXGateConfigExecutor
Visual Basic
Public Class WifiXGateConfigExecutor

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication.XGateConfig..::..WifiXGateConfigExecutor

See Also

WifiXGateConfigExecutor Members
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigExecutor Members

[image] [image]

Pick To Light 设备通讯类库
WifiXGateConfigExecutor Members
WifiXGateConfigExecutor Class Constructors Methods See Also Send Feedback

The WifiXGateConfigExecutor type exposes the following members.

Constructors

 | Name | Description
Public method | WifiXGateConfigExecutor | Initializes a new instance of the WifiXGateConfigExecutor class

Methods

 | Name | Description
Public method | Config | 按 OldIP 配置无线 XGate。
Public method | Reboot | 按 OldIP 重启无线 XGate。

See Also

WifiXGateConfigExecutor Class
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigExecutor Constructor

[image]

Pick To Light 设备通讯类库
WifiXGateConfigExecutor Constructor
WifiXGateConfigExecutor Class See Also Send Feedback
Initializes a new instance of the WifiXGateConfigExecutor class

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public WifiXGateConfigExecutor()
Visual Basic
Public Sub New

See Also

WifiXGateConfigExecutor Class
WifiXGateConfigExecutor Members
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigExecutor Methods

[image] [image]

Pick To Light 设备通讯类库
WifiXGateConfigExecutor Methods
WifiXGateConfigExecutor Class See Also Send Feedback

The WifiXGateConfigExecutor type exposes the following members.

Methods

 | Name | Description
Public method | Config | 按 OldIP 配置无线 XGate。
Public method | Reboot | 按 OldIP 重启无线 XGate。

See Also

WifiXGateConfigExecutor Class
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigExecutor.Config Method

[image]

Pick To Light 设备通讯类库
WifiXGateConfigExecutor..::..Config Method
WifiXGateConfigExecutor Class See Also Send Feedback
按 OldIP 配置无线 XGate。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Config(
    WifiXGateConfigEntity entity
)
Visual Basic
Public Overridable Sub Config (
    entity As WifiXGateConfigEntity
)

Parameters

entity
Type: Ptl.Device.Communication.XGateConfig..::..WifiXGateConfigEntity
配置信息。

See Also

WifiXGateConfigExecutor Class
WifiXGateConfigExecutor Members
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConfigExecutor.Reboot Method

[image]

Pick To Light 设备通讯类库
WifiXGateConfigExecutor..::..Reboot Method
WifiXGateConfigExecutor Class See Also Send Feedback
按 OldIP 重启无线 XGate。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Reboot(
    WifiXGateConfigEntity entity
)
Visual Basic
Public Overridable Sub Reboot (
    entity As WifiXGateConfigEntity
)

Parameters

entity
Type: Ptl.Device.Communication.XGateConfig..::..WifiXGateConfigEntity
携带 OldIP 和密码的配置信息。

See Also

WifiXGateConfigExecutor Class
WifiXGateConfigExecutor Members
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConstants Class

[image]

Pick To Light 设备通讯类库
WifiXGateConstants Class
Members See Also Send Feedback
无线 XGate 相关常量。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static class WifiXGateConstants
Visual Basic
Public NotInheritable Class WifiXGateConstants

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication.XGateConfig..::..WifiXGateConstants

See Also

WifiXGateConstants Members
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConstants Members

[image] [image]

Pick To Light 设备通讯类库
WifiXGateConstants Members
WifiXGateConstants Class Fields See Also Send Feedback

The WifiXGateConstants type exposes the following members.

Fields

Name | Description
SsidPrefix | SSID 前缀。
WebUserName | Web 登录名。

See Also

WifiXGateConstants Class
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConstants Fields

[image] [image]

Pick To Light 设备通讯类库
WifiXGateConstants Fields
WifiXGateConstants Class See Also Send Feedback

The WifiXGateConstants type exposes the following members.

Fields

Name | Description
SsidPrefix | SSID 前缀。
WebUserName | Web 登录名。

See Also

WifiXGateConstants Class
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConstants.SsidPrefix Field

[image]

Pick To Light 设备通讯类库
WifiXGateConstants..::..SsidPrefix Field
WifiXGateConstants Class See Also Send Feedback
SSID 前缀。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public const string SsidPrefix
Visual Basic
Public Const SsidPrefix As String

Field Value

Type: String

See Also

WifiXGateConstants Class
WifiXGateConstants Members
Ptl.Device.Communication.XGateConfig Namespace


WifiXGateConstants.WebUserName Field

[image]

Pick To Light 设备通讯类库
WifiXGateConstants..::..WebUserName Field
WifiXGateConstants Class See Also Send Feedback
Web 登录名。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public const string WebUserName
Visual Basic
Public Const WebUserName As String

Field Value

Type: String

See Also

WifiXGateConstants Class
WifiXGateConstants Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigEntity Class

[image]

Pick To Light 设备通讯类库
XGateConfigEntity Class
Members See Also Send Feedback
XGate 的配置时信息。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class XGateConfigEntity
Visual Basic
<SerializableAttribute>
Public Class XGateConfigEntity

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication.XGateConfig..::..XGateConfigEntity

See Also

XGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigEntity Members

[image] [image]

Pick To Light 设备通讯类库
XGateConfigEntity Members
XGateConfigEntity Class Constructors Properties See Also Send Feedback

The XGateConfigEntity type exposes the following members.

Constructors

 | Name | Description
Public method | XGateConfigEntity | Initializes a new instance of the XGateConfigEntity class

Properties

 | Name | Description
Public property | DeviceType | 获取或设置型号。
Public property | Gateway | 获取或设置默认网关。
Public property | HasPassword | 获取或设置是否有密码。
Public property | IP | 获取或设置 IP。
Public property | MAC | 获取或设置 MAC。
Public property | Mask | 获取或设置子网掩码。
Public property | NewPassword | 获取或设置新密码。
Public property | OldPassword | 获取或设置老密码。
Public property | SerialNumber | 获取或设置序列号。
Public property | Version | 获取或设置固件版本。

See Also

XGateConfigEntity Class
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigEntity Constructor

[image]

Pick To Light 设备通讯类库
XGateConfigEntity Constructor
XGateConfigEntity Class See Also Send Feedback
Initializes a new instance of the XGateConfigEntity class

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGateConfigEntity()
Visual Basic
Public Sub New

See Also

XGateConfigEntity Class
XGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigEntity Properties

[image] [image]

Pick To Light 设备通讯类库
XGateConfigEntity Properties
XGateConfigEntity Class See Also Send Feedback

The XGateConfigEntity type exposes the following members.

Properties

 | Name | Description
Public property | DeviceType | 获取或设置型号。
Public property | Gateway | 获取或设置默认网关。
Public property | HasPassword | 获取或设置是否有密码。
Public property | IP | 获取或设置 IP。
Public property | MAC | 获取或设置 MAC。
Public property | Mask | 获取或设置子网掩码。
Public property | NewPassword | 获取或设置新密码。
Public property | OldPassword | 获取或设置老密码。
Public property | SerialNumber | 获取或设置序列号。
Public property | Version | 获取或设置固件版本。

See Also

XGateConfigEntity Class
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigEntity.DeviceType Property

[image]

Pick To Light 设备通讯类库
XGateConfigEntity..::..DeviceType Property
XGateConfigEntity Class See Also Send Feedback
获取或设置型号。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string DeviceType { get; set; }
Visual Basic
Public Property DeviceType As String
    Get
    Set

Property Value

Type: String

See Also

XGateConfigEntity Class
XGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigEntity.Gateway Property

[image]

Pick To Light 设备通讯类库
XGateConfigEntity..::..Gateway Property
XGateConfigEntity Class See Also Send Feedback
获取或设置默认网关。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Gateway { get; set; }
Visual Basic
Public Property Gateway As String
    Get
    Set

Property Value

Type: String

See Also

XGateConfigEntity Class
XGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigEntity.HasPassword Property

[image]

Pick To Light 设备通讯类库
XGateConfigEntity..::..HasPassword Property
XGateConfigEntity Class See Also Send Feedback
获取或设置是否有密码。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool HasPassword { get; set; }
Visual Basic
Public Property HasPassword As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

XGateConfigEntity Class
XGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigEntity.IP Property

[image]

Pick To Light 设备通讯类库
XGateConfigEntity..::..IP Property
XGateConfigEntity Class See Also Send Feedback
获取或设置 IP。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string IP { get; set; }
Visual Basic
Public Property IP As String
    Get
    Set

Property Value

Type: String

See Also

XGateConfigEntity Class
XGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigEntity.MAC Property

[image]

Pick To Light 设备通讯类库
XGateConfigEntity..::..MAC Property
XGateConfigEntity Class See Also Send Feedback
获取或设置 MAC。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string MAC { get; set; }
Visual Basic
Public Property MAC As String
    Get
    Set

Property Value

Type: String

See Also

XGateConfigEntity Class
XGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigEntity.Mask Property

[image]

Pick To Light 设备通讯类库
XGateConfigEntity..::..Mask Property
XGateConfigEntity Class See Also Send Feedback
获取或设置子网掩码。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Mask { get; set; }
Visual Basic
Public Property Mask As String
    Get
    Set

Property Value

Type: String

See Also

XGateConfigEntity Class
XGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigEntity.NewPassword Property

[image]

Pick To Light 设备通讯类库
XGateConfigEntity..::..NewPassword Property
XGateConfigEntity Class See Also Send Feedback
获取或设置新密码。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string NewPassword { get; set; }
Visual Basic
Public Property NewPassword As String
    Get
    Set

Property Value

Type: String

See Also

XGateConfigEntity Class
XGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigEntity.OldPassword Property

[image]

Pick To Light 设备通讯类库
XGateConfigEntity..::..OldPassword Property
XGateConfigEntity Class See Also Send Feedback
获取或设置老密码。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string OldPassword { get; set; }
Visual Basic
Public Property OldPassword As String
    Get
    Set

Property Value

Type: String

See Also

XGateConfigEntity Class
XGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigEntity.SerialNumber Property

[image]

Pick To Light 设备通讯类库
XGateConfigEntity..::..SerialNumber Property
XGateConfigEntity Class See Also Send Feedback
获取或设置序列号。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string SerialNumber { get; set; }
Visual Basic
Public Property SerialNumber As String
    Get
    Set

Property Value

Type: String

See Also

XGateConfigEntity Class
XGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigEntity.Version Property

[image]

Pick To Light 设备通讯类库
XGateConfigEntity..::..Version Property
XGateConfigEntity Class See Also Send Feedback
获取或设置固件版本。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Version { get; set; }
Visual Basic
Public Property Version As String
    Get
    Set

Property Value

Type: String

See Also

XGateConfigEntity Class
XGateConfigEntity Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigExecutor Class

[image]

Pick To Light 设备通讯类库
XGateConfigExecutor Class
Members See Also Send Feedback
XGate 组播配置协议执行者。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public class XGateConfigExecutor
Visual Basic
Public Class XGateConfigExecutor

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication.XGateConfig..::..XGateConfigExecutor

See Also

XGateConfigExecutor Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigExecutor Members

[image] [image]

Pick To Light 设备通讯类库
XGateConfigExecutor Members
XGateConfigExecutor Class Constructors Methods Fields See Also Send Feedback

The XGateConfigExecutor type exposes the following members.

Constructors

 | Name | Description
Public method | XGateConfigExecutor()()()() | 新建默认的执行者。
Public method | XGateConfigExecutor(IPAddress) | 使用指定的本机 IP 新建执行者。
Public method | XGateConfigExecutor(IPEndPoint, IPEndPoint, TimeSpan, TimeSpan) | 使用指定的本机终结点和远程终结点新建执行者。

Methods

 | Name | Description
Public method | Config | 按 MAC 配置 XGate。
Public method | Initialize | 使用指定的 MAC 和序列号初始化 XGate。
Public method | Reboot | 按 MAC 重启 XGate。
Public method | Search | 查询 XGate。

Fields

Name | Description
DefaultMulticastAddress | 默认的组播地址。
DefaultMulticastPort | 默认的组播端口。
DefaultSearchProtocolTimeout | 默认的查询协议超时时间。
DefaultUsualProtocolTimeout | 默认的普通协议超时时间。

See Also

XGateConfigExecutor Class
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigExecutor Constructor

[image] [image]

Pick To Light 设备通讯类库
XGateConfigExecutor Constructor
XGateConfigExecutor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | XGateConfigExecutor()()()() | 新建默认的执行者。
Public method | XGateConfigExecutor(IPAddress) | 使用指定的本机 IP 新建执行者。
Public method | XGateConfigExecutor(IPEndPoint, IPEndPoint, TimeSpan, TimeSpan) | 使用指定的本机终结点和远程终结点新建执行者。

See Also

XGateConfigExecutor Class
XGateConfigExecutor Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigExecutor Constructor

[image]

Pick To Light 设备通讯类库
XGateConfigExecutor Constructor
XGateConfigExecutor Class See Also Send Feedback
新建默认的执行者。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGateConfigExecutor()
Visual Basic
Public Sub New

See Also

XGateConfigExecutor Class
XGateConfigExecutor Members
XGateConfigExecutor Overload
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigExecutor Constructor (IPAddress)

[image]

Pick To Light 设备通讯类库
XGateConfigExecutor Constructor (IPAddress)
XGateConfigExecutor Class See Also Send Feedback
使用指定的本机 IP 新建执行者。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGateConfigExecutor(
    IPAddress localIP
)
Visual Basic
Public Sub New (
    localIP As IPAddress
)

Parameters

localIP
Type: System.Net..::..IPAddress
本机 IP。

See Also

XGateConfigExecutor Class
XGateConfigExecutor Members
XGateConfigExecutor Overload
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigExecutor Constructor (IPEndPoint, IPEndPoint, TimeSpan, TimeSpan)

[image]

Pick To Light 设备通讯类库
XGateConfigExecutor Constructor (IPEndPoint, IPEndPoint, TimeSpan, TimeSpan)
XGateConfigExecutor Class See Also Send Feedback
使用指定的本机终结点和远程终结点新建执行者。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGateConfigExecutor(
    IPEndPoint localEndPoint,
    IPEndPoint multicastEndPoint,
    TimeSpan searchProtocolTimeout,
    TimeSpan usualProtocolTimeout
)
Visual Basic
Public Sub New (
    localEndPoint As IPEndPoint,
    multicastEndPoint As IPEndPoint,
    searchProtocolTimeout As TimeSpan,
    usualProtocolTimeout As TimeSpan
)

Parameters

localEndPoint
Type: System.Net..::..IPEndPoint
本机终结点。
multicastEndPoint
Type: System.Net..::..IPEndPoint
组播终结点。
searchProtocolTimeout
Type: System..::..TimeSpan
查询协议超时时间。
usualProtocolTimeout
Type: System..::..TimeSpan
普通协议超时时间。

Exceptions

Exception | Condition
System..::..ArgumentNullException | localEndPoint 或 multicastEndPoint 为空。

See Also

XGateConfigExecutor Class
XGateConfigExecutor Members
XGateConfigExecutor Overload
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigExecutor Fields

[image] [image]

Pick To Light 设备通讯类库
XGateConfigExecutor Fields
XGateConfigExecutor Class See Also Send Feedback

The XGateConfigExecutor type exposes the following members.

Fields

Name | Description
DefaultMulticastAddress | 默认的组播地址。
DefaultMulticastPort | 默认的组播端口。
DefaultSearchProtocolTimeout | 默认的查询协议超时时间。
DefaultUsualProtocolTimeout | 默认的普通协议超时时间。

See Also

XGateConfigExecutor Class
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigExecutor.DefaultMulticastAddress Field

[image]

Pick To Light 设备通讯类库
XGateConfigExecutor..::..DefaultMulticastAddress Field
XGateConfigExecutor Class See Also Send Feedback
默认的组播地址。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static readonly IPAddress DefaultMulticastAddress
Visual Basic
Public Shared ReadOnly DefaultMulticastAddress As IPAddress

Field Value

Type: IPAddress

See Also

XGateConfigExecutor Class
XGateConfigExecutor Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigExecutor.DefaultMulticastPort Field

[image]

Pick To Light 设备通讯类库
XGateConfigExecutor..::..DefaultMulticastPort Field
XGateConfigExecutor Class See Also Send Feedback
默认的组播端口。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public const int DefaultMulticastPort
Visual Basic
Public Const DefaultMulticastPort As Integer

Field Value

Type: Int32

See Also

XGateConfigExecutor Class
XGateConfigExecutor Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigExecutor.DefaultSearchProtocolTimeout Field

[image]

Pick To Light 设备通讯类库
XGateConfigExecutor..::..DefaultSearchProtocolTimeout Field
XGateConfigExecutor Class See Also Send Feedback
默认的查询协议超时时间。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static readonly TimeSpan DefaultSearchProtocolTimeout
Visual Basic
Public Shared ReadOnly DefaultSearchProtocolTimeout As TimeSpan

Field Value

Type: TimeSpan

See Also

XGateConfigExecutor Class
XGateConfigExecutor Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigExecutor.DefaultUsualProtocolTimeout Field

[image]

Pick To Light 设备通讯类库
XGateConfigExecutor..::..DefaultUsualProtocolTimeout Field
XGateConfigExecutor Class See Also Send Feedback
默认的普通协议超时时间。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static readonly TimeSpan DefaultUsualProtocolTimeout
Visual Basic
Public Shared ReadOnly DefaultUsualProtocolTimeout As TimeSpan

Field Value

Type: TimeSpan

See Also

XGateConfigExecutor Class
XGateConfigExecutor Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigExecutor Methods

[image] [image]

Pick To Light 设备通讯类库
XGateConfigExecutor Methods
XGateConfigExecutor Class See Also Send Feedback

The XGateConfigExecutor type exposes the following members.

Methods

 | Name | Description
Public method | Config | 按 MAC 配置 XGate。
Public method | Initialize | 使用指定的 MAC 和序列号初始化 XGate。
Public method | Reboot | 按 MAC 重启 XGate。
Public method | Search | 查询 XGate。

See Also

XGateConfigExecutor Class
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigExecutor.Config Method

[image]

Pick To Light 设备通讯类库
XGateConfigExecutor..::..Config Method
XGateConfigExecutor Class See Also Send Feedback
按 MAC 配置 XGate。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool Config(
    XGateConfigEntity entity
)
Visual Basic
Public Function Config (
    entity As XGateConfigEntity
) As Boolean

Parameters

entity
Type: Ptl.Device.Communication.XGateConfig..::..XGateConfigEntity
配置信息。

Return Value

Type: Boolean
是否成功配置。

See Also

XGateConfigExecutor Class
XGateConfigExecutor Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigExecutor.Initialize Method

[image]

Pick To Light 设备通讯类库
XGateConfigExecutor..::..Initialize Method
XGateConfigExecutor Class See Also Send Feedback
使用指定的 MAC 和序列号初始化 XGate。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool Initialize(
    XGateConfigEntity entity
)
Visual Basic
Public Function Initialize (
    entity As XGateConfigEntity
) As Boolean

Parameters

entity
Type: Ptl.Device.Communication.XGateConfig..::..XGateConfigEntity
携带 MAC、序列号和厂家密码的配置信息。

Return Value

Type: Boolean
是否成功配置。

Remarks

不应同时连接多个未初始化的 XGate。

See Also

XGateConfigExecutor Class
XGateConfigExecutor Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigExecutor.Reboot Method

[image]

Pick To Light 设备通讯类库
XGateConfigExecutor..::..Reboot Method
XGateConfigExecutor Class See Also Send Feedback
按 MAC 重启 XGate。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool Reboot(
    XGateConfigEntity entity
)
Visual Basic
Public Function Reboot (
    entity As XGateConfigEntity
) As Boolean

Parameters

entity
Type: Ptl.Device.Communication.XGateConfig..::..XGateConfigEntity
携带 MAC 和密码的配置信息。

Return Value

Type: Boolean
是否成功重启。

See Also

XGateConfigExecutor Class
XGateConfigExecutor Members
Ptl.Device.Communication.XGateConfig Namespace


XGateConfigExecutor.Search Method

[image]

Pick To Light 设备通讯类库
XGateConfigExecutor..::..Search Method
XGateConfigExecutor Class See Also Send Feedback
查询 XGate。

Namespace: Ptl.Device.Communication.XGateConfig
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Collection<XGateConfigEntity> Search()
Visual Basic
Public Function Search As Collection(Of XGateConfigEntity)

Return Value

Type: Collection <(Of <(<' XGateConfigEntity >)>)>
找到的 XGate 集合。

See Also

XGateConfigExecutor Class
XGateConfigExecutor Members
Ptl.Device.Communication.XGateConfig Namespace


Ptl.Device.Communication.XGateSettings Namespace

[image]

Pick To Light 设备通讯类库
Ptl.Device.Communication.XGateSettings Namespace
Send Feedback
XGate 的设置。

Classes

 | Class | Description
Public class | CommunicationSecurity | 通讯安全设置。
Public class | DeviceAddressRange | 总线上设备的地址范围。
Public class | InFrameDelay | 帧间延时。
Public class | OutputPortStatus | 输出口状态。
Public class | SerialPortSettings | 串口参数。
Public class | XGateSettingsExecutor | XGate 工作参数设置协议执行者。


CommunicationSecurity Class

[image]

Pick To Light 设备通讯类库
CommunicationSecurity Class
Members See Also Send Feedback
通讯安全设置。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class CommunicationSecurity
Visual Basic
<SerializableAttribute>
Public Class CommunicationSecurity

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication.XGateSettings..::..CommunicationSecurity

See Also

CommunicationSecurity Members
Ptl.Device.Communication.XGateSettings Namespace


CommunicationSecurity Members

[image] [image]

Pick To Light 设备通讯类库
CommunicationSecurity Members
CommunicationSecurity Class Constructors Fields Properties See Also Send Feedback

The CommunicationSecurity type exposes the following members.

Constructors

 | Name | Description
Public method | CommunicationSecurity | Initializes a new instance of the CommunicationSecurity class

Fields

Name | Description
MaxHostIPsCount | 设置时的最多 IP 数量。

Properties

 | Name | Description
Public property | HostIPs | 获取合法的主站 IP 地址集。
Public property | Port | 获取或设置端口。

See Also

CommunicationSecurity Class
Ptl.Device.Communication.XGateSettings Namespace


CommunicationSecurity Constructor

[image]

Pick To Light 设备通讯类库
CommunicationSecurity Constructor
CommunicationSecurity Class See Also Send Feedback
Initializes a new instance of the CommunicationSecurity class

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public CommunicationSecurity()
Visual Basic
Public Sub New

See Also

CommunicationSecurity Class
CommunicationSecurity Members
Ptl.Device.Communication.XGateSettings Namespace


CommunicationSecurity Fields

[image] [image]

Pick To Light 设备通讯类库
CommunicationSecurity Fields
CommunicationSecurity Class See Also Send Feedback

The CommunicationSecurity type exposes the following members.

Fields

Name | Description
MaxHostIPsCount | 设置时的最多 IP 数量。

See Also

CommunicationSecurity Class
Ptl.Device.Communication.XGateSettings Namespace


CommunicationSecurity.MaxHostIPsCount Field

[image]

Pick To Light 设备通讯类库
CommunicationSecurity..::..MaxHostIPsCount Field
CommunicationSecurity Class See Also Send Feedback
设置时的最多 IP 数量。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public const int MaxHostIPsCount
Visual Basic
Public Const MaxHostIPsCount As Integer

Field Value

Type: Int32

See Also

CommunicationSecurity Class
CommunicationSecurity Members
Ptl.Device.Communication.XGateSettings Namespace


CommunicationSecurity Properties

[image] [image]

Pick To Light 设备通讯类库
CommunicationSecurity Properties
CommunicationSecurity Class See Also Send Feedback

The CommunicationSecurity type exposes the following members.

Properties

 | Name | Description
Public property | HostIPs | 获取合法的主站 IP 地址集。
Public property | Port | 获取或设置端口。

See Also

CommunicationSecurity Class
Ptl.Device.Communication.XGateSettings Namespace


CommunicationSecurity.HostIPs Property

[image]

Pick To Light 设备通讯类库
CommunicationSecurity..::..HostIPs Property
CommunicationSecurity Class See Also Send Feedback
获取合法的主站 IP 地址集。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Collection<string> HostIPs { get; }
Visual Basic
Public ReadOnly Property HostIPs As Collection(Of String)
    Get

Property Value

Type: Collection <(Of <(<' String >)>)>

See Also

CommunicationSecurity Class
CommunicationSecurity Members
Ptl.Device.Communication.XGateSettings Namespace


CommunicationSecurity.Port Property

[image]

Pick To Light 设备通讯类库
CommunicationSecurity..::..Port Property
CommunicationSecurity Class See Also Send Feedback
获取或设置端口。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int Port { get; set; }
Visual Basic
Public Property Port As Integer
    Get
    Set

Property Value

Type: Int32

See Also

CommunicationSecurity Class
CommunicationSecurity Members
Ptl.Device.Communication.XGateSettings Namespace


DeviceAddressRange Class

[image]

Pick To Light 设备通讯类库
DeviceAddressRange Class
Members See Also Send Feedback
总线上设备的地址范围。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class DeviceAddressRange
Visual Basic
<SerializableAttribute>
Public Class DeviceAddressRange

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication.XGateSettings..::..DeviceAddressRange

See Also

DeviceAddressRange Members
Ptl.Device.Communication.XGateSettings Namespace


DeviceAddressRange Members

[image] [image]

Pick To Light 设备通讯类库
DeviceAddressRange Members
DeviceAddressRange Class Constructors Fields Properties See Also Send Feedback

The DeviceAddressRange type exposes the following members.

Constructors

 | Name | Description
Public method | DeviceAddressRange | Initializes a new instance of the DeviceAddressRange class

Fields

Name | Description
MaxAddressesCount | 设置时的最大地址数量。

Properties

 | Name | Description
Public property | Addresses | 获取可使用的地址集。
Public property | BusIndex | 获取或设置所属总线索引。

See Also

DeviceAddressRange Class
Ptl.Device.Communication.XGateSettings Namespace


DeviceAddressRange Constructor

[image]

Pick To Light 设备通讯类库
DeviceAddressRange Constructor
DeviceAddressRange Class See Also Send Feedback
Initializes a new instance of the DeviceAddressRange class

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public DeviceAddressRange()
Visual Basic
Public Sub New

See Also

DeviceAddressRange Class
DeviceAddressRange Members
Ptl.Device.Communication.XGateSettings Namespace


DeviceAddressRange Fields

[image] [image]

Pick To Light 设备通讯类库
DeviceAddressRange Fields
DeviceAddressRange Class See Also Send Feedback

The DeviceAddressRange type exposes the following members.

Fields

Name | Description
MaxAddressesCount | 设置时的最大地址数量。

See Also

DeviceAddressRange Class
Ptl.Device.Communication.XGateSettings Namespace


DeviceAddressRange.MaxAddressesCount Field

[image]

Pick To Light 设备通讯类库
DeviceAddressRange..::..MaxAddressesCount Field
DeviceAddressRange Class See Also Send Feedback
设置时的最大地址数量。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public const int MaxAddressesCount
Visual Basic
Public Const MaxAddressesCount As Integer

Field Value

Type: Int32

See Also

DeviceAddressRange Class
DeviceAddressRange Members
Ptl.Device.Communication.XGateSettings Namespace


DeviceAddressRange Properties

[image] [image]

Pick To Light 设备通讯类库
DeviceAddressRange Properties
DeviceAddressRange Class See Also Send Feedback

The DeviceAddressRange type exposes the following members.

Properties

 | Name | Description
Public property | Addresses | 获取可使用的地址集。
Public property | BusIndex | 获取或设置所属总线索引。

See Also

DeviceAddressRange Class
Ptl.Device.Communication.XGateSettings Namespace


DeviceAddressRange.Addresses Property

[image]

Pick To Light 设备通讯类库
DeviceAddressRange..::..Addresses Property
DeviceAddressRange Class See Also Send Feedback
获取可使用的地址集。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Collection<byte> Addresses { get; }
Visual Basic
Public ReadOnly Property Addresses As Collection(Of Byte)
    Get

Property Value

Type: Collection <(Of <(<' Byte >)>)>

See Also

DeviceAddressRange Class
DeviceAddressRange Members
Ptl.Device.Communication.XGateSettings Namespace


DeviceAddressRange.BusIndex Property

[image]

Pick To Light 设备通讯类库
DeviceAddressRange..::..BusIndex Property
DeviceAddressRange Class See Also Send Feedback
获取或设置所属总线索引。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte BusIndex { get; set; }
Visual Basic
Public Property BusIndex As Byte
    Get
    Set

Property Value

Type: Byte

See Also

DeviceAddressRange Class
DeviceAddressRange Members
Ptl.Device.Communication.XGateSettings Namespace


InFrameDelay Class

[image]

Pick To Light 设备通讯类库
InFrameDelay Class
Members See Also Send Feedback
帧间延时。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class InFrameDelay
Visual Basic
<SerializableAttribute>
Public Class InFrameDelay

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication.XGateSettings..::..InFrameDelay

See Also

InFrameDelay Members
Ptl.Device.Communication.XGateSettings Namespace


InFrameDelay Members

[image] [image]

Pick To Light 设备通讯类库
InFrameDelay Members
InFrameDelay Class Constructors Properties See Also Send Feedback

The InFrameDelay type exposes the following members.

Constructors

 | Name | Description
Public method | InFrameDelay | Initializes a new instance of the InFrameDelay class

Properties

 | Name | Description
Public property | AfterReceived | 获取或设置收后再发延时。
Public property | AfterSent | 获取或设置发后再发延时。

See Also

InFrameDelay Class
Ptl.Device.Communication.XGateSettings Namespace


InFrameDelay Constructor

[image]

Pick To Light 设备通讯类库
InFrameDelay Constructor
InFrameDelay Class See Also Send Feedback
Initializes a new instance of the InFrameDelay class

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public InFrameDelay()
Visual Basic
Public Sub New

See Also

InFrameDelay Class
InFrameDelay Members
Ptl.Device.Communication.XGateSettings Namespace


InFrameDelay Properties

[image] [image]

Pick To Light 设备通讯类库
InFrameDelay Properties
InFrameDelay Class See Also Send Feedback

The InFrameDelay type exposes the following members.

Properties

 | Name | Description
Public property | AfterReceived | 获取或设置收后再发延时。
Public property | AfterSent | 获取或设置发后再发延时。

See Also

InFrameDelay Class
Ptl.Device.Communication.XGateSettings Namespace


InFrameDelay.AfterReceived Property

[image]

Pick To Light 设备通讯类库
InFrameDelay..::..AfterReceived Property
InFrameDelay Class See Also Send Feedback
获取或设置收后再发延时。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte AfterReceived { get; set; }
Visual Basic
Public Property AfterReceived As Byte
    Get
    Set

Property Value

Type: Byte

See Also

InFrameDelay Class
InFrameDelay Members
Ptl.Device.Communication.XGateSettings Namespace


InFrameDelay.AfterSent Property

[image]

Pick To Light 设备通讯类库
InFrameDelay..::..AfterSent Property
InFrameDelay Class See Also Send Feedback
获取或设置发后再发延时。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte AfterSent { get; set; }
Visual Basic
Public Property AfterSent As Byte
    Get
    Set

Property Value

Type: Byte

See Also

InFrameDelay Class
InFrameDelay Members
Ptl.Device.Communication.XGateSettings Namespace


OutputPortStatus Class

[image]

Pick To Light 设备通讯类库
OutputPortStatus Class
Members See Also Send Feedback
输出口状态。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class OutputPortStatus
Visual Basic
<SerializableAttribute>
Public Class OutputPortStatus

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication.XGateSettings..::..OutputPortStatus

See Also

OutputPortStatus Members
Ptl.Device.Communication.XGateSettings Namespace


OutputPortStatus Members

[image] [image]

Pick To Light 设备通讯类库
OutputPortStatus Members
OutputPortStatus Class Constructors Properties See Also Send Feedback

The OutputPortStatus type exposes the following members.

Constructors

 | Name | Description
Public method | OutputPortStatus | Initializes a new instance of the OutputPortStatus class

Properties

 | Name | Description
Public property | ON | 获取或设置是否处于点亮状态。
Public property | OnOffPeriod | 获取或设置亮灭周期。
Public property | OnOffRatio | 获取或设置亮灭比例。

See Also

OutputPortStatus Class
Ptl.Device.Communication.XGateSettings Namespace


OutputPortStatus Constructor

[image]

Pick To Light 设备通讯类库
OutputPortStatus Constructor
OutputPortStatus Class See Also Send Feedback
Initializes a new instance of the OutputPortStatus class

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public OutputPortStatus()
Visual Basic
Public Sub New

See Also

OutputPortStatus Class
OutputPortStatus Members
Ptl.Device.Communication.XGateSettings Namespace


OutputPortStatus Properties

[image] [image]

Pick To Light 设备通讯类库
OutputPortStatus Properties
OutputPortStatus Class See Also Send Feedback

The OutputPortStatus type exposes the following members.

Properties

 | Name | Description
Public property | ON | 获取或设置是否处于点亮状态。
Public property | OnOffPeriod | 获取或设置亮灭周期。
Public property | OnOffRatio | 获取或设置亮灭比例。

See Also

OutputPortStatus Class
Ptl.Device.Communication.XGateSettings Namespace


OutputPortStatus.ON Property

[image]

Pick To Light 设备通讯类库
OutputPortStatus..::..ON Property
OutputPortStatus Class See Also Send Feedback
获取或设置是否处于点亮状态。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool ON { get; set; }
Visual Basic
Public Property ON As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

OutputPortStatus Class
OutputPortStatus Members
Ptl.Device.Communication.XGateSettings Namespace


OutputPortStatus.OnOffPeriod Property

[image]

Pick To Light 设备通讯类库
OutputPortStatus..::..OnOffPeriod Property
OutputPortStatus Class See Also Send Feedback
获取或设置亮灭周期。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public LightOnOffPeriod OnOffPeriod { get; set; }
Visual Basic
Public Property OnOffPeriod As LightOnOffPeriod
    Get
    Set

Property Value

Type: LightOnOffPeriod

See Also

OutputPortStatus Class
OutputPortStatus Members
Ptl.Device.Communication.XGateSettings Namespace


OutputPortStatus.OnOffRatio Property

[image]

Pick To Light 设备通讯类库
OutputPortStatus..::..OnOffRatio Property
OutputPortStatus Class See Also Send Feedback
获取或设置亮灭比例。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public LightOnOffRatio OnOffRatio { get; set; }
Visual Basic
Public Property OnOffRatio As LightOnOffRatio
    Get
    Set

Property Value

Type: LightOnOffRatio

See Also

OutputPortStatus Class
OutputPortStatus Members
Ptl.Device.Communication.XGateSettings Namespace


SerialPortSettings Class

[image]

Pick To Light 设备通讯类库
SerialPortSettings Class
Members See Also Send Feedback
串口参数。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
[SerializableAttribute]
public class SerialPortSettings
Visual Basic
<SerializableAttribute>
Public Class SerialPortSettings

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication.XGateSettings..::..SerialPortSettings

See Also

SerialPortSettings Members
Ptl.Device.Communication.XGateSettings Namespace


SerialPortSettings Members

[image] [image]

Pick To Light 设备通讯类库
SerialPortSettings Members
SerialPortSettings Class Constructors Properties See Also Send Feedback

The SerialPortSettings type exposes the following members.

Constructors

 | Name | Description
Public method | SerialPortSettings | Initializes a new instance of the SerialPortSettings class

Properties

 | Name | Description
Public property | BaudRate | 获取或设置波特率。
Public property | DataBits | 获取或设置数据位数。
Public property | Parity | 获取或设置校验位。
Public property | StopBits | 获取或设置停止位数。

See Also

SerialPortSettings Class
Ptl.Device.Communication.XGateSettings Namespace


SerialPortSettings Constructor

[image]

Pick To Light 设备通讯类库
SerialPortSettings Constructor
SerialPortSettings Class See Also Send Feedback
Initializes a new instance of the SerialPortSettings class

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public SerialPortSettings()
Visual Basic
Public Sub New

See Also

SerialPortSettings Class
SerialPortSettings Members
Ptl.Device.Communication.XGateSettings Namespace


SerialPortSettings Properties

[image] [image]

Pick To Light 设备通讯类库
SerialPortSettings Properties
SerialPortSettings Class See Also Send Feedback

The SerialPortSettings type exposes the following members.

Properties

 | Name | Description
Public property | BaudRate | 获取或设置波特率。
Public property | DataBits | 获取或设置数据位数。
Public property | Parity | 获取或设置校验位。
Public property | StopBits | 获取或设置停止位数。

See Also

SerialPortSettings Class
Ptl.Device.Communication.XGateSettings Namespace


SerialPortSettings.BaudRate Property

[image]

Pick To Light 设备通讯类库
SerialPortSettings..::..BaudRate Property
SerialPortSettings Class See Also Send Feedback
获取或设置波特率。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public int BaudRate { get; set; }
Visual Basic
Public Property BaudRate As Integer
    Get
    Set

Property Value

Type: Int32

See Also

SerialPortSettings Class
SerialPortSettings Members
Ptl.Device.Communication.XGateSettings Namespace


SerialPortSettings.DataBits Property

[image]

Pick To Light 设备通讯类库
SerialPortSettings..::..DataBits Property
SerialPortSettings Class See Also Send Feedback
获取或设置数据位数。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public byte DataBits { get; set; }
Visual Basic
Public Property DataBits As Byte
    Get
    Set

Property Value

Type: Byte

See Also

SerialPortSettings Class
SerialPortSettings Members
Ptl.Device.Communication.XGateSettings Namespace


SerialPortSettings.Parity Property

[image]

Pick To Light 设备通讯类库
SerialPortSettings..::..Parity Property
SerialPortSettings Class See Also Send Feedback
获取或设置校验位。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public Parity Parity { get; set; }
Visual Basic
Public Property Parity As Parity
    Get
    Set

Property Value

Type: Parity

See Also

SerialPortSettings Class
SerialPortSettings Members
Ptl.Device.Communication.XGateSettings Namespace


SerialPortSettings.StopBits Property

[image]

Pick To Light 设备通讯类库
SerialPortSettings..::..StopBits Property
SerialPortSettings Class See Also Send Feedback
获取或设置停止位数。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public StopBits StopBits { get; set; }
Visual Basic
Public Property StopBits As StopBits
    Get
    Set

Property Value

Type: StopBits

See Also

SerialPortSettings Class
SerialPortSettings Members
Ptl.Device.Communication.XGateSettings Namespace


XGateSettingsExecutor Class

[image]

Pick To Light 设备通讯类库
XGateSettingsExecutor Class
Members See Also Send Feedback
XGate 工作参数设置协议执行者。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public class XGateSettingsExecutor
Visual Basic
Public Class XGateSettingsExecutor

Inheritance Hierarchy

System..::..Object
Ptl.Device.Communication.XGateSettings..::..XGateSettingsExecutor

See Also

XGateSettingsExecutor Members
Ptl.Device.Communication.XGateSettings Namespace


XGateSettingsExecutor Members

[image] [image]

Pick To Light 设备通讯类库
XGateSettingsExecutor Members
XGateSettingsExecutor Class Constructors Methods See Also Send Feedback

The XGateSettingsExecutor type exposes the following members.

Constructors

 | Name | Description
Public method | XGateSettingsExecutor | 初始化设置协议执行者。

Methods

 | Name | Description
Public method | GetCommunicationSecurity | 获取通讯安全设置。
Public method | GetDeviceAddressRange | 获取指定总线上的地址范围。
Public method | GetInFrameDelay | 获取帧间延时。
Public method | GetSerialPortSettings | 获取串口参数。
Public method | Reboot | 重启。
Public method | SetCommunicationSecurity | 设置通讯安全设置。
Public method | SetDeviceAddressRange | 设置指定总线上的地址范围。
Public method | SetInFrameDelay | 设置帧间延时。
Public method | SetSerialPortSettings | 设置串口参数。

See Also

XGateSettingsExecutor Class
Ptl.Device.Communication.XGateSettings Namespace


XGateSettingsExecutor Constructor

[image]

Pick To Light 设备通讯类库
XGateSettingsExecutor Constructor
XGateSettingsExecutor Class See Also Send Feedback
初始化设置协议执行者。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public XGateSettingsExecutor(
    ModbusClient client
)
Visual Basic
Public Sub New (
    client As ModbusClient
)

Parameters

client
Type: Ptl.Device.Communication..::..ModbusClient
通讯客户端。

Exceptions

Exception | Condition
System..::..ArgumentNullException | client 为空。

See Also

XGateSettingsExecutor Class
XGateSettingsExecutor Members
Ptl.Device.Communication.XGateSettings Namespace


XGateSettingsExecutor Methods

[image] [image]

Pick To Light 设备通讯类库
XGateSettingsExecutor Methods
XGateSettingsExecutor Class See Also Send Feedback

The XGateSettingsExecutor type exposes the following members.

Methods

 | Name | Description
Public method | GetCommunicationSecurity | 获取通讯安全设置。
Public method | GetDeviceAddressRange | 获取指定总线上的地址范围。
Public method | GetInFrameDelay | 获取帧间延时。
Public method | GetSerialPortSettings | 获取串口参数。
Public method | Reboot | 重启。
Public method | SetCommunicationSecurity | 设置通讯安全设置。
Public method | SetDeviceAddressRange | 设置指定总线上的地址范围。
Public method | SetInFrameDelay | 设置帧间延时。
Public method | SetSerialPortSettings | 设置串口参数。

See Also

XGateSettingsExecutor Class
Ptl.Device.Communication.XGateSettings Namespace


XGateSettingsExecutor.GetCommunicationSecurity Method

[image]

Pick To Light 设备通讯类库
XGateSettingsExecutor..::..GetCommunicationSecurity Method
XGateSettingsExecutor Class See Also Send Feedback
获取通讯安全设置。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public CommunicationSecurity GetCommunicationSecurity()
Visual Basic
Public Function GetCommunicationSecurity As CommunicationSecurity

Return Value

Type: CommunicationSecurity
通讯安全设置。

See Also

XGateSettingsExecutor Class
XGateSettingsExecutor Members
Ptl.Device.Communication.XGateSettings Namespace


XGateSettingsExecutor.GetDeviceAddressRange Method

[image]

Pick To Light 设备通讯类库
XGateSettingsExecutor..::..GetDeviceAddressRange Method
XGateSettingsExecutor Class See Also Send Feedback
获取指定总线上的地址范围。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public DeviceAddressRange GetDeviceAddressRange(
    byte busIndex
)
Visual Basic
Public Function GetDeviceAddressRange (
    busIndex As Byte
) As DeviceAddressRange

Parameters

busIndex
Type: System..::..Byte
基于 0 的总线索引。

Return Value

Type: DeviceAddressRange
指定总线上的地址范围。

See Also

XGateSettingsExecutor Class
XGateSettingsExecutor Members
Ptl.Device.Communication.XGateSettings Namespace


XGateSettingsExecutor.GetInFrameDelay Method

[image]

Pick To Light 设备通讯类库
XGateSettingsExecutor..::..GetInFrameDelay Method
XGateSettingsExecutor Class See Also Send Feedback
获取帧间延时。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public InFrameDelay GetInFrameDelay()
Visual Basic
Public Function GetInFrameDelay As InFrameDelay

Return Value

Type: InFrameDelay
帧间延时。

See Also

XGateSettingsExecutor Class
XGateSettingsExecutor Members
Ptl.Device.Communication.XGateSettings Namespace


XGateSettingsExecutor.GetSerialPortSettings Method

[image]

Pick To Light 设备通讯类库
XGateSettingsExecutor..::..GetSerialPortSettings Method
XGateSettingsExecutor Class See Also Send Feedback
获取串口参数。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public SerialPortSettings GetSerialPortSettings()
Visual Basic
Public Function GetSerialPortSettings As SerialPortSettings

Return Value

Type: SerialPortSettings
串口参数。

See Also

XGateSettingsExecutor Class
XGateSettingsExecutor Members
Ptl.Device.Communication.XGateSettings Namespace


XGateSettingsExecutor.Reboot Method

[image]

Pick To Light 设备通讯类库
XGateSettingsExecutor..::..Reboot Method
XGateSettingsExecutor Class See Also Send Feedback
重启。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void Reboot()
Visual Basic
Public Sub Reboot

Remarks

配置工作参数后需重启才能生效。

See Also

XGateSettingsExecutor Class
XGateSettingsExecutor Members
Ptl.Device.Communication.XGateSettings Namespace


XGateSettingsExecutor.SetCommunicationSecurity Method

[image]

Pick To Light 设备通讯类库
XGateSettingsExecutor..::..SetCommunicationSecurity Method
XGateSettingsExecutor Class See Also Send Feedback
设置通讯安全设置。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void SetCommunicationSecurity(
    CommunicationSecurity communicationSecurity
)
Visual Basic
Public Sub SetCommunicationSecurity (
    communicationSecurity As CommunicationSecurity
)

Parameters

communicationSecurity
Type: Ptl.Device.Communication.XGateSettings..::..CommunicationSecurity
通讯安全设置。

See Also

XGateSettingsExecutor Class
XGateSettingsExecutor Members
Ptl.Device.Communication.XGateSettings Namespace


XGateSettingsExecutor.SetDeviceAddressRange Method

[image]

Pick To Light 设备通讯类库
XGateSettingsExecutor..::..SetDeviceAddressRange Method
XGateSettingsExecutor Class See Also Send Feedback
设置指定总线上的地址范围。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void SetDeviceAddressRange(
    DeviceAddressRange range
)
Visual Basic
Public Sub SetDeviceAddressRange (
    range As DeviceAddressRange
)

Parameters

range
Type: Ptl.Device.Communication.XGateSettings..::..DeviceAddressRange
指定总线上的地址范围。

See Also

XGateSettingsExecutor Class
XGateSettingsExecutor Members
Ptl.Device.Communication.XGateSettings Namespace


XGateSettingsExecutor.SetInFrameDelay Method

[image]

Pick To Light 设备通讯类库
XGateSettingsExecutor..::..SetInFrameDelay Method
XGateSettingsExecutor Class See Also Send Feedback
设置帧间延时。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void SetInFrameDelay(
    InFrameDelay delay
)
Visual Basic
Public Sub SetInFrameDelay (
    delay As InFrameDelay
)

Parameters

delay
Type: Ptl.Device.Communication.XGateSettings..::..InFrameDelay
帧间延时。

See Also

XGateSettingsExecutor Class
XGateSettingsExecutor Members
Ptl.Device.Communication.XGateSettings Namespace


XGateSettingsExecutor.SetSerialPortSettings Method

[image]

Pick To Light 设备通讯类库
XGateSettingsExecutor..::..SetSerialPortSettings Method
XGateSettingsExecutor Class See Also Send Feedback
设置串口参数。

Namespace: Ptl.Device.Communication.XGateSettings
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public void SetSerialPortSettings(
    SerialPortSettings settings
)
Visual Basic
Public Sub SetSerialPortSettings (
    settings As SerialPortSettings
)

Parameters

settings
Type: Ptl.Device.Communication.XGateSettings..::..SerialPortSettings
串口参数。

See Also

XGateSettingsExecutor Class
XGateSettingsExecutor Members
Ptl.Device.Communication.XGateSettings Namespace


Ptl.Device.Log Namespace

[image]

Pick To Light 设备通讯类库
Ptl.Device.Log Namespace
Send Feedback
提供类库运行状态的记录功能。

Classes

 | Class | Description
Public class | DefaultTextFileLogger | 默认的文本文件日志记录器。
Public class | Logger | 提供对日志功能的全局访问。

Interfaces

 | Interface | Description
Public interface | ILogger | 提供简单的日志纪录功能；作为运行状态的记录者，此接口的实现类不应抛出异常来干扰运行。

Enumerations

 | Enumeration | Description
Public enumeration | LogLevel | 日志的级别。


DefaultTextFileLogger Class

[image]

Pick To Light 设备通讯类库
DefaultTextFileLogger Class
Members See Also Send Feedback
默认的文本文件日志记录器。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public class DefaultTextFileLogger : ILogger
Visual Basic
Public Class DefaultTextFileLogger
    Implements ILogger

Inheritance Hierarchy

System..::..Object
Ptl.Device.Log..::..DefaultTextFileLogger

See Also

DefaultTextFileLogger Members
Ptl.Device.Log Namespace


DefaultTextFileLogger Members

[image] [image]

Pick To Light 设备通讯类库
DefaultTextFileLogger Members
DefaultTextFileLogger Class Constructors Methods Properties See Also Send Feedback

The DefaultTextFileLogger type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultTextFileLogger()()()() | 使用默认的目录 App_Data\PtlDeviceLog 初始化文本文件日志记录器。
Public method | DefaultTextFileLogger(String) | 使用指定的目录初始化文本文件日志记录器。

Methods

 | Name | Description
Public method | Delete | 删除给定有效期前的记录。
Public method | Write | 纪录日志。

Properties

 | Name | Description
Public property | Folder | 获取日志文件所在目录。
Public property | IsErrorEnabled | 获取或设置是否纪录错误。
Public property | IsInformationEnabled | 获取或设置是否纪录普通信息。
Public property | IsWarningEnabled | 获取或设置是否纪录警告。

See Also

DefaultTextFileLogger Class
Ptl.Device.Log Namespace


DefaultTextFileLogger Constructor

[image] [image]

Pick To Light 设备通讯类库
DefaultTextFileLogger Constructor
DefaultTextFileLogger Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DefaultTextFileLogger()()()() | 使用默认的目录 App_Data\PtlDeviceLog 初始化文本文件日志记录器。
Public method | DefaultTextFileLogger(String) | 使用指定的目录初始化文本文件日志记录器。

See Also

DefaultTextFileLogger Class
DefaultTextFileLogger Members
Ptl.Device.Log Namespace


DefaultTextFileLogger Constructor

[image]

Pick To Light 设备通讯类库
DefaultTextFileLogger Constructor
DefaultTextFileLogger Class See Also Send Feedback
使用默认的目录 App_Data\PtlDeviceLog 初始化文本文件日志记录器。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public DefaultTextFileLogger()
Visual Basic
Public Sub New

See Also

DefaultTextFileLogger Class
DefaultTextFileLogger Members
DefaultTextFileLogger Overload
Ptl.Device.Log Namespace


DefaultTextFileLogger Constructor (String)

[image]

Pick To Light 设备通讯类库
DefaultTextFileLogger Constructor (String)
DefaultTextFileLogger Class See Also Send Feedback
使用指定的目录初始化文本文件日志记录器。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public DefaultTextFileLogger(
    string folder
)
Visual Basic
Public Sub New (
    folder As String
)

Parameters

folder
Type: System..::..String
日志将按日期、源-级别被分层纪录到此目录下。

Remarks

folder 为本日志记录器专用，在其下放置其他的型如日期的目录可能会被误删。

See Also

DefaultTextFileLogger Class
DefaultTextFileLogger Members
DefaultTextFileLogger Overload
Ptl.Device.Log Namespace


DefaultTextFileLogger Methods

[image] [image]

Pick To Light 设备通讯类库
DefaultTextFileLogger Methods
DefaultTextFileLogger Class See Also Send Feedback

The DefaultTextFileLogger type exposes the following members.

Methods

 | Name | Description
Public method | Delete | 删除给定有效期前的记录。
Public method | Write | 纪录日志。

See Also

DefaultTextFileLogger Class
Ptl.Device.Log Namespace


DefaultTextFileLogger.Delete Method

[image]

Pick To Light 设备通讯类库
DefaultTextFileLogger..::..Delete Method
DefaultTextFileLogger Class See Also Send Feedback
删除给定有效期前的记录。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Delete(
    DateTime expiryDate
)
Visual Basic
Public Overridable Sub Delete (
    expiryDate As DateTime
)

Parameters

expiryDate
Type: System..::..DateTime
有效期。

Implements

ILogger..::..Delete(DateTime)

See Also

DefaultTextFileLogger Class
DefaultTextFileLogger Members
Ptl.Device.Log Namespace


DefaultTextFileLogger.Write Method

[image]

Pick To Light 设备通讯类库
DefaultTextFileLogger..::..Write Method
DefaultTextFileLogger Class See Also Send Feedback
纪录日志。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public virtual void Write(
    string source,
    string message,
    LogLevel level
)
Visual Basic
Public Overridable Sub Write (
    source As String,
    message As String,
    level As LogLevel
)

Parameters

source
Type: System..::..String
源。
message
Type: System..::..String
信息。
level
Type: Ptl.Device.Log..::..LogLevel
级别。

Implements

ILogger..::..Write(String, String, LogLevel)

See Also

DefaultTextFileLogger Class
DefaultTextFileLogger Members
Ptl.Device.Log Namespace


DefaultTextFileLogger Properties

[image] [image]

Pick To Light 设备通讯类库
DefaultTextFileLogger Properties
DefaultTextFileLogger Class See Also Send Feedback

The DefaultTextFileLogger type exposes the following members.

Properties

 | Name | Description
Public property | Folder | 获取日志文件所在目录。
Public property | IsErrorEnabled | 获取或设置是否纪录错误。
Public property | IsInformationEnabled | 获取或设置是否纪录普通信息。
Public property | IsWarningEnabled | 获取或设置是否纪录警告。

See Also

DefaultTextFileLogger Class
Ptl.Device.Log Namespace


DefaultTextFileLogger.Folder Property

[image]

Pick To Light 设备通讯类库
DefaultTextFileLogger..::..Folder Property
DefaultTextFileLogger Class See Also Send Feedback
获取日志文件所在目录。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public string Folder { get; }
Visual Basic
Public ReadOnly Property Folder As String
    Get

Property Value

Type: String

See Also

DefaultTextFileLogger Class
DefaultTextFileLogger Members
Ptl.Device.Log Namespace


DefaultTextFileLogger.IsErrorEnabled Property

[image]

Pick To Light 设备通讯类库
DefaultTextFileLogger..::..IsErrorEnabled Property
DefaultTextFileLogger Class See Also Send Feedback
获取或设置是否纪录错误。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool IsErrorEnabled { get; set; }
Visual Basic
Public Property IsErrorEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ILogger..::..IsErrorEnabled

See Also

DefaultTextFileLogger Class
DefaultTextFileLogger Members
Ptl.Device.Log Namespace


DefaultTextFileLogger.IsInformationEnabled Property

[image]

Pick To Light 设备通讯类库
DefaultTextFileLogger..::..IsInformationEnabled Property
DefaultTextFileLogger Class See Also Send Feedback
获取或设置是否纪录普通信息。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool IsInformationEnabled { get; set; }
Visual Basic
Public Property IsInformationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ILogger..::..IsInformationEnabled

See Also

DefaultTextFileLogger Class
DefaultTextFileLogger Members
Ptl.Device.Log Namespace


DefaultTextFileLogger.IsWarningEnabled Property

[image]

Pick To Light 设备通讯类库
DefaultTextFileLogger..::..IsWarningEnabled Property
DefaultTextFileLogger Class See Also Send Feedback
获取或设置是否纪录警告。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public bool IsWarningEnabled { get; set; }
Visual Basic
Public Property IsWarningEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ILogger..::..IsWarningEnabled

See Also

DefaultTextFileLogger Class
DefaultTextFileLogger Members
Ptl.Device.Log Namespace


ILogger Interface

[image]

Pick To Light 设备通讯类库
ILogger Interface
Members See Also Send Feedback
提供简单的日志纪录功能；作为运行状态的记录者，此接口的实现类不应抛出异常来干扰运行。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public interface ILogger
Visual Basic
Public Interface ILogger

See Also

ILogger Members
Ptl.Device.Log Namespace


ILogger Members

[image] [image]

Pick To Light 设备通讯类库
ILogger Members
ILogger Interface Methods Properties See Also Send Feedback

The ILogger type exposes the following members.

Methods

 | Name | Description
Public method | Delete | 删除给定有效期前的记录。
Public method | Write | 尝试纪录日志。

Properties

 | Name | Description
Public property | IsErrorEnabled | 获取或设置是否纪录错误。
Public property | IsInformationEnabled | 获取或设置是否纪录普通信息。
Public property | IsWarningEnabled | 获取或设置是否纪录警告。

See Also

ILogger Interface
Ptl.Device.Log Namespace


ILogger Methods

[image] [image]

Pick To Light 设备通讯类库
ILogger Methods
ILogger Interface See Also Send Feedback

The ILogger type exposes the following members.

Methods

 | Name | Description
Public method | Delete | 删除给定有效期前的记录。
Public method | Write | 尝试纪录日志。

See Also

ILogger Interface
Ptl.Device.Log Namespace


ILogger.Delete Method

[image]

Pick To Light 设备通讯类库
ILogger..::..Delete Method
ILogger Interface See Also Send Feedback
删除给定有效期前的记录。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
void Delete(
    DateTime expiryDate
)
Visual Basic
Sub Delete (
    expiryDate As DateTime
)

Parameters

expiryDate
Type: System..::..DateTime
有效期。

See Also

ILogger Interface
ILogger Members
Ptl.Device.Log Namespace


ILogger.Write Method

[image]

Pick To Light 设备通讯类库
ILogger..::..Write Method
ILogger Interface See Also Send Feedback
尝试纪录日志。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
void Write(
    string source,
    string message,
    LogLevel level
)
Visual Basic
Sub Write (
    source As String,
    message As String,
    level As LogLevel
)

Parameters

source
Type: System..::..String
源。
message
Type: System..::..String
信息。
level
Type: Ptl.Device.Log..::..LogLevel
级别。

See Also

ILogger Interface
ILogger Members
Ptl.Device.Log Namespace


ILogger Properties

[image] [image]

Pick To Light 设备通讯类库
ILogger Properties
ILogger Interface See Also Send Feedback

The ILogger type exposes the following members.

Properties

 | Name | Description
Public property | IsErrorEnabled | 获取或设置是否纪录错误。
Public property | IsInformationEnabled | 获取或设置是否纪录普通信息。
Public property | IsWarningEnabled | 获取或设置是否纪录警告。

See Also

ILogger Interface
Ptl.Device.Log Namespace


ILogger.IsErrorEnabled Property

[image]

Pick To Light 设备通讯类库
ILogger..::..IsErrorEnabled Property
ILogger Interface See Also Send Feedback
获取或设置是否纪录错误。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
bool IsErrorEnabled { get; set; }
Visual Basic
Property IsErrorEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

ILogger Interface
ILogger Members
Ptl.Device.Log Namespace


ILogger.IsInformationEnabled Property

[image]

Pick To Light 设备通讯类库
ILogger..::..IsInformationEnabled Property
ILogger Interface See Also Send Feedback
获取或设置是否纪录普通信息。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
bool IsInformationEnabled { get; set; }
Visual Basic
Property IsInformationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

ILogger Interface
ILogger Members
Ptl.Device.Log Namespace


ILogger.IsWarningEnabled Property

[image]

Pick To Light 设备通讯类库
ILogger..::..IsWarningEnabled Property
ILogger Interface See Also Send Feedback
获取或设置是否纪录警告。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
bool IsWarningEnabled { get; set; }
Visual Basic
Property IsWarningEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

ILogger Interface
ILogger Members
Ptl.Device.Log Namespace


Logger Class

[image]

Pick To Light 设备通讯类库
Logger Class
Members See Also Send Feedback
提供对日志功能的全局访问。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static class Logger
Visual Basic
Public NotInheritable Class Logger

Inheritance Hierarchy

System..::..Object
Ptl.Device.Log..::..Logger

See Also

Logger Members
Ptl.Device.Log Namespace


Logger Members

[image] [image]

Pick To Light 设备通讯类库
Logger Members
Logger Class Properties See Also Send Feedback

The Logger type exposes the following members.

Properties

Name | Description
HoldingPeriodInDays | 获取或设置日志的保存天数，小于或等于零时始终保存。
Instance | 获取或设置日志记录器，默认为 DefaultTextFileLogger。

See Also

Logger Class
Ptl.Device.Log Namespace


Logger Properties

[image] [image]

Pick To Light 设备通讯类库
Logger Properties
Logger Class See Also Send Feedback

The Logger type exposes the following members.

Properties

Name | Description
HoldingPeriodInDays | 获取或设置日志的保存天数，小于或等于零时始终保存。
Instance | 获取或设置日志记录器，默认为 DefaultTextFileLogger。

See Also

Logger Class
Ptl.Device.Log Namespace


Logger.HoldingPeriodInDays Property

[image]

Pick To Light 设备通讯类库
Logger..::..HoldingPeriodInDays Property
Logger Class See Also Send Feedback
获取或设置日志的保存天数，小于或等于零时始终保存。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static int HoldingPeriodInDays { get; set; }
Visual Basic
Public Shared Property HoldingPeriodInDays As Integer
    Get
    Set

Property Value

Type: Int32

See Also

Logger Class
Logger Members
Ptl.Device.Log Namespace


Logger.Instance Property

[image]

Pick To Light 设备通讯类库
Logger..::..Instance Property
Logger Class See Also Send Feedback
获取或设置日志记录器，默认为 DefaultTextFileLogger。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public static ILogger Instance { get; set; }
Visual Basic
Public Shared Property Instance As ILogger
    Get
    Set

Property Value

Type: ILogger

Exceptions

Exception | Condition
System..::..ArgumentNullException | 设置时使用空值。

See Also

Logger Class
Logger Members
Ptl.Device.Log Namespace


LogLevel Enumeration

[image]

Pick To Light 设备通讯类库
LogLevel Enumeration
See Also Send Feedback
日志的级别。

Namespace: Ptl.Device.Log
Assembly: Ptl.Device (in Ptl.Device.dll) Version: 1.6.0.2 (1.6.0.2)

Syntax

C#
public enum LogLevel
Visual Basic
Public Enumeration LogLevel

Members

Member name | Value | Description
Debug | 0 | 调试信息。
Information | 1 | 普通信息。
Wraning | 2 | 警告。
Error | 3 | 错误。

See Also

Ptl.Device.Log Namespace